[Intrepid] Update kernel to Linux 2.6.27.15

Bug #328652 reported by Stefan Bader on 2009-02-12
8
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Stefan Bader
Intrepid
Undecided
Unassigned

Bug Description

SRU justification:

Impact: Several upstream stable patches to fix problems and get into sync with upstream.

Fix:
* [cifs: make sure we allocate enough storage for socket address](1)
* ixgb: fix bug when freeing resources
* m68knommu: set NO_DMA
* sata_mv: fix 8-port timeouts on 508x/6081 chips
* x86: use early clobbers in usercopy*.c
* Add enable_ms to jsm driver
* fbdev/atyfb: Fix DSP config on some PowerMacs & PowerBooks
* Fix memory corruption in console selection
* Input: atkbd - broaden the Dell DMI signatures
* Input: atkbd - Samsung NC10 key repeat fix
* net: fix packet socket delivery in rx irq handler
* nfsd: Ensure nfsv4 calls the underlying filesystem on LOCKT
* nfsd: only set file_lock.fl_lmops in nfsd4_lockt if a stateowner is found
* PCI: irq and pci_ids patch for Intel Tigerpoint DeviceIDs
* sata_nv: rename nv_nf2_hardreset()
* sata_nv: fix MCP5x reset
* sata_nv: ck804 has borked hardreset too
* [USB: isp1760: Fix probe in PCI glue code](1)
* x86: fix page attribute corruption with cpa()
* cpuidle: update the last_state acpi cpuidle reflecting actual state entered
* cpuidle: upon BIOS bug, default to default_idle rather than polling
* cpuidle: use last_state which can reflect the actual state entered
* cpuidle: Add decaying history logic to menu idle predictor
* ACPI: Avoid array address overflow when _CST MWAIT hint bits are set
* [ACPI: Attach the ACPI device to the ACPI handle as early as possible](2)
* ACPICA: Fixed a couple memory leaks associated with "implicit return"
* ACPICA: Add check for invalid handle in acpi_get_object_info
** ACPI: Change acpi_evaluate_integer to support 64-bit on 32-bit kernels(3)
* ACPI: Fix compiler warnings introduced by 32 to 64 bit acpi conversions
* ACPI EC: Fix regression due to use of uninitialized variable
* ACPICA: Fix wrong resource descriptor length for 64-bit build
* asus-laptop: Add support for P30/P35
* asus-laptop: Fix the led behavior with value > 1
* video: always update the brightness when poking "brightness"
* don't load asus-acpi if model is not supported
* Newly inserted battery might differ from one just removed, so update of battery info fields is required.
* ACPI: Do not modify SCI_EN directly
* ACPI suspend: Blacklist HP xw4600 Workstation for old code ordering
* dlm: initialize file_lock struct in GETLK before copying conflicting lock
* sata_mv: Fix chip type for Hightpoint RocketRaid 1740/1742
* ACPICA: Allow multiple backslash prefix in namepaths
* Linux 2.6.27.15

(1) These patches have been found as regressions in Ubuntu and reported back to upstream
(2) Already applied through another bug fix
(3) Bumps the ABI

Stefan Bader (smb) on 2009-02-12
Changed in linux:
assignee: nobody → stefan-bader-canonical
status: New → In Progress
importance: Undecided → Medium
Stefan Bader (smb) on 2009-02-13
Changed in linux:
status: In Progress → Fix Committed
Martin Pitt (pitti) on 2009-02-25
Changed in linux:
status: Fix Committed → Invalid
Martin Pitt (pitti) wrote :

Accepted linux into intrepid-proposed; please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in linux:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (27.1 KiB)

This bug was fixed in the package linux - 2.6.27-14.33

---------------
linux (2.6.27-14.33) intrepid-proposed; urgency=low

  [Stefan Bader]

  * Fix FTBS due to a mysteriously missing ABI directory.

linux (2.6.27-14.32) intrepid-proposed; urgency=low

  [Stefan Bader]

  * Rebuild of 2.6.27-14.30 with 2.6.27-11.31 security patches applied

linux (2.6.27-14.30) intrepid-proposed; urgency=low

  [ Alexey Starikovskiy ]

  * SAUCE: ACPI: EC: Limit workaround for ASUS notebooks even more
    - LP: #288385

  [ Huaxu Wan ]

  * SAUCE: report rfkill changes event if interface is down
    - LP: #193970

  [ Scott James Remnant ]

  * SAUCE: floppy: Provide a PnP device table in the module.
    - LP: #255651

  [ Steve Beattie ]

  * fix apparmor memory leak on deleted file ops
    - LP: #329489

  [ Stefan Bader ]

  * Revert "ACPI: Fix compiler warnings introduced by 32 to 64 bit acpi
    conversions"
    - LP: #337019
  * Revert "ACPI: Change acpi_evaluate_integer to support 64-bit on 32-bit
    kernels"
    - LP: #337019

  [ Upstream Kernel Changes ]

  * KVM: MMU: Add locking around kvm_mmu_slot_remove_write_access()
    - LP: #335097, #333409
  * ricoh_mmc: Handle newer models of Ricoh controllers
    - LP: #311932

linux (2.6.27-13.29) intrepid-proposed; urgency=low

  [ Colin Ian King ]

  * SAUCE: Bluetooth USB: fix kernel panic during suspend while streaming
    audio to bluetooth headset
    - LP: #331106, #322082

  [ Stefan Bader ]

  * Revert "SAUCE: Work around ACPI corruption upon suspend on some Dell
    machines." (replaced by stable update)
    - LP: #330200
  * Revert "SAUCE: Add back in lost commit for Apple BT Wireless Keyboard"
    (replaced by stable update)
    - LP: #330902

  [ Upstream Kernel Changes ]

  * Revert "vt: fix background color on line feed"
    - LP: #330200
  * ti_usb_3410_5052: support alternate firmware
    - LP: #231276
  * fuse: destroy bdi on umount
    - LP: #324921
  * fuse: fix missing fput on error
    - LP: #324921
  * fuse: fix NULL deref in fuse_file_alloc()
    - LP: #324921
  * inotify: clean up inotify_read and fix locking problems
    - LP: #324921
  * mac80211: decrement ref count to netdev after launching mesh discovery
    - LP: #324921
  * sysfs: fix problems with binary files
    - LP: #324921
  * x86, mm: fix pte_free()
    - LP: #324921
  * alpha: nautilus - fix compile failure with gcc-4.3
    - LP: #324921
  * it821x: Add ultra_mask quirk for Vortex86SX
    - LP: #324921
  * libata: pata_via: support VX855, future chips whose IDE controller use
    0x0571
    - LP: #324921
  * rtl8187: Add termination packet to prevent stall
    - LP: #324921
  * serial_8250: support for Sealevel Systems Model 7803 COMM+8
    - LP: #324921
  * SUNRPC: Fix a memory leak in rpcb_getport_async
    - LP: #324921
  * SUNRPC: Fix autobind on cloned rpc clients
    - LP: #324921
  * USB: fix char-device disconnect handling
    - LP: #324921
  * USB: storage: add unusual devs entry
    - LP: #324921
  * USB: usbmon: Implement compat_ioctl
    - LP: #324921
  * ALSA: hda - add another MacBook Pro 4, 1 subsystem ID
    - LP: #324921
  * ALSA: hda - Add quirk for HP DV6700 laptop
    - LP: #324921
  * ALSA: ...

Changed in linux (Ubuntu Intrepid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers