Dell Inspiron 2650 doesn't boot without acpi=off

Bug #327499 reported by Tiago Requeijo
46
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Incomplete
Medium
Unassigned
Karmic
Fix Released
Medium
Unassigned

Bug Description

SRU Justification:

Impact: The following upstream change
"ACPI: Attach the ACPI device to the ACPI handle as early as possible"
caused the Dell Inspiron 2650 not to boot anymore.

Fix: Upstream revert, which comes in with 2.6.31.6 is supposed to fix this.

---

Binary package hint: linux-image-2.6.28-7-generic

The boot process stops at the point on the image attached below. I tried with kernels 2.6.28-4 through 2.6.28-7, as well as custom compiled 2.6.29-rc3. None of those boots properly. The 2.6.27 series works fine.

The output of lspci is:

00:00.0 Host bridge: Intel Corporation 82845 845 [Brookdale] Chipset Host Bridge (rev 05)
00:01.0 PCI bridge: Intel Corporation 82845 845 [Brookdale] Chipset AGP Bridge (rev 05)
00:1d.0 USB Controller: Intel Corporation 82801CA/CAM USB Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801CA/CAM USB Controller #2 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 42)
00:1f.0 ISA bridge: Intel Corporation 82801CAM ISA Bridge (LPC) (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801CAM IDE U100 Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801CA/CAM SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801CA/CAM AC'97 Audio Controller (rev 02)
00:1f.6 Modem: Intel Corporation 82801CA/CAM AC'97 Modem Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 Go] (rev b2)
02:01.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 78)
02:04.0 CardBus bridge: O2 Micro, Inc. OZ601/6912/711E0 CardBus/SmartCardBus Controller

Revision history for this message
Tiago Requeijo (tiago-requeijo-dev) wrote :
Revision history for this message
Tiago Requeijo (tiago-requeijo-dev) wrote :
Revision history for this message
Tiago Requeijo (tiago-requeijo-dev) wrote :

This is a problem with acpi. Booting with 2.6.28 and 2.6.29 works passing acpi=off as a kernel boot-time parameter. Kernels 2.6.27-xx and earlier didn't require any special parameter at boot time.

Revision history for this message
Evan Goers (megatog615) wrote :

I have the same problem(same laptop) on Debian Sid. Neither linux-image-2.6.28-1-686 nor linux-image-2.6.29-1-686 boot properly.
I wonder if other Dell laptops around the same era are affected as well?

Revision history for this message
Onno Leerink (onno-leerink-bode) wrote :

I have the same problem with the dell inspiron 2650. With the 2.6.27 kernel the next line is:

 [ 0.762725] pci 0000:02:04.0: power state changed by ACPI to D0.

Now it just stops and I can only press the power button.

With the 2.6.28 kernel and pci=noacpi option the next line is:

[ 1.111966] pci 0000:02:04.0: found PCI INT A -> IRQ 10

I did some testing:
booting with the "acpi=off" kernel parameter -> normal boot
booting with "acpi=ht" kernel parameter -> normal boot

booting with "pci=noacpi" kernel parameter -> normal boot
booting with "acpi=noirq" kernel parameter -> same boot problem
booting with "pnpacpi=off" kernel parameter -> same boot problem
booting with "noapic" kernel parameter -> same boot problem
booting with "nolapic" kernel parameter -> same boot problem

The bios (A13) is up to date and gives no options concerning ACPI.

Revision history for this message
pjw (pjw1965) wrote :

I can confirm, that on my Dell Inspiron 2650 acpi=off boots the kernel with 2.6.28, but the laptop cannot switch off after shutdown.

Revision history for this message
Evan Goers (megatog615) wrote :

This does not appear to be Ubuntu specific then. Can someone try any other distros to confirm that it is a kernel bug?

Revision history for this message
Evan Goers (megatog615) wrote :

Also, there is a Bugzilla report on kernel.org:

http://bugzilla.kernel.org/show_bug.cgi?id=13002

It looks to be reported by Tiago Requeijo, the reporter of this bug in Launchpad. In the Bugzilla report, they recommend using git-bisect to find which commit caused this regression. I have no idea how to do that, nor do I use the git kernel(I use the linux-source package). Can someone who knows how do this and post the results there(as well as here)?

Revision history for this message
Tiago Requeijo (tiago-requeijo-dev) wrote :

Evan, I haven't had too much free time lately, but I plan on running a git-bisect sometime during the next couple weeks or so. I'll post the results on the kernel bugzilla report.

In the meantime, I've been using the "pci=noacpi" boot parameter, which boots and lets the laptop shutdown properly.

Changed in linux:
status: Unknown → Incomplete
Revision history for this message
pjw (pjw1965) wrote :

I tested the Mainline-Kernels for Ubuntu from http://kernel.ubuntu.com/~kernel-ppa/mainline/:

v2.6.27.20 works fine
v2.6.27.23 does not work

Revision history for this message
Evan Goers (megatog615) wrote :

How about 2.6.27.21 and 2.6.27.22?

Revision history for this message
pjw (pjw1965) wrote :

Correction:

I tested the Mainline-Kernels for Ubuntu from http://kernel.ubuntu.com/~kernel-ppa/mainline/:

v2.6.27.20 works fine
v2.6.27.23 works fine
v2.6.28.1 does not work (first kernel with bug)

Revision history for this message
Tiago Requeijo (tiago-requeijo-dev) wrote :

The results from the git-bisect are at http://bugzilla.kernel.org/show_bug.cgi?id=13002#c17

Revision history for this message
dave b. (d+b) wrote :

My inspiron 2600 is also affected by this problem. I am running debian lenny, the 2.6.26 kernel boots fine. However, i cannot boot a 2.6.29 kernel. I am yet to test the various acpi boot options.

Revision history for this message
Alistair Marshall (thatscottishengineer) wrote :

This bug is marked s incomplete. Why? What information is missing?

I just 'upgraded' my dads laptop and now the system doesn't boot. About to set the grub menu to boot the 2.6.27 kernel unless someone has a better solution.

Revision history for this message
Tiago Requeijo (tiago-requeijo-dev) wrote :

See http://bugzilla.kernel.org/show_bug.cgi?id=13002. You can either revert the faulty patch yourself, wait for ubuntu (or someone else) to package a kernel that has the fix, or use "pci=noacpi" in your kernel parameters.

Changed in linux:
status: Incomplete → In Progress
Revision history for this message
maximilian (nomaxiri) wrote :

I have same boot problem with MSI VX600X notebook,
booting with the "acpi=off" kernel parameter -> normal boot
booting with "acpi=ht" kernel parameter -> normal boot
booting with "nolapic" kernel parameter -> normal boot
booting with "pci=noacpi" kernel parameter -> can't boot
booting with "acpi=noirq" kernel parameter -> can't boot
booting with "pnpacpi=off" kernel parameter -> can't boot
booting with "noapic" kernel parameter -> can't boot

If I would like to revert the faulty patch, how should I do?

Revision history for this message
Evan Goers (megatog615) wrote :

Any update on this bug?

nolapic does not appear to work here with linux-image-2.6.30.

Revision history for this message
maximilian (nomaxiri) wrote :

Kernel 2.6.31-5 (Ubuntu 9.10 Alpha 4) works no parameters needed. Maybe problem solved with reverted patch? I'll wait for kernel.org to release kernel 2.6.31 (now is prepatch).

Revision history for this message
Joshua Coombs (josh-coombs-gmail) wrote :

My 2650 still requires pci=noacpi with 2.6.31-6, and I have yet to get the touchpad working in X with any Karmic alpha, so it looks like there is still work to go on this.

Changed in linux:
status: In Progress → Fix Released
Revision history for this message
Evan Goers (megatog615) wrote :

How does that constitute a fix released? All that was done was a test for reverting the faulty patch against the mainline. Is this change in the mainline kernel as of now? If so, then it is fixed. If not, please don't mark this as fixed.

Eric Drechsel (ericdrex)
Changed in linux:
status: Fix Released → In Progress
Revision history for this message
Eric Drechsel (ericdrex) wrote :

perhaps someone could create a patched kernel package to test, since the conditions seem slightly different in each report. In the case I'm seeing, only acpi=off works.

Changed in linux:
status: In Progress → Fix Released
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
tags: added: 2.6.31.6
Revision history for this message
Stefan Bader (smb) wrote :

My PPA (https://launchpad.net/~stefan-bader-canonical/+archive/karmic/+packages) is currently building 2.6.31-16.51~pre2, which should contain the upstream patch that should fix the problem.

Changed in linux (Ubuntu Karmic):
importance: Undecided → Medium
status: New → Fix Committed
Stefan Bader (smb)
description: updated
panos (djtakis1002)
Changed in linux (Ubuntu):
assignee: nobody → panos (djtakis1002)
Changed in linux (Ubuntu Karmic):
status: Fix Committed → Fix Released
Steve Langasek (vorlon)
Changed in linux (Ubuntu):
assignee: panos (djtakis1002) → nobody
Changed in linux (Ubuntu Karmic):
status: Fix Released → Fix Committed
Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Accepted linux into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Revision history for this message
oliver (oliver-schneider) wrote : Re: kernel 2.6.28 doesn't boot on a dell inspiron 2650

Test result :
- New proposed kernel works fine for me running Karmic on Dell Inspiron 2650.
- Boot is ok. Acpi is working again.
Thanks a lot!

Martin Pitt (pitti)
tags: added: verification-done
removed: verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (11.9 KiB)

This bug was fixed in the package linux - 2.6.31-17.54

---------------
linux (2.6.31-17.54) karmic-proposed; urgency=low

  [ John Johansen ]

  * SAUCE: AppArmor: Fix oops after profile removal
    - LP: #475619
  * SAUCE: AppArmor: Fix Oops when in apparmor_bprm_set_creds
    - LP: #437258
  * SAUCE: AppArmor: Fix cap audit_caching preemption disabling
    - LP: #479102
  * SAUCE: AppArmor: Fix refcounting bug causing leak of creds
    - LP: #479115
  * SAUCE: AppArmor: Fix oops there is no tracer and doing unsafe
    transition.
    - LP: #480112

  [ Leann Ogasawara ]

  * Revert "[Upstream] (drop after 2.6.31) usb-storage: Workaround devices
    with bogus sense size"
    - LP: #461556
  * Revert "[Upstream] (drop after 2.6.31) Input: synaptics - add another
    Protege M300 to rate blacklist"
    - LP: #480144

  [ Tim Gardner ]

  * [Config] udeb: Add squashfs to fs-core-modules
    - LP: #352615

  [ Upstream Kernel Changes ]

  * Revert "e1000e: swap max hw supported frame size between 82574 and
    82583"
    - LP: #461556
  * Revert "drm/i915: Fix FDI M/N setting according with correct color
    depth"
    - LP: #480144
  * Revert "agp/intel: Add B43 chipset support"
    - LP: #480144
  * Revert "drm/i915: add B43 chipset support"
    - LP: #480144
  * Revert "ACPI: Attach the ACPI device to the ACPI handle as early as
    possible"
    - LP: #327499, #480144
  * SCSI: Retry ADD_TO_MLQUEUE return value for EH commands
    - LP: #461556
  * SCSI: Fix protection scsi_data_buffer leak
    - LP: #461556
  * SCSI: sg: Free data buffers after calling blk_rq_unmap_user
    - LP: #461556
  * ARM: pxa: workaround errata #37 by not using half turbo switching
    - LP: #461556
  * tracing/filters: Fix memory leak when setting a filter
    - LP: #461556
  * x86/paravirt: Use normal calling sequences for irq enable/disable
    - LP: #461556
  * USB: ftdi_sio: remove tty->low_latency
    - LP: #461556
  * USB: ftdi_sio: remove unused rx_byte counter
    - LP: #461556
  * USB: ftdi_sio: clean up read completion handler
    - LP: #461556
  * USB: ftdi_sio: re-implement read processing
    - LP: #461556
  * USB: pl2303: fix error characters not being reported to ldisc
    - LP: #461556
  * USB: digi_acceleport: Fix broken unthrottle.
    - LP: #461556
  * USB: serial: don't call release without attach
    - LP: #461556
  * USB: option: Toshiba G450 device id
    - LP: #461556
  * USB: ipaq: fix oops when device is plugged in
    - LP: #461556
  * USB: cp210x: Add support for the DW700 UART
    - LP: #461556
  * USB: Fix throttling in generic usbserial driver
    - LP: #461556
  * USB: storage: When a device returns no sense data, call it a Hardware
    Error
    - LP: #400652, #461556
  * arm, cris, mips, sparc, powerpc, um, xtensa: fix build with bash 4.0
    - LP: #461556
  * intel-iommu: Cope with broken HP DC7900 BIOS
    - LP: #461556
  * futex: Detect mismatched requeue targets
    - LP: #461556
  * futex: Fix wakeup race by setting TASK_INTERRUPTIBLE before queue_me()
    - LP: #461556
  * tpm-fixup-pcrs-sysfs-file-update
    - LP: #461556
  * TPM: fix pcrread
    - LP: #461556
  * Bluetooth: Disconnect HIDRAW devices on disconnect
    - LP...

Changed in linux (Ubuntu Karmic):
status: Fix Committed → Fix Released
Changed in linux:
importance: Unknown → Medium
Revision history for this message
Christopher M. Peñalver (penalvch) wrote :

Tiago Requeijo, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.13-rc1

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

Changed in linux (Ubuntu):
status: Triaged → Incomplete
Edle8 (edle8)
summary: - kernel 2.6.28 doesn't boot on a dell inspiron 2650
+ Dell Inspiron 2650 doesn't boot without acpi=off
Mathew Hodson (mhodson)
tags: added: needs-upstream-testing
removed: 2.6.31.6
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.