Ubuntu

Ubuntu lacks support for Ralink rt2870 based 802.11n chipsets

Reported by Daniele Napolitano on 2009-02-07
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Medium
Manoj Iyer
Declined for Hardy by Tim Gardner
Jaunty
Medium
Manoj Iyer

Bug Description

The Ralink rt2870 802.11n USB driver is provided by Ralink itself:
http://www.ralinktech.com.tw/data/drivers/2008_0925_RT2870_Linux_STA_v1.4.0.0.tar.bz2

Must be activate this make options from /os/linux/config.mk:
HAS_WPA_SUPPLICANT=y
HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y

For support of Sitecom WL-315 USB 802.11n adapter (0df6:0039) must be this patch:

--- rt2870.h 2009-02-07 01:27:09.000000000 +0100
+++ rt2870.h~ 2009-02-07 01:26:58.000000000 +0100
@@ -95,6 +95,7 @@
  {USB_DEVICE(0x0DF6,0x002B)}, /* Sitecom */ \
  {USB_DEVICE(0x0DF6,0x002C)}, /* Sitecom */ \
  {USB_DEVICE(0x0DF6,0x002D)}, /* Sitecom */ \
+ {USB_DEVICE(0x0DF6,0x0039)}, /* Sitecom */ \
  {USB_DEVICE(0x14B2,0x3C06)}, /* Conceptronic */ \
  {USB_DEVICE(0x14B2,0x3C28)}, /* Conceptronic */ \
  {USB_DEVICE(0x2019,0xED06)}, /* Planex Communications, Inc. */

Related branches

Changed in linux:
status: New → Confirmed

Thanks for the bug report Daniele. Just adding a note for the Ubuntu kernel team that this driver is currently in the staging directory. I also glanced at the upstream git tree and it doesn't appear this patch has been accepted into upstream staging yet either.

Daniele, just curious if you also submitted this patch to the upstream kernel? If not, it would be great if you did that as well. For now, I'll close the upstream bug watch associated with this report until we hear back from you. Thanks.

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in linux:
status: New → Invalid
Manoj Iyer (manjo) on 2009-03-16
Changed in linux:
assignee: nobody → manjo
Manoj Iyer (manjo) wrote :

Can you please test the kernel in

http://people.ubuntu.com/~manjo/lp326621-jaunty/

and report back here ?

Thanks

Changed in linux:
status: Triaged → Incomplete
Manoj Iyer (manjo) wrote :

I do not have the hardware to test this fix, so if you can please test this kernel and verify that it works I can submit the patch to ubuntu kernel

Daniele Napolitano (dnax88) wrote :

The problem is that this hardware isn't mine... This patch should be for Jaunty?

description: updated
Tim Gardner (timg-tpi) wrote :
Changed in linux (Ubuntu Jaunty):
milestone: none → ubuntu-9.04-beta
status: Incomplete → Fix Committed
Daniele Napolitano (dnax88) wrote :

Added remote bug watch

Changed in linux:
importance: Undecided → Unknown
status: Invalid → Unknown
Changed in linux:
status: Unknown → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.28-11.36

---------------
linux (2.6.28-11.36) jaunty; urgency=low

  [ Amit Kucheria ]

  * Updating imx51 configs one more time
  * Disable CONFIG_UEVENT_HELPER_PATH

  [ Anton Veretenenko ]

  * SAUCE: sony-laptop: add support for Sony Vaio FW series function/media
    keys
    - LP: #307592

  [ Brad Figg ]

  * Have AUFS use current VFS APIs so it can build with or without
    AppArmor.

  [ Bryan Wu ]

  * Build-in "Ram block device support" to boot up with initramfs
    - LP: #329098
  * Remove brd module from iop32x modules list
    - LP: #329098
  * Increase the CONFIG_BLK_DEV_RAM_SIZE to 8192 on i.MX51

  [ Ike Panhc ]

  * SAUCE: Fixing symbol name in HECI module
    - LP: #336549

  [ Manoj Iyer ]

  * SAUCE: Added quirk for Ralink rt2870 802.11n USB driver
    - LP: #326621

  [ Upstream Kernel Changes ]

  * udf:SAUCE (drop after 2.6.30): Fix oops when invalid character in
    filename occurs
    - LP: #321606

 -- Stefan Bader <email address hidden> Fri, 20 Mar 2009 16:52:08 +0100

Changed in linux:
status: Fix Committed → Fix Released
Siep Kroonenberg (siepo) wrote :

Another RT2870 device which isn't detected: Sweex LW303, device id 177f:0302 according to lsusb.

Daniele Napolitano (dnax88) wrote :

@Siep Kroonenberg: Please report this in a new bug. Since this bug is resolved, no one looks here.

Note: Making patch for it is very simple ;)

Changed in linux:
status: Confirmed → Fix Released
Changed in linux:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.