Wrong firmware selected for a acx111 card

Bug #32602 reported by Ilkka Tuohela on 2006-02-23
8
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Ben Collins

Bug Description

I tested a zyxel G-162 wireless card, and noticed it uses incorrect firmware.
Correct line to load this card is to use firmware_ver=1.2.0.30 at least
for this revision I tested...

Attached is the lspci -vv output for this card, as requested in
/lib/firmware/2.6.15-16-686/acx/readme.txt file.

Sitsofe Wheeler (sitsofe) wrote :

This looks related to Bug #26703

Adam Conrad (adconrad) wrote :

acx firmware selection is handled by the kernel, LRM just ships the binaries.

Changed in linux-restricted-modules-2.6.15:
assignee: nobody → ben-collins
Ilkka Tuohela (hile) wrote :

Yes, it is handled by kernel, but Ubuntu package has this comment in /lib/firmware/2.6.15-19-686/acx/readme.txt:

The acx loads the firmware marked "default", unless you pass it another
version using the firmware_ver=XXXX module parameter. If your card requires other than the default, please file a bug report to Ubuntu with the output of "lspci -vv", "lspci -vvn" and "lsusb".

So, either this bug is to be handled by a ubuntu patch or this readme file is misleading (if the patch should go to upstream kernel).

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this linux-source-2.6.15 kernel bug to the new "linux" package. We appreciate your patience and understanding as we make this transition. Also, if you would be interested in testing the upcoming Intrepid Ibex 8.10 release, it is available at http://www.ubuntu.com/testing . Please let us know your results. Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers