Ubuntu

[Toshiba Satellite L300] suspend/resume problem

Reported by Attila Hammer on 2009-02-03
52
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Fedora)
Won't Fix
Unknown
linux (Ubuntu)
Medium
Unassigned
Nominated for Jaunty by adityaw

Bug Description

Dear Developers!

I sending this bugreport with apport. this bug produced my ToshibA Satellite Pro L300 notebook.

ProblemType: KernelOops
Architecture: i386
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/share/apport/apportcheckresume
FlagFile: suspend
InterpreterPath: /usr/bin/python2.5
OopsText: Suspend/Resume or hibernate problem

Originator: Steve Conklin <email address hidden>
Package: linux-image-2.6.28-6-generic 2.6.28-6.17
ProcAttrCurrent: unconfined
ProcCmdLine: User Name=UUID=b158e650-3ed6-4fa2-9fc1-f84bad804a4b ro quiet splash
ProcCmdline: /usr/bin/python /usr/share/apport/apportcheckresume
ProcEnviron: PATH=(custom, no user)
ProcVersionSignature: Ubuntu 2.6.28-6.17-generic
SourcePackage: linux
StressLog: Error: [Errno 2] No such file or directory: '/var/lib/pm-utils/stress.log'
Tags: suspend resume hibernate
Title: Suspend/Resume or hibernate problem
UserGroups:

Attila Hammer (hammera) wrote :
Adam Niedling (krychek) wrote :

Is this a duplicate of #324805 ?

Changed in linux:
status: New → Incomplete

I think yes, but I not sure, because I using i386 architecture.
But the simptoms are very same with bug 324805 .
So, when I trying suspend my notebook, and after this I would like
resume, impossible using the system, only long power down help.
I don't known what happen with display, because I am a blind person.
When trying resume my notebook, my screen reader is not talking.

Attila

Hi Attila,

I tend to think you have a separate bug than what's reported at bug 324805. The reason I say this is because you have different hardware than that bug reporter. Even you may be experiencing the same symptoms, suspend/resume issue are usually hardware specific. So for now, lets not mark yours as a duplicate. Thanks.

Changed in linux:
importance: Undecided → Medium
status: Incomplete → Triaged

Has suspend/resume ever worked in the past, if so which kernel release (cat /proc/version_signature)? If your screen reader works on the raw console then it is worth switching to VT-1 with control-alt-F1 and logging in there. Trigger the suspend with the command pm-suspend from the prompt there. It is possible that something will appear there.

Changed in linux:
status: Triaged → Incomplete

Kernel version: Ubuntu 2.6.28-7.20-generic

When trying pm-suspend, impossible get back the system when press power
button. My screen reader does'nt talk.
When my wife coming home, we looking what happen the system.

Attila

Andy Whitcroft (apw) wrote :

@Attila -- thanks I understand this must be frustrating.

Changed in linux:
status: Incomplete → In Progress
status: In Progress → Incomplete
Attila Hammer (hammera) wrote :

When trying pm-suspend command:
The display is blank.
If I press power button, not happen nothing, the display is blank, the
system is freeze.

Attila

Andy Whitcroft (apw) on 2009-02-12
Changed in linux:
status: Incomplete → In Progress
status: In Progress → Incomplete
khiraly (khiraly123) wrote :

I have the same problem. My laptop is a Toshiba L300-19J, quite similar to the original reporter.

It suspends correctly, even the power led lights in and lights out constantly.
When I wake it up (using the power button), the power leds lights continously,
and the led of the "FN" key works, but the capslock led doesnt. The display just stays black.

I only tried with 9.04 alpha 4 version (which comes with 2.6.28-6-generic).
Should I try with 2.6.29 kernel? There is a touchpad related problem (two finger scrolling does not work),
and maybe the 2.6.29 kernel recognize correctly. So I will try out the newer kernel
as soon as available in the repository.

khiraly (khiraly123) wrote :

Ok, I tried to follow the https://wiki.ubuntu.com/DebuggingKernelSuspend tutorial.
I initiated this command:
sync; echo 1 > /sys/power/pm_trace; pm-suspend

The computer went to suspend just fine, After I pressed the power button,
and the harddisk led lighted up for one or two second, and after nothing.

So I rebooted, and now I see this in my dmesg:
[code]
[ 20.707383] Using IPI No-Shortcut mode
[ 20.707525] registered taskstats version 1
[ 20.707637] Magic number: 13:588:144
[ 20.707647] block ram9: hash matches
[ 20.707665] acpi device:15: hash matches
[ 20.707706] rtc_cmos 00:03: setting system clock to 2009-02-19 20:07:36 UTC (1235074056)
[ 20.707709] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[/code]

I have looking at lspci, but there is no device 15, or should I convert from dec to hex? So device 15 is actually 0x0f in hex, so should I look at 00:0f.0 ? Because there is no such device either.

Here is my lspci output:
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
03:00.0 Network controller: Intel Corporation Wireless WiFi Link 5100

khiraly (khiraly123) wrote :

I have found the device:15 directory under /sys/devices directory:

/sys/devices/LNXSYSTM:00/device:00/PNP0A08:00/device:14/device:15

-r--r--r-- 1 root root 4096 2009-02-19 21:30 path
drwxr-xr-x 2 root root 0 2009-02-19 21:30 power
lrwxrwxrwx 1 root root 0 2009-02-19 21:25 subsystem -> ../../../../../../bus/acpi
-rw-r--r-- 1 root root 4096 2009-02-19 21:25 uevent

How should I know which driver do I need to unload for further testing?

khiraly (khiraly123) wrote :

I have installed the newest available pre-packaged kernel from here:
http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.29-rc5/

uname -a
Linux lamagep 2.6.29-020629rc5-generic #020629rc5 SMP Sun Feb 15 18:53:03 UTC 2009 i686 GNU/Linux

The resume symptoms is the same as before (the hdd led lights up for a second),
but it also produces a weird sound like trying to spin up the DVD-reader.
When I switch on the laptop it has this weird sound (just didnt notice before), so it is definitly the dvd-reader.
Just when I switch on it spin up twice, but with resume it spin up only once, and after nothing.

There is no hash matches in the dmesg this time. (I suspended with:
sync; echo 1 > /sys/power/pm_trace; pm-suspend )
The magic number:
[ 7.359471] Magic number: 13:187:827

I also attache the lsmod output and the full dmesg.

In my previous comment I forgot to add some more info to the device:15 directory:
cat /sys/devices/LNXSYSTM:00/device:00/PNP0A08:00/device:14/device:15/path

\_SB_.PCI0.EXP3.PXS3

Any hint, how should I debug more? Im willing anything to try out, I buyed this laptop to be a laptop.
(I carefully choosed all components be from intel. I had previously a laptop with nvidia inside)

I do not use any restricted module on my system, so Im hoping I can find the root of this problem with a bit of help.

khiraly (khiraly123) wrote :
khiraly (khiraly123) wrote :

Ok, I tried to unload every possible module, to see if it fails too.
I quit from X, and killed gdm.
And I unload every module what I could.
Here is the output of lsmod:
Module Size Used by
binfmt_misc 8132 1
bnep 12092 2
intel_agp 25916 1
agpgart 35112 1 intel_agp
fuse 56216 1

And the laptop fails the suspend, the same as before.
I dont know what are using for example intel_agp module,
so I cant unload it.

There is a magic number, but no hash match:(
I attache the dmesg output after the failed resume.

khiraly (khiraly123) wrote :

I managed to unload the fuse module too (umount fusectl)

So it suspended, but the resume fails. So it is the same problem as before.

My modules when suspended:
Module Size Used by

binfmt_misc 8132 1
bnep 12092 2
intel_agp 25916 1
agpgart 35112 1 intel_agp

So the bug is either in the kernel, or I suspect the agpgart module too.

Any hint how to remove it (rmmod)? Need to figure out what is using this module.

I really did anything what I could, so need some help/hints how to test this nasty bug more.

Thank you!

khiraly (khiraly123) wrote :

Hi!

I tried disabling the second CPU core. I read on this bug #276943:
" Resume from suspend doesn't work on the Mobile 4 Series chipsets "

I disabled using a script from this forum (comment #12):
http://ubuntuforums.org/showthread.php?p=6105510#post6105510

Didnt help. It failed as before.
I disabled the second core from BIOS, it didnt help either.

It looks like disk does not respond after hibernate/suspend.
(lighting up the hdd led for a second is not really a disk start)

I keep looking/trying it makes me nuts. Would be nice some help however.

khiraly (khiraly123) wrote :

It looks like the problem is with the SATA controller. The relevant line from lspci:
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)

I have found the exact same problem in Redhat bugzilla #476392:
" Suspend and Hibernate don't work on HP DV5T "
https://bugzilla.redhat.com/show_bug.cgi?id=476392

The HP DV5T has the exact same SATA controller, the symptom are the same too.

What is the proper method to notify upstream? Looks like the bug is identified.

khiraly (khiraly123) wrote :

Looks like the problem is with the SATA controller.

Changed in linux:
status: Incomplete → Confirmed
Changed in linux:
status: Unknown → Confirmed

I looked my desktop machine this problem.
Unfortunately, the problem is present, so this is not Toshiba specific
problem. I have got an Asus MPV-Mx motherboard, and Nvidia Geforce 6100
chipset.
I using one 250 GB 7200 RPM sata-II hdd. When I suspend my machine and
try press power button again, the hdd is not spinning up, only long
power button press solving the problem (poweroff my machine).
Another problem: when I try suspend my desktop computer, The power
supply not going stand by.
In Windows xp when I choosing stand by, The power supply powered off
correct.

Next comment I will be send lspci data.

Attila

Hello,

I have a similar problem with my Toshiba L300-19F. My suspicion is that the problem is because these Toshibas are not using Phoenix Bios anymore, but the bios is from "insyde". I believe this BIOS is not handling suspend correctly. Details for my PC:

# dmidecode 2.9
SMBIOS 2.4 present.
35 structures occupying 1491 bytes.
Table at 0x000E8150.

Handle 0x0000, DMI type 0, 24 bytes
BIOS Information
 Vendor: INSYDE
 Version: 1.40
 Release Date: 11/24/2008
 ROM Size: 1024 kB
 Characteristics:
  PCI is supported
  BIOS is upgradeable
  BIOS shadowing is allowed
  Boot from CD is supported
  Selectable boot is supported
  BIOS ROM is socketed
  EDD is supported
  Japanese floppy for NEC 9800 1.2 MB is supported (int 13h)
  Japanese floppy for Toshiba 1.2 MB is supported (int 13h)
  5.25"/360 KB floppy services are supported (int 13h)
  5.25"/1.2 MB floppy services are supported (int 13h)
  3.5"/720 KB floppy services are supported (int 13h)
  3.5"/2.88 MB floppy services are supported (int 13h)
  8042 keyboard services are supported (int 9h)
  CGA/mono video services are supported (int 10h)
  ACPI is supported
  USB legacy is supported
  Targeted content distribution is supported

khiraly (khiraly123) wrote :

Long story short: I succesfully suspend/resume my laptop.

First I suspected, that I have the same problem as these bugreports:
https://bugzilla.redhat.com/show_bug.cgi?id=476392
http://bugzilla.kernel.org/show_bug.cgi?id=12276

And finally it turned out, that it is NOT SATA related.

The bug is somewhere in pm-suspend script (pm-action).
Im unable to figure out what is wrong inside this overcomplicated script,
because it messes with d-bus, and other stuff, and I cant clearly see what programs/kernel calls are issued.

But I can suspend/resume with the following command just fine (need a root shell):
echo -n mem >/sys/power/state

So I ended up creating my custom shell script for suspend/resume, and replaced the pm-action file, it works.

However I have problems with my video card (intel 4500mhd), because the perfomance is poor after resume.
Half in 3D (enemy terrority, compiz aren't smooth anymore, even wesnoth game has issues when panning the screen).

Would be nice if ubuntu could bugfix this broken pm-action script, bacuse it hardfreeze the laptop when resumes (original problem).

Are there any debug logs of pm-action when running? To track down which calls went wrong.

I cant really understand why this script needed in the first place.
The suspend/resume process is clearly a kernel job.

chemamartin (chemamartin) wrote :

It does not seem the same computer. Mine is Toshiba Satellite Pro L300 with Intel ® integrated graphics card 965gm. By using the suspension script the screen does nothing, not even a blinking cursor. We need to press power button 4 seconds to turn off the computer.

Attila Hammer (hammera) wrote :

This method does'nt suspend my computer (Toshiba Satelite L300), only 4
sec power button press help. :-(:-(

What helps with my Toshiba L300 and which may give a clue, is to rmmod (remove) the driver for my network card RTL8187.

so: rmmod rtl8187

When I do that, laptop suspends fine. To also be able to get correctly out of suspend, I have to do

pm-suspend --quirk-s3-mode --quirk-vbe-post

That does the trick. However I don't know how to get this done properly automatically when clicking "suspend" in gnome.

Joe (jaoag) wrote :

To have these quirks applied automatically, you must change the relevant fdi file. (/usr/share/hal/fdi/information/10freedesktop/20-video-quirk-toshiba.fdi)

BACK UP THE FILE BEFORE MAKING ANY CHANGES

add these lines just before the line <!-- these need no quirks -->

<match key="system.hardware.product" contains_outof="L300">
    <merge key="power_management.quirk.vbe_post" type="bool">true</merge>
    <merge key="power_management.quirk.s3_bios" type="bool">false</merge>
</match>

or just apply the attached patch.
sudo patch -p0 <toshiba.patch

Changed in linux (Fedora):
status: Confirmed → Won't Fix
Yuri (oxygenych) wrote :

I have a notebook Toshiba L300-11G. I tried to suspend my laptop in Ubuntu 10.04 beta 2 with kernel 2.6.32, It works perfectly first time, but doesn't resume from suspend next time. Does anyone have the issue?

Have the same issue here with L300, first suspend/hibernate works ok, next time blank screen. I relly don't know why this bug is in "Won't Fix" status. It's really frustrating as supend/hibernate works flawlessly under Windows. None of fixes suggested here made it work. 10.04 final, kernel 2.6.32-24-generic #38-Ubuntu. I am willing to experiment to get it working.

peterwil (peter-william) wrote :

I have the same issue with Suspend/hibernate.. It definitely shows black screen and
no resume regardless of pressing any key sequences.
The only way out is to full hardware reboot through power button.
I had recompiled kernel and have been running 2.6.30 a few months ago.
Hoping that this would be fixed in 10.04.. but looks like we are stuck.. from the
messages above.

Ubuntu is great!. But with the overheating problem and the suspend/resume
on Toshiba L300.. is literally unusable.. Pl. some kernel developers should be
able to clear the acpi module problems .. here..

Larry G. Gagnon (lggagnon) wrote :

I solved both Function Key and fan control problems with my Toshiba Satellite L300 by upgrading my BIOS from version 1.5 to version 2.2. Full description on how to do that here:
https://wiki.archlinux.org/index.php/Toshiba_Satellite_L300

Andy Whitcroft (apw) wrote :

Can anyone confirm whether this issue is still present in Natty? Also I see that BIOS upgrades have been slated to help with this. Please report back here. Thanks!

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Alexander Kabakow (alexzak) wrote :

I have toshiba satelite l300 - 144 laptop with original bios firmware.
Today I've upgraded ubuntu from 10.10 to 11.04, so all packages up to date.

I can say, that I have no problems with suspend/resume. (Don't using suspend feature, so didn't sow it earlier)
Suspend/resume - works for me.

I have overheating problems. I don't think it is ubuntu specific.

Mail me, if you have questions

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.