e1000e-ich9m: no wired ethernet adapter Intel 82567LM Dell E6500 @ ubuntu 8.04

Bug #322737 reported by Supercows on 2009-01-29
26
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Debian
Fix Released
Unknown
linux (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned
linux-ubuntu-modules-2.6.24 (Ubuntu)
Wishlist
Unassigned
Hardy
Undecided
Stefan Bader

Bug Description

SRU Justification:

Impact: Some Intel network cards cannot be used as the IDs are missing from the e1000e driver.

Fix: The patch has been backported from Intrepid and adds the missing IDs to the driver.

Testcase: Boot to Hardy when 82567LM card is present. It is detected with the updated driver, otherwise not.

---

I have made a new ubuntu installation at my new E6500 Dell laptop. Wlan is working but wired lan isnt't working.
I have searched every ware and found much but nothing could help me. I think it is a driver failure ??

uname -a:
Linux lt-666 2.6.24-23-generic #1 SMP Mon Jan 26 01:04:16 UTC 2009 x86_64 GNU/Linux

root@lt-666:/home/rob# lsb_release -rd
Description: Ubuntu 8.04.2
Release: 8.04

l have the output from dmesg see the attachment.

lspc:
root@lt-666:/home/rob# lspci
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:03.0 Communication controller: Intel Corporation Mobile 4 Series Chipset MEI Controller (rev 07)
00:03.2 IDE interface: Intel Corporation Mobile 4 Series Chipset PT IDER Controller (rev 07)
00:03.3 Serial controller: Intel Corporation Mobile 4 Series Chipset AMT SOL Redirection (rev 07)
00:19.0 Ethernet controller: Intel Corporation 82567LM Gigabit Network Connection (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M-E LPC Interface Controller (rev 03)
00:1f.2 RAID bus controller: Intel Corporation Mobile 82801 SATA RAID Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
03:01.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ba)
03:01.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 04)
03:01.2 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 21)
03:01.3 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev 11)
0c:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g (rev 01)

lshw:
root@lt-666:/home/rob# lshw -C network
  *-network UNCLAIMED
       description: Ethernet controller
       product: 82567LM Gigabit Network Connection
       vendor: Intel Corporation
       physical id: 19
       bus info: pci@0000:00:19.0
       version: 03
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi cap_list
       configuration: latency=0
  *-network
       description: Wireless interface
       product: BCM4312 802.11b/g
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:0c:00.0
       logical name: wlan0
       version: 01
       serial: 00:22:5f:1d:81:55
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=wl0 driverversion=5.10.27.12 ip=10.3.6.73 latency=0 module=wl multicast=yes wireless=IEEE 802.11bg
root@lt-666:/home/rob#

In Udev 70 the adapter is also not found.

What do i need to do to get my wired adapter working?

Supercows (rob-onland) wrote :
Supercows (rob-onland) wrote :

I have tried ubuntu 8.10 and I have the problems there alos. I get the same output from lshw. -> UNCLAIMED network.

Raghav Puranmalka (raghavp) wrote :

I have Ubuntu 8.10. I am receiving the same output as above.

Florian Dorn (florian-dorn) wrote :

Same here, but with:
lsb_release -rd
Description: Ubuntu 8.04.2
Release: 8.04

  *-network UNCLAIMED
       description: Ethernet controller
       product: 82567LM-3 Gigabit Network Connection
       vendor: Intel Corporation
       physical id: 19
       bus info: pci@0000:00:19.0
       version: 02
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi cap_list
       configuration: latency=0

Chad Pembleton (cpembleton) wrote :

Had same issue with Optiplex 760. Below is a link to the download for the linux 2.6 driver for this nic.

Works like a champ.

Ubuntu 8.0.4 x64

http://downloadcenter.intel.com/confirm.aspx?httpDown=http://downloadmirror.intel.com/15817/eng/e1000e-0.5.18.3.tar.gz&agr=&ProductID=3003&DwnldId=15817&strOSs=&OSFullName=&lang=eng

I confirm: driver for Intel® 82567 Gigabit Ethernet Controller (default embedded nic of the Optiplex 760) is not in base ubuntu 8.04.2 LTS kernel (2.6.24-23).

You have to :
 * apt-get install build-essential linux-libc-dev linux-headers-2.6.24-23-server
 * download the Intel driver source from Intel.com (see link above)
 * tar zxvf ... cd e1000e-0.5.18.3/src/ && sudo make CFLAGS_EXTRA=-DDISABLE_PCI_MSI install
 * then add 'e1000e' to your /etc/modules and reboot

It should be nice to have this driver integrated in the ubuntu kernel for 8.04.3 ? :)

Fabián Rodríguez (magicfab) wrote :

Confirming this. I also found an upstream bug report in Debian, which I linked. I am also using an Optiplex 760.

lspci -nn shows:
00:19.0 Ethernet controller [0200]: Intel Corporation 82567LM-3 Gigabit Network Connection [8086:10de] (rev 02)

I'll most probably file an SRU or backports request, not sure why.

I am told there a power-saving feature in this card that makes it invisible unless using Windows drivers, I am looking into this. I'd rather not use any manually installed or compiled drivers, as I require long term support (LTS :)

Changed in linux (Ubuntu):
status: New → Confirmed
Changed in debian:
status: Unknown → New
Fabián Rodríguez (magicfab) wrote :

In my previous comment I meant to write "not sure which" :) Sorry.

Fabián Rodríguez (magicfab) wrote :

For the record, I just tested this in Intrepid using a live CD and it worked just fine.

Stefan Bader (smb) wrote :

We have an e1000e driver in Hardy LUM, so it would be a SRU. We will need to check how much change would be required to get that particular hardware working with that.

Changed in linux (Ubuntu):
assignee: nobody → Stefan Bader (stefan-bader-canonical)

I'm getting this on a HP d7900eC Workstation. Has there been any movement tog et the driver included Stefan ?

Stefan Bader (smb) wrote :

Sorry, got a bit sidetracked by other issues. It looks like there might be a small change to allow devices with the IDs 8086:10de and 8086:10df. I build a test package with it at placed it at http://people.ubuntu.com/~smb/bug322737/.
If that works, then this would look like a SRU acceptable change. Please let me know.

Stefan Bader (smb) wrote :

As the card is working in Intrepid (with the in-kernel driver), I change the linux status to released. For Hardy the e1000e driver is in LUM.

Changed in linux-ubuntu-modules-2.6.24 (Ubuntu):
assignee: nobody → Stefan Bader (stefan-bader-canonical)
importance: Undecided → Wishlist
status: New → In Progress
Changed in linux (Ubuntu):
assignee: Stefan Bader (stefan-bader-canonical) → nobody
status: Confirmed → Fix Released
Stefan Bader (smb) wrote :

Anybody had tried the Hardy test package who would be able to give feedback here?

Simeon Walker (simeon-walker) wrote :

Unfortunately (for this bug) the installations I was having trouble with have been moved into virtual machines.

I have tested this. It does work on my HP7900. Is there any info you want from the test?

-stephen

Stephen Lien Harrell wrote:
> I have tested this. It does work on my HP7900. Is there any info you
> want from the test?
>
> -stephen
>

Hi Stephen,

no thanks, as this is a either it works or not problem, this is exactly the
info I was looking for. Thanks.

Frye (samuli-jarvinen) wrote :

Hi,

Could you please also create an udeb to be used with the installer.

Thanks in advance,

glance (glance-acc) wrote :

Hi.

I have teseted this fix on a HP dc7900 and it works.

My guess is that this fix should be going into the e1000e driver in the linux-backports-modules package or just update the e1000e driver there to a newer version from intel.

Anyone of them works for me.

Stefan Bader (smb) wrote :

As this requires only a few additional IDs to be added to the driver, I have added this to the updated linux-ubuntu-modules and uploaded today. It will be first available in proposed (or you can get it from my Hardy PPA https://launchpad.net/~stefan-bader-canonical/+archive/hardy).

Changed in linux-ubuntu-modules-2.6.24 (Ubuntu):
status: In Progress → Fix Committed
Stefan Bader (smb) on 2009-09-08
description: updated
Martin Pitt (pitti) wrote :

Accepted linux-ubuntu-modules-2.6.24 into hardy-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in linux (Ubuntu Hardy):
status: New → Invalid
Changed in linux-ubuntu-modules-2.6.24 (Ubuntu):
assignee: Stefan Bader (stefan-bader-canonical) → nobody
status: Fix Committed → Invalid
Changed in linux-ubuntu-modules-2.6.24 (Ubuntu Hardy):
assignee: nobody → Stefan Bader (stefan-bader-canonical)
status: New → Fix Committed
tags: added: verification-needed
glance (glance-acc) wrote :

Tested the package in proposed and it works like a charm.

Martin Pitt (pitti) on 2009-09-18
tags: added: verification-done
removed: verification-needed
Martin Pitt (pitti) wrote :

Accepted linux into hardy-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-ubuntu-modules-2.6.24 - 2.6.24-24.41

---------------
linux-ubuntu-modules-2.6.24 (2.6.24-24.41) hardy-proposed; urgency=low

  [Stefan Bader]

  * SAUCE: igb-next: Fix up the makefile to actually do a build
    - LP: #352440

linux-ubuntu-modules-2.6.24 (2.6.24-24.40) hardy-proposed; urgency=low

  [AceLan Kao]

  * SAUCE: Fix the MIC of the Lenovo webcam problem
    - LP: #310760

  [Stefan Bader]

  * Merge WEXT scan capabilities to iwlwifi
    - LP: #200950
  * SAUCE: Add support in e1000e for a couple of ICH10 PCI IDs
    - LP: #322737
  * Add standalone Intel igb driver as igb-next to support 82576 cards
    - LP: #352440

 -- Stefan Bader <email address hidden> Mon, 14 Sep 2009 21:05:16 +0200

Changed in linux-ubuntu-modules-2.6.24 (Ubuntu Hardy):
status: Fix Committed → Fix Released
Changed in debian:
status: New → Fix Committed
Changed in debian:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.