[Intrepid] Update kernel to Linux 2.6.27.12

Bug #321472 reported by Stefan Bader on 2009-01-26
8
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Stefan Bader
Intrepid
Medium
Stefan Bader

Bug Description

SRU justification:

Impact: Many bug fixes imported from upstream stable tree (2.6.27.12)

Fix:
* Linux 2.6.27.12
* PCI PM: Split PCI Express port suspend-resume
* PCI: handle PCI state saving with interrupts disabled
* PCI: Suspend and resume PCI Express ports with interrupts disabled
* PCI: Rework default handling of suspend and resume
* x86: fix RIP printout in early_idt_handler
* x86, cpa: dont use large pages for kernel identity mapping with DEBUG_PAGEALLOC
* x86: avoid theoretical vmalloc fault loop
* USB: storage: recognizing and enabling Nokia 5200 cell phoes
* USB: storage: extend unusual range for 067b:3507
* USB: another unusual_devs entry for another bad Argosy storage device
* powerpc: Disable Collaborative Memory Manager for kdump
* nfs: remove redundant tests on reading new pages
* mvsas: increase port type detection delay to suit Seagate's 10k6 drive ST3450856SS 0003
* mm lockless pagecache barrier fix
* mm: fix assertion
* ibmvfc: Improve async event handling
* ibmvfc: Delay NPIV login retry and add retries
* fs: symlink write_begin allocation context fix
* fix switch_names() breakage in short-to-short case
* eCryptfs: check readlink result was not an error before using it
* e1000e: fix IPMI traffic
* s390 specific system call wrappers
* System call wrappers part 33
* System call wrappers part 32
* System call wrappers part 31
* System call wrappers part 30
* System call wrappers part 29
* System call wrappers part 28
* System call wrappers part 27
* System call wrappers part 26
* System call wrappers part 25
* System call wrappers part 24
* System call wrappers part 23
* System call wrappers part 22
* System call wrappers part 21
* System call wrappers part 20
* System call wrappers part 19
* System call wrappers part 18
* System call wrappers part 17
* System call wrappers part 16
* System call wrappers part 15
* System call wrappers part 14
* System call wrappers part 13
* System call wrappers part 12
* System call wrappers part 11
* System call wrappers part 10
* System call wrappers part 09
* System call wrappers part 08
* System call wrappers part 07
* System call wrappers part 06
* System call wrappers part 05
* System call wrappers part 04
* System call wrappers part 03
* System call wrappers part 02
* System call wrappers part 01
* System call wrapper special cases
* s390: enable system call wrappers
* powerpc: Enable syscall wrappers for 64-bit
* System call wrapper infrastructure
* Make sys_syslog a conditional system call
* Make sys_pselect7 static
* Remove __attribute__((weak)) from sys_pipe/sys_pipe2
* Rename old_readdir to sys_old_readdir
* Convert all system calls to return a long
* Move compat system call declarations to compat header file
* inotify: fix type errors in interfaces
* x86, UV: remove erroneous BAU initialization
* x86: fix incorrect __read_mostly on _boot_cpu_pda
* x86: default to SWIOTLB=y on x86_64
* USB: unusual_devs.h additions for Pentax K10D
* USB: isp1760: use a specific PLX bridge instead of any bdridge
* USB: emi26: fix oops on load
* SCSI: eata: fix the data buffer accessors conversion regression
* SCSI: aha152x_cs: Fix regression that keeps driver from using shared interrupts
* sched_clock: prevent scd->clock from moving backwards, take #2
* minix: fix add link's wrong position calculation
* md: fix bitmap-on-external-file bug.
* iwlwifi: use GFP_KERNEL to allocate Rx SKB memory
* ioat: fix self test for multi-channel case
* dm raid1: fix error count
* dm log: fix dm_io_client leak on error paths
* devices cgroup: allow mkfifo
* cgroups: fix a race between cgroup_clone and umount
* ALSA: hda - Add quirk for HP6730B laptop
* ALSA: caiaq - Fix Oops with MIDI

Stefan Bader (smb) on 2009-01-26
Changed in linux:
assignee: nobody → stefan-bader-canonical
importance: Undecided → Medium
status: New → In Progress
Stefan Bader (smb) on 2009-01-26
Changed in linux:
status: In Progress → Fix Committed
Steve Langasek (vorlon) wrote :

Accepted linux into intrepid-proposed; please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Rick Gabriel (klaxian1) wrote :

When using the new 2.6.27-12 kernel, my keyboard and mouse stops responding after logging into X. To clarify, they do work on the login screen, but that's it. The only thing changed was the new kernel. Booting from 2.6.27-11 works normally. If it helps, I am running a Lenovo T61 laptop with an amd64 system. Please let me know if I should create a new bug report for this. Thanks.

Stefan Bader (smb) wrote :

@klaxian, yes please create a new bug. Include what gfx driver you are using. And if you have an alternate computer, maybe you can try to see whether you can login with ssh to see whether there are unusual dmesg messages or perhaps something in top hogging cpu.

Rick Gabriel (klaxian1) wrote :

It seems to be working normally now from a cold start. I'm not sure why the problem occurred in the first place. I will post a new bug report if it happens again.

Approved Intrepid nomination and set it to Fix Committed while these patches make their way through intrepid-proposed. Will set the actively developed linux task to Fix Released as these are already included in the latest 2.6.28-11.42 Jaunty kernel.

Changed in linux (Ubuntu Intrepid):
assignee: nobody → Stefan Bader (stefan-bader-canonical)
importance: Undecided → Medium
status: New → Fix Committed
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (27.1 KiB)

This bug was fixed in the package linux - 2.6.27-14.33

---------------
linux (2.6.27-14.33) intrepid-proposed; urgency=low

  [Stefan Bader]

  * Fix FTBS due to a mysteriously missing ABI directory.

linux (2.6.27-14.32) intrepid-proposed; urgency=low

  [Stefan Bader]

  * Rebuild of 2.6.27-14.30 with 2.6.27-11.31 security patches applied

linux (2.6.27-14.30) intrepid-proposed; urgency=low

  [ Alexey Starikovskiy ]

  * SAUCE: ACPI: EC: Limit workaround for ASUS notebooks even more
    - LP: #288385

  [ Huaxu Wan ]

  * SAUCE: report rfkill changes event if interface is down
    - LP: #193970

  [ Scott James Remnant ]

  * SAUCE: floppy: Provide a PnP device table in the module.
    - LP: #255651

  [ Steve Beattie ]

  * fix apparmor memory leak on deleted file ops
    - LP: #329489

  [ Stefan Bader ]

  * Revert "ACPI: Fix compiler warnings introduced by 32 to 64 bit acpi
    conversions"
    - LP: #337019
  * Revert "ACPI: Change acpi_evaluate_integer to support 64-bit on 32-bit
    kernels"
    - LP: #337019

  [ Upstream Kernel Changes ]

  * KVM: MMU: Add locking around kvm_mmu_slot_remove_write_access()
    - LP: #335097, #333409
  * ricoh_mmc: Handle newer models of Ricoh controllers
    - LP: #311932

linux (2.6.27-13.29) intrepid-proposed; urgency=low

  [ Colin Ian King ]

  * SAUCE: Bluetooth USB: fix kernel panic during suspend while streaming
    audio to bluetooth headset
    - LP: #331106, #322082

  [ Stefan Bader ]

  * Revert "SAUCE: Work around ACPI corruption upon suspend on some Dell
    machines." (replaced by stable update)
    - LP: #330200
  * Revert "SAUCE: Add back in lost commit for Apple BT Wireless Keyboard"
    (replaced by stable update)
    - LP: #330902

  [ Upstream Kernel Changes ]

  * Revert "vt: fix background color on line feed"
    - LP: #330200
  * ti_usb_3410_5052: support alternate firmware
    - LP: #231276
  * fuse: destroy bdi on umount
    - LP: #324921
  * fuse: fix missing fput on error
    - LP: #324921
  * fuse: fix NULL deref in fuse_file_alloc()
    - LP: #324921
  * inotify: clean up inotify_read and fix locking problems
    - LP: #324921
  * mac80211: decrement ref count to netdev after launching mesh discovery
    - LP: #324921
  * sysfs: fix problems with binary files
    - LP: #324921
  * x86, mm: fix pte_free()
    - LP: #324921
  * alpha: nautilus - fix compile failure with gcc-4.3
    - LP: #324921
  * it821x: Add ultra_mask quirk for Vortex86SX
    - LP: #324921
  * libata: pata_via: support VX855, future chips whose IDE controller use
    0x0571
    - LP: #324921
  * rtl8187: Add termination packet to prevent stall
    - LP: #324921
  * serial_8250: support for Sealevel Systems Model 7803 COMM+8
    - LP: #324921
  * SUNRPC: Fix a memory leak in rpcb_getport_async
    - LP: #324921
  * SUNRPC: Fix autobind on cloned rpc clients
    - LP: #324921
  * USB: fix char-device disconnect handling
    - LP: #324921
  * USB: storage: add unusual devs entry
    - LP: #324921
  * USB: usbmon: Implement compat_ioctl
    - LP: #324921
  * ALSA: hda - add another MacBook Pro 4, 1 subsystem ID
    - LP: #324921
  * ALSA: hda - Add quirk for HP DV6700 laptop
    - LP: #324921
  * ALSA: ...

Changed in linux (Ubuntu Intrepid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers