Missing pata_cs5535 module for geode based controllers

Bug #318805 reported by Alan Pope 🍺🐧🐱 πŸ¦„ on 2009-01-19
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Leann Ogasawara

Bug Description

Binary package hint: debian-installer

The netinst (and I believe alternate) CD is missing the pata_cs5535 ATA driver which is used in the ION 503 and rebadged Viglen MPC-L devices. This prevents the installer from being able to 'see' the local hard disk, and this makes it difficult to install.

I plucked the pata_cs5535.ko from /lib/modules/2.6.27-7-generic/kernel/drivers/ata/pata_cs5535.ko from another machine that was already running 2.6.27-7 (the version of the kernel on the netinst iso I used) and ran depmod -a. I then inserted the module and the disk sparked into life, whereupon I could complete the install.

Could pata_cs5535.ko please be added to the next build of the iso images?

Colin Watson (cjwatson) wrote :

The modules are delivered to the installer by the kernel build process, and so it's the kernel that needs to be changed here.

Changed in linux:
importance: Undecided → Medium
status: New → Triaged
Changed in linux:
assignee: nobody → ben-collins
status: Triaged → In Progress
Changed in linux:
assignee: ben-collins → ubuntu-kernel-team
status: In Progress → Triaged
Matt Daubney (daubers) wrote :

This problem still exists in the netboot for the current Jaunty Beta. Following the above instructions worked as a work around. This is using 2.6.28-11-generic

zzz (oldman-deactivatedaccount) wrote :

Hit this bug today whilst clean formatting a Viglen MPC-L using the netboot installer from Jaunty's final release to do a NetbootInstallFromInternet

Linux and initrd.gz from http://archive.ubuntu.com/ubuntu/dists/jaunty/main/installer-i386/current/images/netboot/ubuntu-installer/i386/

It would be nice if this could be fixed for Karmic.

Changed in linux (Ubuntu):
assignee: Ubuntu Kernel Team (ubuntu-kernel-team) → Leann Ogasawara (leannogasawara)
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.31-5.24

---------------
linux (2.6.31-5.24) karmic; urgency=low

  [ Amit Kucheria ]

  * ARM: IMX51: Make video capture drivers compile
  * [Config] IMX51: Config updates

  [ Andy Whitcroft ]

  * remove leftovers of dm-bbr

  [ Leann Ogasawara ]

  * Add pata_cs5535 to pata-modules
    - LP: #318805

  [ Luke Yelavich ]

  * [Config] CONFIG_PPC64=y for powerpc64-smp
  * [Config] Set the maximum number of CPUs to 1024 for powerpc64-smp
  * [Config] CONFIG_PPC_PS3=y for powerpc64-smp
  * [Config] CONFIG_PPC_MAPLE=y on powerpc64-smp
  * [Config] CONFIG_PPC_PASEMI=y on powerpc64-smp
  * [Config] CONFIG_CPU_FREQ_PMAC64=y on powerpc64-smp
  * [Config] Enable all PS3 drivers in powerpc64-smp

  [ Mario Limonciello ]

  * LIRC -- fix lirc-i2c 2.6.31 compilation

  [ Matthew Garrett ]

  * [Upstream] dell-laptop: Fix rfkill state queries

  [ Tim Gardner ]

  * [Config] Ignore armel ABI and module changes
  * [Config] Update configs after rebase against 2.6.31-rc5

  [ Upstream ]

  * Rebased to 2.6.31-rc5

 -- Andy Whitcroft <email address hidden> Tue, 28 Jul 2009 10:10:09 +0100

Changed in linux (Ubuntu):
status: In Progress → Fix Released
Martin-Γ‰ric Racine (q-funk) wrote :

Actually, the correct option for pata_cs5535 is CONFIG_PATA_CS5535=y, rather than =m.

Hi popey,

Would be great if you could test and confirm this is now resolved for you. Thanks.

Leann, Could I test this with a karmic daily server image? If not which one?

Indeed the karmic daily server image I think should work.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers