all_generic_ide boot option no longer working with 2.6.28-4.9

Bug #315006 reported by Bogdan Gribincea on 2009-01-08
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by Bogdan Gribincea

Bug Description

My motherboard's (ASRock P45XE) PATA controller only works when i use the all_generic_ide option. At least it did up to 2.6.28-4.6. Since updating to 2.6.28-4.9 this workaround stopped working.

Let me know if i can provide further information.
Thank you.

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: linux-image-2.6.28-4-generic 2.6.28-4.9
ProcCmdLine: root=UUID=81942248-db70-46ef-97df-836006aad399 ro rootfstype=ext4 vga=791 all_generic_ide nohz=off elevator=anticipatory
ProcEnviron:
 LANGUAGE=en_US
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.28-4.9-generic
SourcePackage: linux

My PATA IDE device seems to only be 'supported' by the pata_acpi and ata_generic drivers. pata_acpi loads but doesn't detect the device so i need a way to load ata_generic instead.

In the 2.6.28-4.6 kernel the IDE drivers were modules, 4.9 has them compiled into the kernel and i couldn't find a way to disable pata_acpi.

Valmantas Palikša (walmis) wrote :

This affects me too. My old box doesn't work with libata, it gives revalidation errors and fails to boot, therefore i build my own amd74xx module and blacklist the libata ones, unfortunately this no longer works.

Igor Wojnicki (wojnicki) wrote :

It seems that ata_generic.ko is missing! It has not been built. Please correct it, since it breaks some older hardware.

It affects me too!

Temporary workaround: install linux-image-386, there is ata_generic.ko compiled with it, so it will work.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers