[intrepid] proposed 2.6.27-11.22 kernel breaks t61 lcd brightness

Bug #314119 reported by Steve Beattie on 2009-01-05
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Andy Whitcroft

Bug Description

The kernel currently in intrepid-proposed, 2.6.27-11.22, causes the brightness settings on my lenovo t61 laptop to no longer work. Altering the LCD brightness settings while running the kernel in intrepid-updates, 2.6.27-10.20, does work.

One thing that's different between the two kernels is that in the -10.20 kernel, there are two directories under /proc/acpi/video/, VID/ and VID1/; however in the -11.22 kernel, only the VID/ directory exists. echo'ing data into /proc/acpi/video/VID/LCD0/brightness on either kernel does nothing to change the screen brightness (but does change the value reported in that /proc entry), but in the -10.20 kernel, writing values to the brightness file under the VID1/ tree (i.e. writing to /proc/acpi/video/VID1/LCD0/brightness) *does* change the screen's brightness.

Writing values to the files under /sys/devices/virtual/backlight/acpi_video0/ in the -11.22 kernel also has no effect (except to change the reported value).

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 8.10
Package: linux-image-2.6.27-11-generic 2.6.27-11.22
ProcCmdLine: root=UUID=ab7c1e48-2b72-48b9-8a34-e17be5fea3b6 ro quiet vga=0x031b
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/opt/wabi/bin:/usr/sbin:/sbin:/home/username/bin:/home/username/bin/j2sdk:/usr/games:/opt/wabi/bin:/usr/sbin:/sbin:/home/username/bin:/home/username/bin/j2sdk:/usr/games:/opt/wabi/bin:/usr/sbin:/sbin:/home/username/bin:/home/username/bin/j2sdk:/usr/games
 LANG=en_US.UTF-8
 SHELL=bash
ProcVersionSignature: Ubuntu 2.6.27-11.22-generic
SourcePackage: linux

Steve Beattie (sbeattie) wrote :

Hi Steve,

I don't suppose you'd be willing to do a git bisect to help narrow down the patch? 2.6.27-11.21 pulled in the upstream 2.6.27.8 and 2.6.27.9 stable patch sets - bug 308761 . 2.6.27-11.22 pulled in the 2.6.27.10 stable patch set - bug 309731 . You might even want to just quickly test the 2.6.27-11.21 build to try to quickly narrow down which patch set to focus on - https://edge.launchpad.net/ubuntu/intrepid/i386/linux-image-2.6.27-11-generic/2.6.27-11.21 . I'll post comments to bug 308761 and 309731 about this regression. Thanks.

Changed in linux:
importance: Undecided → High
status: New → Triaged

Hi Leann,

On Tue, Jan 06, 2009 at 06:41:23PM -0000, Leann Ogasawara wrote:
> I don't suppose you'd be willing to do a git bisect to help narrow down
> the patch? 2.6.27-11.21 pulled in the upstream 2.6.27.8 and 2.6.27.9
> stable patch sets - bug 308761 . 2.6.27-11.22 pulled in the 2.6.27.10
> stable patch set - bug 309731 . You might even want to just quickly
> test the 2.6.27-11.21 build to try to quickly narrow down which patch
> set to focus on - https://edge.launchpad.net/ubuntu/intrepid/i386/linux-
> image-2.6.27-11-generic/2.6.27-11.21 . I'll post comments to bug 308761
> and 309731 about this regression. Thanks.

I tested 2.6.27-11.21 and brightness adjustments were broken there
as well. It seems quite likely to be a regression introduced by the
fixes for bug 257827; per the discussion with apw in that bug, adding
"options thinkpad_acpi brightness_enable=1" to /etc/modprobe.d/options
as a workaround causes the brightness settings to work again.

apw did ask that I test with a Jaunty kernel to see if the problem exists
there as well; is there any tips or tricks to installing a jaunty kernel
on intrepid? Otherwise I suppose I could boot one of the jaunty livecds.

Thanks.

Andy Whitcroft (apw) on 2009-01-07
Changed in linux:
assignee: nobody → apw
status: Triaged → In Progress
Andy Whitcroft (apw) wrote :

Could you test the kernels at the URL below, it seems that some BIOSen have bad ACPI brightness interfaces which will now be being used, this kernel should detect and ignore these. It would be good to know if this fixes your issues:

    http://people.ubuntu.com/~apw/lp311716-intrepid/

For testing the Jaunty kernel you should be able to pick up the raw kernel .deb directly from the pool.

Stefan Bader (smb) wrote :

Steve, could you post the DMI info for your laptop (dmidecode), so we can add an an exception for it? Thanks.

Stefan Bader (smb) wrote :

Oops, should have updated the bug before posting. Steve, if the kernel from Andy works, then the dmi info is not required.

Steve Beattie (sbeattie) wrote :

Andy,

I tested the kernel at http://people.ubuntu.com/~apw/lp311716-intrepid/
(after disabling the thinkpad_acpi brightness_enable module option)
and brightness controls do indeed work with that kernel. Thanks!
It results in there only being thinkpad_screen/ under
/sys/devices/virtual/backlight/.

Oddly, I also tried the current jaunty kernel, 2.6.28-4.9, (on
intrepid) and gnome-power-manager is able to adjust brightness levels
with that kernel somehow, despite both the /proc/acpi/video and
/sys/devices/virtual/backlight/acpi_video0/ interfaces not doing anything.

Thanks again!

Launchpad Janitor (janitor) wrote :
Download full text (16.6 KiB)

This bug was fixed in the package linux - 2.6.27-11.25

---------------
linux (2.6.27-11.25) intrepid-proposed; urgency=low

  [ Jeff Layton ]

  * SAUCE: cifs: make sure we allocate enough storage for socket address
    - LP: #318565

linux (2.6.27-11.24) intrepid-proposed; urgency=low

  [ Stefan Bader ]

  * Revert "SAUCE: don't use buggy _BCL/_BCM/_BQC for backlight control"
    - LP: #311716
  * SAUCE: acpi: Hack to enable video and vendor backlight implementations
    - LP: #311716
  * SAUCE: Force vendor backlight control on ThinkPad T61
    - LP: #311716

  [ Upstream Kernel Changes ]

  * Revert "thinkpad_acpi: fingers off backlight if video.ko is serving
    this functionality"
    - LP: #311716

linux (2.6.27-11.23) intrepid-proposed; urgency=low

  [ Andy Whitcroft ]

  * SAUCE: don't use buggy _BCL/_BCM/_BQC for backlight control
    - LP: #311716, #314119

  [ Jim Lieb ]

  * SAUCE: atl2: add tx bytes statistic
    - LP: #268622

  [ Upstream Kernel Changes ]

  * i915: Save/restore MCHBAR_RENDER_STANDBY on GM965/GM45
    - LP: #276943

linux (2.6.27-11.22) intrepid-proposed; urgency=low

  [ Andy Whitcroft ]

  * Revert "synchronise our linux-libc-dev with the kernel userspace
    headers". It was causing regressions.
    - LP: #300803

  [ Brian Rogers ]

  * SAUCE: Add support for MSI TV@nywhere Plus remote
    - LP: #281647

  [ Tim Gardner ]

  * SAUCE: Dell laptop digital mic does not work, PCI 1028:0271
    - LP: #309508

  [ Upstream Kernel Changes ]

  * Revert "sched_clock: prevent scd->clock from moving backwards"
  * AMD IOMMU: enable device isolation per default
  * bonding: fix miimon failure counter
  * x86 Fix VMI crash on boot in 2.6.28-rc8
  * libata: fix Seagate NCQ+FLUSH blacklist
  * e1000e: fix double release of mutex
  * can: Fix CAN_(EFF|RTR)_FLAG handling in can_filter
  * can: omit received RTR frames for single ID filter lists
  * iwlwifi: clean key table in iwl_clear_stations_table function
  * net: eliminate warning from NETIF_F_UFO on bridge
  * unicode table for cp437
  * console ASCII glyph 1:1 mapping
  * key: fix setkey(8) policy set breakage
  * firewire: fw-ohci: fix IOMMU resource exhaustion
  * ieee1394: add quirk fix for Freecom HDD
  * SUNRPC: Fix a performance regression in the RPC authentication code
  * b1isa: fix b1isa_exit() to really remove registered capi controllers
  * macfb: Do not overflow fb_fix_screeninfo.id
  * setup_per_zone_pages_min(): take zone->lock instead of zone->lru_lock
  * xilinx_hwicap: remove improper wording in license statement
  * Linux 2.6.27.10 except for "iwlagn: fix RX skb alignment". Besides causing
    an ABI bump it only applies to machines using > 4K page size (such as PowerPC).
    Pick this one up on the next ABI bumping upload.
    - LP: #309731

linux (2.6.27-11.21) intrepid-proposed; urgency=low

  [ Andy Whitcroft ]

  * synchronise our linux-libc-dev with the kernel userspace headers
    - LP: #300803

  [ Jim Lieb ]

  * SAUCE: [PATCH 1/1] USB: Unusual devs patch for Nokia 5610
    - LP: #287701

  [ Michael Krufky ]

  * sms1xxx: use new firmware for Hauppauge WinTV MiniStick
    - LP: #299671
  * sms1xxx: add autodetection support for Hauppa...

Changed in linux:
status: In Progress → Fix Released
A.Kromic (akromic) wrote :

How is this a duplicate of bug #311716, when this bug is about brightness controls _not_working_ (happens to me too) and the other bug concerns _inverted_controls_ (doesn't hapen to me) which is something completely different?

Charlie DeTar (chazen) wrote :

Hi akromic,

I am not a maintainer and am not sure about the justifications, but I also reported a bug regarding brightness controls not working which was marked as a duplicate of #311716. Buried among the many comments of that bug are suggestions that it be renamed something more general like "problems with brightness after kernel update" rather than the misleading name regarding inverted brightness, so I would surmise that both problems are related to the same changes in the kernel and will be fixed by the same patch.

Following the suggestions in comments on that bug, I was able to work around the brightness controls not working on my Lenovo X61s by adding the following to /etc/modprobe.d/options:

options thinkpad_acpi brightness_enable=1

Charlie

Stefan Hammer (j-4) wrote :

Thanks Charlie! With your workaround my brightness level works correct now!
I had the problem, that after starting ubuntu, or after suspend/hibernate/screen-off my brightness was on lowest level, which peeved a lot. You always had to change brightness level to jump back to previous setting.
thank you!

Jango

A.Kromic (akromic) wrote :

Actually, this bug seems to be duplicate of bug #313231, rather than bug #311716. Bug #313231 deals with exactly this problem, and it has several duplicates like this one.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers