Ubuntu

Regression: bug: int 14 cr2... booting 2.6.28 in jaunty fails on ASUS P5q and maybe others

Reported by Jouni Mettala on 2008-12-30
44
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Tim Gardner
Nominated for Jaunty by Benjamin Bender

Bug Description

With recent Kernel (2.6.28) just after starting a Kernel from grub i see:

BUG Int 14 : CR2 ffb41000
             EDI ffb40710 ESI 000008f0 EBP c04c3f08 ESP c04c3ee0
             EBX ffb40fff EDX 00000000 ECX ffb40ffb EAX ffb41000
             err 00000000 EIP c02ddfa1 cs 00000000 flg 00010046
STACK etc.

Older kernels (2.6.27) work well.

i have an ASUS P5QL-PRO.

So i did a little bit of research and it cleared out that its a regression of the patch described here:
http://lkml.org/lkml/2008/10/9/267

This patch was reverted here:
https://lists.ubuntu.com/archives/intrepid-changes/2008-October/009184.html

Beside the revert messages, I couldnt find any reason for the revert.

Anyhow, I took the latest kernel source 2.6.28-6 (which, btw, dont boot either) and patched it with the patch from above. After the build and install the system boots as expected.

Related branches

Jouni Mettala (jouni-mettala) wrote :
Jouni Mettala (jouni-mettala) wrote :

bug 310075 could be related because i810drm modules are now built in to kernel.

Jouni Mettala (jouni-mettala) wrote :

Boot without initrd is succesful. Livecd gives also error when booting.

Roland Dreier (roland.dreier) wrote :

I have nearly the same issue here. I just did a fresh install from the current livecd (which booted fine), but when booting from the hard disk, I get the same "BUG: INT 14: CR2 ff..." type message. The message appears nearly instantly after the kernel has started, so something very early in initialization is triggering it.

If I delete the initrd line from the grub entry and specify the root partition by hand, then the kernel is able to boot all the way to a fully working userspace.

I've never tried any other Jaunty kernels other than 2.6.28-4 on this system, so I don't know if it's a regression from 28-3 for me or not.

Benjamin Bender (benben) wrote :

Same here for 2.6.28-5 - 2.6.27-11 boots successfully.

Board is a Asus P5Q-pro.

If you need further informations/assistance - let me know :)

Benjamin Bender (benben) wrote :

oh, 2.6.28-6 came out just recently - same bug as the 2(?) kernels before.

This could be a regression off these:
https://bugs.launchpad.net/ubuntu/intrepid/+source/linux/+bug/263543
http://lkml.org/lkml/2008/10/9/267
http://bugs.archlinux.org/task/12255

Benjamin Bender (benben) on 2009-01-29
description: updated
Changed in linux:
status: New → Confirmed

So i did a little bit of research and it cleared out that my last post is right.

Its a regression of the patch described here:
http://lkml.org/lkml/2008/10/9/267

This patch was reverted here:
https://lists.ubuntu.com/archives/intrepid-changes/2008-October/009184.html

Beside the revert messages, I couldnt find any reason for the revert.

Anyhow, I took the latest kernel source 2.6.28-6 (which, btw, dont boot either) and patched it with the patch from above. After the build and install the system boots as expected.

I think we need the kernel-team to get in touch with this but I dont know how. any help to get this fix back would be really appreciated.

description: updated
Benjamin Bender (benben) on 2009-01-31
description: updated
Felix Geyer (debfx) wrote :

Before kernel 2.6.27.2 came out I submitted that patch to Ubuntu.
As soon as Ubuntu updated to 2.6.27.2 the patch has been dropped because it has been applied upstream since that version.

Then in 2.6.28-1.1 the upstream patch has been reverted: https://lists.ubuntu.com/archives/jaunty-changes/2008-November/001218.html
The changelog says:
  [ Upstream Kernel Changes ]
  * Revert "x86, early_ioremap: fix fencepost error"

Which is just wrong as this patch has never been reverted upstream.
So please drop that reverse patch as it surely causes the same problems as is Intrepid.

Tim Gardner (timg-tpi) wrote :
Changed in linux:
assignee: nobody → timg-tpi
milestone: none → jaunty-alpha-6
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (4.5 KiB)

This bug was fixed in the package linux - 2.6.28-8.21

---------------
linux (2.6.28-8.21) jaunty; urgency=low

  [ Andy Whitcroft ]

  * SAUCE: switch the Asus Pundit P1-AH2 to old acpi sleep ordering
    - LP: #327267

  [ Tim Gardner ]

  * Added LPIA arch support
  * Added libdrm-dev as a 'Replaces' to linux-libc-dev
  * SAUCE: LPIA support for 9202 HDA Sigmatel codec
  * SAUCE: Add an X86_LPIA Kconfig option
  * SAUCE: UHCI USB quirk for resume
  * SAUCE: LPIA Reboot fix for Intel Crownbeach development boards
  * SAUCE: LPIA Logical reset of USB port on resume
  * Set CONFIG_WIRELESS_OLD_REGULATORY=n, added wireless-crda
    as an install dependency.

  [ Upstream Kernel Changes ]

  * Revert "Revert "x86, early_ioremap: fix fencepost error""
    - LP: #312554
  * drm/i915: capture last_vblank count at IRQ uninstall time too
    - LP: #320813
  * drm/i915: add get_vblank_counter function for GM45
    - LP: #320813
  * Staging: comedi: fix Kbuild
  * Staging: meilhaus: fix Kbuild
  * Staging: android: binder: fix arm build errors
  * Staging: android: timed_gpio: Fix build to build on kernels after
    2.6.25.
  * Staging: android: fix build error on 64bit boxes
  * Staging: android: Add lowmemorykiller documentation.
  * Staging: android: task_get_unused_fd_flags: fix the wrong usage of
    tsk->signal
  * staging: agnx: drivers/staging/agnx/agnx.h needs <linux/io.h>
  * Staging: usbip: usbip_start_threads(): handle kernel_thread failure
  * Staging: poch: fix verification of memory area
  * Documentation: move DMA-mapping.txt to Doc/PCI/
  * sgi-xp: fix writing past the end of kzalloc()'d space
  * do_wp_page: fix regression with execute in place
  * wait: prevent exclusive waiter starvation
  * shm: fix shmctl(SHM_INFO) lockup with !CONFIG_SHMEM
  * revert "rlimit: permit setting RLIMIT_NOFILE to RLIM_INFINITY"
  * prevent kprobes from catching spurious page faults
  * sound: usb-audio: handle wMaxPacketSize for FIXED_ENDPOINT devices
  * md: Ensure an md array never has too many devices.
  * md: Fix a bug in linear.c causing which_dev() to return the wrong
    device.
  * ACPI: Enable bit 11 in _PDC to advertise hw coord
  * ACPI: dock: Don't eval _STA on every show_docked sysfs read
  * ieee1394: ohci1394: increase AT req. retries, fix ack_busy_X from
    Panasonic camcorders and others
  * firewire: ohci: increase AT req. retries, fix ack_busy_X from Panasonic
    camcorders and others
  * firewire: sbp2: fix DMA mapping leak on the failure path
  * firewire: sbp2: add workarounds for 2nd and 3rd generation iPods
  * ieee1394: sbp2: add workarounds for 2nd and 3rd generation iPods
  * module: remove over-zealous check in __module_get()
  * x86: APIC: enable workaround on AMD Fam10h CPUs
  * eeepc-laptop: fix oops when changing backlight brightness during
    eeepc-laptop init
  * eeepc-laptop: Add support for extended hotkeys
  * e1000: fix bug with shared interrupt during reset
  * e1000: Fix PCI enable to honor the need_ioport flag
  * agp/intel: Fix broken ® symbol in device name.
  * ALSA: hda - Add quirk for FSC Amilo Xi2550
  * ALSA: hda - Add missing COEF initialization for ALC887
  * ALSA: hda - Add missing initialization ...

Read more...

Changed in linux:
status: Fix Committed → Fix Released
jon_herr (jon-net-widgets) wrote :

I installed 9.04 Beta on a mini-itx system with a VIA processor and experienced this bug with the latest kernel...

FYI - system info:
http://mini-itx.com/2007/12/10/via-launch-artigo-pico-itx-builder-kit

2.6.28-11-generic <------ crashes

2.6.27-11-generic <----- WORKS

The specifics are:

BUG: Int 14: CR2 ffffb0f0

etc...

Jon

I'm getting this too on a Via EPIA-5000 system (Via Samuel 2 cpu) on 2.6.28-11-generic.

I'll just go and mark the bug I placed a duplicate of this one; sorry. :-)

Karen Avetyan (karenavetyan) wrote :

I have the same error on Asus P4T533-C with Ubuntu 9.04 final

Felix Geyer (debfx) wrote :

"BUG: Int 14" is a generic error message, so you probably hit another bug.

If you have some time you can debug the problem by using git bisect (http://kerneltrap.org/node/11753) and open a new bug report.

The Madman (madman-lxl) wrote :

I'm having the same type of issue as above. As i have a different motherboard I've entered it in as a new bug here: https://bugs.launchpad.net/ubuntu/+bug/366587

I'm hoping Ben or Felix might be able to confirm if mine is the same issue or just another issue that looks almost the same.
Cheers and thank you in advance.

Felix Geyer (debfx) wrote :

linux-image-2.6.28-11-generic 2.6.28-11.41 (RC) and 2.6.28-11.42 (final) on amd64 work fine for me (ASUS P5QL-Pro).

The Madman (madman-lxl) wrote :

Thank you. that confirms that it is a different bug. Cheers.

Santiago Zarate (santiago-ve) wrote :

I just got the same bug on a Desktop, intel based chipset. not a common bug (Yesterday we had an install fest in my country, and we didnt see this happening (More than 200 installs). I'm actually using Jaunty Final release...

Taifu (marcoberi) wrote :

Same bug here, unable to boot with latest kernel up to date

Mainboard: Intel DQ965COKRMX1 GbE RAID

EviL (wap-evil) wrote :

i have the same problem , ubuntu 8.10 has work`d but the new 9 version give me that error on boot (from hdd , cd , usb)

so i found in bios an option that after i have disable it ubuntu work`s fine .

Memory Hole At 15M-16M you must disable this option .

(more about function of tis option here http://www.techarp.com/showfreebog.aspx?lang=0&bogno=109 )

also you may see attached picture to this post.

On Tue, Jun 2, 2009 at 10:23 PM, EviL <email address hidden> wrote:

> i have the same problem , ubuntu 8.10 has work`d but the new 9 version
> give me that error on boot (from hdd , cd , usb)

Thanks a lot.

Anyway I left kubuntu and I installed ubuntu and everything worked fine.

> so i found in bios an option that after i have disable it ubuntu work`s
> fine .
> Memory Hole At 15M-16M you must disable this option .

I saw that option, unfortunately I cannot test it now because I've
reinstalled and I've no more the broken kubuntu.

Thanks again for your kindness.
Ciao.
Marco.

--
http://thinkcode.tv - Prossimamente su questi schermi
http://beri.it - Blog di una testina di vitello
http://stacktrace.it - Aperiodico di resistenza informatica

Djun Kim (djun-kim) wrote :

I see the same error in the same circumstances with Ubuntu 9.04 Server i386 (Kernel 2.6.28-11-generic) on a Mac Mini 1.66 GHz Core Duo.

miguelquiros (mquiros) wrote :

Also hit by this bug with kernel 2.6.28-15, booting fine with old 2.6.24-24 (have not tried with intermediate versions). If the initrd is not used, the kernel boots fine as indicated in previous posts. At first sight, there is no problem in using the system after booting without the initrd (how necessary is the initrd? any disadvantage for not using the initrd at boot?).
As the size of the kernel has increased a lot from 24-24 to 28-15 (almost double size), I think that the system cannot cope with the larger kernel and the initrd at the same time. What are the memory requirements for booting with 2.6.28-15 plus initrd?
Updating BIOS changes nothing for me, my BIOS has not either the "Memory Hole" option anywhere.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers