Dell laptop digital mic does not work, PCI 1028:0271

Bug #309508 reported by Tim Gardner on 2008-12-18
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Tim Gardner
Intrepid
High
Unassigned

Bug Description

An as yet unreleased Dell laptop digital microphone does not work.

Related branches

Tim Gardner (timg-tpi) on 2008-12-18
Changed in linux:
assignee: nobody → timg-tpi
importance: Undecided → Medium
status: New → In Progress
Tim Gardner (timg-tpi) wrote :

SRU Justification

Impact: Digital microphone does not work.

Patch Description: Add quirk for the laptop

Patch: http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-intrepid.git;a=commit;h=ac0b497efb3f074abd49799a000b5bef2c24695d

Test Case: See bug description. This patch has already been verified to work by Dell.

Changed in linux:
importance: Medium → High
milestone: none → intrepid-updates
status: In Progress → Fix Committed
Colin Watson (cjwatson) wrote :

Accepted linux into intrepid-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Mario Limonciello (superm1) wrote :

I can confirm that the fix in intrepid-proposed works properly.
I also verify that the jaunty kernel DOES NOT work properly, and needs either this fix or the proper upstream fix pulled in.

Changed in linux:
status: Fix Committed → Confirmed
importance: Undecided → High
milestone: none → intrepid-updates
status: New → Fix Committed
milestone: intrepid-updates → jaunty-alpha-3
Changed in dell:
status: New → Fix Committed
Steve Beattie (sbeattie) wrote :

Thanks, Mario.

Jerone Young (jerone) wrote :

Do we know if this is fixed upstream? May want to send the patch upstream to ensure it's there for post Jaunty also.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.28-4.10

---------------
linux (2.6.28-4.10) jaunty; urgency=low

  [ Andy Whitcroft ]

  * update kernel bootloader recommends: to prefer grub
    - LP: #314004
  * SAUCE: don't use buggy _BCL/_BCM/_BQC for backlight control
    - LP: #311716
  * SAUCE: test-suspend -- add the suspend test scripts
    - LP: #316419

  [ Colin Watson ]

  * Enable udebs for armel

  [ Tim Gardner ]

  * SAUCE: Dell laptop digital mic does not work, PCI 1028:0271
    - LP: #309508
  * Enable CIFS_XATTR=y and CONFIG_CIFS_POSIX=y
    - LP: #220658

 -- Tim Gardner <email address hidden> Thu, 08 Jan 2009 10:38:22 -0700

Changed in linux:
status: Fix Committed → Fix Released
Davidiam (hectorjerezano) wrote :

last week I downloaded and tested Jaunty alpha2 and my first problem I detected was that I hear a extrange noise coming from the speakers instated of the usual beep.
I have a dell1420 with HDA Intel sound card!
later the same day my speakers got damage I suspected because the test I did with de live cd of jaunty, in intrepid the speakers were lossing volumen until I got no sound. So I call Dell to have them replace, after they replace the two speakers I got my sound back so my suspicions were right. Now I am 100% sure it was the new driver from Juanty alpha2 that damage the two speakers and I and afraid of testing aplha3.

Launchpad Janitor (janitor) wrote :
Download full text (16.6 KiB)

This bug was fixed in the package linux - 2.6.27-11.25

---------------
linux (2.6.27-11.25) intrepid-proposed; urgency=low

  [ Jeff Layton ]

  * SAUCE: cifs: make sure we allocate enough storage for socket address
    - LP: #318565

linux (2.6.27-11.24) intrepid-proposed; urgency=low

  [ Stefan Bader ]

  * Revert "SAUCE: don't use buggy _BCL/_BCM/_BQC for backlight control"
    - LP: #311716
  * SAUCE: acpi: Hack to enable video and vendor backlight implementations
    - LP: #311716
  * SAUCE: Force vendor backlight control on ThinkPad T61
    - LP: #311716

  [ Upstream Kernel Changes ]

  * Revert "thinkpad_acpi: fingers off backlight if video.ko is serving
    this functionality"
    - LP: #311716

linux (2.6.27-11.23) intrepid-proposed; urgency=low

  [ Andy Whitcroft ]

  * SAUCE: don't use buggy _BCL/_BCM/_BQC for backlight control
    - LP: #311716, #314119

  [ Jim Lieb ]

  * SAUCE: atl2: add tx bytes statistic
    - LP: #268622

  [ Upstream Kernel Changes ]

  * i915: Save/restore MCHBAR_RENDER_STANDBY on GM965/GM45
    - LP: #276943

linux (2.6.27-11.22) intrepid-proposed; urgency=low

  [ Andy Whitcroft ]

  * Revert "synchronise our linux-libc-dev with the kernel userspace
    headers". It was causing regressions.
    - LP: #300803

  [ Brian Rogers ]

  * SAUCE: Add support for MSI TV@nywhere Plus remote
    - LP: #281647

  [ Tim Gardner ]

  * SAUCE: Dell laptop digital mic does not work, PCI 1028:0271
    - LP: #309508

  [ Upstream Kernel Changes ]

  * Revert "sched_clock: prevent scd->clock from moving backwards"
  * AMD IOMMU: enable device isolation per default
  * bonding: fix miimon failure counter
  * x86 Fix VMI crash on boot in 2.6.28-rc8
  * libata: fix Seagate NCQ+FLUSH blacklist
  * e1000e: fix double release of mutex
  * can: Fix CAN_(EFF|RTR)_FLAG handling in can_filter
  * can: omit received RTR frames for single ID filter lists
  * iwlwifi: clean key table in iwl_clear_stations_table function
  * net: eliminate warning from NETIF_F_UFO on bridge
  * unicode table for cp437
  * console ASCII glyph 1:1 mapping
  * key: fix setkey(8) policy set breakage
  * firewire: fw-ohci: fix IOMMU resource exhaustion
  * ieee1394: add quirk fix for Freecom HDD
  * SUNRPC: Fix a performance regression in the RPC authentication code
  * b1isa: fix b1isa_exit() to really remove registered capi controllers
  * macfb: Do not overflow fb_fix_screeninfo.id
  * setup_per_zone_pages_min(): take zone->lock instead of zone->lru_lock
  * xilinx_hwicap: remove improper wording in license statement
  * Linux 2.6.27.10 except for "iwlagn: fix RX skb alignment". Besides causing
    an ABI bump it only applies to machines using > 4K page size (such as PowerPC).
    Pick this one up on the next ABI bumping upload.
    - LP: #309731

linux (2.6.27-11.21) intrepid-proposed; urgency=low

  [ Andy Whitcroft ]

  * synchronise our linux-libc-dev with the kernel userspace headers
    - LP: #300803

  [ Jim Lieb ]

  * SAUCE: [PATCH 1/1] USB: Unusual devs patch for Nokia 5610
    - LP: #287701

  [ Michael Krufky ]

  * sms1xxx: use new firmware for Hauppauge WinTV MiniStick
    - LP: #299671
  * sms1xxx: add autodetection support for Hauppa...

Changed in linux:
status: Fix Committed → Fix Released
Changed in dell:
status: Fix Committed → Fix Released
Changed in somerville:
status: New → Fix Released
no longer affects: dell
Timothy R. Chavez (timrchavez) wrote :

The bug task for the somerville project has been removed by an automated script. This bug has been cloned on that project and is available here: https://bugs.launchpad.net/bugs/1305695

no longer affects: somerville
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers