2.6.28: Keyboard not usable during boot (cryptsetup passphrase)

Bug #309205 reported by Daniel Hahler on 2008-12-18
4
Affects Status Importance Assigned to Milestone
cryptsetup (Ubuntu)
High
Unassigned
linux (Ubuntu)
High
Unassigned

Bug Description

Using the 2.6.28 kernel in Ubuntu Jaunty (with 2.6.28.2, 2.6.28.3 and 2.6.28.4) I cannot enter the passphrase for my encrypted root partition.
Pressing any key does not produce a star on the prompt (usplash), but it does not work when using the recovery boot option, too.

This happens in rare cases with 2.6.27, too, but not every time; I can reset the computer and it will work on the next try.

With 2.6.28 however, I have never managed to get a working keyboard and have tried it a lot of times already.

Keyboard:
Bus 001 Device 003: ID 045e:00db Microsoft Corp. Natural Ergonomic Keyboard 4000 V1.0

Daniel Hahler (blueyed) on 2009-01-01
description: updated
Daniel Hahler (blueyed) wrote :

Still, with the latest 2.28.5 kernel, the keyboard is not usable (and I cannot enter the passphrase).

Additionally, now I'm not stuck at the usplash prompt, but get dropped into a busybox (where the keyboard does not work still).

Attaching "sudo lspci -vnvn", if that may help.

Daniel Hahler (blueyed) wrote :

Adding cryptsetup task - still not knowing what's causing it.

pierce has confirmed the problem btw.

And I've noticed that when the cryptsetup prompt for the root partition shows up, the moving usplash progress meter stops (while it keeps going from left to right and back again in the old 2.6.27 kernel (and initramfs!?) that works for me).

Daniel Hahler (blueyed) wrote :

Fixed with the latest bunch of updates (cryptsetup 2:1.0.6-7ubuntu2, linux 2.6.28.7.7, usplash 0.5.28).

I'm closing the bug tasks as Invalid, since I don't know what change has fixed it now.

Thanks.

Changed in cryptsetup:
importance: Undecided → High
status: New → Invalid
Changed in linux:
importance: Undecided → High
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers