Lenovo ThinkCentre M55 no sound, AD1986A

Bug #308872 reported by Pekka Panula on 2008-12-17
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

On my ThinkCenter model, 8811-91G, i have never got any sound using Ubuntu 7.10, 8.04 nor with 8.10.

I did run alsa-info.sh and results are in here: http://www.alsa-project.org/db/?f=43476f616e01efe95008cbfa8425a15116617dc3

Sound codec on this model is Analog Devices AD1986A.
As far as alsamixer etc shows, i dont see muted channels, except mic, lineout and aux.

This has problem has been always, on Windows i got sound but not never with any Linux distro i have runned on this model, i have runned Ubuntu 7.10, 8.04, 8.10 and never on those distro versions i dont have got any sound what so ever.
So i have decided to report it finally.

Update: updated to Jaunty (9.04), still no sound.
Here is updated alsa-info.sh runned under 9.04: http://www.alsa-project.org/db/?f=925dd643620ba39df8cbc28018d741254b89ada6

Pekka Panula (grimdin) on 2009-04-24
description: updated
description: updated
pocztapolska (pocztapolska) wrote :

Same problem with ASUS P5VD2-MX (Analog Devices AD1986A):/ no sound

Pekka Panula (grimdin) wrote :

I finally founded a fix to no-sound problem, model is needed to set to 3stack.

I modified /etc/modprobe.d/alsa-base.conf and added line:
options snd-hda-intel model=3stack

then sudo alsa force-reload and after that i can get sound.

This bug can be closed.

Changed in linux (Ubuntu):
status: New → Fix Committed
Pekka Panula (grimdin) wrote :

After 10.10 ubuntu upgrade i am getting no sound, i am using same option:
options snd-hda-intel model=3stack

But this time still no sound, same hardware as previously reported, nothing has been changed, only upgrade to 10.10.

I did get this on dmesg when i did alsa force-reload:
[ 835.245877] hda_codec: invalid CONNECT_LIST verb 12[2]:2100

Dunno if it has any meaning.

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Santi Calvo (santicalvo) wrote :

I recently installed ubuntu 10-10 on Lenovo ThinkCenter M58...

Added line options snd-hda-intel model=3stack to /etc/modprobe.d/alsa-base.conf,

tested several other configurations and no audio on internal speakers.

Headphones work perfect.

Also try a Linux Mint live-cd with the same result.

Raymond (superquad-vortex2) wrote :

Node 0x1e [Pin Complex] wcaps 0x400104: Mono Amp-Out
  Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=1
  Amp-Out vals: [0x80]
  Pincap 0x00000010: OUT
  Pin Default 0x911711f0: [Fixed] Speaker at Int Rear
    Conn = Analog, Color = Black
    DefAssociation = 0xf, Sequence = 0x0
    Misc = NO_PRESENCE
  Pin-ctls: 0x40: OUT
  Connection: 1
     0x0e

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers