kernel bug when bluetooth headset is turned ON

Bug #306089 reported by alex on 2008-12-07
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I believe I experience a kernel bug whenever I enable/turn on my bluetooth headset. I tried Ubuntu's latest git kernel (Ubuntu-2.6.27-9.19) after having this issue with the current stable kernel 2.6.27-9-generic and get the same error.

I didn't get this error/bug with the newest kernel from http://kernel.org/pub/linux/kernel/v2.6/linux-2.6.27.8.tar.bz2.

Note: I use bluez 4.23 from https://launchpad.net/~blueman/+archive because I can't get my headset to work with with v4.12... It doesn't work with 4.23 either but it was worth a try.

Please see attached file and let me know if you need anything else.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.10
Package: linux-image-generic 2.6.27.10.13
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: linux-meta
Uname: Linux 2.6.27-10-generic i686

alex (1alex) wrote :
digger vermont (digver) wrote :

Seems like the same problem. Happens when turning on a bluetooth headset. I'm using an up-to-date Jaunty installation.

uname -a
Linux judy 2.6.28-4-generic #9-Ubuntu SMP Tue Jan 6 19:34:01 UTC 2009 i686 GNU/Linux

 dlocate -l linux |grep ^ii\ \ linux
ii linux 2.6.28.4.4 Generic complete Linux kernel.
ii linux-backports-modules-2.6.28-4- 2.6.28-4.1 Ubuntu supplied Linux modules for version 2.
ii linux-firmware 1.3 Firmware for Linux kernel drivers
ii linux-generic 2.6.28.4.4 Complete Generic Linux kernel
ii linux-headers-2.6.28-4 2.6.28-4.9 Header files related to Linux kernel version
ii linux-headers-2.6.28-4-generic 2.6.28-4.9 Linux kernel headers for version 2.6.28 on x
ii linux-headers-generic 2.6.28.4.4 Generic Linux kernel headers
ii linux-image 2.6.28.4.4 Generic Linux kernel image.
ii linux-image-2.6.27-11-generic 2.6.27-11.22 Linux kernel image for version 2.6.27 on x86
ii linux-image-2.6.28-4-generic 2.6.28-4.9 Linux kernel image for version 2.6.28 on x86
ii linux-image-generic 2.6.28.4.4 Generic Linux kernel image
ii linux-libc-dev 2.6.28-4.9 Linux Kernel Headers for development
ii linux-restricted-modules 2.6.28.4.4 Generic Linux restricted modules.
ii linux-restricted-modules-2.6.28-4 2.6.28-4.4 Non-free Linux kernel modules for version 2.
ii linux-restricted-modules-common 2.6.28-4.4 Non-free Linux 2.6.28 modules helper script
ii linux-restricted-modules-generic 2.6.28.4.4 Restricted Linux modules for generic kernels
ii linux-sound-base 1.0.18.dfsg-1ubuntu2 base package for ALSA and OSS sound systems

digger vermont (digver) wrote :

Oh here's the bluetooth part.

dlocate -l blue |grep ^ii
ii bluetooth 4.25-0ubuntu4 Bluetooth support
ii bluez 4.25-0ubuntu4 Bluetooth tools and daemons
ii bluez-alsa 4.25-0ubuntu4 Bluetooth audio support
ii bluez-cups 4.25-0ubuntu4 Bluetooth printer driver for CUPS
ii bluez-gnome 1.8-0ubuntu1 Bluetooth utilities for GNOME
ii bluez-gstreamer 4.25-0ubuntu4 Bluetooth gstreamer support
ii bluez-hcidump 1.42-1build1 Analyses Bluetooth HCI packets
ii bluez-utils 4.25-0ubuntu4 Transitional package
ii libbluetooth-dev 4.25-0ubuntu4 Development files for using the BlueZ Linux
ii libbluetooth3 4.25-0ubuntu4 Library to use the BlueZ Linux Bluetooth sta
ii python-bluez 0.15-1.1 Python wrappers around BlueZ for rapid bluet

Paweł Banasik (pbanasik) wrote :

Hello,

What's the status of this issue? There hasn't been any activity here since 2 months... Is there any newer kernel version which would fix the problem?

Andy Whitcroft (apw) wrote :

This is not a bug in the linux-meta package, moving to the linux package.

affects: linux-meta (Ubuntu) → linux (Ubuntu)
Jeremy Foshee (jeremyfoshee) wrote :

Hi test34,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/lucid.

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 306089

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Incomplete and has not had any updated comments for quite some time. As a result this bug is being closed. Please reopen if this is still an issue in the current Ubuntu release http://www.ubuntu.com/getubuntu/download . Also, please be sure to provide any requested information that may have been missing. To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-expired
Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers