thinkpad brightness controls reversed (please implement fix from fedora dudes)

Bug #301524 reported by Gary Trakhman on 2008-11-24
40
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Low
Andy Whitcroft

Bug Description

Binary package hint: linux-image

brightness steps are reversed as reported by lshal. This causes the Fn-Home and Fn-End buttons to work in reverse, and the brightness increases on idle, etc. The link below has a patch to fix video.c in the kernel, it will implement a sort on the brightness values. Please implement this for us ubuntu users and help push it up to the linux kernel.

https://bugzilla.redhat.com/show_bug.cgi?id=470465

gary@gary-laptop:~$ cat /proc/acpi/video/VGA/LCDD/brightness
levels: 100 90 85 80 75 70 65 60 55 50 45 40 35 30 25 20
current: 25

I have a thinkpad SL300 with intel GM45 graphics.

Changed in linux:
status: Unknown → Fix Released
Changed in linux:
status: Fix Released → Invalid
Andy Whitcroft (apw) wrote :

Was http://bugzilla.kernel.org/show_bug.cgi?id=12037 which was marked duplicate of this bug

Changed in linux-meta:
status: New → Triaged
Changed in linux:
status: Invalid → Unknown
assignee: nobody → apw
status: Triaged → In Progress
Changed in linux:
status: Unknown → Incomplete
Andy Whitcroft (apw) on 2009-01-07
Changed in linux:
importance: Undecided → Low
Andy Whitcroft (apw) wrote :

Could you test the kernels at the URL below, it seems that some BIOSen have bad ACPI brightness interfaces which will now be being used, this kernel should detect and ignore these. It would be good to know if this fixes your issues:

    http://people.ubuntu.com/~apw/lp311716-intrepid/

This is the fix proposed in comment 34 of the linked upstream bug.

With that kernel the brightness hotkeys dont do anything at all anymore (although I tested on Jaunty, not Intrepid). I also have the sl300 with intel GM45 graphics.

Changed in linux:
status: Incomplete → Fix Released
Changed in linux:
status: Fix Released → Confirmed
Changed in linux:
status: Confirmed → Incomplete
Gary Trakhman (gary-trakhman) wrote :

latest 2.6.28-5 brings back the reversed keys, whereas in 2.6.28-4 and before I couldn't do anything brightness related once the kernel boots.

Changed in linux:
status: Incomplete → In Progress

As this isn't fixed while bug 311716 (of which this one was reported as a duplicate) is fixed, and looking at the upstream bugreport, this seems to be a different issue. Marked as not a duplicate.

Nick Booker (nmbooker) wrote :

My results on Intrepid...

I installed apw's kernel on an SL300 type 2738-53G running Intrepid, and it disabled brightness adjustment completely, both with keys and with the Gnome brightness applet.

empo@ubuntu:~$ cat /proc/acpi/video/VGA/LCDD/brightness
<not supported>

The current Intrepid kernel has reversed brightness keys.

Going for lunch now...

Changed in linux:
status: In Progress → Incomplete
Changed in linux:
status: Incomplete → Fix Released
Changed in linux:
status: Fix Released → Confirmed
Changed in linux:
status: Confirmed → Incomplete
Changed in linux:
status: Incomplete → Fix Released

This is fixed in lucid.

Changed in linux (Ubuntu):
status: In Progress → Fix Released
Changed in linux:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.