Fn keys not working on Sony VAIO VGN-FS115MR

Bug #29987 reported by Igor Zubarev on 2006-01-29
66
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Fn keys don't work in Breezy and Dapper Flight 3, Karmic 9.10

Sony VAIO VGN-FS115MR

Phil Bull (philbull) wrote :

Thanks for the report.

Do you know the make/model of your touchpad device at all, and what driver it is using?

Also, do any function keys work? If it's for functions such as e-mail, they won't work because it probably requires the driver software to set this up under Windows. To check, go to System | Preferences | Keyboard Shortcuts and try to set up some of the function keys as shortcuts.

Changed in laptop-mode:
assignee: nobody → desktop-bugs
status: Unconfirmed → Needs Info
Phil Bull (philbull) wrote :

Oops, cross-posted slightly.

You've posted a similar bug:

https://launchpad.net/distros/ubuntu/+source/xorg-driver-synaptics/+bug/29985/

Changed in laptop-mode:
assignee: desktop-bugs → ubuntu-x-swat
Igor Zubarev (igor.zubarev) wrote :

As I know touchpad is synaptics.
I tryed Flight 4. The result the same -sloww and not clickable/scrollable touchpad

I tryed Keyboard Shortcuts.
All shortcuts works (Alt-F1 etc)
But if I try to set combination of Fn button and any other I see a problem.
Program doesn't understand the push of Fn button!

Jerome S. Gotangco (jsgotangco) wrote :

It seems you have two issues here. Re-assigning to appropriate packages.

As for your Fn keys, when you press your Fn combo, does anything appear in /var/log/acpid ?

As for your touchpad issue, can you confirm if you have the latest version of xserver-xorg-input-synaptics (0.14.3+seriouslythistime-0ubuntu3)? We've had a good number of machines for the Ubuntu Laptop Mission working with that.

I tryed Dapper Flight 6 Live CD
Fn keys on Sony VAIO VGN-FS115MR still not working.

As I see when I press Fn combo, nohing appears in /var/log/acpid.
Here it is:
[Sat Apr 8 16:50:33 2006] starting up
[Sat Apr 8 16:50:33 2006] 53 rules loaded
[Sat Apr 8 16:50:56 2006] client connected from 5393[108:108]
[Sat Apr 8 16:50:56 2006] 1 client rule loaded

Press of Fn key in "Keyboard buttons combinatons" sucks! If I press Fn alone
I see no result.
If I press Fn with other key I see ONLY that key in combination box. It
seems Fn button isn't recognizebale
 at all!

But now in Dapper I see no touchpad issue! :-)

Finally I've installed Dapper Flight 6 on laptop.
But Fn buton still doesn't work. I can't assign ANY key combination to it.

Igor Zubarev (igor.zubarev) wrote :

All acpid configs IGNORED! I found bad strings in acpid:

[Thu Apr 20 13:13:51 2006] DBG: ignoring conf file /etc/acpi/events/sony-brightness-down.dpkg-new
[Thu Apr 20 13:13:51 2006] DBG: ignoring conf file /etc/acpi/events/sony-brightness-up.dpkg-new
[Thu Apr 20 13:13:51 2006] DBG: ignoring conf file /etc/acpi/events/sony-hibernate.dpkg-new
[Thu Apr 20 13:13:51 2006] DBG: ignoring conf file /etc/acpi/events/sony-mute.dpkg-new
[Thu Apr 20 13:13:51 2006] DBG: ignoring conf file /etc/acpi/events/sony-sleep.dpkg-new
[Thu Apr 20 13:13:51 2006] DBG: ignoring conf file /etc/acpi/events/sony-volume-down.dpkg-new
[Thu Apr 20 13:13:51 2006] DBG: ignoring conf file /etc/acpi/events/sony-volume-up.dpkg-new

FOR DETAIL SEE ATTACHMENT.

Here is acpid with IGNOR of SONY confs.

Here is acpid after FRESH Dapper Beta install.
I have the same problem with Fn keys.

Changed in hotkey-setup:
assignee: ubuntu-x-swat → nobody

None of the FS series of laptops have the hardware required for the sonypi module to work. It's a shame as there are over 38 different models of laptops in the FS series alone. As all the FS models are so similar.. if you were to get one model working, then all the other models should work as well.

I reported the same bug with my FS laptop a while back here: https://launchpad.net/distros/ubuntu/+bug/38323/+index

I've also set up a site here: http://ubuntufs.wordpress.com/about/ to collect as much info as possible & to try to find away to get full support for them too.
Hope this info helps you..

Paul Sladen (sladen) wrote :

Wasn't this fixed with recognising ICH6 as being Type3.

Not too sure? I tried it setup as type 1,2 & 3 but got no joy for any of them.
By the way.. it seems that this isn't a sonypi problem as the FS series of laptops don't have the correct hardware to use the sonypi module.

This forum tell's you what needs to be done to get the special key's working.. http://forums.gentoo.org/viewtopic-t-335267-postdays-0-postorder-asc-start-0.html?sid=36cf14bdb4acb4a90bf3363a9cd572aa

Trip (djturner) wrote :

oops.. double post, please ignore.

/var/log/acpid

/var/log/kern.log

Lovely; this still doesn't work in Linux 2.6.20-15. Spicctrl doesn't even do anything despite /dev/sonypi's existence and the appropriate modules being loaded. Nothing works! :(

Matt Sicker (jvz) wrote :

I'm on a Sony Vaio VGN-FS550 notebook, and I can confirm this issue exists on all the VGN-FS notebooks at least.

Since this issue is still an issue in Feisty, I'm upgrading the package to 2.6.20 and confirming this so that someone in the kernel team can take a look at this.

Changed in linux-source-2.6.15:
status: Needs Info → Confirmed

take a look at http://jpoa.info/blog/?p=13 . I have a VAIO FS 920 and it works for me.

Matt Sicker (jvz) wrote :

Yeah, that doesn't work; it just crashes when I try to use an Fn key combo. VGN-FS550 as I said before.

Matt Sicker (jvz) wrote :

Oh wait, I see the problem. Your script you link to copies the module to the wrong directory; it should copy it to /lib/modules/$(uname -r)/etc... rather than a hardcoded path to 2.6.20-15-generic.

Keys now basically work, but the mute button will not unmute properly...

Matt Sicker (jvz) wrote :

OK, and here is a decent /etc/fsfn.conf file to use:

DEVICE=AUTO
F2_CMD=/etc/acpi/mutebtn.sh
F3_CMD=/etc/acpi/voldownbtn.sh
F4_CMD=/etc/acpi/volupbtn.sh
F7_CMD=/etc/acpi/mediabtn.sh
F12_CMD=/etc/acpi/sleepbtn.sh
S1_CMD=/etc/acpi/webbtn.sh
S2_CMD=/etc/acpi/mailbtn.sh

Better to let hotkeys-daemon or whatever handle the keypresses for XF86* buttons. I don't define the F5 and F6 ones because for some reason, setting them to "/etc/acpi/sonybright.sh down" and up respectively doesn't seem to work, so I let the default fsfn functionality take over for it.

I think we should work on getting this sony_acpi patch into the Ubuntu kernel when possible as well as including the fsfn daemon for VGN-FS users.

Matt Sicker (jvz) wrote :

We've got a fix that mostly works, now all we need to do is integrate it with Ubuntu [Gutsy?].

Changed in linux-source-2.6.20:
status: Confirmed → In Progress

Hi this patch fsfn.conf does not work on my VGN-FS570

...mark

Matt Sicker (jvz) wrote :

Hey, still doesn't work in Linux 2.6.22, so I'm upgrading this.

Matt Sicker (jvz) wrote :

And I don't know if this is even being worked on anymore. Someone needs to claim this bug if so.

Changed in linux-source-2.6.22:
status: In Progress → Confirmed
Toufik (toufik2) wrote :

I confirm that this bug is still present in Gusty fresh install (tested also with kernel 2.6.23.1) on a Vaio VGN-FS315B

By the way, here are some strange behaviour I've seen:

Extract of dmesg:
...
[ 21.196000] apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16ac)
[ 21.196000] apm: overridden by ACPI.
[ 21.396000] sonypi: Sony Programmable I/O Controller Driver v1.26.
[ 21.400000] sonypi: please try the sony-laptop module instead and report failures, see also http://www.linux.it/~malattia/wiki/index.php/Sony_drivers
[ 21.400000] sonypi: detected type3 model, verbose = 0, fnkeyinit = off, camera = off, compat = off, mask = 0xffffffff, useinput = on, acpi = on
[ 21.400000] sonypi: enabled at irq=11, port1=0x1080, port2=0x1084
[ 21.400000] sonypi: device allocated minor is 63
[ 21.436000] input: Sony Vaio Jogdial as /class/input/input8
[ 21.480000] input: Sony Vaio Keys as /class/input/input9
[ 21.532000] sonypi command failed at /build/buildd/linux-source-2.6.22-2.6.22/drivers/char/sonypi.c : sonypi_call1 (line 652)
[ 21.580000] sonypi command failed at /build/buildd/linux-source-2.6.22-2.6.22/drivers/char/sonypi.c : sonypi_call2 (line 663)
[ 21.628000] sonypi command failed at /build/buildd/linux-source-2.6.22-2.6.22/drivers/char/sonypi.c : sonypi_call2 (line 665)
[ 21.676000] sonypi command failed at /build/buildd/linux-source-2.6.22-2.6.22/drivers/char/sonypi.c : sonypi_call1 (line 652)
[ 21.724000] sony-laptop: Sony Notebook Control Driver v0.5.
[ 21.724000] input: Sony Vaio Keys as /class/input/input10
[ 21.724000] input: Sony Vaio Jogdial as /class/input/input11
[ 21.932000] Failure registering capabilities with primary security module.
[ 24.832000] [drm] Initialized drm 1.1.0 20060810
[ 24.836000] ACPI: PCI Interrupt 0000:00:02.0[A] -> GSI 16 (level, low) -> IRQ 16
[ 24.836000] [drm] Initialized i915 1.6.0 20060119 on minor 0
...

sonypi and sony-laptop are both loaded. However, a kernel message seems to tell that sonypi is deprecated in favour of sony-laptop. In fact they are both loaded via /etc/init.d/hotkey-setup. I suspect this is a bug since the new inputs (Sony Vaio Keys and Sony Vaio Jogdial) are created twice which might confuse xorg. Indeed, adding a new section in xorg.conf to capture the new inputs (as referenced in http://www.linux.it/~malattia/wiki/index.php/Sony-laptop ) makes xorg crash. If removing sonypi, xorg starts normally. Unfortunately, the FN keys don't work and pressing one of them results in a message in dmesg:

...
[12438.196000] atkbd.c: Unknown key pressed (translated set 2, code 0xf5 on isa0060/serio0).
[12438.196000] atkbd.c: Use 'setkeycodes e075 <keycode>' to make it known.
[12438.256000] atkbd.c: Unknown key released (translated set 2, code 0xf5 on isa0060/serio0).
[12438.256000] atkbd.c: Use 'setkeycodes e075 <keycode>' to make it known.
...

sony_acpi worked on my laptop (from dapper to feisty), as sony_laptop has replaced sony_acpi, this is a regression.

Confirm for Gutsy.
Fn keys doesn't work.
Similair dmesg.

Confirm for Gutsy. Sony VGN-FS115MR
Fn keys doesn't work.
Similair dmesg.

cref (zccref-adv) wrote :

Confirm for Gutsy. Sony VGN-SZ56
Fn+F2,F3,F4( sound control ) works well but Fn+F5,F6(brightness control) doesn't work.

marvman90 (fatlip) wrote :

On my VGN-FS215M, the Fn isn't recognized whatsoever. Running Gutsy.

Xavier Verne (xavier-verne) wrote :

Confirm for Gutsy. Sony VGN-FE11H
No FN Keys

BandD (swords-into-plowshares) wrote :

Confirm for Gusty. Sony VGN-FS260P/W. NO FN KEYS RECOGNIZED.

Brian Murray (brian-murray) wrote :

I am assigning this bug to the 'ubuntu-kernel-team' per their bug policy. For future reference you can learn more about their bug policy at https://wiki.ubuntu.com/KernelTeamBugPolicies .

Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-team
Toufik (toufik2) wrote :

Confirmed with Hardy Alpha 2 LiveCD on a Vaio VGN-FS315B, useful files are attached

Jan Ask (janaskhoej-gmail) wrote :

Confirmed. Function keys don't work on this Vaio vgn-tz50b. Tested with Hardy daily build 25/1/2008

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Ralph Janke (txwikinger) wrote :

Unfortunately this bug report is being closed because we received no response to the last inquiry for information. However, the Intrepid Ibex 8.10 Beta release was most recently announced - http://www.ubuntu.com/testing/intrepid/beta . If you are able to confirm this is still an issue with this most recent release please feel free to reopen this report. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks.

Changed in linux:
status: Incomplete → Won't Fix
Trip (djturner) wrote :

Running the latest version of Intrepid (updated today) and the problem still exists I'm afraid :(

If you need any more info or testing done on it then please feel free to contact me. I'm pretty busy at the moment but I will find the time to help out if it gets this bug sorted out once and for all :)

Changed in linux-source-2.6.22:
status: Won't Fix → New
Changed in linux:
status: Won't Fix → New
heinjan (heinjan) wrote :

Same here with a vaio BX196VP. The Fn-keys are not working with the interpid beta, updated today.

Every fn-keypress generates these exact 2 lines in dmesg, the same for all fn-keys:

[ 2180.629831] atkbd.c: Unknown key released (translated set 2, code 0xf5 on isa0060/serio0).
[ 2180.629846] atkbd.c: Use 'setkeycodes e075 <keycode>' to make it known.

Roy Kimbrell (roy-kimbrell) wrote :

On a Sony Vaio VGN A270P, there are only a few function keys activated when you hold down the "Fn" key (such as screen brightness up and down). The screen brightness keys seem to work. However, the CD/DVD eject button does not work. This worked fine in Gutsy (7.10). It stopped working in 8.04 and does not work in 8.10.

ingegnerlillo (ingegnerlillo) wrote :

Same problem of heinjan on a vaio vgn fs 115s

Xev doesn't recognize anything when fn key is pressed

vincent__ (vincent-lark) wrote :

Same kind of problem on Vaio VGN-FW21M

Keeping this open against the actively developed kernel but against 2.6.22 this does not qualify for a Stable Release Update and will be closed - http://wiki.ubuntu.com/StableReleaseUpdates . Thanks.

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged
Changed in linux-source-2.6.22:
status: New → Won't Fix

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

This bug report was marked as Triaged a while ago but has not had any updated comments for quite some time. Please let us know if this issue remains in the current Ubuntu release, http://www.ubuntu.com/getubuntu/download . If the issue remains, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: Triaged → Incomplete
Igor Zubarev (igor.zubarev) wrote :

Doesn't work for 9.10 Alfa 3.

Still doesn't work in 9.04 (Jaunty). Vaio VGN-FS620.

heinjan (heinjan) on 2009-08-07
Changed in linux (Ubuntu):
status: Incomplete → New
Changed in linux (Ubuntu):
status: New → Confirmed
description: updated

Still doesn't work in 9.10 (Karmic) FS115-MR

ingegnerlillo (ingegnerlillo) wrote :

No solutions yet?

More over brightness applet doesn't work as expected, I can only choose between 2 different brightness level...

description: updated
Changed in linux (Ubuntu):
status: Confirmed → Triaged
ingegnerlillo (ingegnerlillo) wrote :

I can confirm that this still doesn't work in lucid lynx... :(

Changed in linux (Ubuntu):
status: Triaged → Confirmed
Xavier Verne (xavier-verne) wrote :

Dear fellows,

I just tried liveUSB of oneiric on my VGNFE11H and it seems new FN key are working : especially BRIGHTNESS (FN+F5 or F6) and Hibernate (FN+F12) !
I can at last set up my brigthness under Linux !

Any website or project where I could deliver this information widely and precisely (testing each FN keys).

For me this bug is in oneiric partially fixed.

Igor Zubarev, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command in the development release from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please do not test the kernel in the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. As well, please comment on which kernel version specifically you tested.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream', and comment as to why specifically you were unable to test it.

Please let us know your results. Thanks in advance.

summary: - [sonypi] Not work Fn keys on Sony VAIO VGN-FS*
+ Fn keys not working on Sony VAIO VGN-FS115MR
no longer affects: linux-source-2.6.22 (Ubuntu)
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-upstream-testing
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers