Microphone Capture ALWAYS muted

Bug #299642 reported by Dr.Suave on 2008-11-18
44
This bug affects 5 people
Affects Status Importance Assigned to Milestone
GNOME media utilities
Expired
Low
gnome-media (Ubuntu)
Low
Ubuntu Desktop Bugs
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Every time I double click on the volume control in Gnome I find that microphone capture is muted. I can click unmute, but recording is not enabled. After clicking unmute, if I close the mixer and then open it again, I find capture has been muted again.

What I expected to happen when I clicked 'unmute' on microphone capture, was to be able to use microphone capture!

If a make a loud enough noise, I can get a faint recording of it - but that's the limit. This occurs with both my internal and external microphones.

However, this bug seems to only occur in Gnome, as when I installed KDE, microphone capture worked fine. I logged out of KDE and back into Gnome, and found the same problem.

I'm currently using Ubuntu 8.10, and did not have this problem with Gutsy Gibbon. Possibly the Gnome update broke this feature?

I'm using Intel82801CA-ICH3 (Alsa Mixer).

I've experienced this as well.

Using kmix, I was able to enable the capture device. I was unable to enable it using either gnome-volume-settings or alsamixer. The device stays enabled after kmix exits.

This should probably be filed under alsa or gnome-volume-settings, but I can't figure out how to do that w/ Launchpad ;)

robzor (robban2005) wrote :

i can confirm this on 8.10 32bit version, and kmix does not help me.

I even tried the same microphone on another computer to confirm it was not something wrong with the microphone.
The microphone works perfectly on another computer.

I think i have tried every possible combination of settings in volume-control and kmix but no matter what i try the microphone is always muted after i close/open volume-controller.

And recording produces at best some random "white noise" no matter what i try. Soon i will completely wipe out pulseaudio or maybe ubuntu entirely and use a more stable sound system.

Dr.Suave (wilf-horsfall) wrote :

I had the same problem on another laptop, tried the kmix solution, and it worked for me. I just apt-get'ed kmix, then enabled microphone capture in there.

robzor, maybe before wiping ubuntu you should try
sudo apt-get kubuntu-desktop
have a play around there, see if you can get it working. Since installing the kubuntu desktop, I've found that in gnome although microphone recording stays on mute in the gnome volume manager, when I use an application like Skype, microphone capture automatically unmutes itself and adjusts the sound levels according to how loud I'm talking.

Jonas Bonn (jonas.bonn) wrote :

Confirmed in Jaunty, March 18, 2009

Changed in linux (Ubuntu):
status: New → Confirmed
Pedro Villavicencio (pedro) wrote :

could you test the same without login into gnome but testing with alsamixer on the command line and see if the microphone is muted there too?

Changed in gnome-media (Ubuntu):
importance: Undecided → Low
Dr.Suave (wilf-horsfall) wrote :

OK, how do I avoid logging into a desktop environment?

I can confirm it works in KDE, and I can test XFCE - there must be a way of logging into the command line bypassing the dektop environment, but I'm afraid I don't know how.

Jonas Bonn (jonas.bonn) wrote :

The problem is specifically with the gnome-volume-control applet which always shows all recording channels as muted, irregardless of their actual status.
The applet works, however, in that it does change the state of the channels.
alsamixer shows the real state, and alsamixer also reflects changes to the mute-state of the channels performed via the gnome-volume-control.

Without a desktop environment, alsamixer works and shows the channels unmuted.

I believe something has changed, however, recently as I previously was unable to unmute the channels at all. This is vague, but all I've got right now... sorry.

Hardik Dalwadi (hardik-dalwadi) wrote :

Bug has been already filed at upstream [1].

[1] http://bugzilla.gnome.org/show_bug.cgi?id=578174

Even snap of code confirms that :), But i don't know how to solve.

## gnome-media-2.26.0/gst-mixer/src/trac.c (Line 390) ##
--
/* only the record button here */
  msg = g_strdup_printf (_("Toggle audio recording from %s"),
ctrl->track->label);
  /* FIXME:
   * - there's something fishy about this button, it
   * is always FALSE.
   */
--

Changed in gnome-media (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: Confirmed → Triaged
Changed in gnome-media:
status: Unknown → Confirmed
Robert Ancell (robert-ancell) wrote :

Dr. Suave, could you confirm which mute button is causing the problem?

I have found a problem with the audio recording toggle button (The microphone with the red X as shown in the attached screenshot) which causes it to always be disabled when starting up. This button is only shown for inputs in the "Recording" tab.

The mute button (the icon to the left of the microphone button) does not seem to have any effect and is always set to not muted when I start. It is not visible in alsamixer. The sound system has requested the volume control application to show this button, I will investigate why this is.

In my case it is happening to all buttons as shown in image.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-media - 2.27.3.1-0ubuntu1

---------------
gnome-media (2.27.3.1-0ubuntu1) karmic; urgency=low

  [ Robert Ancell ]
  * debian/patches/06_track_capture_toggle.patch:
    - Make record toggles for capture tracks correctly set on startup (LP: #299642)

  [ Luke Yelavich ]
  * New upstream release
    - gnome-volume-control
      + Bug 584963 – Scrolling on applet doesn't take into account that others
        might have changed the volume'
      + Bug 564311 – "Connection failed" when PA drops off
    - Updated translations:
      + es (Jorge González)
      + et (Ivar Smolin)
  * debian/patches/99_autoconf.patch: Refreshed

 -- Luke Yelavich <email address hidden> Wed, 01 Jul 2009 11:10:54 +1000

Changed in gnome-media (Ubuntu):
status: Triaged → Fix Released
Changed in linux (Ubuntu):
status: New → Invalid
Changed in gnome-media:
importance: Unknown → Low
Changed in gnome-media:
status: Confirmed → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.