Ubuntu

SATA (root) hard drive gone on resume from suspend

Reported by shawnlandden on 2008-11-18
4
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Medium
TJ

Bug Description

suspending works fine, on resume i either get a static graphic or the first line half-cut off of tty0, of a log in screen where any attemp to log in is read error, eventually the screen gets filled with read errors or simply stays frozen

root drive is ST3500630AS, i switched fstab to /dev/sdxx from UUIDs and that didnt help, also switched drives position on controller.

 am compiling upstream to test that

shawnlandden (shawnlandden) wrote :

why cant i do multiple attachments at once?

shawnlandden (shawnlandden) wrote :
shawnlandden (shawnlandden) wrote :
shawnlandden (shawnlandden) wrote :
shawnlandden (shawnlandden) wrote :
shawnlandden (shawnlandden) wrote :
shawnlandden (shawnlandden) wrote :
shawnlandden (shawnlandden) wrote :

tested with vanilla from git andstill has problems

Hi scientus,

I apologize for the extremely delayed response here. You mentioned you were able to verify this issue exists with the upstream vanilla kernel as well. Just curious if you'd also filed a bug with the upstream bugzilla bug tracker - bugzilla.kernel.org .

Also, in case you may be interested in testing the latest pre-release of Jaunty 9.04 (currently Alpha4), it contains a newer 2.6.28 based kernel - http://cdimage.ubuntu.com/releases/jaunty/ . Let us know your results if you do test. Thanks.

shawnlandden (shawnlandden) wrote :

yes, i have tested with 2.6.28, and have reported to bugzilla.kernel.org, but as i dont currently have a serial console they cant really help he, but eventually i will do that and work with them

If you could also post a reference to the upstream bug # here that would be great too. Thanks.

TJ (tj) wrote :

This looks like it could be a duplicate of bug #334644 "[MSI MS-7374] suspend/resume failure" which would be more accurately described as "Nvidia MCP78S chip-set and AHCI IDE controllers not saving/restoring the device interrupt over the suspend/resume cycle.

The attached lspci log doesn't include the device [vendor:model] IDs so could you please attach the results of:

sudo -i
lspci --vvnn > /tmp/lspci-vvnn.log
exit

Changed in linux (Ubuntu):
assignee: nobody → intuitivenipple
importance: Undecided → Medium
status: New → In Progress
Changed in linux:
status: Unknown → In Progress
Changed in linux:
status: In Progress → Fix Released
Changed in linux (Ubuntu):
status: In Progress → Fix Released
Changed in linux:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.