Ubuntu doesn't support some logitech and labtec webcams

Bug #293176 reported by fraiddoki
80
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Cheese
Invalid
Undecided
Unassigned
Linux
Invalid
Undecided
Unassigned
XawTV
Invalid
Undecided
Unassigned
aMSN
Invalid
Undecided
Unassigned
libv4l (Ubuntu)
Invalid
Undecided
Unassigned
linux (Ubuntu)
Invalid
Medium
Unassigned

Bug Description

Hello,

 it's the first version of ubuntu where my webcam is not supported

My webcam is ID 046d:0870 Logitech, Inc. QuickCam Express

So, under Debian Lenny (for example), she works great when i make
Code:

sudo m-a update && sudo m-a prepare && sudo m-a a-i qc-usb-source

Please, help me to use my webcam, i don't understand what is wrong.

Bye

ps, the forum thread: http://ubuntuforums.org/showthread.php?t=969293

Tags: webcam
Revision history for this message
fraiddoki (fredo-5555) wrote :

fred@fred-laptop:~$ xawtv
This is xawtv-3.95.dfsg.1, running on Linux/i686 (2.6.27-7-generic)
xinerama 0: 1280x800+0+0
/dev/video0 [v4l]: no overlay support
v4l-conf had some trouble, trying to continue anyway
libv4l2: error getting capabilities: Erreur inconnue 515
ioctl: VIDIOC_QUERYCAP(driver="";card="";bus_info="";version=0.0.0;capabilities=0x0 []): Erreur inconnue 515
Warning: Cannot convert string "-*-ledfixed-medium-r-*--39-*-*-*-c-*-*-*" to type FontStruct

fraiddoki (fredo-5555)
Changed in xawtv:
status: New → Confirmed
fraiddoki (fredo-5555)
Changed in cheese:
assignee: nobody → webcam-support
status: New → Confirmed
Changed in xawtv:
assignee: nobody → webcam-support
fraiddoki (fredo-5555)
Changed in linux:
status: New → Confirmed
Changed in amsn:
status: New → Confirmed
Revision history for this message
Andres Mujica (andres.mujica) wrote : Re: Ubuntu 8.10 doesn't support logitech and labtec webcam

Hi, thanks for your report, is it possible for you to test if this bug still exists with fully updated Intrepid? If it is still an issue can you send as separate attachments the output for the following files?

 uname -a > uname-a.log
 cat /proc/version_signature > proc_version_signature.log
 sudo lspci -vvnn > lspci-vvnn.log (those are 2 v's not a w)
 dmesg > dmesg.log
 lsusb > lsusb.log
 lshal > lshal.log

 Thanks in advance

Changed in cheese:
assignee: webcam-support → nobody
status: Confirmed → Incomplete
Changed in linux:
status: Confirmed → Incomplete
Changed in xawtv:
assignee: webcam-support → nobody
status: Confirmed → Incomplete
Changed in amsn:
status: Confirmed → Incomplete
Revision history for this message
Chris (clmorse) wrote : RE: [Bug 293176] Re: Ubuntu 8.10 doesn't support logitech and labtec webcam

Hi,

Still not working, get no camera found in cheese and xawtv does not start at all. cmdline invocation gives errors, pasted below. I added the requested logs.

Regards,
Chris.

chris@chris-desktop:~/log_for_debug$ xawtv
This is xawtv-3.95.dfsg.1, running on Linux/x86_64 (2.6.27-9-generic)
xinerama 0: 1680x1050+0+0
WARNING: No DGA direct video mode for this display.
can't open /dev/video0: No such file or directory
v4l-conf had some trouble, trying to continue anyway
v4l2: open /dev/video0: No such file or directory
v4l2: open /dev/video0: No such file or directory
v4l: open /dev/video0: No such file or directory
no video grabber device available
chris@chris-desktop:~/log_for_debug$

***************************************************************

"If we knew what it was we were doing, it would not be called research, would it?"
- Albert Einstein
***************************************************************

> From: <email address hidden>
> To: <email address hidden>
> Date: Wed, 17 Dec 2008 03:12:45 +0000
> Subject: [Bug 293176] Re: Ubuntu 8.10 doesn't support logitech and labtec webcam
>
> Hi, thanks for your report, is it possible for you to test if this bug
> still exists with fully updated Intrepid? If it is still an issue can
> you send as separate attachments the output for the following files?
>
> uname -a > uname-a.log
> cat /proc/version_signature > proc_version_signature.log
> sudo lspci -vvnn > lspci-vvnn.log (those are 2 v's not a w)
> dmesg > dmesg.log
> lsusb > lsusb.log
> lshal > lshal.log
>
> Thanks in advance
>
> ** Changed in: cheese
> Assignee: Webcam Support for Ubuntu Linux (webcam-support) => (unassigned)
> Status: Confirmed => Incomplete
>
> ** Changed in: linux
> Status: Confirmed => Incomplete
>
> ** Changed in: xawtv
> Assignee: Webcam Support for Ubuntu Linux (webcam-support) => (unassigned)
> Status: Confirmed => Incomplete
>
> ** Changed in: amsn
> Status: Confirmed => Incomplete
>
> ** Changed in: ubuntu
> Assignee: Webcam Support for Ubuntu Linux (webcam-support) => (unassigned)
> Status: Confirmed => Invalid
>
> ** Changed in: linux (Ubuntu)
> Sourcepackagename: None => linux
> Status: Invalid => Incomplete
>
> --
> Ubuntu 8.10 doesn't support logitech and labtec webcam
> https://bugs.launchpad.net/bugs/293176
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in aMSN: Incomplete
> Status in Cheese Camera Application: Incomplete
> Status in The Linux Kernel: Incomplete
> Status in XawTV TV Viewer: Incomplete
> Status in “linux” source package in Ubuntu: Incomplete
>
> Bug description:
> Hello,
>
> it's the first version of ubuntu where my webcam is not supported
>
> My webcam is ID 046d:0870 Logitech, Inc. QuickCam Express
>
> So, under Debian Lenny (for example), she works great when i make
> Code:
>
> sudo m-a update && sudo m-a prepare && sudo m-a a-i qc-usb-source
>
> Please, help me to use my webcam, i don't understand what is wrong.
>
> Bye
>
>
> ps, the forum thread: http://ubuntuforums.org/showthread.php?t=969293

Revision history for this message
Nobbit (lew-n-myschkin) wrote : Re: Ubuntu 8.10 doesn't support logitech and labtec webcam

I am really a noob, but my webcam wouldn't work under ubuntu 8.10 as well. Until i tried:

LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype

whatever application u need it to run - delete skype and set name there. worked for me. good luck.
oh, and btw: don't close the terminal, because the allpication will shut down as well ;-)

Revision history for this message
Nobbit (lew-n-myschkin) wrote :

sorry for double posting,
1) the solution came from http://ubuntuforums.org/showpost.php?p=6115686&postcount=30
2) friend of mine just wrote a small code, so u don't have to run via terminal always, but automatically start with right lib. Take a look here: http://www.atokar.net/index.php/topic,236.0.html
Hope that helps

Revision history for this message
Dianne Reuby (pramclub) wrote :

I've got this with a Logitech Quickcam Chat - all I get is a black screen in both Cheese and Camstream. The solution given in Nobbit's post doesn't work for me. Although the module seems to be loaded, I get "Module gspca not found".

I do notice that when I boot, the light on the camera comes on. But if I load a webcam app, the light goes out. It works in XP with no problem, so I know the camera is working.

Revision history for this message
Andres Mujica (andres.mujica) wrote :

this is confirmed as this is a problem with qc-usb module

Changed in cheese:
status: Incomplete → Invalid
Changed in linux:
status: Incomplete → Invalid
Changed in xawtv:
status: Incomplete → Invalid
Changed in amsn:
status: Incomplete → Invalid
Changed in linux:
status: Incomplete → Confirmed
Revision history for this message
Andres Mujica (andres.mujica) wrote :

Also this is a libv4l issue.

Please note that this must be solved right now with the intrepid-proposed repo.

Can you test enabling that repo in order to check if that´ s the case?

Thanks for your input

Changed in libv4l:
status: New → Confirmed
Revision history for this message
clarezoe (clarezoe) wrote :

I have the same problem. None of the workarounds work for me. I have a Logitech Labtec: Vendor 0x046d Product:0x08a2
Andres, what do you mean by "intrepid-proposed repo" where to enable it?

Thanks!

Revision history for this message
Andres Mujica (andres.mujica) wrote :
Revision history for this message
alejaaandro (alejaaandro) wrote :

nope... the LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so <application> doesn't work for me..

ubuntu intrepid with ID 046d:08f5 Logitech, Inc. QuickCam Messenger Communicate

Revision history for this message
Chol (chol83) wrote :

Same problem here. For me, neither LD_PRELOAD, nor the current proposed repo works :-(

Revision history for this message
mrpurple (mrpurple) wrote :

helping a friend with his webcam :
lsusb => ID 046d:0870 Logitech, Inc. QuickCam Express
i gave a look to the web site http://qce-ga.sourceforge.net/ but when i compile i get errors.
then in a freenode rooms a guy suggest to me to tray with the source from repository so i did but impossible to compile that
In canforama it works fine (colors are different from true) .
some try are :
http://paste.ubuntu.com/120575/
http://paste.ubuntu.com/120579/

the command " LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype " give this :

ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed : Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed : Input/output error(5)
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed : Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed : Input/output error(5)
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed : Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed : Input/output error(5)
Skype V4L: Device does not support video capture
Starting the process...
Skype Xv: Xv ports available: 33
Skype XShm: XShm support enabled
Skype Xv: Using Xv port 57
Skype Xv: No suitable overlay format found
Aborted

thank you for any help on this

Revision history for this message
Vítor E. Silva Souza (vitorsouza) wrote :

Check this comment: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/287336/comments/4

This program worked for me and I also have a Quickcam Express.

I suggest downloading his C program, compiling and placing it /usr/local/bin. Then create the script quickcam-start.sh in the same directory, with the following contents:

#!/bin/sh
if [ -c /dev/video0 ]; then
        /usr/local/bin/set_cam_exp /dev/video0 2000
fi

Now, create the file /etc/udev/rules.d/10-local.rules with the following contents:

# Adjust camera parameters upon insertion.
KERNEL=="video0", RUN+="/usr/local/bin/quickcam-start.sh"

You will need to sudo to create those files. Don't remember if rebooting is required, but I don't think so. Plug in your camera and the set_cam_exp program should be run automatically to set the brightness. Worked for me...

Revision history for this message
TnT (tntbass) wrote :

Running the command(s):
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so camorama -r
or:
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so camorama -r& (& added to make it a background process)
or:
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
or:
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype& (& added to make it a background process)

Worked for me. I've had the same problems since upgrading to Kubuntu 8.10.
I never did try adding the other repository. Is the permanent fix in there?

Revision history for this message
TnT (tntbass) wrote :

Forget it, the & will make it a background process, but it will still end if the terminal is closed. Any ideas?

Revision history for this message
Ramon Casha (rcasha) wrote : Re: [Bug 293176] Re: Ubuntu 8.10 doesn't support logitech and labtec webcam

You can create a script file to launch skype with the preloaded library:

#!/bin/sh
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype

..and then replace the Skype command in the Gnome/KDE menu with your script
file.

Ramon Casha

2009/2/28 TnT <email address hidden>

> Forget it, the & will make it a background process, but it will still
> end if the terminal is closed. Any ideas?
>
> --
> Ubuntu 8.10 doesn't support logitech and labtec webcam
> https://bugs.launchpad.net/bugs/293176
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Revision history for this message
Tamas Schneider (tschneider) wrote : Re: Ubuntu 8.10 doesn't support logitech and labtec webcam

it is not work for me:

uname -a
Linux msi-laptop 2.6.27-13-generic #1 SMP Thu Feb 26 07:31:49 UTC 2009 x86_64 GNU/Linux

lsusb
Bus 002 Device 005: ID 046d:08aa Logitech, Inc. Labtec Notebooks

LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
ERROR: ld.so: object '/usr/lib/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded: ignored.

LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so skype
ERROR: ld.so: object '/usr/lib/libv4l/v4l2convert.so' from LD_PRELOAD cannot be preloaded: ignored.

Revision history for this message
Vítor E. Silva Souza (vitorsouza) wrote :

@Tamas: did you try WireSpot's C program? Check my comment in this issue:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/293176/comments/14

Revision history for this message
Tamas Schneider (tschneider) wrote :

thx, but:

./set_cam_exp /dev/video0 2000
V4L2_CID_EXPOSURE is not supported

Revision history for this message
Andres Mujica (andres.mujica) wrote :

is possible for the affected users to test with Jaunty beta?

thanks

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Revision history for this message
Ramon Casha (rcasha) wrote :

Testing with Jaunty Beta:

Linux desktop 2.6.28-11-generic #40-Ubuntu SMP Fri Apr 3 17:39:51 UTC 2009 i686 GNU/Linux
Bus 001 Device 004: ID 046d:0928 Logitech, Inc. Quickcam Express

Cheese works
Skype works
xawtv works

Seems to be working, yay!

Revision history for this message
Chol (chol83) wrote :

Linux chol-ibm 2.6.28-11-generic #41-Ubuntu SMP Wed Apr 8 04:38:53 UTC 2009 i686 GNU/Linux

Bus 003 Device 002: ID 046d:0870 Logitech, Inc. QuickCam Express

Skype & Cheese do not work :-(

Revision history for this message
Shane Kerr (shane-time-travellers) wrote :

I am also having problems, using Jaunty beta.

Like Chol, I am also using one of the older Logitech QuickCam USB models:

  Bus 001 Device 003: ID 046d:0870 Logitech, Inc. QuickCam Express

When I run gstreamer-properties, select the "Video" tab, select the "Video for Linux (v4l)" plugin with the device (listed as "Unknown"), and click "Test", I get a dialogue box that says:

  Video for Linux (v4l): Could not get/set settings from/on resource.

In the terminal I ran it from, I see:

  gstreamer-properties-Message: Error running pipeline 'Video for Linux (v4l)': Could not get/set settings from/on resource. [v4l_calls.c(198): gst_v4l_open (): /GstPipeline:pipeline0/GstV4lSrc:v4lsrc3:
  Device opened, but wrong type (0x0)]

I can look at the device via "qcset", as follows:

shane@shane-desktop:~$ qcset -i /dev/video0
Name : Logitech QuickCam USB
Type :
Channels : 1
Audio devices : 0
Maxsize : 360,296
Minsize : 32,32

Overlay coords: 0,0
Capture size : 360,296
Chromakey : 0
Flags :

Channel : 0
Name : Camera
Tuners : 0
Flags :
Type : camera
Norm : 0

Brightness : 32768
Hue : 32768
Color : 32768
Contrast : 32768
Whiteness : 32768
Depth : 24
Palette : RGB888 packed into 24bit words.

shane@shane-desktop:~$ qcset -r /dev/video0
Sensor registers:
    00 01 02 03 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F
00: 08 08 09 09 00 00 63 63 00 00 20 20 12 12 01 01
10: 9B 9B 0A 0A 02 02 02 02 4B 4B 5B 5B 74 74 C0 C0
20: C0 C0 C0 C0 C0 C0 C9 C9 00 00 31 31 01 01 08 08
30: 04 04 00 00 10 10 00 00 00 00 00 00 00 00 00 00
40: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
50: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
60: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
70: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

STV registers:
      00 01 02 03 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F
 400: 7F 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
 410: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
 420: AA 00 02 00 02
1400: 7F 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
1410: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
1420: AA 00 02 00 02
1440: 00 00 00 20 02 04 01
1500: 1D B5 A8 95 07 00
15C0: 00 4F 03 01 04 00 00 00 0F 00
1680: 0A
1700: 00
B000: 00

Finally, if I run "camorama" then the process freezes, and cannot be killed even with SIGKILL from root. It is stuck in state "D" reading from the camera source, until the machine is rebooted.

Revision history for this message
Savvas Radevic (medigeek) wrote :

Not working here either, gspca/tv8532 for device 046d:0920 - I get "Input/output error" :(

$ apt-cache policy libv4l-0 gstreamer-tools
libv4l-0:
  Installed: 0.5.8-1
  Candidate: 0.5.8-1
  Version table:
 *** 0.5.8-1 0
        500 http://archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status
gstreamer-tools:
  Installed: 0.10.22-1
  Candidate: 0.10.22-1
  Version table:
 *** 0.10.22-1 0
        500 http://archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status

Bus 005 Device 004: ID 046d:0920 Logitech, Inc. QuickCam Express

[53417.344016] usb 5-2: new full speed USB device using uhci_hcd and address 4
[53417.508779] usb 5-2: configuration #1 chosen from 1 choice
[53417.511586] gspca: probing 046d:0920
[53417.928461] gspca: probe ok

$ gst-launch -v v4l2src device=/dev/video0 ! xvimagesink
Setting pipeline to PAUSED ...
/GstPipeline:pipeline0/GstV4l2Src:v4l2src0.GstPad:src: caps = video/x-raw-yuv, format=(fourcc)YV12, width=(int)352, height=(int)288, framerate=(fraction)100/1
Pipeline is live and does not need PREROLL ...
Setting pipeline to PLAYING ...
New clock: GstSystemClock
libv4l2: error dequeuing buf: Input/output error
libv4l2: error dequeuing buf: Input/output error
libv4l2: error dequeuing buf: Input/output error
^CCaught interrupt -- handling interrupt.
Interrupt: Stopping pipeline ...
Execution ended after 9636191082 ns.
Setting pipeline to PAUSED ...

summary: - Ubuntu 8.10 doesn't support logitech and labtec webcam
+ Ubuntu doesn't support some logitech and labtec webcams
Revision history for this message
Savvas Radevic (medigeek) wrote :

OK, I have managed to make it work, but the input is *ugly* (greenish)!
Original guide: http://hansdegoede.livejournal.com/6630.html

1. Run this command in terminal:
v4l-info | grep 'device info\|version'

You will see:
ioctl VIDIOCGTUNER: Invalid argument
ioctl VIDIOCGFBUF: Invalid argument
### v4l2 device info [/dev/video0] ###
 version : 2.3.0
### video4linux device info [/dev/video0] ###

2. We will need to compile and upgrade the gspca to the newest available version (2.5.0 at the point of writing)
Now run these commands in terminal:

sudo apt-get install mercurial ncurses-dev
hg clone http://linuxtv.org/hg/~jfrancois/gspca/
cd gspca
sudo make menuconfig

Don't change anything, press Tab to choose "Exit" and press Enter.

3. Continue running these:
make
sudo make install

4. Disconnect all your webcam devices.
5. Now reboot:
sudo reboot

6. Login properly.
7. Connect your webcam.
8. Run:
sudo apt-get install cheese
cheese

You should now see your hulk-like green face. Or maybe your webcam works better than mine. :)

Notes:
- 64-bit Ubuntu users:
a) for 32-bit devices (e.g. skype) you need:
sudo apt-get install lib32v4l-0
LD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so skype

b) for some applications you might need:
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so name-of-application
or
LD_PRELOAD=/usr/lib64/libv4l/v4l1compat.so name-of-application

(where name-of-application is your application)

- 32-bit Ubuntu users
 for some applications you might need:
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so name-of-application
or
LD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so name-of-application
(where name-of-application is your application)

Revision history for this message
Shane Kerr (shane-time-travellers) wrote :

Some of the problems may be fixed in the 2.6.29 kernel (which is not in Intrepid or Jaunty):

http://www.h-online.com/open/Steady-growth-What-s-new-in-Linux-2-6-29--/features/112914/4

The documentation does list the USB identifier for the the QuickCam I have here at least:

http://tinyurl.com/dd9cgu

Revision history for this message
Savvas Radevic (medigeek) wrote :

P.S. Run this command to check if it was installed correctly:
v4l-info | grep 'device info\|version'

ioctl VIDIOCGTUNER: Invalid argument
ioctl VIDIOCGFBUF: Invalid argument
### v4l2 device info [/dev/video0] ###
 version : 2.5.0
### video4linux device info [/dev/video0] ###

Note: You have to have your webcam connected to make v4l-info work!

Revision history for this message
Diegstroyer (diegstroyer) wrote :

Same problem with Logitech, Inc. QuickCam Express (ID 046d:0920), and sometimes, when I try to use it, system freeze completely.

I'm using Jaunty with kernel 2.6.28-11-generic.

With dmesg command:

[ 301.488202] usb 5-2: new full speed USB device using uhci_hcd and address 3
[ 301.685286] usb 5-2: configuration #1 chosen from 1 choice
[ 301.687574] gspca: probing 046d:0920
[ 302.140361] gspca: probe ok

Cam don't works with none: cheese, amsn, Skype, camstream, camorama, XawTv...

With 8.04 works perfectly.

Thanks.

Revision history for this message
Songoku (juliocesargoku) wrote :

En el amsn a pesar de que la webcam esta reconocida por el sistema (jaunty) y de echo con programas como el wxcam puedo grabar de ella lo cierto es que cuando intento seleccionar la webcam en el amsn la lucecita de esta parpadea unos segundos y la vista previa de la camara permanece en negro no saliendo la imagen que captura la webcam (normal ya que la luz se apaga luego la camara se debe apagar pues cuando esta activa la luz esta encendida). Esto antes no pasaba en versiones anteriores del ubuntu. La camara es una logitech quickamweb, osea una reliquia pero a mi me vale de sobra y hasta ahora no e tenido problema con ella salvo como ya digo en el amsn en el ubuntu jaunty. Pego aqui lo que tira la consola cuando abro el amsn a traves de ella e intento configurar la webcam (e de decir que el amsn la detecta perfectamente, de echo detecta la webcam y la tarjeta de tv y da a elegir entre ambas).

julio-cesar@mi-equipo:~$ amsn
libv4l2: error getting capabilities: Unknown error 515
libv4l2: error getting capabilities: Unknown error 515
libv4l2: error getting capabilities: Unknown error 515
libv4l2: error getting capabilities: Unknown error 515
open(/dev/video0): Unknown error 515
libv4l2: error getting capabilities: Unknown error 515
open(/dev/video0): Unknown error 515
julio-cesar@mi-equipo:~$

Tampoco me funciona lo de precargar la libreria osea esto:

LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so amsn

Saludos...

P.D perdon por escribir en español y no en inglés pero es que apenas si leo inglés mucho menos puedo siquiera pensar en escribirlo.

Revision history for this message
zelrikriando (zelrikriando-gmail) wrote :

I cannot use my webcam on ibex. It's a QuickCam Messenger:

Bus 003 Device 002: ID 046d:08f0 Logitech, Inc. QuickCam Messenger

Here is a pastebin of the driver installation from easycam2 :

http://pastebin.com/m144b6a6b

and the output from dmesg :

http://pastebin.com/daddb229

Obviously, I cannot do anything with my cam right now. It is useless

Revision history for this message
Ramon Becerra Reynoso (ingcomrbr) wrote :

LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so <application> doesn't work for me..

ubuntu jaunty with Logitech, Inc. QuickCam Messenger Communicate

Revision history for this message
Vanessa Dannenberg (vanessadannenberg) wrote :

This bug is still present in Jaunty (unless my camera is just broken, which is possible - it is quite old). The LD_PRELOAD... trick does not work for me, nor does running the camera app (xawtv, cheese...) as root.

Revision history for this message
m0nstersnatch (gutza37) wrote :

same here: Logitech QuickCam Web does not work in Jaunty 9.04

Linux xenopol 2.6.28-15-generic #49-Ubuntu SMP Tue Aug 18 18:40:08 UTC 2009 i686 GNU/Linux

[ 4407.251624] usbcore: registered new interface driver snd-usb-audio
[ 4407.252562] quickcam: QuickCam USB camera found (driver version QuickCam USB 0.6.6 $Date: 2006/11/04 08:38:14 $)
[ 4407.270116] usbcore: registered new interface driver quickcam

Bus 002 Device 002: ID 046d:0850 Logitech, Inc. QuickCam Web

i tried compiling the module quickcam.ko from http://qce-ga.sourceforge.net but received this error:
...
/home/monstersnatch/Desktop/qc-usb/qc-usb-0.6.6/qc-driver.c:2529: error: ‘struct video_device’ has no member named ‘type’
/home/monstersnatch/Desktop/qc-usb/qc-usb-0.6.6/qc-driver.c: At top level:
/home/monstersnatch/Desktop/qc-usb/qc-usb-0.6.6/qc-driver.c:3008: error: unknown field ‘type’ specified in initializer
/home/monstersnatch/Desktop/qc-usb/qc-usb-0.6.6/qc-driver.c:3009: error: unknown field ‘hardware’ specified in initializer
/home/monstersnatch/Desktop/qc-usb/qc-usb-0.6.6/qc-driver.c: In function ‘qc_usb_init’:
/home/monstersnatch/Desktop/qc-usb/qc-usb-0.6.6/qc-driver.c:3158: error: ‘struct video_device’ has no member named ‘priv’
make[2]: *** [/home/monstersnatch/Desktop/qc-usb/qc-usb-0.6.6/qc-driver.o] Error 1
make[1]: *** [_module_/home/monstersnatch/Desktop/qc-usb/qc-usb-0.6.6] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.28-15-generic'
make: *** [quickcam.ko] Error 2

does someone have an ideea how to fix this ?
thanks a lot

Revision history for this message
picca (picca-pudr) wrote :

Skype, cheese video (K)ubuntu 9.10 not working with Bus 003 Device 002: ID 0c45:60c0 Microdia PC Camera with Mic (SN9C105), which is MSI Clip Cam. Everything I needed was the trick mentioned in #4 :
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
or
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so cheese
and the webcam works!

Revision history for this message
Gergely Fábián (gergely.fabian) wrote :

The LD_PRELOAD trick is not working for me (on Karmic 9.10 64bit). I've got a QuickCam Express webcam, and both in Skype and Cheese I have the greenish image.
Using kernel 2.6.31-17-generic.

Revision history for this message
Gergely Fábián (gergely.fabian) wrote :

Forgot to add: I'm using the LD_PRELOAD trick (32bit one) in a proper way (I get no error with it), because without it Skype (2.1 beta, installed from skype.com) gives a nearly full-green still webcame image, but with the trick I can see the real image, just that it's greenish. For Cheese LD_PRELOAD changes nothing (all the time real, greenish image).

Revision history for this message
Gergely Fábián (gergely.fabian) wrote :

Tested QuickCam Express in Lucid Lynx Alpha 2 (64bit) and it works like a charm with Cheese.
Skype needs the LD_PRELOAD trick. With Cheese the video orientation is ok, but Skype shows it horizontally mirrored.

Revision history for this message
Opvolger (opvolger) wrote :

I have plugged in my webcam a Logitecg QuickCam Zoom. It is detected, microphone is working but the screen is not good.
Pictures are taken in the drak, that is oke, but the lines!

http://www.opvolger.net/opvolger/images/linux/2010-01-21-222223.jpg

Is this a known bug? or is my webcam dead?

Ubuntu 9.10 (32 bit). The rest of the hardware is working perfect!

Revision history for this message
Diegstroyer (diegstroyer) wrote : Re: [Bug 293176] Re: Ubuntu doesn't support some logitech and labtec webcams

Try your webcam with Ubuntu 10.04 Alpha (liveCD) or 8.04 (LiveCD), i
think that is a ubuntu kernel's bug.

My webcam works good with 10.04 and 8.04, but wrong with 9.04 and 9.10.

Good luck.

El dj 21 de 01 de 2010 a les 21:48 +0000, en/na Opvolger va escriure:
> I have plugged in my webcam a Logitecg QuickCam Zoom. It is detected, microphone is working but the screen is not good.
> Pictures are taken in the drak, that is oke, but the lines!
>
> http://www.opvolger.net/opvolger/images/linux/2010-01-21-222223.jpg
>
> Is this a known bug? or is my webcam dead?
>
> Ubuntu 9.10 (32 bit). The rest of the hardware is working perfect!
>

Revision history for this message
Dianne Reuby (pramclub) wrote :

Tried mine after upgrading to 9.10 and it's working OK in Cheese with no tweaking at all.

Revision history for this message
Opvolger (opvolger) wrote :

I have tried my webcam an other pc (with windows), it is the cam, on windows the same result. So i think it is time for a new webcam... Thx for the fast replay...

Revision history for this message
facucampeon (facucampeon) wrote :
Download full text (4.0 KiB)

hello, I'm newcomer in this web bugs on ubuntu.
Basically are the same bugs that are here nothing but my webcam works in Chesse, xawtv, in camorama not, and I need to amsn 0.98.1

facu facundo @: ~ $ lsusb
Bus 001 Device 003: ID 054C: 01bd Sony Corp. MRW62E Multi-Card Reader / Writer
Bus 001 Device 001: ID 1d6b: 0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b: 0001 Linux Foundation 1.1 Rootes hub
Bus 004 Device 001: ID 1d6b: 0001 Linux Foundation 1.1 Rootes hub
Bus 003 Device 001: ID 1d6b: 0001 Linux Foundation 1.1 Rootes hub
Bus 002 Device 002: ID 0458:7004 KYE Systems Corp. (Mouse Systems) VideoCAM Express
Bus 002 Device 001: ID 1d6b: 0001 Linux Foundation 1.1 Rootes hub

the channel is spca561a

v4l2: USB camera 0458:7004 and this is the device

Code:

sudo ma update & & sudo ma prepare & & sudo ma ai qc-usb-source

probe these codes but the last code change it

sudo m-a-i spca5xx-source

install but gave error

-------------------------------------------------- -------------------------------------------------- --------------------------------------
Updated info files from packages 1
Getting the sources for kernel version: 2.6.28-17-generic
Kernel headers available in / usr / src / linux
Creating symlink ...
Could not create the symbolic link / usr / src / linux!
apt-get install build-essential
apt-get: install build-essential
Reading package lists ... Made
Building dependency tree
Reading state information ... Made
build-essential is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
W: Duplicate sources.list entry http://ar.archive.ubuntu.com jaunty-updates/main Packages (/ var/lib/apt/lists/ar.archive.ubuntu.com_ubuntu_dists_jaunty-updates_main_binary-amd64_Packages)
W: Duplicate sources.list entry http://ar.archive.ubuntu.com jaunty-updates/restricted Packages (/ var/lib/apt/lists/ar.archive.ubuntu.com_ubuntu_dists_jaunty-updates_restricted_binary-amd64_Packages)
W: Duplicate sources.list entry http://ar.archive.ubuntu.com jaunty-updates/main Packages (/ var/lib/apt/lists/ar.archive.ubuntu.com_ubuntu_dists_jaunty-updates_main_binary-amd64_Packages)
W: Duplicate sources.list entry http://ar.archive.ubuntu.com jaunty-updates/restricted Packages (/ var/lib/apt/lists/ar.archive.ubuntu.com_ubuntu_dists_jaunty-updates_restricted_binary-amd64_Packages)
W: Duplicate sources.list entry http://ar.archive.ubuntu.com jaunty-updates-i386/main Packages (/ var/lib/apt/lists/ar.archive.ubuntu.com_ubuntu_dists_jaunty-updates-i386_main_binary-amd64_Packages)
W: Duplicate sources.list entry http://ar.archive.ubuntu.com jaunty-updates-i386/restricted Packages (/ var/lib/apt/lists/ar.archive.ubuntu.com_ubuntu_dists_jaunty-updates-i386_restricted_binary-amd64_Packages)
W: Duplicate sources.list entry http://ar.archive.ubuntu.com jaunty-updates-i386/main Packages (/ var/lib/apt/lists/ar.archive.ubuntu.com_ubuntu_dists_jaunty-updates-i386_main_binary-amd64_Packages)
W: Duplicate sources.list entry http://ar.archive.ubuntu.com jaunty-updates-i386/restricted Packages (/ var/lib/apt/lists/ar.archive.ubuntu.com_ubuntu_dists_jaunty-updates-i386_restricted_binary-amd64_Packages)
W: You may want to run apt-get...

Read more...

Revision history for this message
facucampeon (facucampeon) wrote :
Download full text (4.2 KiB)

hola, soy recien llegado en esta web acerca de bugs de ubuntu.
Basicamente son los mismos bugs que estan aqui nada mas que mi webcam funciona en Chesse, xawtv, en camorama no, y yo lo necesito para amsn 0.98.1

facundo@facu:~$ lsusb
Bus 001 Device 003: ID 054c:01bd Sony Corp. MRW62E Multi-Card Reader/Writer
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 0458:7004 KYE Systems Corp. (Mouse Systems) VideoCAM Express
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

el canal es spca561a

v4l2: USB camera 0458:7004 y este es el dispositivo

Code:

sudo m-a update && sudo m-a prepare && sudo m-a a-i qc-usb-source

probe estos codigos pero al ultimo codigo lo modifique

sudo m-a a-i spca5xx-source

instalo pero dio error

------------------------------------------------------------------------------------------------------------------------------------------
Actualizado los ficheros infos de los paquetes 1
Obteniendo los fuentes de la versión del núcleo: 2.6.28-17-generic
Encabezados del núcleo disponibles en /usr/src/linux
Creando enlace simbólico...
¡No se pudo crear el enlace simbólico /usr/src/linux!
apt-get install build-essential
apt-get: install build-essential
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
build-essential ya está en su versión más reciente.
0 actualizados, 0 se instalarán, 0 para eliminar y 1 no actualizados.
W: Duplicate sources.list entry http://ar.archive.ubuntu.com jaunty-updates/main Packages (/var/lib/apt/lists/ar.archive.ubuntu.com_ubuntu_dists_jaunty-updates_main_binary-amd64_Packages)
W: Duplicate sources.list entry http://ar.archive.ubuntu.com jaunty-updates/restricted Packages (/var/lib/apt/lists/ar.archive.ubuntu.com_ubuntu_dists_jaunty-updates_restricted_binary-amd64_Packages)
W: Duplicate sources.list entry http://ar.archive.ubuntu.com jaunty-updates/main Packages (/var/lib/apt/lists/ar.archive.ubuntu.com_ubuntu_dists_jaunty-updates_main_binary-amd64_Packages)
W: Duplicate sources.list entry http://ar.archive.ubuntu.com jaunty-updates/restricted Packages (/var/lib/apt/lists/ar.archive.ubuntu.com_ubuntu_dists_jaunty-updates_restricted_binary-amd64_Packages)
W: Duplicate sources.list entry http://ar.archive.ubuntu.com jaunty-updates-i386/main Packages (/var/lib/apt/lists/ar.archive.ubuntu.com_ubuntu_dists_jaunty-updates-i386_main_binary-amd64_Packages)
W: Duplicate sources.list entry http://ar.archive.ubuntu.com jaunty-updates-i386/restricted Packages (/var/lib/apt/lists/ar.archive.ubuntu.com_ubuntu_dists_jaunty-updates-i386_restricted_binary-amd64_Packages)
W: Duplicate sources.list entry http://ar.archive.ubuntu.com jaunty-updates-i386/main Packages (/var/lib/apt/lists/ar.archive.ubuntu.com_ubuntu_dists_jaunty-updates-i386_main_binary-amd64_Packages)
W: Duplicate sources.list entry http://ar.archive.ubuntu.com jaunty-updates-i386/restricted Packages (/var/lib/apt/lists/ar.archive.ubuntu.com_ubuntu_dists_ja...

Read more...

Revision history for this message
facucampeon (facucampeon) wrote :

facundo@facu:~/Descargas/gspcav1-01.00.10$ sudo make
make -C /lib/modules/`uname -r`/build SUBDIRS=/home/facundo/Descargas/gspcav1-01.00.10 CC=cc modules
make[1]: se ingresa al directorio `/usr/src/linux-headers-2.6.28-17-generic'
scripts/Makefile.build:46: *** CFLAGS was changed in "/home/facundo/Descargas/gspcav1-01.00.10/Makefile". Fix it to use EXTRA_CFLAGS. Alto.
make[1]: *** [_module_/home/facundo/Descargas/gspcav1-01.00.10] Error 2
make[1]: se sale del directorio `/usr/src/linux-headers-2.6.28-17-generic'
make: *** [default] Error 2
facundo@facu:~/Descargas/gspcav1-01.00.10$

Revision history for this message
Diegstroyer (diegstroyer) wrote :
Download full text (4.8 KiB)

Has probado emesene? Mercury messenger?

Es raro que si te funciona en cheese no funcione en ams, la has
configurado en preferencias del amsn?

Deberías usar la 9.10, soluciona muchos problemas con webcams, a mi me
funciona, pero se me ve verde (Logitech Quickcam Express), por ahí he
leído que en la 10.04 Alpha funciona bien la mia, pero prefiero esperar.

Saludos.

El dj 11 de 02 de 2010 a les 18:09 +0000, en/na facucampeon va escriure:
> hola, soy recien llegado en esta web acerca de bugs de ubuntu.
> Basicamente son los mismos bugs que estan aqui nada mas que mi webcam funciona en Chesse, xawtv, en camorama no, y yo lo necesito para amsn 0.98.1
>
> facundo@facu:~$ lsusb
> Bus 001 Device 003: ID 054c:01bd Sony Corp. MRW62E Multi-Card Reader/Writer
> Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> Bus 002 Device 002: ID 0458:7004 KYE Systems Corp. (Mouse Systems) VideoCAM Express
> Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
>
> el canal es spca561a
>
> v4l2: USB camera 0458:7004 y este es el dispositivo
>
> Code:
>
> sudo m-a update && sudo m-a prepare && sudo m-a a-i qc-usb-source
>
> probe estos codigos pero al ultimo codigo lo modifique
>
> sudo m-a a-i spca5xx-source
>
> instalo pero dio error
>
>
> ------------------------------------------------------------------------------------------------------------------------------------------
> Actualizado los ficheros infos de los paquetes 1
> Obteniendo los fuentes de la versión del núcleo: 2.6.28-17-generic
> Encabezados del núcleo disponibles en /usr/src/linux
> Creando enlace simbólico...
> ¡No se pudo crear el enlace simbólico /usr/src/linux!
> apt-get install build-essential
> apt-get: install build-essential
> Leyendo lista de paquetes... Hecho
> Creando árbol de dependencias
> Leyendo la información de estado... Hecho
> build-essential ya está en su versión más reciente.
> 0 actualizados, 0 se instalarán, 0 para eliminar y 1 no actualizados.
> W: Duplicate sources.list entry http://ar.archive.ubuntu.com jaunty-updates/main Packages (/var/lib/apt/lists/ar.archive.ubuntu.com_ubuntu_dists_jaunty-updates_main_binary-amd64_Packages)
> W: Duplicate sources.list entry http://ar.archive.ubuntu.com jaunty-updates/restricted Packages (/var/lib/apt/lists/ar.archive.ubuntu.com_ubuntu_dists_jaunty-updates_restricted_binary-amd64_Packages)
> W: Duplicate sources.list entry http://ar.archive.ubuntu.com jaunty-updates/main Packages (/var/lib/apt/lists/ar.archive.ubuntu.com_ubuntu_dists_jaunty-updates_main_binary-amd64_Packages)
> W: Duplicate sources.list entry http://ar.archive.ubuntu.com jaunty-updates/restricted Packages (/var/lib/apt/lists/ar.archive.ubuntu.com_ubuntu_dists_jaunty-updates_restricted_binary-amd64_Packages)
> W: Duplicate sources.list entry http://ar.archive.ubuntu.com jaunty-updates-i386/main Packages (/var/lib/apt/lists/ar.archive.ubuntu.com_ubuntu_dists_jaunty-updates-i386_main_binary-amd64_Packages)
> W: Duplicate sources.list entr...

Read more...

Revision history for this message
facucampeon (facucampeon) wrote :

thanks!!

Probe con emesene y la camara anda bien tengo la ultima versión emesene 1.6 "mate".
tiene para configurar el microfono?
Debe de ser un bug de amsn, menos mal que hay alternativas

Revision history for this message
Tom Fifield (fifieldt) wrote :

Good news all - my Logitech, Inc. QuickCam Express is "plug and play" in Lucid. Check it out.

Revision history for this message
Savvas Radevic (medigeek) wrote :

Confirming the above comment. Works out of the box in Ubuntu 10.04 Lucid Lynx!

$ lsusb
Bus 006 Device 002: ID 046d:0920 Logitech, Inc. QuickCam Express

Notes:
1. Connect directly: Plug it directly to the usb on the back of your PC, do not use any usb hubs or 3rd party usb extensions
2. Skype: If you want to run it with skype install the package "lib32v4l-0" which contains the v4l1compat.so file for 32-bit applications:

sudo apt-get install ia32-libs lib32v4l-0

..Then execute this to load the 32-bit library:

LD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so skype

Note #3: 32-bit Skype: Yes, skype is 32-bit even in 64-bit debian packages.

Revision history for this message
Tom Fifield (fifieldt) wrote :

Given affected versions of Ubuntu have passed end-of-life, propose marking this bug as "Invalid"

Changed in libv4l (Ubuntu):
status: Confirmed → Invalid
Changed in linux (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers