distorted sound Intel Corporation 82801H

Bug #291798 reported by Lukas Heizmann on 2008-10-31
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)

Bug Description

Hi there!

After installing Intrepid Ibex on my ThinkPad R61i my sound is distorted. (With Hardy it worked...) I did some tests on that, trying to use plain OSS and Alsa and it was the same as using PulseAudio. So I think this is due to a bug in the driver.

lukas@lukas-laptop:~$ lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)

Cheers Lukas

Anthony Noto (angusthefuzz) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it without more information.

Please include the following additional information, if you have not already done so (pay attention to lspci's additional options), as required by the Ubuntu Kernel Team:
1. Please include the output of the command "uname -a" in your next response. It should be one, long line of text which includes the exact kernel version you're running, as well as the CPU architecture.
2. Please run the command "dmesg > dmesg.log" after a fresh boot and attach the resulting file "dmesg.log" to this bug report.
3. Please run the command "sudo lspci -vvnn > lspci-vvnn.log" and attach the resulting file "lspci-vvnn.log" to this bug report.

Additionally, please include the information requested from the "Reporting Sound Bugs" section of https://wiki.ubuntu.com/DebuggingSoundProblems as separate attachments.

Lukas Heizmann (lukas-heizmann) wrote :

Here are some informations automatically collected by alsa-info.sh: http://www.alsa-project.org/db/?f=6ff6206e3097ab0cb6e255717b587aa7f3ad9229

Lukas Heizmann (lukas-heizmann) wrote :
Lukas Heizmann (lukas-heizmann) wrote :
Anthony Noto (angusthefuzz) wrote :

Thanks for the information. One last piece of information we need to collect is the output of alsa-script located here: https://wiki.ubuntu.com/DebuggingSoundProblems

Lukas Heizmann (lukas-heizmann) wrote :

I think I've already posted the output of the alsa-script above. Here's the link again: http://www.alsa-project.org/db/?f=6ff6206e3097ab0cb6e255717b587aa7f3ad9229
Or isn't this the information you need?

Anthony Noto (angusthefuzz) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in linux:
assignee: angusthefuzz → ubuntu-audio
status: Incomplete → Confirmed
Vladislav Muravyev (rex-lux) wrote :

it could help in your case (see last comment):
it helped me, at least.

Daniel R. Grayson (dan-math) wrote :

This is a serious problem also for me, on my Thinkpad R61i. The suggestion above (which amounts to setting the sample rate to 48000) helped once, but now it doesn't. With the default 44100 in place, there were these error messages:

     Dec 6 08:53:31 gallium pulseaudio[8496]: alsa-util.c: Device hw:1 doesn't support 44100 Hz, changed to 37286 Hz.
     Dec 6 08:53:31 gallium pulseaudio[8496]: alsa-util.c: Device hw:1 doesn't support 2 channels, changed to 1.
     Dec 6 08:53:31 gallium pulseaudio[8496]: alsa-util.c: Device front:0 doesn't support 44100 Hz, changed to 48000 Hz.
     Dec 6 08:53:31 gallium pulseaudio[8496]: alsa-util.c: Device front:0 doesn't support 44100 Hz, changed to 48000 Hz.

Let me know if there's any way I can help, too.

Longshoreman (longshoreman) wrote :

Hi I am having serious problems too!
I have no sound and have not had since day one
I am running Ubuntu 9.10 Jaunty on a Medion Notebook and my sound card is as follows
Audio device: Intel Corporation 82801H (ICH8 Family) HD
Audio Controller (rev 03) 00:1c.0 PCI bridge: Having checked the ALSA siktre it would seem that my sound card is not supported. I have sent am e-mail but as yet have had no response.

On Tue, May 12, 2009 at 2:35 AM, Longshoreman <email address hidden> wrote:
> I am running Ubuntu 9.10 Jaunty on a Medion Notebook and my sound card is as follows

9.10? Jaunty? Which is it? (9.10 is Karmic, not Jaunty - which is 9.04)

You should be able to use "apport-collect -p alsa-base 291798" regardless.

Architecture: i386
 /dev/snd/controlC0: mauerbach 3377 F.... mixer_applet2
 Card hw:0 'ICH7'/'Intel ICH7 with AD1981B at irq 23'
   Mixer name : 'Analog Devices AD1981B'
   Components : 'AC97a:41445374'
   Controls : 28
   Simple ctrls : 20
DistroRelease: Ubuntu 9.04
Package: alsa-base 1.0.18.dfsg-1ubuntu8
PackageArchitecture: all
 PATH=(custom, user)
Uname: Linux 2.6.28-11-generic i686
UserGroups: adm admin audio cdrom dialout lpadmin plugdev pulse pulse-access pulse-rt sambashare

Ari A (ari5av) wrote :
Ari A (ari5av) wrote :
Ari A (ari5av) wrote :
Ari A (ari5av) wrote :
Ari A (ari5av) wrote :
Ari A (ari5av) wrote :
Ari A (ari5av) wrote :
Ari A (ari5av) wrote :
Ari A (ari5av) wrote :
Ari A (ari5av) wrote :
Changed in linux (Ubuntu):
assignee: Ubuntu Audio Team (ubuntu-audio) → nobody
Longshoreman (longshoreman) wrote :

HI to reiterate I have been without souns since installing Ubuntu 8.10 and also following installation of Jaunty.
My sound hardware is
       description: Audio device
       product: 82801H (ICH8 Family) HD Audio Controller
       vendor: Intel Corporation
       physical id: 1b
       bus info: pci@0000:00:1b.0
       version: 03
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=HDA Intel latency=0 module=snd_hda_intel
I think? I have worked out that ALSA do not as yet support my sound card.
On advise I have tried to install OSS but again no luck.
I think? (I am a Ubuntu virgin so tend to get lost with all the codes (but finding out is half the fun!))
I currently have OSS sound but querying this by System-Preferences-Sound gives
audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink: Could not open audio device for playbac.
So still no further forward!
As always any help would be wonderful!
David ';^)>

Longshoreman (longshoreman) wrote :

Sound Problems – Solved

Hi All,
I have been doing lots of work trawling the net and picking brains far better than mine, then experimenting since last posting and I have a partial solution to the problem.

As we cannot get rid oft he PULSE AUDIO code without loosing the Ubuntu Desktop I have founs a workaround.

The solution that (eventually worked for me) I have listed below so that it may be of help to others

First we need to make ready the system the receive the OSS packsge so we need to install the Prereqrusites:

Open Terminal from the Taskbar (Applications > Accessories > Terminal)
Copy and paste the Code

sudo apt-get install linux-headers-generic linux-source build-essential

into the Terminal Box.
It will ask you for your password (this you set-up when you installed Ubuntu)
This will run the code and then go back to the prompt..
Then go to the OSS (Open Sound System) website and download oss:deb (distribution package)


I choose linux 2.6 - deb - x86 (It worked for me)

Right Click package.
Select open with GDebi Package Installer.

When this installed open

System > Preferences > Sound
In Sound Preferences in the Devices tab select OSS in all the option boxes.

Next right click in the task bar and Add the Gnome Volume Control.

Now Open Gnome Volume Control
Make sure that the Volume slide is set to max (to the right) and Mute is not selected (with a tick)
> Click Volume Control Box
> Volume Control Splash Box Opens
> Click Preferences Box
> Preferences Box Opens.
> Tick All Boxes > Close.
This will open all the volume control sliders for all various sound outputs.
> First make sure all the volume slides are near the top
Then with and audio source playing (CD?)
>Make sure vmiz0 is up near the top to maximise the output sound.
> Tick and untick the Mute Boxes for each control.
(It may seem daft, but even though a Mute Box may not show as muted it may still be!)
You should be listening now for sound
Depending on the chip set and Audio Card in your machine one or more of these output will control
Right Internal Speaker
Right Internal Speaker
Headphone Jack (Green)
Others (and there are many) will control recording and other stuff – not as yet investigated!
In my case the choices below worked.
*codec1 jack internal black shown twice > controls left and right internal speakers
*codec1 jack green > controls the Headphone socket (Green makes sense yes!)
.*vmix0-outvol > is the main output volume control (this in universal I think)
Now you should have sound from the outputs you desire and you can close the box.

As the Pluse Audio code is still installed it will periodically and at ramdom times re-assert itself and your sound will vanish again.

If this happens just open the Volume cotrole again and re-click the mute box at thge base of the sliders for the sound output you require (you sound hear a CLICK from the speakers which shows you have sound output again.

It has been a journey of dispare and discovery but hay thats Open Source right!?

Please post your results and comments It would be good to know how your get on.

Good Luck!

Brad Figg (brad-figg) on 2010-03-11
tags: added: sound-distorted

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers