[Intrepid] Atheros ath5k wireless driver not enabled by default

Bug #291576 reported by Pjotr12345 on 2008-10-31
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned

Bug Description

The Atheros ath5k wireless driver should be enabled by default! Please reverse this wrong decision.

Many first-time Ubuntu users will give up on Ubuntu, because of this. Their interests should weigh more heavily than the interests of upgraders with a manually installed Madwifi driver.

Related branches

schiemanski (schiemanski) wrote :

I agree with this.
I use the ath_pci driver with a patch and it works but this is not really an option for "first time ubuntu users".

ihc100 (arieht) wrote :

Just returned to 8.04 because atheros was only working now and then.
Thank you for mking my remote control working out of the box.

Wontfix bug as it is documented in release notes ?

http://www.ubuntu.com/getubuntu/releasenotes/810#Atheros%20ath5k%20wireless%20driver%20not%20enabled%20by%20default

"While not installed by default, this linux-backports-modules-intrepid-generic package is included on the Ubuntu 8.10 CD and DVD images for ease of installation."

Are release notes made - as we say in France - for dogs ?

schiemanski (schiemanski) wrote :

FredBezies, it seems that you don't known what the issue is...We know how we must act, but "first time ubuntu users" will not read those release notes ( of course)

You cannot know how wrong you are. Here is my wifi chipset.

05:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)

"We know how we must act, but "first time ubuntu users" will not read those release notes ( of course)"

And that is THE issue. If you want to fight with maintainers, feel free to do so. I acted the same way at first, but I saw if was the way to go.

If think this bug is and will stay invalid. Feel free to disagree. But I finally approve this decision.

stevenb (steven-gcc) wrote :

I am one of those "first time ubuntu users", but I'm not exactly new to Linux (been using it for almost a decade). I even did read the release notes. I even found that package (linux-backports-modules-intrepid*) on my DVD. And I still have no clue what to do. Except, I suppose, be a first-and-last-time ubuntu user, and find me a distribution that does work out-of-the-box :-(

IMHO the release notes are not helpful at all without some description (or a pointer to that) about how to install that package.

Lars Gjesse (larsgjesse) wrote :

While both drivers may have their strengths/weaknesses, it is certainly a weakness of Ubuntu 8.10 that it ships with a driver which does not work out of the box.
I use Ubuntu 8.10 on a Thinkpad T60, and for me it was a really big nuisance that I couldn't make suspend/resume work properly, until I discovered bug #275692 (reload ath_pci module on resume). Certainly, the average first-time user isn't going to fix this problem by himself - he'll simply dump Ubuntu.
It is even more frustrating to find that this problem was reported 6 months earlier on Hardy (bug #194607) and it is still not fixed.
I replaced madwifi with ath5k, and it works immediately. No patches required to make suspend/resume work. ath5k also makes WPA authentication complete much faster, for some reason which I don't know.
At the bottom line, based on my experience with Ubuntu 8.10, I agree that shipping madwifi as default was a big mistake. Sadly, it has probably scared away a lot of potential users.
If bug #194607 had been resolved in Hardy, avoiding bug #275692 in Intrepid, ath_pci would probably have worked OK for most users. But really, Ubuntu - come on and address the bugs. It's sooo embarrasing to let these kinds of problems pass through several releases.

Sander Jonkers (jonkers) wrote :

FWIW:

Things seem to be have been solved in Jaunty / 9.04: A friend of mine live-booted Jaunty Alpha 5 on his eMachines D620 with the Atheros wifi chipset, and reported:

"Jep, bingo, 9.05 alpha-5 ouf-of-the-box. lsmod shows ath5k."

HTH

Pjotr12345, thank you for taking the time to report this bug and helping to make Ubuntu better. Are you having a WiFi issue in a supported release? If so, could you please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect 291576

affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers