PS3: NetworkManager cannot connect to WPA/WPA2 wireless networks

Bug #289982 reported by Dan Munckton on 2008-10-27
40
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Colin Watson
Ubuntu PS3 Port
High
Dan Munckton
linux (Ubuntu)
Undecided
Unassigned
Nominated for Intrepid by Kasper
Nominated for Jaunty by Kasper
linux-ports (Ubuntu)
Undecided
Dan Munckton
Nominated for Intrepid by Kasper
Nominated for Jaunty by Kasper

Bug Description

Binary package hint: network-manager

Does connect to WEP networks ok though. Pretty much the same symptoms as bug #101857 (which is already closed).

Experienced on Intrepid as of 2008-10-24.

Will attach logs.

Dan Munckton (munckfish) on 2008-10-27
Changed in network-manager:
status: New → Incomplete
Changed in ubuntu-ps3-port:
importance: Undecided → High
status: New → Incomplete
description: updated
Tim Kornhammar (tim-kornhammar) wrote :

Attached some kernel logs to the problem.

Network manager cannot detect any networks, however it can try to connect to a hidden but then it breaks on the WPA/WPA2 password.

$ iwlist wlan0 scan
Does detect the networks, so does wifi-radar. Doesn't work to connect though. Hope the log help some.

Dan Munckton (munckfish) wrote :

Suggested text for release notes:

"On PS3 NetworkManager fails to connect to WPA/WPA2 wireless networks. However connecting to WEP encrypted networks works successfully."

Alexander Sack (asac) wrote :

unlikely that this is a NM issue. What driver/chipset does NM use?

Alexander Sack (asac) wrote :

err, "what driver/chipset does PS3 use" ?

asac thanks for your reply.

I wasn't sure where in the network stack this problem would be coming
from so I dumped it on Network Manager to start with.

The PS3 uses these drivers

ps3_gelic_net
ps3_gelic_wireless

I had my eye on the following upstream patch [0], do you think this is
likely to be related? If so I'll test it and arrange for it to be to
included in the PS3 kernel as an SRU if it works.

Cheers

Dan

[0]
http://git.kernel.org/?p=linux/kernel/git/geoff/ps3-linux-patches.git;a=blob;f=ps3-stable/ps3-gelic-wireless-wpa2-220.patch;h=15d7db6a75653d59e8c95379641d0b57a037436a;hb=e9921b224710f27b1ab43d2fd6d38b9b01a821d0

Alexander Sack (asac) wrote :

yes, that sounds like a good straw to go after. let us know.

Dan Munckton (munckfish) wrote :

The PS3 uses a linux-ports kernel not the mainline 'linux' sources, updated bug to reflect this.

Changed in linux:
status: Incomplete → Invalid
Changed in linux-ports:
status: New → Incomplete
Colin Watson (cjwatson) wrote :

Release notes text added:

== PlayStation 3 issues ==

There are a variety of other known issues affecting Play``Station 3 systems, documented in more detail in the [[http://psubuntu.com/wiki/IntrepidReleaseNotes|PS3 release notes]]. They include:

 * To get back to the Sony Play``Station 3 XMB operating system from the boot prompt, users need to type `game` and press the Return key ([[https://launchpad.net/bugs/277839|bug 277839]]). If this is for some reason not possible, carrying out a hard-reset (see PS3 instruction manual) will return to the XMB on next run.
 * Users may occasionally see an intermittent shutdown hang with a message like "IRQ 50: nobody cared". The problem has been reported upstream. Press and hold the PS3 power button until you hear 2 beeps will force power off. The system will boot normally on next run ([[https://launchpad.net/bugs/220370|bug 220370]]).
 * Network``Manager does not list available wireless networks, although it is possible to connect to a wireless network with a known SSID using the "connect to hidden wireless network" option ([[https://launchpad.net/bugs/289977|bug 289977]]); and it cannot connect to WPA/WPA2 wireless networks, although WEP works ([[https://launchpad.net/bugs/289982|bug 289982]]).

Changed in ubuntu-release-notes:
assignee: nobody → kamion
status: New → Fix Released
Jussi Saarinen (jms) wrote :

Have you tried to connect with wpasupplicant using ps3 driver? I couldn't connect with linux-ports kernel 2.6.25-2 with wpa_supplicant option "-Dps3", error message was "Unsupported driver 'ps3'".
I found this (https://bugzilla.redhat.com/show_bug.cgi?id=463852)

"The WEXT driver should work correctly with the PS3 Gelic wireless driver as of
2.6.27 kernel and wpa_supplicant 0.6.4, both of which ship with rawhide. The
"ps3" wpa_supplicant driver is deprecated as it was used before the kernel had
WEXT support for IW_ENC_CAPA_4WAY_HANDSHAKE. Please let me know if the WEXT
driver doesn't work by reopening this bug, and then we'll try to pin down where
the problem is."

So I tried next with kernel from Geoffs git (2.6.28-rc2) using option "-Dwext" and ps3 connected succesfully to WPA enabled AP.

Alexander Sack (asac) wrote :

On Thu, Oct 30, 2008 at 05:27:20PM -0000, jms wrote:
> Have you tried to connect with wpasupplicant using ps3 driver? I couldn't connect with linux-ports kernel 2.6.25-2 with wpa_supplicant option "-Dps3", error message was "Unsupported driver 'ps3'".
> I found this (https://bugzilla.redhat.com/show_bug.cgi?id=463852)
>
> "The WEXT driver should work correctly with the PS3 Gelic wireless driver as of
> 2.6.27 kernel and wpa_supplicant 0.6.4, both of which ship with rawhide. The
> "ps3" wpa_supplicant driver is deprecated as it was used before the kernel had
> WEXT support for IW_ENC_CAPA_4WAY_HANDSHAKE. Please let me know if the WEXT
> driver doesn't work by reopening this bug, and then we'll try to pin down where
> the problem is."
>

yes, HW specific wpasupplicant drivers are really a problem and we
should use wext nowadays. If there are still drivers that dont work
with wext it really is time to fix those.

> So I tried next with kernel from Geoffs git (2.6.28-rc2) using option
> "-Dwext" and ps3 connected succesfully to WPA enabled AP.
>

NM always uses -Dwext in intrepid.

 - Alexander

Great. Starting to get a good picture of the problem here. I think I
know the patches we need to fix this and bug 289977.

Will try to find time to work on this over the weekend.

Dan Munckton (munckfish) on 2008-11-03
Changed in ubuntu-ps3-port:
assignee: nobody → munckfish
status: Incomplete → In Progress
Changed in linux-ports:
assignee: nobody → munckfish
status: Incomplete → In Progress
Dan Munckton (munckfish) wrote :

Tested using new 2.6.27 based Jaunty ports kernel but WPA2 still not working. Will now dig deeper.

Updated info on the wireless:
http://www.kernel.org/pub/linux/kernel/people/geoff/cell/ps3-howto/ps3-wireless-howto.txt

Seems like wpa_supplicant 0.6.4 is required to get wext to work.

On Thu, Nov 13, 2008 at 05:15:31PM -0000, Tim Kornhammar wrote:
> Updated info on the wireless:
> http://www.kernel.org/pub/linux/kernel/people/geoff/cell/ps3-howto/ps3-wireless-howto.txt
>
> Seems like wpa_supplicant 0.6.4 is required to get wext to work.
>

Thats available in intrepid. also i network-manager PPA i guess - of
course ther eare no ppc builds in ppa, but well.

 - Alexander

I have successfully built, booted and used the git of Linux 2.6.28-rc8 and wpasupplicant 0.6.4. I have packages of both the kernel image and the kernel source if anyone wants to check them out.

I am using latest updates of Intrepid and using the supplied kboot.

The release solves many of the problems like booting, shutdown, wireless and wpa. However it still does remain some weird bugs in network manager.

Kaniz fatima (fatikaniz) wrote :

Hey Tim
Can you tell me where your kernel packages are ??
Thanks.

Here are the kernel packages:
http://www.ludd.ltu.se/~scuba/debs/

Alexander Sack (asac) wrote :

On Wed, Dec 17, 2008 at 07:33:38PM -0000, Tim Kornhammar wrote:
> I have successfully built, booted and used the git of Linux 2.6.28-rc8
> and wpasupplicant 0.6.4. I have packages of both the kernel image and
> the kernel source if anyone wants to check them out.
>
> I am using latest updates of Intrepid and using the supplied kboot.
>
> The release solves many of the problems like booting, shutdown, wireless
> and wpa. However it still does remain some weird bugs in network
> manager.
>

Are those wierd bugs filed yet? Can you do so and give us the bug ids
here?

 - Alexander

Filed now:

Network manager does not show wireless strength
https://bugs.launchpad.net/ubuntu-ps3-port/+bug/309457

Networkmanager does not autoconnect/connect on first try to wireless
https://bugs.launchpad.net/ubuntu-ps3-port/+bug/309459

emuman (emuman-gmx) wrote :

WPA2 does work for me with a custom 2.6.28 kernel. Is it planned to official release a bugfix for the 2.6.25 kernel in intrepid for ps3?

ntyonline (tzeyangng) wrote :

Seem to me the custom kernel will fix the problem, do anyone can provide the step by step to update it on the Psubuntu 8.1? I am fairly new to ubuntu. thanks.

ntyonline (tzeyangng) wrote :

Tim: can you please provide some steps to follow? thank you.

Just install the kernel packages previously provided and you are all
set. However it is only a RC8 and not the released version of kernel
2.6.28, the full version includes the VRAM patch.

On Mon, Jan 26, 2009 at 5:34 AM, ntyonline <email address hidden> wrote:
> Tim: can you please provide some steps to follow? thank you.
>
> --
> PS3: NetworkManager cannot connect to WPA/WPA2 wireless networks
> https://bugs.launchpad.net/bugs/289982
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Tim Kornhammar
<email address hidden>

Varning! E-post till och från Sverige, eller som passerar servrar i
Sverige, avlyssnas av Försvarets Radioanstalt, FRA.
WARNING! E-mail to and from Sweden, or via servers in Sweden, is
monitored by the National Defence Radio Establishment.

Kasper (kasper4711) wrote :

My PS3 won't boot any more with the 2.6.28 RC8 Kernel :(

Fresh install of Intrepid, custom Kernel+Headers installed with "dpkg -i". After reboot I get some kernel error messages (sorry, cannot provide exact error atm).

Dan Munckton (munckfish) wrote :

This is still a problem with Jaunty's new 2.6.28-1.6 linux-ports kernel. Possibly some kernel config setting is missing in the official kernel.

@Tim Kornhammar - could you upload your custom kernel config so I can compare?

Changed in ubuntu-ps3-port:
milestone: none → ubuntu-9.04
Dan Munckton (munckfish) wrote :

Attaching new logs. These are from booting Jaunty on PS3, then once everything has settled trying to manually connect to my wifi network ('munckfish'). Possibly notable messages are:

From daemon.log ...
Feb 20 15:51:30 ps3 NetworkManager: nm_setting_802_1x_get_pkcs11_engine_path: assertion `NM_IS_SETTING_802_1X (setting)' failed

From syslog ...
Feb 20 15:51:30 ps3 kernel: [ 1009.428514] gelic_eurus_sync_cmd_worker: cmd issue failed
Feb 20 15:51:40 ps3 kernel: [ 1019.433866] gelic_eurus_sync_cmd_worker: cmd issue failed
...

Dan Munckton (munckfish) wrote :
Dan Munckton (munckfish) wrote :

I used the default config ...
$ make ps3_defconfig

I haven't used the official kernel but 2.6.29-rc4 and it works when being stubborn (turn of wireless in nm-applet, wait ~3 sec, turn it on again).

Can test to boot the PS3 with the official kernel instead and see what happens, but with the stubbornness above it looks like it has to do with network manager.

Dan Munckton (munckfish) wrote :

Ok I had a break through today, similar to what you describe Tim - it seems I can get the PS3 to connect to my WPA wifi network, but only by removing the ethernet cable.

So I'm tempted to say this bug is closed now, and the problem we have left is probably bug 309457.

Changed in linux-ports:
status: In Progress → Fix Released
Changed in ubuntu-ps3-port:
status: In Progress → Fix Released
Changed in ubuntu-ps3-port:
status: Fix Released → Fix Committed
status: Fix Committed → In Progress
Steve Langasek (vorlon) wrote :

please don't change bug status without explanation.

Changed in ubuntu-ps3-port:
status: In Progress → Fix Released
amol (amol-chokshi) wrote :

hi there my ps3 ubuntu wireless is not working is there any fix available

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.