ath5k driver missing after latest intrepid update

Bug #289014 reported by Walter_Wittel on 2008-10-25
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Nominated for Hardy by ajr901
Nominated for Intrepid by stuartmarsden

Bug Description

https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/276508 (so maybe dupe) but this summary is more specific to the problem (276508 is older bug). Also this should attach files.

After upgrading intrepid this evening I lost wireless, and it turns out the ath5k directory/driver is missing ( 2.6.27-7-generic #1 SMP Fri Oct 24 06:42:44 UTC 2008 i686). The driver was there and had been working up until tonight. Perhaps this is a packaging problem rather than a kernel problem. Please reassign if appropriate.

I tried a reinstall from Synaptic but that didn't help.

walter@waltwld6:/lib/modules$ find . -iname 'ath5k*'
./2.6.27-6-generic/kernel/drivers/net/wireless/ath5k
./2.6.27-6-generic/kernel/drivers/net/wireless/ath5k/ath5k.ko
walter@waltwld6:/lib/modules$ find . -iname 'ath9k*'
./2.6.27-6-generic/kernel/drivers/net/wireless/ath9k
./2.6.27-6-generic/kernel/drivers/net/wireless/ath9k/ath9k.ko
./2.6.27-7-generic/kernel/drivers/net/wireless/ath9k
./2.6.27-7-generic/kernel/drivers/net/wireless/ath9k/ath9k.ko

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.10
Package: linux-image-2.6.27-7-generic 2.6.27-7.14
ProcCmdLine: root=UUID=e7e3a0a1-603b-4422-8949-699ba6633f22 ro quiet splash
ProcEnviron:
 PATH=/home/username/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.27-7.14-generic
SourcePackage: linux

Walter_Wittel (wittelw) wrote :
stuartmarsden (stuartmarsden) wrote :

I can confirm this. Wireless stopped working after latest update. Searched for ath5k and it is not present in the new kernel. Tried ath_pci and ath9k in case they had been extended to work with all chipsets but did not work. I presume this is some oversight.

This is a showstopper bug for many. I am using a asus 900 eee pc.

Changed in linux:
status: New → Confirmed
Valmantas Palikša (walmis) wrote :

It was done deliberately since the in-kernel ath5k was unstable. You can get the updated modules in linux-backports-modules package.

stuartmarsden (stuartmarsden) wrote :

Was stable for me. It surely is better to have unstable wireless than no wireless. People will just assume that the wireless does not work and will not know to use backports.

stuartmarsden (stuartmarsden) wrote :

Can confirm that all is well after installing linux-backports-modules

If the initial install detects the card and loads this package then should not be a problem. If it does not then leaving out this driver is a bad idea.

Walter_Wittel (wittelw) wrote :

I's like to agree with Stuart that ath5k was stable for me on my Asus 900 (restored connections after suspend better than my Vista machine). I also agree that knowing how to use backports is another barrier to entry.

IMHO the next 12 months is a golden opportunity for Ubuntu to gain significant market share in the netbook space. Even though Microsoft is struggling there don't think they will give up without a fight. I don't think Ubuntu should wait another 6 months to support this chip set out-of-box.

That said, and with thanks to all those providing help to me in past bugs and forums, here are the steps it took for me to get the backports installed (and my wireless working):

1) System->admin->"Software Sources"
2) On "Updates" tab check "Unsupported updates (intrepid-backports)"
3) When prompted click "Reload" to update the indexes
4) System->admin->"Synaptic..."
5) Find and mark for installation "linux-backports-modules-intrepid"
6) Click "Apply"
7) optionally from Terminal type "modprobe -l | grep ath5k" and you should see the location of the driver displayed to confirm it is there.
8) Reboot and your wireless should be working again.

Note: I've seen other bugs say you must add the line "blacklist ath_pci" to a file in /etc/modprobe.d, but that doesn't seem to be required anymore (I think it was for the -6 kernel). Also I'm sure there is a way to get the driver loaded from terminal without a reboot, but I'll have to defer to more experienced users to outline those steps.

Ath5k seemed stable for me to on my Compaq pressario A960. The propriatary packaged ath_hal doesn't work because it's versjon 0.9.18.0 and my card (AR2425) needs versjon 0.10.5.6.

Working wifi is a critical component. Even the wireless on/off button was working for me until today.

tomko222 (tomko222) wrote :

ath5k was stable in my computer...

decoherence (totalmassretain) wrote :

ASUS eeePC 900... wireless worked great until the fateful update that removed ath5k. Installing the backported modules got it working again.

Since everybody in this thread has a vested interest in seeing this driver get "stable" and be included again, it would be nice if someone with the knowledge could point out (in this thread) the specific issue that resulted in it being removed. Thanks to whoever can do that.

Perhaps jockey could be extended to pick up on things like this? Well, that's another report...

Also, Walter, to get the driver working without a reboot, just type

sudo modprobe ath5k

and Bob is your uncle.

Walter_Wittel (wittelw) wrote :

I found after a fresh Intrepid install for unrelated reasons :-( that my steps above got wireless working, but I was having intermittent problems with throughput. I added a file with "blacklist ath_pci" to a file in /etc/modprobe.d and things seem much better now. If this is the only thing needed to make the backport stable it would be great to add it to the install scripts and get this driver into the distribution.

Like decoherence I agree it would be great to know what the problem was and if any on this thread can help.

BTW thanks decoherence for the modprobe suggestion. As I recall modprobe worked (I could see the driver running with lsmod), but even when it was running if I right-clicked the Network Manager panel applet I didn't have an "Enable wireless" checkbox. I'll try this again if I ever get into this state again...

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers