r8169 counters, Intel Atom 230 (D945GCLF)

Bug #288845 reported by Prem Rara on 2008-10-24
12
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Hardy
Medium
Unassigned
Intrepid
Medium
Unassigned

Bug Description

Binary package hint: linux-image-generic

Re: http://ubuntuforums.org/showthread.php?t=884174

rig:
D945GCLF board
Intel Atom @ 1.6GHZ w/HT

It looks like it's a linux kernel bug:
http://www.gossamer-threads.com/lists/linux/kernel/982159

The ethernet controller is:

Realtek Semiconductor Co., Ltd. RTL8101E PCI Express Fast Ethernet controller (rev ff)

does not seem to work in any of the Ubuntu versions.

Hi Prem Rara,

Per the kernel team's bug policy, can you please attach the following information. Please be sure to attach each file as a separate attachment.

* cat /proc/version_signature > version.log
* dmesg > dmesg.log
* sudo lspci -vvnn > lspci-vvnn.log

For more information regarding the kernel team bug policy, please refer to https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks again and we appreciate your help and feedback.

Changed in linux-meta:
status: New → Incomplete
Prem Rara (fortran01) wrote :
Prem Rara (fortran01) wrote :
Prem Rara (fortran01) wrote :
Prem Rara (fortran01) wrote :
Prem Rara (fortran01) wrote :

This is the upstream report:
http://bugzilla.kernel.org/show_bug.cgi?id=10180

and I tried the patch on Ubuntu 2.6.24-19.41-generic:
http://linuxtrek1.blogspot.com/2008/10/ubuntu-on-intel-d945gclf-with-intel.html
Works.

Changed in rtl8169:
status: Unknown → Fix Released

Thanks Prem Rara. The patch referenced is in the upstream mainline kernel. Unfortunately it didn't make it into the Intrepid Ibex 2.6.27 kernel. I'll open both an Intrepid and Hardy nomination for the kernel team to consider backporting. Thanks.

ogasawara@yoji:~/linux-2.6$ git log 523a609496dbc3897e530db2a2f27650d125ea00
commit 523a609496dbc3897e530db2a2f27650d125ea00
Author: Francois Romieu <email address hidden>
Date: Wed Sep 10 22:28:56 2008 +0200

    r8169: fix RxMissed register access

    - the register is defined for the 8169 chipset only and there is
      no 8169 beyond RTL_GIGA_MAC_VER_06.
    - only the lower 3 bytes of the register are valid

    Fixes:
    1. http://bugzilla.kernel.org/show_bug.cgi?id=10180
    2. http://bugzilla.kernel.org/show_bug.cgi?id=11062 (bits of)

    Tested by Hermann Gausterer and Adam Huffman.

    Signed-off-by: Francois Romieu <email address hidden>
    Cc: Edward Hsu <email address hidden>
    Signed-off-by: Jeff Garzik <email address hidden>

Changed in linux-meta:
status: Incomplete → New
Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
milestone: none → intrepid-updates
status: New → Triaged
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
milestone: none → ubuntu-8.04.2
status: New → Triaged
Florian Effenberger (floeff) wrote :

I have similar issues with my board. Using recent Ubuntu 8.04 kernel, downloading latest driver from Realtek website, compiling it and blacklisting r8169 seems to cure the issue.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Rick Silva (silvari) wrote :

FWIW, I'm having a good amount of success with the r8169 driver, for an ethernet controller that lspci identifies as "Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)"

- board is Intel D945GCLF w/ Atom @ 1.6ghz, ICH7
- OS is Ubuntu Intrepid;
- 'uname -r' ==> "2.6.27-9-generic"
- acpid is running, apmd is disabled.

the link is stable and performance appears to be good, been running as such since Hardy.

However, I am having one problem with it: the NIC doesn't work after a resume from suspend. I'm not able to get any packets off the machine. The interface comes up, everything looks good in 'ifconfig -a' ; I can ping the interface's IP address, and 'netstat -r' looks fine. The orange (speed/link) LED on the physical connector is lit, but the green (activity) LED never lights. arping doesn't work either.

Florian Effenberger (floeff) wrote :

With the recent hardy kernel, it works out of the box for me!

Linux nibbler 2.6.24-22-server #1 SMP Mon Nov 24 20:06:28 UTC 2008 x86_64 GNU/Linux
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E PCI Express Fast Ethernet controller (rev 02)

Seems the correct driver has been included. ;-) Thanks!

The patch referenced in comment 7 (https://bugs.edge.launchpad.net/ubuntu/+source/linux/+bug/288845/comments/7) is already in the upcoming Jaunty 2.6.28 based kernel. As a result I'm marking the actively developed linux task as Fix Released but the Intrepid and Hardy nominations will remain open. Thanks.

Changed in linux:
milestone: intrepid-updates → none
status: Triaged → Fix Released
Florian Effenberger (floeff) wrote :

Are you sure? With 2.6.24-23-server (Ubuntu 8.04) it seems to work fine without any manual patching!

Steve Langasek (vorlon) wrote :

marking as invalid for hardy since this is reported to already be fixed.

Changed in linux:
status: Triaged → Invalid
Prem Rara (fortran01) wrote :

Still a lot of drops with the recent kernel:

root@atom02:~# ifconfig eth0
eth0 Link encap:Ethernet HWaddr 00:1c:c0:6f:5d:03
          inet addr:192.168.1.111 Bcast:192.168.1.255 Mask:255.255.255.0
          inet6 addr: fe80::21c:c0ff:fe6f:5d03/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:391 errors:0 dropped:2644014028 overruns:0 frame:0
          TX packets:73 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:28814 (28.1 KB) TX bytes:11558 (11.2 KB)
          Interrupt:220 Base address:0x4000

root@atom02:~# uname -a
Linux atom02 2.6.24-23-server #1 SMP Mon Jan 26 00:55:21 UTC 2009 i686 GNU/Linux
root@atom02:~# cat /etc/issue
Ubuntu 8.04.1 \n \l

Florian Effenberger (floeff) wrote :

Oh, you're right...same's true for me :-(

floeff@nibbler:~$ ifconfig eth0
eth0 Link encap:Ethernet Hardware Adresse 00:1c:c0:5d:1a:3c
          inet Adresse:192.168.2.254 Bcast:192.168.2.255 Maske:255.255.255.0
          inet6-Adresse: fe80::21c:c0ff:fe5d:1a3c/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metrik:1
          RX packets:577594 errors:0 dropped:1867106877334 overruns:0 frame:0
          TX packets:437775 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000
          RX bytes:534225028 (509.4 MB) TX bytes:53860821 (51.3 MB)
          Interrupt:252 Basisadresse:0xe000

floeff@nibbler:~$ uname -a
Linux nibbler 2.6.24-23-server #1 SMP Mon Jan 26 01:36:05 UTC 2009 x86_64 GNU/Linux

komputes (komputes) wrote :

I can confirm this bug on a Dell Mini 9 running 8.10 i386 (linux 2.6.27-11-generic). Jaunty seems to work fine. Installing the server kernel (2.6.27-11-server) seems to be a workaround for this, but booting from the server kernel takes away the possibility to use wireless on this particular machine (Broadcom BCM4312 - Bug #345647).

Jim Lieb (lieb) wrote :

Fixed in Jaunty.

Changed in linux (Ubuntu Intrepid):
status: Triaged → Invalid
Changed in rtl8169:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.