Ubuntu

On HP EliteBook 8530w; Kernel stops booting at ACPI: Thermal Zone [DTSZ]

Reported by falstaff on 2008-10-23
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
High
Andy Whitcroft
Intrepid
High
Andy Whitcroft

Bug Description

I tried todays Intrepid daily build on my new HP EliteBook 8530w. When I tried to install Ubuntu with the alternate disc, the kernel stopped booting some seconds after the boot menu. I changed the boot paramter and removed "quiet". I made a picture at the point the kernel hangs (see Attachement)

The kernel stopps working when he says:
ACPI: Thermal Zone [DTSZ]

With the kernel parameter "acpi=off" everything works....

===

SRU Justification

Justification: HP machines will not boot without this fix

Impact: HP (and potentially others with an _INI ACPI method) trip a check which is intended to be ASUS specific. This triggers a panic.

Fix Description: Limints the work around to ACUS hardware via a DMI match.

Patch: http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-intrepid.git;a=commit;h=0bc6d5188cfce75bcb8b9c715054ff9ba262758d

Risks: this should be low risk

TEST CASE: boot such a system

falstaff (falstaff) wrote :

Same problem is in 32-Bit also....

Sanix (suter-daniel) wrote :

I can confirm this problem. I tried with several boot options such as nolapic and so on. It still doesn't work, I get different errors though.

falstaff (falstaff) wrote :

Hi Sanix,

Nice to see another ubuntu user who own this device... can you contact me (e-mail should be visible in my profile), maybe we can share information how to bring other things to work on it....

yakuizhao (yakui-zhao) wrote :

Will you please attach the output of acpidump?
 Will you please try the boot option of "processor.max_cstate=1" or "idle=poll" and see whether the system still hang?
Thanks.

falstaff (falstaff) wrote :
falstaff (falstaff) wrote :

I tried this boot options, and both didn't worked...

Intresting is, that SuSE 11 with latest updates seems to work: http://www.linlap.com/wiki/HP+EliteBook+8530W

I'll gona try some other kernel versions...

falstaff (falstaff) wrote :

I tried the new 2.6.28-rc2, which did not work. Then I tried 2.6.25.19, which worked with ACPI, but only some times. About every second time he hangs at the same point where the current Ubuntu 8.10 kernel does. But sometimes he boots and acpi seems to work.

I attached output of dmesg when booting succeeded with 2.6.25.19.

falstaff (falstaff) wrote :

A pretty simple workaround is available:
Disable the BIOS option "Fan always ON on AC Power" under "System Config" -> "Device Config". With this option I could boot the system with latest Intrepid Kernel....

I found this here: http://www.linlap.com/wiki/HP+EliteBook+8530W, thanks to freak42

Sanix (suter-daniel) wrote :

There's still one bug though, after entering the user login data, gnome hangs for about 60 seconds. This behaviour does not exist in OpenSuse 11.

Here an extract from the .xsession log
/etc/gdm/Xsession: Beginning session setup...
Setting IM through im-switch for locale=en_US.
Start IM through /etc/X11/xinit/xinput.d/all_ALL linked to /etc/X11/xinit/xinput.d/default.
x-session-manager[8228]: WARNING: Unable to find provider 'gnome-wm' of required component 'windowmanager'
Xlib: extension "XEVIE" missing on display ":0.0".

(at-spi-registryd-wrapper:8309): atk-bridge-WARNING **: AT_SPI_REGISTRY was not started at session startup.

(at-spi-registryd-wrapper:8309): atk-bridge-WARNING **: IOR not set.

(at-spi-registryd-wrapper:8309): atk-bridge-WARNING **: Could not locate registry
x-session-manager[8228]: atk-bridge-WARNING: AT_SPI_REGISTRY was not started at session startup.
x-session-manager[8228]: atk-bridge-WARNING: IOR not set.
x-session-manager[8228]: atk-bridge-WARNING: Could not locate registry
Checking for Xgl: not present.
Detected PCI ID for VGA:
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Comparing resolution (1680x1050) to maximum 3D texture size (8192): Passed.
Checking for Software Rasterizer: Not present.
Checking for nVidia: present.
Checking for FBConfig: present.
Checking for Xgl: not present.
/usr/bin/compiz.real (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format
Starting gtk-window-decorator
x-session-manager[8228]: WARNING: Application 'gnome-wm.desktop' failed to register before timeout
seahorse nautilus module initialized
Initializing nautilus-share extension

(gnome-panel:839: Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -15 and height 24
Unable to open desktop file /usr/share/applications/sunbird.desktop for panel launcher: No such file or directory
Nautilus-Share-Message: Called "net usershare info" but it failed: 'net usershare' returned error 255: net usershare: cannot open usershare directory /var/lib/samba/usershares. Error No such file or directory
Please ask your system administrator to enable user sharing.

x-session-manager[8228]: WARNING: Application 'libcanberra-login-sound.desktop' failed to register before timeout

Tracker version 0.6.6 Copyright (c) 2005-2007 by Jamie McCracken (<email address hidden>)

This program is free software and comes without any warranty.
It is licensed under version 2 or later of the General Public License which can be viewed at http://www.gnu.org/licenses/gpl.txt

Initialising tracker...
starting HAL detection for ac adaptors...found /org/freedesktop/Hal/devices/computer_power_supply_ac_adapter_AC
Throttle level is 0
Failure: Module initalization failed

** (nautilus:8399): WARNING **: Unable to add monitor: Not supported
evolution-alarm-notify-Message: Setting timeout for 30284 1225666800 1225636516
evolution-alarm-notify-Message: Mon Nov 3 00:00:00 2008

evolution-alarm-notify-Message: Sun Nov 2 15:35:16 2008

I'm afraid the same problem affects HP EliteBook 8530p. The system randomly freezes even after adding acpi=off to the boot command line and disabling "Fan always ON on AC Power".

This is stopping Ubuntu to work in this new HP line.

As someone mentioned before that latest SuSE seems to work here, I'd like to add that Fedora 10 is also booting in this machine apparently with no issues.

Dana Goyette (danagoyette) wrote :

I also have the same model laptop, and as I commented in this other bug report (found it before I found this one), I can use serial-over-LAN to get stacktraces of the OOPSes.
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/294339
Should I reattach my attachments and comments to this bug report?

falstaff (falstaff) wrote :

Dana,

Did you tried it with the BIOS option "Fan always ON on AC Power"?

bye
falstaff

Dana Goyette (danagoyette) wrote :

I was using it with that BIOS setting enabled, because that's my preference, but now that I've disabled that option, it boots. However, I'd consider that more of a workaround, and not a fix -- I'd like to be able to get it to boot with that option enabled.

Perhaps I should try doing a diff of the disassembled DSDT, between option enabled disabled.

Dana Goyette (danagoyette) wrote :

Correction: I diff'd the two binary dsdt files, and there's no difference.

bogdan (kuko200099) wrote :

This is a kernel bug and is no distribution-dependent, so i think is better to report this bug to bugzilla.kernel.org

falstaff (falstaff) wrote :

Is already solved in 2.6.27.7, can we put this fix in Ubuntu too?

http://bugzilla.kernel.org/show_bug.cgi?id=11884

Changed in linux-meta:
assignee: nobody → ubuntu-kernel-acpi
Andy Whitcroft (apw) wrote :

@falstaff -- 2.6.27.7 should already be included in the updated kernels in Intrepid -proposed. Can you check that kernel and report back. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Andy Whitcroft (apw) wrote :

If this is a kernel bug then its package 'linux' not 'linux-meta'.

Dana Goyette (danagoyette) wrote :

Does the Jaunty 2.6.28-5 kernel also include this fix?

falstaff (falstaff) wrote :

I've installed the latest Kernel from proposed, but it still doesnt work...
$ uname -a
Linux alpha 2.6.27-11-generic #1 SMP Fri Jan 23 13:58:13 UTC 2009 x86_64 GNU/Linux

Might be that its another bug on 8530w. Anyway, there are some other outputs now in dmesg, this two lines doesnt appear anymore:
[ 3.268250] ACPI: EC: missing OBF confirmation, don't expect it any longer.
[ 3.774580] ACPI: EC: missing write data confirmation, don't expect it any longer.

On the Kernel bugzilla they talked about this lines, so it changes something... Despite of the boot bug, I sometimes had some ACPI-Errors when I was reading battery temerature, so it might be solve this problem... :-)

falstaff (falstaff) wrote :

Hm, I read the comments on Kernel Bugzilla once again. As far as I understand the "Fan always on" bug is solved by a patch which is only applied to 2.6.29-rc1 (second last comment). So I think it isn't included in 2.6.27.7! Can we apply this patch in 2.6.27-11 anyway?

http://bugzilla.kernel.org/attachment.cgi?id=19835&action=view

Changed in linux:
importance: Undecided → High
status: New → Triaged
Andy Whitcroft (apw) on 2009-02-12
Changed in linux:
assignee: ubuntu-kernel-acpi → apw
status: Triaged → In Progress
Andy Whitcroft (apw) wrote :

@falstaff -- ahh, yes looking at the bug there are two copies of the patch but neither seem to be applied to Intrepid or Jaunty.

I have pulled the version of the patch for older kernels and applied it to both the Intrepid and Jaunty kernels (I believe we have testers for both). If those of you who can test this could test these kernels and report back here. Please include the architecture and release you tested in your report. The kernels are at the URL below:

    http://people.ubuntu.com/~apw/lp288285-intrepid/
    http://people.ubuntu.com/~apw/lp288385-jaunty/

Andy Whitcroft (apw) on 2009-02-12
Changed in linux:
status: In Progress → Incomplete
Changed in linux:
status: Unknown → Fix Released
falstaff (falstaff) wrote :

I tested it on my HP 8530w on Intrepid AMD64. It works with the new kernel from the link above with BIOS option "Fan always ON on AC Power" enabled!

alex_b (barth-alexander) wrote :

For the records, the same bug also affects HP EliteBook 6930p.

Andy Whitcroft (apw) on 2009-03-02
Changed in linux:
status: Incomplete → In Progress
Andy Whitcroft (apw) on 2009-03-02
Changed in linux:
assignee: nobody → apw
importance: Undecided → High
status: New → In Progress
Andy Whitcroft (apw) wrote :

Commited fixes for this to both Intrepid and Jaunty.

Changed in linux:
status: In Progress → Fix Committed
status: In Progress → Fix Committed
Andy Whitcroft (apw) on 2009-03-05
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.28-8.28

---------------
linux (2.6.28-8.28) jaunty; urgency=low

  [ Alexey Starikovskiy ]

  * SAUCE: ACPI: EC: Limit workaround for ASUS notebooks even more
    - LP: #288385

  [ Scott James Remnant ]

  * SAUCE: Auto-load esp module when device opened.
  * SAUCE: Auto-load bridge module when socket opened.
  * SAUCE: Auto-load af_netlink module when socket opened.
  * SAUCE: Auto-load wanrouter module when socket opened.
  * SAUCE: Auto-load ip_queue module when socket opened.
  * SAUCE: Auto-load ip6_queue module when socket opened.
  * SAUCE: Auto-load cn module when socket opened.
  * SAUCE: Auto-load scsi_transport_iscsi module when socket opened.
  * SAUCE: Auto-load ftl module when device opened.
  * SAUCE: Auto-load pcd module when device opened.
  * SAUCE: Auto-load pf module when device opened.
  * SAUCE: Auto-load nftl module when device opened.
  * SAUCE: Auto-load mousedev module when psaux device opened.
  * SAUCE: Auto-load mousedev module when /dev/input/mice opened.
  * SAUCE: Auto-load rng-core module when device opened.
  * SAUCE: Auto-load openprom module when device opened.
  * SAUCE: Auto-load applicom module when device opened.
  * SAUCE: Auto-load toshiba module when device opened.
  * SAUCE: Auto-load cyclades module when device opened.
  * SAUCE: Auto-load riscom8 module when device opened.
  * SAUCE: Auto-load specialix module when device opened.
  * SAUCE: Auto-load videodev module when device opened.
  * SAUCE: Auto-load i2c_dev module when device opened.
  * SAUCE: Auto-load mtdchar module when device opened.
  * SAUCE: Auto-load pt module when device opened.
  * SAUCE: Auto-load pg module when device opened.
  * SAUCE: Auto-load cdc_acm module when device opened.
  * SAUCE: Auto-load msr module when device opened.
  * SAUCE: Auto-load cpuid module when device opened.
  * SAUCE: quickcam: Enable double-buffering by default
  * SAUCE: libata: Ignore HPA by default.
  * SAUCE: hostap: Change initial operation mode to managed (infra)
  * SAUCE: floppy: Provide a PnP device table in the module.
    - LP: #255651
  * SAUCE: Auto-load mwave module when device opened.
  * Build CONFIG_FUSE_FS into kernel, not as module.

  [ Stefan Bader ]

  * Enable build of ext4 as a module on LPIA
    - LP: #331848

  [ Tim Gardner ]

  * Update configs to fix LPIA FTBS

 -- Tim Gardner <email address hidden> Thu, 05 Mar 2009 10:43:24 -0700

Changed in linux:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Accepted intrepid into linux-proposed; please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

I enabled Proposed and installed the latest Kernel (2.6.27-13-generic). But I think this Kernel doesn't include this fix yet, uname -a shows that the Kernel was compiled in February...

$ uname -a
Linux alpha 2.6.27-13-generic #1 SMP Thu Feb 26 07:31:49 UTC 2009 x86_64 GNU/Linux

falstaff (falstaff) wrote :

Today I get a new Kernel on Intrepid, the kernel boots now with "Fan always ON on AC Power" enabled under Intrepid too!

$ uname -a
Linux alpha 2.6.27-14-generic #1 SMP Fri Mar 13 19:54:51 UTC 2009 x86_64 GNU/Linux

Thanks!

Martin Pitt (pitti) on 2009-03-25
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :
Download full text (27.1 KiB)

This bug was fixed in the package linux - 2.6.27-14.33

---------------
linux (2.6.27-14.33) intrepid-proposed; urgency=low

  [Stefan Bader]

  * Fix FTBS due to a mysteriously missing ABI directory.

linux (2.6.27-14.32) intrepid-proposed; urgency=low

  [Stefan Bader]

  * Rebuild of 2.6.27-14.30 with 2.6.27-11.31 security patches applied

linux (2.6.27-14.30) intrepid-proposed; urgency=low

  [ Alexey Starikovskiy ]

  * SAUCE: ACPI: EC: Limit workaround for ASUS notebooks even more
    - LP: #288385

  [ Huaxu Wan ]

  * SAUCE: report rfkill changes event if interface is down
    - LP: #193970

  [ Scott James Remnant ]

  * SAUCE: floppy: Provide a PnP device table in the module.
    - LP: #255651

  [ Steve Beattie ]

  * fix apparmor memory leak on deleted file ops
    - LP: #329489

  [ Stefan Bader ]

  * Revert "ACPI: Fix compiler warnings introduced by 32 to 64 bit acpi
    conversions"
    - LP: #337019
  * Revert "ACPI: Change acpi_evaluate_integer to support 64-bit on 32-bit
    kernels"
    - LP: #337019

  [ Upstream Kernel Changes ]

  * KVM: MMU: Add locking around kvm_mmu_slot_remove_write_access()
    - LP: #335097, #333409
  * ricoh_mmc: Handle newer models of Ricoh controllers
    - LP: #311932

linux (2.6.27-13.29) intrepid-proposed; urgency=low

  [ Colin Ian King ]

  * SAUCE: Bluetooth USB: fix kernel panic during suspend while streaming
    audio to bluetooth headset
    - LP: #331106, #322082

  [ Stefan Bader ]

  * Revert "SAUCE: Work around ACPI corruption upon suspend on some Dell
    machines." (replaced by stable update)
    - LP: #330200
  * Revert "SAUCE: Add back in lost commit for Apple BT Wireless Keyboard"
    (replaced by stable update)
    - LP: #330902

  [ Upstream Kernel Changes ]

  * Revert "vt: fix background color on line feed"
    - LP: #330200
  * ti_usb_3410_5052: support alternate firmware
    - LP: #231276
  * fuse: destroy bdi on umount
    - LP: #324921
  * fuse: fix missing fput on error
    - LP: #324921
  * fuse: fix NULL deref in fuse_file_alloc()
    - LP: #324921
  * inotify: clean up inotify_read and fix locking problems
    - LP: #324921
  * mac80211: decrement ref count to netdev after launching mesh discovery
    - LP: #324921
  * sysfs: fix problems with binary files
    - LP: #324921
  * x86, mm: fix pte_free()
    - LP: #324921
  * alpha: nautilus - fix compile failure with gcc-4.3
    - LP: #324921
  * it821x: Add ultra_mask quirk for Vortex86SX
    - LP: #324921
  * libata: pata_via: support VX855, future chips whose IDE controller use
    0x0571
    - LP: #324921
  * rtl8187: Add termination packet to prevent stall
    - LP: #324921
  * serial_8250: support for Sealevel Systems Model 7803 COMM+8
    - LP: #324921
  * SUNRPC: Fix a memory leak in rpcb_getport_async
    - LP: #324921
  * SUNRPC: Fix autobind on cloned rpc clients
    - LP: #324921
  * USB: fix char-device disconnect handling
    - LP: #324921
  * USB: storage: add unusual devs entry
    - LP: #324921
  * USB: usbmon: Implement compat_ioctl
    - LP: #324921
  * ALSA: hda - add another MacBook Pro 4, 1 subsystem ID
    - LP: #324921
  * ALSA: hda - Add quirk for HP DV6700 laptop
    - LP: #324921
  * ALSA: ...

Changed in linux (Ubuntu Intrepid):
status: Fix Committed → Fix Released
nUboon2Age (nuboon2age) on 2010-08-28
summary: - Kernel stops booting on HP EliteBook 8530w
+ On HP EliteBook 8530w; Kernel stops booting at ACPI: Thermal Zone [DTSZ]
Changed in linux:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.