Ubuntu

Disabling ath5k in 2.6.27

Reported by Loïc Minier on 2008-10-23
46
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Critical
Tim Gardner
Intrepid
Critical
Tim Gardner
linux-lpia (Ubuntu)
Critical
Amit Kucheria
Intrepid
Critical
Amit Kucheria

Bug Description

ath5k as released in 2.6.27 does not work very well for many people. Having it co-exist with madwifi also causes races like in bug 284354.

The better option is to disable the in-kernel ath5k and recommend that users install LBM

The linux-backports-modules package provides an updated version of the ath5k module.

Related branches

Loïc Minier (lool) wrote :

I'm not milestoning this; it's nice to get the driver disabled for intrepid, but hell wont freeze over if it isn't.

I'm tracking status in intrepid, and for jaunty we don't care: the in kernel ath5k as of early 2.6.28 will be good enough to replace madwifi completely.

Changed in linux:
assignee: nobody → timg-tpi
Loïc Minier (lool) wrote :
Loïc Minier (lool) wrote :

This also bug #284354 for the discussions around wifi support on Q1U which triggered this.

Pete Graner (pgraner) on 2008-10-23
Changed in linux:
importance: Undecided → Critical
status: New → In Progress
Loïc Minier (lool) on 2008-10-23
Changed in linux-lpia:
assignee: nobody → amitk
Colin Watson (cjwatson) on 2008-10-23
Changed in linux:
milestone: none → ubuntu-8.10
Changed in linux-lpia:
importance: Undecided → Critical
milestone: none → ubuntu-8.10

Please do not disable it. It is a nightmare to use wifi without it with atheros 5007eg chipset.

Loïc Minier (lool) wrote :

FredBezies, you can use linux-backport-modules's ath5k; the current one gives poor performance and disconnects, or doesn't work at all.

So it will be time to me to say good bye to ubuntu for one simple reason : I have no problem using this version ath5k module. And using linux backport modules is not an option for me.

Sorry to say this.

Steve Langasek (vorlon) wrote :

I understand that this fix is present in the unapproved queue now.

Changed in linux:
status: In Progress → Fix Committed
Steve Langasek (vorlon) wrote :

Fred,

linux-backport-modules is a supported Ubuntu package; why is using it not an option for you?

I had bad time with a previous backport module package. I don't want to reproduce this era.

So, I will close my account tonight. Bye Ubuntu, I had a good time since dapper time.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.27-7.14

---------------
linux (2.6.27-7.14) intrepid; urgency=low

  [ Tim Gardner ]

  * Disable ath5k in 2.6.27
    - LP: #288148

 -- Tim Gardner <email address hidden> Thu, 23 Oct 2008 07:40:43 -0600

Changed in linux:
status: Fix Committed → Fix Released
Amit Kucheria (amitk) on 2008-10-24
Changed in linux-lpia:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-lpia - 2.6.27-4.9

---------------
linux-lpia (2.6.27-4.9) intrepid; urgency=low

  [ Amit Kucheria ]

  * SAUCE: Start new release Ignore: yes
  * SAUCE: Add LPIA keyword in front of all our tags
  * SAUCE: Disable DYANMIC_FTRACE
    - LP: #263555
  * SAUCE: Disable ath5k from configs
    - LP: #288148
  * SAUCE: Fix rebase script some more
  * SAUCE: Change default TCP congestion algorithm to cubic
    - LP: #278801
  * SAUCE: Enable vesafb module

 -- Amit Kucheria <email address hidden> Thu, 23 Oct 2008 20:07:26 +0000

Changed in linux-lpia:
status: Fix Committed → Fix Released
Amit Kucheria (amitk) on 2008-10-24
description: updated
Ken Hagan (k-a-hagan) wrote :

I've just "lost" my wireless and grabbed linux-backports-modules-intrepid as suggested. This has restore *a* module with the name ath5k, but I can hardly see my router from just a few feet away, whereas I've never previously had trouble with whatever you guys just removed.

I imagine everyone's experience will vary, so you may be stuck between a rock and a hard place, but I personally would really like to get back to where I was the other day!

Ok, seems the backports package works on a eeePC 900, no performance loss as far as I can tell.

But it kind of sucked loosing network connectivity after a simple update without any warning. Bit difficult to search for this solution when you are offline... I would have expected these kind of things to be documented more clearly with 8.10 now being a release candidate and all. Please be more careful when it comes to network drivers.

Troy R. (dsm-iv-tr) wrote :

I agree with Jaap Karssenberg - please be more careful in the future with critical drivers.

This modification is a SHAME ! I have lost my wifi connectivity just after a simple update. Before my wireless connection was perfect. I am eeePC 900 and you talk about a "Out of the box" experience with Intrepid. It was true but now it's a lie because Wifi it's one of the most important thing on this computer. It's the first time I am very angry against Ubuntu team.

Paul O'Keefe (pbokeefe) wrote :

I always read the change log for the Kernel at least before I apply an update and thus I knew my ATH5K support would disappear. But I've long felt that update-manager or some other tool should preserve the last few changelogs locally so that when you applied an update and something suddenly stopped working you had a way to go back through your locally kept logs to try to determine the root cause.

I think the note here should have been much more explanatory. Something to the effect of "You WILL lose wireless connectivity and must take the following steps to restore it"

For my personal situation, merely installing the LBM package did not instantly restore connectivity. While I'm still troubleshooting and expect I'll eventually get either that module, MadWiFi or NdisWrapper to work, I can see that for many people, especially who only have wireless connectivity on their laptop/netbook that this could be terribly frustrating.

That said, all of you should be mindful that you are currently running a pre-release version of Intrepid, that this is not GA software and that you have put yourself in a unique situation by electing to use this distribution. The goal for everybody is to have stable software in six more days. I've experienced the performance problems with the ATH5K module that this thread are addressing and agree that stability for release must be a paramount goal.

IMHO it's a bad idea.

brethmas (brethmas) wrote :

I just changed my wificard to be linux-compatible, and you want to cancel my new one.....
It works perfectly.
Please keep it working.
This is a very common stuff and a lot of people will be lost if you make such a change.

Please can someone from the ubuntu team can reply ? I have performed "apt-get install linux-backports-modules-intrepid" but it don't works at all. I still lost my wifi since a simple update. When I check the OFFICIAL documentation I can read : "Wireless should work out-of-the-box with Ubuntu 8.10 Intrepid Ibex". https://help.ubuntu.com/community/EeePC/Fixes

Please enable ath5k in the kernel again or post a working fix ! LBM don't works for me in my eeePC, and as I see for many others.

Following up on my earlier post, I was not able to get LBM to work on my
Acer 4720z. I dropped back to NDISWRAPPER while I continue
troubleshooting, but this did break my install. I'll investigate the
LBM package further tomorrow.

On Mon, 2008-10-27 at 00:15 +0000, Moreira Mickaël wrote:

> Please can someone from the ubuntu team can reply ? I have performed
> "apt-get install linux-backports-modules-intrepid" but it don't works at
> all. I still lost my wifi since a simple update. When I check the
> OFFICIAL documentation I can read : "Wireless should work out-of-the-box
> with Ubuntu 8.10 Intrepid Ibex".
> https://help.ubuntu.com/community/EeePC/Fixes
>
> Please enable ath5k in the kernel again or post a working fix ! LBM
> don't works for me in my eeePC, and as I see for many others.
>

Willem2k (willem2k) wrote :

So yeah, next time you decide to kill, or 'update' something that's working perfectly fine for a whole lot of users : a heads up or an opt-out would be nice.

Loïc Minier (lool) wrote :

Please people, venting your frustation here doesn't help anyone.

1) this was discussed publicly (ubuntu-devel and kernel-team lists)
2) this was enabled and removed within a development cycle
3) there are workarounds (madwifi, lbm)

It's too late for the 8.10 release now; let's focus on:
- improving the next release
- fixing the most severe regressions via SRUs

If your card doesn't work with lbm's ath5k and it used to work with older ath5k, please open a new bug report with lspci -vvnn >lspci.txt, and dmesg output of failing and succeeding boots with the version of the packages you used in both cases.

Thanks,

The problem is quite tricky... It is a very sensible point ...

How can you install lbm or madwifi when you don't have any internet connection left ?

So please, set up a procedure to update from hardy to intrepid only via wifi !!!!

Download LBM package earlier without installing it. Or use a cable to connect to internet.

As many persons say before, download and install LBM don't solve the problem.

Ken Hagan (k-a-hagan) wrote :

 Loïc Minier wrote...
"Please people, venting your frustation here doesn't help anyone.
 1) this was discussed publicly (ubuntu-devel and kernel-team lists)
 2) this was enabled and removed within a development cycle
 3) there are workarounds (madwifi, lbm)"

I understand. As it happens, I pulled down the day's fixes this evening (as usual) and everything is suddenly working again, which is pretty much the experience I expect as a beta tester. That said, I think it is worth recording these experiences even if we can't explain them. I note that something called "SCIM" seemed to be introduced at the weekend, around the time my machine went belly-up, and there were patches for it this evening. I can't personally see the connection between input methods and wireless, and it's probably a red herring, but perhaps it's the flash of inspiration someone else needs.

SR (sniperifle) wrote :

I've found that the LBM does indeed work after I disabled the existing proprietary drivers in System -> Hardware Drivers and leaving the ath5k drivers on (listed as "drivers for Atheros 5xxx"). I then restarted the computer and wireless was back on. That is what I did previously in prior kernels of Intrepid, except that time around the ath5k driver wasn't in the list, but disabling the regular Atheros drivers did the trick back then too.

ekso (ekso) wrote :

To make the ath5k module from the LBM work you need to blacklist the others (ath_pci and ath_hal) and make sure ath5k is not blacklisted anywhere. Community solution was posted on the wiki here:

https://help.ubuntu.com/community/WifiDocs/Driver/Atheros

And on the forums.

And really people, "ubuntu-devel" and "kernel-team lists" are not something you can call "public". They don't show up on google searches, they don't show up for the end user (if they even are accessible by the end-user). If you want to make something public, right now Ubuntu seems to have JUST the forums. Maybe this is something that should be thought out better, but right now if you want to make something public, simple information like "your wifi will certainly break after this upgrade, please install package X", you *need to post in the forums*, preferably making a sticky out of it.

---> I strongly agree with Paul O'Keefe and Willem2k, *this was not publicized enough.*

Paul O'Keefe (pbokeefe) wrote :

If you can live with the performance....

Go to www.2wire.com and check the speed meter (just for comparison)

Kernel ath5K from LBM: 156 KBPS
NDIS Wrapper with net511 driver: 2.37 MBPS

from same location with same interference levels.

Pings to the local router show similar performance with NDIS Wrapper
driver in under 2 msec and Kernel driver in the 200 msec range.

On Thu, 2008-11-06 at 23:17 +0000, eks wrote:

> To make the ath5k module from the LBM work you need to blacklist the
> others (ath_pci and ath_hal) and make sure ath5k is not blacklisted
> anywhere. Community solution was posted on the wiki here:
>
> https://help.ubuntu.com/community/WifiDocs/Driver/Atheros
>
> And on the forums.
>
> And really people, "ubuntu-devel" and "kernel-team lists" are not
> something you can call "public". They don't show up on google searches,
> they don't show up for the end user (if they even are accessible by the
> end-user). If you want to make something public, right now Ubuntu seems
> to have JUST the forums. Maybe this is something that should be thought
> out better, but right now if you want to make something public, simple
> information like "your wifi will certainly break after this upgrade,
> please install package X", you *need to post in the forums*, preferably
> making a sticky out of it.
>
> ---> I strongly agree with Paul O'Keefe and Willem2k, *this was not
> publicized enough.*
>

gpk (gpk-kochanski) wrote :

> I've found that the LBM does indeed work after I disabled the existing proprietary drivers...

Same here. You have to "blacklist" the ath_pci and ath_hal modules.
See http://ubuntuforums.org/showthread.php?t=166624 .

blacklist ath_hal
blacklist ath_pci

...then reboot, and wireless works again.

Paul O'Keefe (pbokeefe) wrote :

Tim ---

Just applied the LBM update from today and retested the LBM ATH5K .vs. the NDISWRAPPER module. There are still performance problems, however the LBM ATH5K module seems very stable now. I cannot duplicate the earlier lost packet behavior I was observing in October.

ping2520 (ping2520) on 2009-08-16
Changed in linux (Ubuntu):
status: Fix Released → New

This bug has already been closed and the fix has been confirmed. If you have a valid reason for reopening this bug, I would suggest filing a new bug report instead.

Changed in linux (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers