hdaps does not work

Bug #281977 reported by Pascal d'Hermilly on 2008-10-12
46
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

The kernel module seems load fine. However the data I get when I run hdaps-pivot or poll /sys/devices/platform/hdaps/position are totally static even with the laptop on the side.

Karol Krizka (kkrizka) wrote :

I have the same problem on my laptop (Thinkpad X61), with all the latest upgrades in the Interpid repositories. I also tried to compile the hdaps module myself (from the tp_smapi sources) and that got it working again...

Jaime (jaime-lopez) wrote :

Seems like hdaps_ec.ko is gone (in previous ubuntu releases, it was the driver of choice for Thinkpads T60+)

Sammy Spets (sammys) wrote :

Same for me on Thinkpad X61/Intrepid. Compiled it from source using instructions from http://www.krizka.net/2008/01/23/thinkpad-x61-tablet-tilt-detection-and-ubuntu-hardy-heron/ and it's working.

Changed in linux:
status: New → Confirmed
Karol Krizka (kkrizka) wrote :

Any updates on this? It's still broken in Jaunty...

it works but after updates it's broken

pk@pk-laptop:~$ hdaps-gl
open: No such file or directory

pk@pk-laptop:~$ sudo modprobe hdaps
FATAL: Error inserting hdaps (/lib/modules/2.6.28-11-generic/kernel/drivers/hwmon/hdaps.ko): No such device

dist: jaunty

Pieter (diepes) wrote :

i seem to have the same problem
# uname -a
Linux pumba 2.6.28-13-generic #45-Ubuntu SMP Tue Jun 30 19:49:51 UTC 2009 i686 GNU/Linux

Jul 10 20:49:06 pumba kernel: [12525.783543] hdaps: inverting axis readings.
Jul 10 20:49:06 pumba kernel: [12525.783549] hdaps: LENOVO ThinkPad R61 detected.
Jul 10 20:49:06 pumba kernel: [12525.784263] input: hdaps as /devices/platform/hdaps/input/input12
Jul 10 20:49:06 pumba kernel: [12525.801713] hdaps: driver successfully loaded.

cat /sys/devices/platform/hdaps/position
always give the same value.

bug is in karmic too

pk@pk-laptop:~$ uname -a
Linux pk-laptop 2.6.31-2-generic #16-Ubuntu SMP Mon Jul 6 20:36:55 UTC 2009 x86_64 GNU/Linux

Philip Muškovac (yofel) wrote :

Could you guys try the newer tp-smapi modules from the repository? I don't know why they're not in the kernel but anyway:

sudo apt-get install tp-smapi-source
sudo module-assistant build tp-smapi-source
sudo module-assistant install tp-smapi-source

Geir Ove Myhr (gomyhr) wrote :

For newer thinkpads only the tp-smapi module works. For various personal/political reasons, it can not be included in the mainline kernel, and ubuntu doesn't want to maintain a kernel patch that is unlikely to make it into the kernel. The "right" place to get this fixed is in the mainline kernel. The discussion leading to this decision is in bug 297213 and on the mailing list following the post https://lists.ubuntu.com/archives/kernel-team/2009-April/005545.html .

I'm marking this as a won't fix, since it is really the same bug as bug 297213.

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix
Geir Ove Myhr (gomyhr) wrote :

Actually it looks like the mainline hdaps driver now does an honest attempt at supporting newer thinkpad models. http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=history;f=drivers/hwmon/hdaps.c;h=d3612a1f198135d1a719428fc5f77e417674e671;hb=b6a33fe2cc1b44851174967943fe5989f7e0550f
It does not do this as well as the tp-smapi module (it doesn't work), but the social engeneering required to get tp-smapi into the mainline kernel is beyond the scope of ubuntu, so the best we can hope for is a fix in the mainline version. Setting the status back to Confirmed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers