ALC268 audio broken in intrepid

Bug #281322 reported by Tim Cole on 2008-10-10
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Ever since rebooting after the most recent Intrepid update, audio has been broken for me. Most of my mixer settings are missing, and with master volume turned all the way up, I get only crackling noises instead of the expected audio.

Linux bede 2.6.27-6-generic #1 SMP Tue Oct 7 04:15:23 UTC 2008 x86_64 GNU/Linux

Description: Ubuntu intrepid (development branch)
Release: 8.10

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)

card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Parthan SR (parth-technofreak) wrote :

Thank you for taking your time to report this bug and help make Ubuntu better. Can you provide the following information attached as separate attachments to this bug report for us to work further on your bug?

1. uname -a
2. lspci -vvnn
3. Follow instructions provided at https://wiki.ubuntu.com/DebuggingSoundProblems

Tim Cole (tcole) wrote :
Download full text (22.6 KiB)

Mixer settings are back as of 2.6.27-7-generic, but I still get crackling noises rather than normal audio. I gave you uname -a above, but here it is again (with the new kernel version):

Linux bede 2.6.27-7-generic #1 SMP Fri Oct 10 03:55:01 UTC 2008 x86_64 GNU/Linux

And here is the unabridged output of lspci -vvnn:

00:00.0 Host bridge [0600]: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub [8086:2a00] (rev 03)
 Subsystem: Toshiba America Info Systems Device [1179:ff64]
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort+ >SERR- <PERR- INTx-
 Latency: 0
 Capabilities: [e0] Vendor Specific Information <?>
 Kernel driver in use: agpgart-intel
 Kernel modules: intel-agp

00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a02] (rev 03)
 Subsystem: Toshiba America Info Systems Device [1179:ff64]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Interrupt: pin A routed to IRQ 16
 Region 0: Memory at d3100000 (64-bit, non-prefetchable) [size=1M]
 Region 2: Memory at c0000000 (64-bit, prefetchable) [size=256M]
 Region 4: I/O ports at 6110 [size=8]
 Capabilities: [90] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
  Address: 00000000 Data: 0000
 Capabilities: [d0] Power Management version 3
  Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
  Bridge: PM- B3+
 Kernel modules: intelfb

00:02.1 Display controller [0380]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a03] (rev 03)
 Subsystem: Toshiba America Info Systems Device [1179:ff64]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Region 0: Memory at d3200000 (64-bit, non-prefetchable) [size=1M]
 Capabilities: [d0] Power Management version 3
  Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
  Bridge: PM- B3+

00:1a.0 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 [8086:2834] (rev 03)
 Subsystem: Toshiba America Info Systems Device [1179:ff64]
 Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Interrupt: pin A routed to IRQ 16
 Region 4: I/O ports at 60c0 [size=32]
 Kernel driver in use: uhci_hcd
 Kernel modules: uhci-hcd

00:1a.1 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 [8086:2835] (rev 03)
 Subsystem: Toshiba America Info Systems Device [1179:ff64]
 Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepp...

Tim Cole (tcole) wrote :

Found it. Looks like the saved mixer settings were corrupted; twiddling them in alsamixer fixed things.

Tim Cole (tcole) on 2008-10-11
Changed in linux:
status: Incomplete → Invalid
Graham Jones (jones139) wrote :

I think this is a bug - I just installed Ubuntu 8.10 on my Fujitsu Siemens Amilio L2727 laptop and had exactly the same problem - just crackling when it tried to play sound.
alsamixer only gave me one channel to adjust, which looked ok, but using gnome-alsamixer showed me a second device (Realtek ALC268), and the PCM channel was set to zero volume on this - increasing the PCM volume sorted it.
Does the installation of Ubuntu 8.10 adjust the alsa settings incorrectly?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers