Ubuntu

alsa sound fades out when headphones are plugged in until you inaudible

Reported by Derek Buranen on 2008-10-07
48
This bug affects 5 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned
linux (Ubuntu)
Low
Daniel T Chen

Bug Description

Binary package hint: alsa-base

Sound works fine from the speakers, but when headphones are plugged in, sound gradually diminishes until it is silent. Unplugging the headphones leaves it silent on the speakers. Reboot resets the position and sound is fine until 'phones plugged in.

My card is a "Sigmatel STAC9227" in a Dell Dimension e520 desktop but it seems to affect similar cards.

More info of the problem: http://ubuntuforums.org/showthread.php?t=913328&page=3

To address this, you can restart alsa and pulseaudio:

 sudo alsa force-reload
 pulseaudio

Workaround :
alt-f2
gksudo gedit /etc/modprobe.d/alsa-base.conf
add "options snd-hda-intel model=3stack" to end of file (without quotes), save
reboot

Derek Buranen (eburner) wrote :

Adding "options snd-hda-intel model=dell-3stack" to the bottom of my "/etc/modprobe.d/alsa-base" did not fix it in my case.

ubername (ubername) wrote :

Adding "options snd-hda-intel model=dell-3stack" to the bottom of my "/etc/modprobe.d/alsa-base" did not fix it in my case, either.

Also DellE520, Sigmatel9227.

ubername (ubername) wrote :

This problem seems to have gone away with various recent upgrades, but I don't know what fixed it for me.

Derek Buranen (eburner) wrote :

Still a problem here with all the latest updates. ubername, you do anything else?

Daniel T Chen (crimsun) wrote :

Please execute the alsa-info.sh script referenced from https://wiki.ubuntu.com/DebuggingSoundProblems and attach the URL here.

Please note that any possible fix will /not/ be in 8.10. -updates is possible but more likely 9.04.

Changed in alsa-driver:
status: New → Incomplete
Tim Ross (tim-ross) wrote :

Hi, I have had the same problem. I ran the alsa-info script and the output can be found here

http://www.alsa-project.org/db/?f=dbdf44b7f7a1ff7fc634cef975b7089fddd19736

The sound works if you keep the same speakers plugged in from boot, but as soon as I unplug the speakers/headphones and reconnect I get the fading effect.

jdbausch (jdbausch) wrote :

I'd just like to write a "me too" to this issue:

"The sound works if you keep the same speakers plugged in from boot, but as soon as I unplug the speakers/headphones and reconnect I get the fading effect."

after upgrading to Intrepid from hardy. the suggested fixes have not worked for me.

I have a Dimension e521

Derek Buranen (eburner) wrote :

still not working in Jaunty Alpha 2 with 2.6.28-4-generic

ubername (ubername) wrote :

Also not working in Jaunty (with updates to 09/02/09 - whatever alpha version that makes it)

Gari Araolaza (garaolaza) wrote :

Hi, no news from me.

Just to confirm this error in three Dell Dimension E520 and Ubuntu 8.10 systems.

Mikhail Moussikhine (belamiru) wrote :

I also confirm the same effect with the latest Ubuntu 9.04 and HT Omega Claro Halo.

Alsa info:
http://www.alsa-project.org/db/?f=d096043dca1f471400f1d8d2c17bfdd57f3f9524

I tried to upgrade to 1.0.19 drivers and the result is still the same. Sound fades out in about 5 sec. Furthermore, I was not able to get any sound from any other program but "Sound Preferences" Test Playback.

me too; DellE520, Sigmatel9227. When the headphones are unplugged before the fade is complete, the volume remains stable through the speakers though at its lower level; when the headphones are plugged in again, the fade resumes.

<daniel>Please execute the alsa-info.sh script [...] and attach the URL here.</daniel>

It said it uploaded the info, but never told me the URL, and I couldn't find it at www.alsa-project.org. So I ran it again without uploading; result is attached.

I have the same problem on Dell Dimension E521 with Sigmatel STAC9227

Here's my URL from the script: http://www.alsa-project.org/db/?f=8ecba9a6cc78bc8e98c81976cbdb3fc0941762a0

Brian Beck (brian-beck) wrote :

Same problem on a Dell Dimension C521, Kubuntu 9.04

$ uname -a
Linux skaro 2.6.28-11-generic #41-Ubuntu SMP Wed Apr 8 04:39:23 UTC 2009 x86_64 GNU/Linux

$ cat /proc/asound/cards
 0 [NVidia ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfe024000 irq 23

Link generated by alsa-info.sh:
http://www.alsa-project.org/db/?f=7249d3c3923d24d3a43c2625efc65e53f48651ce

If there is further information you require please let me know.

Thanks,
Brian

On Fri, 10 Apr 2009, Brian Beck wrote:

> http://www.alsa-project.org/db/?f=7249d3c3923d24d3a43c2625efc65e53f48651ce

Brian, you're using the wrong model quirk. You should be using
model=3stack, not model=model=hp-m4. (Note your extra "model=".)

Brian Beck (brian-beck) wrote :

I noticed that after I posted, and made the change and reboot my computer. Still no sound. Here's a re-run of the alsa-info.sh script:

http://www.alsa-project.org/db/?f=196fef41d023bf3ebabaa5b581fee3c51a70bc69

Thanks,
Brian

Brian Beck (brian-beck) wrote :

Daniel, I looked at your post again, and adding:

options snd-hda-intel model=3stack

to the bottom of /etc/modprobe.d/alsa-base.conf does in fact fix the problem!

Thank you so much,
Brian

Daniel T Chen (crimsun) on 2009-04-10
Changed in alsa-driver (Ubuntu):
status: New → Won't Fix
Daniel T Chen (crimsun) wrote :

Mikhail Moussikhine, you're using a separate codec (not even HDA but AC'97). Please file a separate bug so that you don't confuse people further.

Daniel T Chen (crimsun) wrote :
Changed in linux (Ubuntu):
assignee: nobody → Daniel T Chen (crimsun)
importance: Undecided → Low
status: Incomplete → Fix Committed
Mikhail Moussikhine (belamiru) wrote :

Well, duh. I did say that in my post.

The name of the bug does not specify that it is HDA specific. I use oxygen driver. And I have _exactly_ the same effect.

Ubuntu 9.04 is out. Plug-in headphones. Sound fades out in 5 sec. I will not confuse your further, though. Thanks.

I also added "options snd-hda-intel model=3stack" to the bottom of /etc/modprobe.d/alsa-base.conf and the problem was fixed.

Link generated by alsa-info.sh before I have added that new line:

http://www.alsa-project.org/db/?f=12490beb76d4796e72a24cb6f5665839d62d773a

My computer is a Dell Dimension C521.

Everthon Valadão (everthonvs) wrote :

@Daniel T Chen: the "options snd-hda-intel model=3stack" trick fixed here too, thanks!

Daniel T Chen (crimsun) wrote :

Derek, can you run the alsa-info.sh script to attach your audio hardware info to this bug report? (Alternately, if you're using Jaunty, just use "apport-collect -p alsa-base 279478".)

Everthon, if you're using Jaunty, can you also use "apport-collect -p alsa-base 279478", please?

AplayDevices:
 **** Lista de Dispositivos PLAYBACK Hardware ****
 placa 0: NVidia [HDA NVidia], dispositivo 0: STAC92xx Analog [STAC92xx Analog]
   Dispositivo secundário: 1/1
   Dispositivo secundário #0: subdevice #0
Architecture: i386
AudioDevicesInUse:
 COMANDO DE ACESSO DO USUÁRIO PID
 /dev/snd/controlC0: everthon 27118 F.... mixer_applet2
Card0.Amixer.info:
 Card hw:0 'NVidia'/'HDA NVidia at 0xfe024000 irq 23'
   Mixer name : 'SigmaTel STAC9227'
   Components : 'HDA:83847618,102801f4,00100201'
   Controls : 30
   Simple ctrls : 21
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: alsa-base 1.0.18.dfsg-1ubuntu8
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 LANG=pt_BR.UTF-8
Uname: Linux 2.6.28-11-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare vboxusers video

Everthon Valadão (everthonvs) wrote :
Everthon Valadão (everthonvs) wrote :
Everthon Valadão (everthonvs) wrote :
Everthon Valadão (everthonvs) wrote :
Everthon Valadão (everthonvs) wrote :
Everthon Valadão (everthonvs) wrote :
Everthon Valadão (everthonvs) wrote :
Everthon Valadão (everthonvs) wrote :
Koen Beek (koen-beek) on 2009-05-02
description: updated

AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 0/1
   Subdevice #0: subdevice #0
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: burner 4472 F.... mixer_applet2
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xdffdc000 irq 16'
   Mixer name : 'SigmaTel STAC9227'
   Components : 'HDA:83847618,102801dd,00100201'
   Controls : 30
   Simple ctrls : 21
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: alsa-base 1.0.18.dfsg-1ubuntu8
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
Uname: Linux 2.6.28-11-generic i686
UserAsoundrc:
 # ALSA library configuration file

 # Include settings that are under the control of asoundconf(1).
 # (To disable these settings, comment out this line.)
 </home/burner/.asoundrc.asoundconf>
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse lpadmin netdev plugdev powerdev sambashare scanner tape video

Derek Buranen (eburner) wrote :
Derek Buranen (eburner) wrote :
Derek Buranen (eburner) wrote :
Derek Buranen (eburner) wrote :
Derek Buranen (eburner) wrote :
Derek Buranen (eburner) on 2009-05-05
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Changed in alsa-driver (Ubuntu):
status: Won't Fix → Fix Released
Daniel T Chen (crimsun) on 2009-05-05
Changed in alsa-driver (Ubuntu):
status: Fix Released → Won't Fix
Changed in linux (Ubuntu):
status: Fix Released → Triaged
tags: added: apport-collected
42 comments hidden view all 122 comments
Daniel T Chen (crimsun) wrote :

Upstream has asked everyone experiencing these symptoms to try the latest daily snapshot. Because we don't have the latest daily stable snap in Ubuntu 9.10 or 10.04, please do the following if you're experiencing either Derek's symptom (i.e., you need model=3stack to avoid the volume diminishing to inaudible) or Leann's symptom (i.e., you need model=3stack to have jack sense properly working):

* Remove the manually added model=3stack quirk in /etc/modprobe.d/alsa-base.conf (or wherever you added it)
* Install linux-backports-modules-alsa-karmic-generic
* Reboot
* Verify that the symptom remains reproducible
* Use apport-collect -p alsa-base 279478 (note that you should do this step regardless whether it's reproducible)
* If reproducible, purge linux-backports-modules-alsa-2.6.31-14-generic, then download and compile http://www.kernel.org/pub/linux/kernel/people/tiwai/snapshot/alsa-driver-20091105.tar.bz2, and repeat the previous three steps (reboot, verify, and use apport-collect)

AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: gariko 1920 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xdfddc000 irq 29'
   Mixer name : 'SigmaTel STAC9227'
   Components : 'HDA:83847618,102801dd,00100201'
   Controls : 31
   Simple ctrls : 21
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
Package: alsa-base 1.0.20+dfsg-1ubuntu5
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=eu_ES.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
Uname: Linux 2.6.31-14-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (gnome-settings-daemon:1935): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:1935): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:1977): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:1969): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed

8 comments hidden view all 122 comments
Gari Araolaza (garaolaza) wrote :

I reproduce the problem installing linux-backports-modules-alsa-karmic-generic.

The sound works fine downloading and copiling the alsa driver. Apport information follows

AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: gariko 1781 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xdfddc000 irq 29'
   Mixer name : 'SigmaTel STAC9227'
   Components : 'HDA:83847618,102801dd,00100201'
   Controls : 31
   Simple ctrls : 21
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
Package: alsa-base 1.0.20+dfsg-1ubuntu5
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=eu_ES.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
Uname: Linux 2.6.31-14-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (gnome-settings-daemon:1795): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:1795): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:1838): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:1830): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed

8 comments hidden view all 122 comments

Hi Daniel,

Sorry for the delay with my feedback. I've done the following and verified that jack sense is working. I'll attach my /proc/asound/card*/codec* info. I'll also attach my /proc/asound/card*/codec* info when passing in probe_only=1.

1) Made sure any model quirks have been removed from alsa-base.conf:

ogasawara@emiko:~$ grep -n "snd-hda-intel" /etc/modprobe.d/alsa-base.conf
42:options snd-hda-intel power_save=10 power_save_controller=N

2) Installed linux-backports-modules-alsa-karmic-generic (note I'm running a bleeding edge pre karmic-proposed kernel hence the ~pre1 in the version)

ogasawara@emiko:~$ apt-cache policy linux-backports-modules-alsa-karmic-generic
linux-backports-modules-alsa-karmic-generic:
  Installed: 2.6.31.16.29~pre1
  Candidate: 2.6.31.16.29~pre1
  Version table:
 *** 2.6.31.16.29~pre1 0
        500 http://ppa.launchpad.net karmic/main Packages
        100 /var/lib/dpkg/status
     2.6.31.14.27 0
        500 http://us.archive.ubuntu.com karmic/universe Packages

3) Rebooted (again note I'm running a bleeding edge pre karmic-proposed kernel)

ogasawara@emiko:~$ uname -a
Linux emiko 2.6.31-16-generic #50~pre1-Ubuntu SMP Thu Nov 5 17:34:39 UTC 2009 i686 GNU/Linux

ogasawara@emiko:~$ cat /proc/version_signature
Ubuntu 2.6.31-16.50~pre1-generic

4) Verify sound is working and jack sense is properly working.

1 comments hidden view all 122 comments

Adding proc/asound/card*/codec* info when passing in probe_only=1

ogasawara@emiko:~$ grep -n "snd-hda-intel" /etc/modprobe.d/alsa-base.conf
42:options snd-hda-intel power_save=10 power_save_controller=N probe_only=1

1 comments hidden view all 122 comments

Upgraded to Alsa 1.0.21 & added options snd-hda-intel model=ref & removed all other snd-hda-intel lines. This worked. 3stack apparently does NOT work on all e520's STAC92xx.

Getting very tired of having to fix Alsa every time I upgrade Ubuntu.

@helpdeskdan
We've already resolved this in alsa-driver git.

Daniel T Chen (crimsun) wrote :

Resolved in Lucid.

Changed in linux (Ubuntu):
status: Triaged → Fix Released

AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: joe 1508 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xdffdc000 irq 16'
   Mixer name : 'SigmaTel STAC9227'
   Components : 'HDA:83847618,102801dd,00100201'
   Controls : 32
   Simple ctrls : 22
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
NonfreeKernelModules: nvidia
Package: alsa-base 1.0.20+dfsg-1ubuntu5
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-17.54-generic-pae
Uname: Linux 2.6.31-17-generic-pae i686
UserGroups:

9 comments hidden view all 122 comments

Already fixed in linux-backports-modules-2.6.31 (wait for the new one
based on 1.0.22.1)

bvlad (bernard-banks) wrote :

I have a Dell e520 with Ubuntu 9.10. I had the sound fading issue through headphones, but I did the following that was mentioned in the original post and it seems to have fixed it:

Workaround :
alt-f2
gksudo gedit /etc/modprobe.d/alsa-base.conf
add "options snd-hda-intel model=3stack" to end of file (without quotes), save
reboot

That model quirk workaround is incorrect. We've fixed it in Lucid (and
in the daily linux-alsa-driver-modules builds in
ppa:ubuntu-audio-dev).

Displaying first 40 and last 40 comments. View all 122 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments