[ath9k] AR5418 frequently fails to connect to WEP/WPA network

Bug #278190 reported by Richard on 2008-10-04
104
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
Mactel Support
Medium
Unassigned
linux (Ubuntu)
Medium
Unassigned
Declined for Hardy by Tim Gardner
Nominated for Karmic by Bruno Beaufils
Nominated for Lucid by Bruno Beaufils
Intrepid
Medium
Unassigned

Bug Description

The wireless network can be seen, and occasionally connects after a cold boot. Most of the time network-manager complains that the WEP/WPA key is not correct, pops up a dialogue repeatedly.

It may or may not obtain a DHCP lease. However, no data gets transmitted.

Scenario 1: (See comment by Dennis Heinson for another scenario)
Beta release updated 4/10/08 on a gen 2 MacBook Pro (atheros wifi) connecting to a BT home hub with WEP 64 bit encryption (configuration as shipped). No previous problems with Kubuntu 7.10 and the same hardware using self-compiled drivers.

Linux xxxxx-01 2.6.27-4-generic #1 SMP Wed Sep 24 01:29:06 UTC 2008 x86_64 GNU/Linux
NetworkManager 0.7.0.
03:00.0 Network controller: Atheros Communications Inc. AR5418 802.11abgn Wireless PCI Express Adapter (rev 01)

dmesg output:
[ 67.910954] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 89.204588] wlan0: authenticate with AP 00:1f:9f:3d:0f:c5
[ 89.405056] wlan0: authenticate with AP 00:1f:9f:3d:0f:c5
[ 89.605035] wlan0: authenticate with AP 00:1f:9f:3d:0f:c5
[ 89.805054] wlan0: authentication with AP 00:1f:9f:3d:0f:c5 timed out
[ 100.984690] wlan0: authenticate with AP 00:1f:9f:3d:0f:c5
[ 100.984764] wlan0: authenticate with AP 00:1f:9f:3d:0f:c5
[ 100.987561] wlan0: authenticated
[ 100.987572] wlan0: associate with AP 00:1f:9f:3d:0f:c5
[ 100.990918] wlan0: RX AssocResp from 00:1f:9f:3d:0f:c5 (capab=0x411 status=0 aid=1)
[ 100.990927] wlan0: associated
[ 100.998059] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 111.684110] wlan0: no IPv6 routers present
[ 152.817637] wlan0: disassociating by local choice (reason=3)
[ 154.415879] wlan0: authenticate with AP 00:1f:9f:3d:0f:c5
[ 154.415976] wlan0: authenticate with AP 00:1f:9f:3d:0f:c5
[ 154.418307] wlan0: authenticated
[ 154.418316] wlan0: associate with AP 00:1f:9f:3d:0f:c5
[ 154.427591] wlan0: RX AssocResp from 00:1f:9f:3d:0f:c5 (capab=0x411 status=0 aid=1)
[ 154.427603] wlan0: associated
[ 499.651325] wlan0: disassociating by local choice (reason=3)

Richard (ubuntu-richard) wrote :
Richard (ubuntu-richard) wrote :

http://ubuntuforums.org/showpost.php?p=5898116&postcount=12 tested but does not work.

$ cat /proc/modules | grep ath
ath9k 296248 0 - Live 0xffffffffa02d4000
mac80211 253568 1 ath9k, Live 0xffffffffa0273000

Richard (ubuntu-richard) wrote :

[ 204.715490] ath9k: 0.1
[ 204.723692] ath9k 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 204.723717] ath9k 0000:03:00.0: setting latency timer to 64
[ 204.859189] phy0: Selected rate control algorithm 'ath9k_rate_control'
[ 204.952755] phy0: Atheros 5416: mem=0xffffc200066a0000, irq=17
[ 209.001011] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 209.228874] NET: Registered protocol family 17
[ 217.028354] wlan0: authenticate with AP 00:1f:9f:3d:0f:c5
[ 217.224181] wlan0: authenticate with AP 00:1f:9f:3d:0f:c5
[ 217.424167] wlan0: authenticate with AP 00:1f:9f:3d:0f:c5
[ 217.624137] wlan0: authentication with AP 00:1f:9f:3d:0f:c5 timed out

Richard (ubuntu-richard) wrote :

Tested with today's kernel update, still broken:

Linux elrsr-01 2.6.27-5-generic #1 SMP Fri Oct 3 00:36:38 UTC 2008 x86_64 GNU/Linux

Richard (ubuntu-richard) wrote :

Tested with, still broken:

network-manager_0.7~~svn20081004t225044-0ubuntu1_amd64.deb

Richard (ubuntu-richard) wrote :

Tested with 2.6.27-6-generic, not solved.

To reproduce:

Turn on, let WEP network connect. Disable wireless from gnome network manager. Enable wireless again - network connection will fail with Authentication Required.

Prabhanjan Kambadur (pkambadu) wrote :

Same bug -- I am using a MacBook Ist Gen. I first noticed it when NetWork Manager failed to connect to networks after suspend+resume. I have the latest updates of Intrepid Ibex. Here are the details:

#uname -a
Linux ***** 2.6.27-7-generic #1 SMP Fri Oct 10 03:55:24 UTC 2008 i686 GNU/Linux

# lsb_release -rd
Description: Ubuntu intrepid (development branch)
Release: 8.10

NetworkManager - 0.7.0.

Changed in mactel-support:
importance: Undecided → Medium
Richard (ubuntu-richard) wrote :

Tested today with Linux xxxx-01 2.6.27-6-generic and nm 0.7~~svn20081008t224042-0ubuntu3, still broken.

Prabhanjan Kambadur (pkambadu) wrote :

This might be a temporary workaround, but I *think* that this might fix the problem till a more permanent solution is found.

#sudo rmmod ath_pci
#sudo modprobe ath_pci

Anju

Richard (ubuntu-richard) wrote :

I'm not using ath_pci, I'm using ath_k, s oyour solution doesn't work (removing and reloading ath9k doesn't help either).

description: updated
Dennis Heinson (dheinson) wrote :

Scenario 2:
Atheros AR5418 168c:0024 Wifi-N card.

modinfo ath9k
vermagic: 2.6.27-7-generic SMP mod_unload modversions 586
srcversion: 56C428B2A623B579492E35B

kernel 2.6.27-7-generic
linux-backports-modules 2.6.27.7.10

NetworkManager tries to connect, but usually does not associate [dmesg]:
[14849.660084] wlan0: authenticate with AP 00:1f:3f:13:d2:ec
[14849.860087] wlan0: authentication with AP 00:1f:3f:13:d2:ec timed out

The NetworkManager logs do not reveal anything more than that.

When it does associate, it fetches an IP address but no data gets transmitted.

Thus, it might even be a mac80211 problem.

Thanks!

Dennis Heinson (dheinson) wrote :

I just poked around in the ath9k bug tracker and found this:
http://bugzilla.kernel.org/show_bug.cgi?id=11394

I am quite certain the problem is similar and the fix mentioned in the bug tracker will get wifi to work on this device.

Alexander Sack (asac) wrote :

Tim, please take a look.

Changed in linux:
importance: Undecided → Unknown
status: New → Unknown
assignee: nobody → timg-tpi
importance: Undecided → Medium
status: New → Triaged
Alexander Sack (asac) wrote :

Tim: e.g. take a look at Linville's patch: http://bugzilla.kernel.org/show_bug.cgi?id=11394#c20

Alexander Sack (asac) wrote :

not a NM issue.

Changed in network-manager:
status: New → Invalid
Dennis Heinson (dheinson) wrote :

Note: Here is the output from iwconfig. Notice that the Bit rate is 0!

wlan0 IEEE 802.11abgn ESSID:"WLAN"
          Mode:Managed Frequency:2.412 GHz Access Point: 00:1F:3F:13:D2:EC
          Bit Rate=0 kb/s Tx-Power=23 dBm
          Retry min limit:7 RTS thr:off Fragment thr=2352 B
          Power Management:off
          Link Quality=79/100 Signal level:-55 dBm Noise level=-106 dBm
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Pete Graner (pgraner) wrote :

This won't make 8.10 GA due to the late date, I've marked this for the intrepid-updates milestone so we can get it in the first post GA update.

Changed in linux:
milestone: none → intrepid-updates
Changed in linux:
status: Unknown → Fix Released
Nathan Farrar (nfarrar) wrote :

I'm having the same problem, I've posted to ubuntuforums.com, but no responses so far:
http://ubuntuforums.org/showthread.php?p=6092508#post6092508

I have an Asus M70 laptop with an Atheros AR928X Atheros card. It uses the ATH9K wireless driver. I installed 8.1 RC x64, but check my system for updates/patches every day.

When I attempt to connect to an access point, I get time out error messages. I've tried several different access points.

Quote:
$ dmesg | grep wlan0
[ 29.762849] wlan0: authenticate with AP 00:02:8a:78:c0:08
[ 29.764550] wlan0: authenticated
[ 29.764552] wlan0: associate with AP 00:02:8a:78:c0:08
[ 29.766273] wlan0: RX AssocResp from 00:02:8a:78:c0:08 (capab=0x421 status=0 aid=233)
[ 29.766274] wlan0: associated
[ 30.953073] wlan0: disassociating by local choice (reason=3)
[ 35.424125] wlan0: No ProbeResp from current AP 00:02:8a:78:c0:08 - assume out of range
[ 95.628523] wlan0: authenticate with AP 00:1c:10:19:86:c7
[ 95.828043] wlan0: authenticate with AP 00:1c:10:19:86:c7
[ 96.028104] wlan0: authenticate with AP 00:1c:10:19:86:c7
[ 96.228081] wlan0: authentication with AP 00:1c:10:19:86:c7 timed out
[ 120.653270] wlan0: authenticate with AP 00:1c:10:19:86:c7
[ 120.852076] wlan0: authenticate with AP 00:1c:10:19:86:c7
[ 121.052082] wlan0: authenticate with AP 00:1c:10:19:86:c7
[ 121.252122] wlan0: authentication with AP 00:1c:10:19:86:c7 timed out
[ 139.517262] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 214.836220] wlan0: authenticate with AP 00:1c:10:19:86:c7
[ 215.032079] wlan0: authenticate with AP 00:1c:10:19:86:c7
[ 215.232079] wlan0: authenticate with AP 00:1c:10:19:86:c7
[ 215.432078] wlan0: authentication with AP 00:1c:10:19:86:c7 timed out

Quote:
$ dmesg | grep wlan0
[ 27.427978] wlan0: authenticate with AP 00:02:8a:78:c0:08
[ 27.437924] wlan0: authenticated
[ 27.437927] wlan0: associate with AP 00:02:8a:78:c0:08
[ 27.439474] wlan0: RX AssocResp from 00:02:8a:78:c0:08 (capab=0x421 status=0 aid=225)
[ 27.439477] wlan0: associated
[ 27.451352] wlan0: disassociating by local choice (reason=3)
[ 48.243550] wlan0: No ProbeResp from current AP 00:02:8a:78:c0:08 - assume out of range
[ 120.436805] wlan0: authenticate with AP 00:02:8a:78:c0:08
[ 120.637044] wlan0: authenticate with AP 00:02:8a:78:c0:08
[ 120.846574] wlan0: authenticate with AP 00:02:8a:78:c0:08
[ 121.044072] wlan0: authentication with AP 00:02:8a:78:c0:08 timed out
[ 162.700688] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[14806.247910] wlan0: authenticate with AP 00:02:8a:78:c0:08
[14806.445045] wlan0: authenticate with AP 00:02:8a:78:c0:08
[14806.644083] wlan0: authenticate with AP 00:02:8a:78:c0:08
[14806.844074] wlan0: authentication with AP 00:02:8a:78:c0:08 timed out

Quote:
$ lspci | grep Ath
03:00.0 Network controller: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) (rev 01)

Quote:
$ lsmod | grep ath9k
ath9k 296120 0
mac80211 253440 1 ath9k

Nathan Farrar (nfarrar) wrote :

I found a solution, here's a copy of my post on the ubuntuforums:

Turns out that this has something to do with the Wireless & Bluetooth being on the same chip (or perhaps not, still working on it). In /sys/devices/platform/asus-laptop/ there are two files that I had to modify in order to make this work:

/sys/devices/platform/asus-laptop/bluetooth
/sys/devices/platform/asus-laptop/wlan

They each contain a single boolean value. The bluetooth value contained a 1 and the wlan contained a 0. You cannot modify this values while your system is running, therefore, the solution was to add two lines to my /etc/rc.local file:

echo 0 > /sys/devices/platform/asus-laptop/bluetooth # disable bluetooth
echo 1 > /sys/devices/platform/asus-laptop/wlan # enable wireless

As soon as I restarted, it came up with absolutely no problems.

Now, it may be that they can both be enabled at the same time, I haven't tested that far yet.

Download full text (4.1 KiB)

This seems to affect some of the Macs with Broadcom hardware as well.
Oddly, oftentimes, users install wife in place of n-m and things start
working.

Ricky

On Nov 6, 2008, at 8:18 AM, F4RR4R <email address hidden> wrote:

> I found a solution, here's a copy of my post on the ubuntuforums:
>
> Turns out that this has something to do with the Wireless & Bluetooth
> being on the same chip (or perhaps not, still working on it). In
> /sys/devices/platform/asus-laptop/ there are two files that I had to
> modify in order to make this work:
>
> /sys/devices/platform/asus-laptop/bluetooth
> /sys/devices/platform/asus-laptop/wlan
>
> They each contain a single boolean value. The bluetooth value
> contained
> a 1 and the wlan contained a 0. You cannot modify this values while
> your
> system is running, therefore, the solution was to add two lines to my
> /etc/rc.local file:
>
> echo 0 > /sys/devices/platform/asus-laptop/bluetooth # disable
> bluetooth
> echo 1 > /sys/devices/platform/asus-laptop/wlan # enable wireless
>
> As soon as I restarted, it came up with absolutely no problems.
>
> Now, it may be that they can both be enabled at the same time, I
> haven't
> tested that far yet.
>
> --
> [ath9k] AR5418 frequently fails to connect to WEP/WPA network
> https://bugs.launchpad.net/bugs/278190
> You received this bug notification because you are a member of Mactel
> Support, which is the registrant for Mactel Support.
>
> Status in The Linux Kernel: Fix Released
> Status in Mactel Support: New
> Status in “linux” source package in Ubuntu: Triaged
> Status in “network-manager” source package in Ubuntu: Invalid
> Status in linux in Ubuntu Intrepid: Triaged
> Status in network-manager in Ubuntu Intrepid: Invalid
>
> Bug description:
> The wireless network can be seen, and occasionally connects after a
> cold boot. Most of the time network-manager complains that the WEP/
> WPA key is not correct, pops up a dialogue repeatedly.
>
> It may or may not obtain a DHCP lease. However, no data gets
> transmitted.
>
> Scenario 1: (See comment by Dennis Heinson for another scenario)
> Beta release updated 4/10/08 on a gen 2 MacBook Pro (atheros wifi)
> connecting to a BT home hub with WEP 64 bit encryption
> (configuration as shipped). No previous problems with Kubuntu 7.10
> and the same hardware using self-compiled drivers.
>
> Linux xxxxx-01 2.6.27-4-generic #1 SMP Wed Sep 24 01:29:06 UTC 2008
> x86_64 GNU/Linux
> NetworkManager 0.7.0.
> 03:00.0 Network controller: Atheros Communications Inc. AR5418
> 802.11abgn Wireless PCI Express Adapter (rev 01)
>
> dmesg output:
> [ 67.910954] ADDRCONF(NETDEV_UP): wlan0: link is not ready
> [ 89.204588] wlan0: authenticate with AP 00:1f:9f:3d:0f:c5
> [ 89.405056] wlan0: authenticate with AP 00:1f:9f:3d:0f:c5
> [ 89.605035] wlan0: authenticate with AP 00:1f:9f:3d:0f:c5
> [ 89.805054] wlan0: authentication with AP 00:1f:9f:3d:0f:c5 timed
> out
> [ 100.984690] wlan0: authenticate with AP 00:1f:9f:3d:0f:c5
> [ 100.984764] wlan0: authenticate with AP 00:1f:9f:3d:0f:c5
> [ 100.987561] wlan0: authenticated
> [ 100.987572] wlan0: associate with AP 00:1f:9f:3d:0f:c5
> [ 100.990918] ...

Read more...

Dennis Heinson (dheinson) wrote :

@Ricky Campbell:
a) Please do not quote the whole message. It pollutes this bug report.
b) If there is an issue with a different hardware, please open a new bug for that hardware
c) If you consider this a non-hardware issue, open a new bug for the appropriate package.

@F4RR4R:
I get this issue even with Bluetooth turned off. There is another bug, 270748, which describes a similar issue as yours.

My $.05: With all the ath9k breakage, someone should investigate current kernel fixes and reap the benefits of the new patches for Ubuntu.

Ricky Campbell (cyberdork33) wrote :

Sorry, replying from a handheld device... the quoted part doesn't even show here, so I don't know why it even matters.

I only stated what I did because I think the problem is related. Installation of wicd* seems to make the problem go away... thus it is likely doing something differently... I am sorry you don't appreciate the additional info.

Network-Manager is already in the bug report, opening another bug report for the same thing wouldn't make any sense.

Any progress on this issue? It's the main reason why I'm still on 8.04 using a custom build madwifi driver, which locks up my system at least 3 times a day. Is there any way I can help speed up the process?

F4RR4R wrote:
> echo 0 > /sys/devices/platform/asus-laptop/bluetooth # disable bluetooth
> echo 1 > /sys/devices/platform/asus-laptop/wlan # enable wireless
>
>
hmm ... so its a mode for chip thing? I assume that echo 1 on both
doesn't work either, right? also you say you can only select mode on
startup: maybe this means you can change mode when all interfaces are
properly ifdown'ed? Stopping NM should do that (check with ifconfig).

btw, what happens if you unload the asus-laptop module?

John Pugh (jpugh) wrote :

I don't think this can be attributed to bluetooth/wireless on the same chip.

This problem manifests itself AFTER some time being connected so I think that it is related to the kernel problem reported in https://bugs.edge.launchpad.net/ubuntu/+source/linux/+bug/267089

This problem does not show up until after a specific amount of time. I believe the problem is related to the buffer overrun.

Luis R. Rodriguez (mcgrof) wrote :

FYI

Bluetooth coexsistance is now supported in ath9k, and its available on AR9280 revision 10 and later. To test use the btcoex_enable module parameter. This is available on compat-wireless.

Luis R. Rodriguez (mcgrof) wrote :

Please upgrade to at least linux-image-2.6.27-11-generic.

Please see:

http://wireless.kernel.org/en/users/Drivers/ath9k#Mostcommonknownissues

and to get the latest ath9k driver:

http://wireless.kernel.org/en/users/Drivers/ath9k#Getthelatestath9kdriver

Dennis Heinson (dheinson) wrote :

Luis, thanks for the input. I can confirm this is solved in 2.6.27-11 and should have probably posted this here earlier. Keep up the good work.

The -11 Ubuntu Kernel is available in the proposed repository.

Changed in linux:
status: Triaged → Fix Committed
arky (arky) wrote :

Unfortunately this problem showed up in the next version 2.6.28-11-generic . It works find in 2.6.27-11-generic

Jason Feldstein (fieldstone) wrote :

I'm having this problem on Jaunty also, with the 2.6.28-11-generic kernel version, but oddly enough only after suspending and resuming. If I reboot, it goes away until I suspend again. (This is on an eee PC 1000HE.)

Andreas Hjortland (an-hjort) wrote :

I've got the same problem with my Asus M70TL, but my computer wont find the wireless network at work. There is a lot of wireless networks in the neighbourhood, but the network at work don't show unless I boot in windows (which have some driver problem which is making me mad)... At home I see the network, but I cannot connect to it... It just fails to connect and asks me for the password (again I have tried doing the same in windows, and there it works)... I have attached the dmesg | grep wlan0 file, for you to see through if it is of any use.

Alex (alexanderlane) wrote :

This bug is indeed present in Jaunty and affects AR5008 as well as AR5418.

I've had far better luck connecting to WEP WAPs using Wicd (over the shoddy performance attributed to n-m)

Wicd gets me connected to my preferred WAPs from startup -- but I'm unable to reconnect upon resume (after suspend). Prabhanjan Kambadur reports the same problem in this very thread. I'll take it to a new report if that would be appropriate.

0b:00.0 Network controller: Atheros Communications Inc. AR5008 Wireless Network Adapter (rev 01)
-Ubuntu Jaunty on MacbookPro 3,1 "Santa Rosa" (dual-boot)
-ath9k is in use

Please let me know what else I can provide in the way of details.

Tim Gardner (timg-tpi) wrote :

2.6.27-4.5

  * ath9k: Assign seq# when mac80211 requests this

Changed in linux (Ubuntu Intrepid):
assignee: Tim Gardner (timg-tpi) → nobody
status: Fix Committed → Fix Released
Changed in linux (Ubuntu Jaunty):
assignee: Tim Gardner (timg-tpi) → nobody
milestone: intrepid-updates → none
status: Triaged → Fix Released
Changed in mactel-support:
status: New → Invalid
Changed in mactel-support:
status: Invalid → Confirmed
status: Confirmed → Fix Released
Krzysztof Janowicz (janowicz) wrote :

ales i have exactly the same problem with jaunty on my macbook pro 3.1 see also the details at: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/362985 it worked after some updates with jaunty but now the wifi is nearly useless, it always stops for 10-15 seconds, than continues for some seconds, stops again,.... moreover i cannot connect to some networks which worked for intrepid.

Alex (alexanderlane) wrote :

Since my previous comment on this thread, I've gotten WiFi working quite well in Jaunty. All I had to do was install the following packages:

linux-backports-modules-jaunty
wicd

(Reboot.)

Hope it works for you, too!

Krzysztof Janowicz (janowicz) wrote :

thx! i will try it this way. by the way 11n ist not working at all, i can only connect to the router using 11g. you?

Krzysztof Janowicz (janowicz) wrote :

alex, thanks now it works!

Korey (korey-renner) wrote :

Confirmed for fresh install of Jaunty amd64 from CD. (final release)
installing linux-backports-modules-jaunty and rebooting allows me to connect, but now I'm noticing it occasionally losing connection and then finding it again.

Dell Studio XPS 1340 with an Atheros AR928X wireless controller.

dooma (wendschh) wrote :

HI -

I have a Lenovo T60P which which I'm pretty sure has an AR5418 card. In Intrepid, wireless worked great. Upgraded to Jaunty over the weekend, and since then, the wireless performance has been very poor:

1) At high bandwidth usage, wireless will disconnect, but WICD (and N-m tried both) will show it's still connected. But there is no connection. I must press refresh on wicd and manually recconect. This is annoying

2) After prolonged usage (about an hour) the wireless wil just disconnect all together. The only way to reconnect at this point is to log off and log on.

I am running Ath9k.

On the plus side, the little switch on the front now turns the wireless radio on and off, and this never worked before upgrading to Jaunty. Still, I'd rather have wifi running without these errors.

Thomas Schiex (thomas-schiex) wrote :

I confirm Korey's observation on the same platfrom: XPS 1340 (so-called XPS studio 13) with an AR928X wireless controller: connection was a nightmare but stable once established. After installing linux-backports-modules-jaunty, connection works like a charm but may break from time to time. Reconnection is fast, so this is not so painfull but still annoying.

Giancaldo (giancaldo) wrote :

I've got an ar5008 and the thing is almost useless with the ath9k driver. I do have backports installed. It works for maybe the first 5 seconds after I connect, but after that it's just dead. Thankfully the old madwifi drivers drivers work perfectly.

Cyril Bouthors (cyril) wrote :

I've got an ar5008 and I'm hit by that bug too (can't connect to WPA).

I've tried with Ubuntu 9.10 alpha, running 2.6.31-10-generic and the same bug is still present.

Shaun Mallette (chicagonpg) wrote :

Same problem here with a MacbookPro 3,1 "Santa Rosa" chip AR5008 Kernel 2.6.27.14-generic on 8.10
Wifi will connect with no problem on startup but fails to reconnect once connection is dropped.
Also once it is connected and I want to use a different router WPA it will not connect to the router of choice.
Have to reboot to get a connection again.

Bruno Beaufils (beaufils) wrote :

The problem reappear with Karmic on MacBookPro 3,1. Even the fix of comments 35 is no more working. Network goes down very frequently and is not able to come back :-(

Changed in mactel-support:
status: Fix Released → Confirmed
Changed in linux (Ubuntu):
status: Fix Released → Confirmed
Changed in linux (Ubuntu Jaunty):
status: Fix Released → Confirmed
Bruno Beaufils (beaufils) wrote :

One may find a way of fixing this VERY annoyng bug in comment 33 of bug 333730.

Richard, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command in the development release from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. As well, please comment on which kernel version specifically you tested.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream', and comment as to why specifically you were unable to test it.

Please let us know your results. Thanks in advance.

no longer affects: network-manager (Ubuntu)
no longer affects: network-manager (Ubuntu Intrepid)
no longer affects: network-manager (Ubuntu Jaunty)
no longer affects: linux (Ubuntu Jaunty)
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Changed in mactel-support:
status: Confirmed → Invalid
Changed in linux:
importance: Unknown → Medium
Benjamin Schmid (benbuntu) wrote :

Same issue here on precise on Realtek hardware. I do not observe this issue in my home router network, but using my Android hotspot. The connection works first, but soon gets lost. As a workaround I can disable/enable the wifi network via laptop switch and it immediately reconnects.

tags: added: needs-kernel-logs needs-upstream-testing
removed: ath9k
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.