irda broken on Thinkpad T23 with 2.6.27-4-generic, works with 2.6.24-16-generic

Bug #278188 reported by Johan Kiviniemi on 2008-10-04
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Intrepid
Undecided
Unassigned

Bug Description

I’m running intrepid on a Thinkpad T23. The irda driver is nsc-ircc.

irdadump only prints packets being sent. When I try to send data from a cellphone to the computer, the sending of discovery packets is paused, but nothing is actually received.

Everything works fine when I boot to the older kernel image from hardy.

irdadump output with the hardy kernel:

16:18:44.252420 xid:cmd f2df8a98 > ffffffff S=6 s=0 (14)
16:18:44.340195 xid:cmd f2df8a98 > ffffffff S=6 s=1 (14)
16:18:44.428203 xid:cmd f2df8a98 > ffffffff S=6 s=2 (14)
16:18:44.516203 xid:cmd f2df8a98 > ffffffff S=6 s=3 (14)
16:18:44.604194 xid:cmd f2df8a98 > ffffffff S=6 s=4 (14)
16:18:44.686339 xid:rsp f2df8a98 < 0000e9bd S=6 s=4 Nokia 6220 hint=b125 [ PnP Modem Fax Telephony IrCOMM IrOBEX ] (27)
16:18:44.692247 xid:cmd f2df8a98 > ffffffff S=6 s=5 (14)
16:18:44.780190 xid:cmd f2df8a98 > ffffffff S=6 s=* virhe hint=0400 [ Computer ] (21)

On the intrepid kernel, the response from the phone never gets through.

Christoph Klaffl (z3r0c00l) wrote :

I can confirm this bug on my machine (Acer Travelmate 660)
The problem is exact the same.

The nsc-ircc is loaded fine like the one in hardy.

The problem is also described in the following pages:
http://bugzilla.kernel.org/show_bug.cgi?id=11566
https://lists.linux-foundation.org/pipermail/bugme-new/2008-September/019844.html

For me, the described workaround (isn't really one I think) didn't worked.

looking forward to a solution :-D, so I can upgrade to intrepid.

I attached the dmesg output from hardy and intrepid, maybe in help in some way but I don't think so because I found no significant differences.

c,Ya

Christoph Klaffl (z3r0c00l) wrote :
Christoph Klaffl (z3r0c00l) wrote :

I forgot: My kernel version is 2.6.27-7-generic
c,Ya

Christoph Klaffl (z3r0c00l) wrote :

Little Update:

I downloaded the linux source code via synaptic and replaced the nsc-ircc driver with the version from kernel 2.6.24-21. I compiled it and installed it -> Problem still exists, so the error isn't in the nsc-ircc driver, but I don't know where to search :-( I now installed the hardy kernel in intrepid and now IrDA works in intrepid but only with the old kernel.

Short note: irdadump runs much slower with the newer kernel, it seems that something is blocking.

c,Ya

djtm (djtm) wrote :

You could try bisecting the differences.
Then you would know what caused it to stop working.
I'm sure that would be very helpful.

Christoph Klaffl (z3r0c00l) wrote :

Sorry I don't know what you mean :-)
Can you explain it in other words please?

Christoph Klaffl (z3r0c00l) wrote :

Update

I installed kernel version 2.6.28-3 from here: http://archive.ubuntu.com/ubuntu/pool/main/l/linux/
irda is still not working :-(

c,Ya

Christoph Klaffl (z3r0c00l) wrote :

Ok, it seems that the irda subystem is broken in 2.6.27 :-(
Details are available here: http://bugzilla.kernel.org/show_bug.cgi?id=11795

c,Ya

Christoph Klaffl (z3r0c00l) wrote :

I just compiled & installed kernel 2.6.28rc9 (latest prepatch) and IrDA works like expected :-D
I checked irdadump, ircp and ircomm0, everthing works :-).

I hope that these irda patches get backported to the intrepid kernel.

c,Ya

Johan Kiviniemi (ion) wrote :

I verified that the patch fixes irda. Attaching it, cherry-picked against the current intrepid kernel tree.

Christoph Klaffl (z3r0c00l) wrote :

So it will be included in future offical intrepid kernel updates?
Then I think we can mark this bug as fixed

c,Ya

Brad Figg (brad-figg) on 2009-04-28
Changed in linux (Ubuntu):
status: New → Fix Released
Robie Basak (racb) wrote :

This is not in ubuntu-intrepid/master.

@Johan - I presume you meant that you tested the patch cherry picked against the intrepid git tree, rather than actually committing it?

This is a severe regression as IrDA is not functional at all with Intrepid (upstream regression for 2.6.27, fixed in 2.6.28 with this patch as Johan points out above: http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=69c30e1e7492192f882a3fc11888b320fde5206a).

What is needed to get this considered for SRU? I've read the StableReleaseUpdates wiki page but it isn't quite clear how this applies to the kernel.

Changed in linux (Ubuntu):
status: Fix Released → Confirmed

The patch referenced at http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=69c30e1e7492192f882a3fc11888b320fde5206a is already available in the latest Jaunty release so setting this back to Fix Released. I'll add an Intrepid nomination for the kernel team to consider this for an SRU, but of course I'll leave it to the discretion of the kernel team to make the final decision if they'll indeed backport the patch. Thanks.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Alex Valavanis (valavanisalex) wrote :

Intrepid Ibex reached end-of-life on 30 April 2010 so I am closing the
report. The bug has been fixed in newer releases of Ubuntu.

Changed in linux (Ubuntu Intrepid):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.