Ubuntu

Atheros WLAN AR242x LED doesn't work

Reported by Ralf Hildebrandt on 2008-09-27
56
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by Conrad Knauer

Bug Description

For the first time ever my Atheros AR242x WLAN (in an Acer Aspire One) does indeed work with ath5k.

Hooray!

The card is shown as:

03:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)
 Subsystem: Foxconn International, Inc. Device e008
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 128 bytes
 Interrupt: pin A routed to IRQ 18
 Region 0: Memory at 55200000 (64-bit, non-prefetchable) [size=64K]
 Capabilities: [40] Power Management version 2
  Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Capabilities: [50] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
  Address: 00000000 Data: 0000
 Capabilities: [60] Express (v1) Legacy Endpoint, MSI 00
  DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <512ns, L1 <64us
   ExtTag- AttnBtn- AttnInd- PwrInd- RBE- FLReset-
  DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
   RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop-
   MaxPayload 128 bytes, MaxReadReq 512 bytes
  DevSta: CorrErr+ UncorrErr+ FatalErr- UnsuppReq+ AuxPwr- TransPend-
  LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 <512ns, L1 <64us
   ClockPM- Suprise- LLActRep- BwNot-
  LnkCtl: ASPM L0s L1 Enabled; RCB 128 bytes Disabled- Retrain- CommClk+
   ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
  LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
 Capabilities: [90] MSI-X: Enable- Mask- TabSize=1
  Vector table: BAR=0 offset=00000000
  PBA: BAR=0 offset=00000000
 Capabilities: [100] Advanced Error Reporting <?>
 Capabilities: [140] Virtual Channel <?>
 Kernel driver in use: ath5k_pci
 Kernel modules: ath_pci, ath5k

Everything works (even the kill switch on the computer) EXCEPT: The LEDs don't work at all. The do work with madwifi, so I do know that it's an LED and not just a black hole.

There's a bounty on this bug:
http://www.fossfactory.org/project/p187

VijayakumarK (vijayakumark) wrote :
Download full text (3.2 KiB)

I have the same problem of Wireless LED not working with HP dv6700 laptop. It is always orange. It should turn blue when Wireless is on ( works as expected in Windoze )

==============
output of uname -a
Linux vijayk-laptop 2.6.27-7-generic #1 SMP Tue Oct 14 18:40:44 UTC 2008 i686 GNU/Linux
root@vijayk-laptop:# cat /etc/issue
Ubuntu intrepid (development branch) \n \l
==============

output of lspci -vvv ( wireless section alone )
==============
03:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)
        Subsystem: Hewlett-Packard Company Device 137a
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 19
        Region 0: Memory at f6000000 (64-bit, non-prefetchable) [size=64K]
        Capabilities: [40] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [50] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
                Address: 00000000 Data: 0000
        Capabilities: [60] Express (v1) Legacy Endpoint, MSI 00
                DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <512ns, L1 <64us
                        ExtTag- AttnBtn- AttnInd- PwrInd- RBE- FLReset-
                DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
                        RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop-
                        MaxPayload 128 bytes, MaxReadReq 512 bytes
                DevSta: CorrErr- UncorrErr+ FatalErr- UnsuppReq+ AuxPwr- TransPend-
                LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 <512ns, L1 <64us
                        ClockPM- Suprise- LLActRep- BwNot-
                LnkCtl: ASPM Disabled; RCB 128 bytes Disabled- Retrain- CommClk+
                        ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
                LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
        Capabilities: [90] MSI-X: Enable- Mask- TabSize=1
                Vector table: BAR=0 offset=00000000
                PBA: BAR=0 offset=00000000
        Capabilities: [100] Advanced Error Reporting <?>
        Capabilities: [140] Virtual Channel <?>
        Kernel driver in use: ath5k_pci
        Kernel modules: ath_pci, ath5k

===============
Output of dmesg | grep 'ath'
[ 66.628870] ath5k_pci 0000:03:00.0: PCI INT A -> Link[LK4E] -> GSI 19 (level, low) -> IRQ 19
[ 66.628951] ath5k_pci 0000:03:00.0: setting latency timer to 64
[ 66.628976] ath5k_pci 0000:03:00.0: registered as 'phy0'
[ 66.633824] ath5k phy0: Support for RF2425 is under development.
[ 67.003757] ath5k phy0: Atheros AR2425 chip found (MAC: 0xe2, PHY: 0x70)
[ 67.020476] ath_hal: 0.9.18.0 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
[ 67.039454] ath_pci: 0.9.4
===============
Plese feel free to ask any other i...

Read more...

ihtarlik (ihtarlik) wrote :

My LED is also permanently stuck on orange. It should also be noted that module "led_class" is loaded.

I should also point out this being a secondary concern, since the wifi card is not able to do anything else including scanning or attaching to an access point.

Eduardo Cereto (dudus) wrote :

I have the same setup as op. The default wireless driver set by intrepid doesn't work (ath_pci). But it seems to work using ath5k on backport kernel modules with minor hiccups. But the leds are always off

michaël (mr-michaelcox) wrote :

Confirmed on asus X51RL (running intrepid and backports-generic modules). Lights always off.

Kassad (sam-teletubbie) wrote :

There is a patch, which fixes the LED issue as well as activates rfkill, so you can disable Wifi to save power:
https://lists.ath5k.org/pipermail/ath5k-devel/2009-January/001718.html
Please pay attention, that there are also some improvements for the patch which are discussed and committed on the list.
Can someone apply the correct patch for the proposed updates in 8.10. I would love to have this functionality on my Samsung nc10. Because I don't want to patch my kernel for myself, since it would mean possible problems updating the system via package management.
Thanks

Conrad Knauer (atheoi) wrote :

I'm running Jaunty (pre-release) on my Aspire One and after blacklisting the acer_wmi kernel module, not only does the WiFi work automagically, but the LED blinks upon activity now :) So... fix released? :)

Conrad Knauer (atheoi) wrote :

acer_wmi issue is Bug 319825 BTW...

Changed in linux:
status: New → Fix Released
Steeve Cottin (stef-cottin) wrote :

Confirmed on AO751h (Acer Aspire Oe Pro 751) running jaunty (2.6.28-14-generic). Lights always off !

+++ LSPCI +++

$ sudo lspci -vxxx
00:00.0 Host bridge: Intel Corporation System Controller Hub (SCH Poulsbo) (rev 07)
 Subsystem: Acer Incorporated [ALI] Device 0244
 Flags: bus master, fast devsel, latency 0
[...]
03:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)
 Subsystem: Foxconn International, Inc. Device e00d
 Flags: bus master, fast devsel, latency 0, IRQ 17
 Memory at d0000000 (64-bit, non-prefetchable) [size=64K]
 Capabilities: [40] Power Management version 2
 Capabilities: [50] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
 Capabilities: [60] Express Legacy Endpoint, MSI 00
 Capabilities: [90] MSI-X: Enable- Mask- TabSize=1
 Capabilities: [100] Advanced Error Reporting <?>
 Capabilities: [140] Virtual Channel <?>
 Kernel driver in use: ath5k_pci
 Kernel modules: ath_pci, ath5k

+++ LSMOD ; MODINFO +++

$ lsmod | grep ath
ath5k 107520 0
mac80211 217592 1 ath5k
led_class 12036 2 ath5k,acer_wmi
cfg80211 38288 2 ath5k,mac80211

$ modinfo ath5k
filename: /lib/modules/2.6.28-14-generic/kernel/drivers/net/wireless/ath5k/ath5k.ko
version: 0.6.0 (EXPERIMENTAL)
license: Dual BSD/GPL
description: Support for 5xxx series of Atheros 802.11 wireless LAN cards.
author: Nick Kossifidis
author: Jiri Slaby
srcversion: A29DFCA2F56F1FD810F5FA0
...
depends: led-class,cfg80211,mac80211
vermagic: 2.6.28-14-generic SMP mod_unload modversions 586

$ modinfo led_class
filename: /lib/modules/2.6.28-14-generic/kernel/drivers/leds/led-class.ko
description: LED Class Interface
license: GPL
author: John Lenz, Richard Purdie
srcversion: 32DAFD0CD9EE07AC4AC07FF
depends:
vermagic: 2.6.28-14-generic SMP mod_unload modversions 586

+++ DMESG +++
$ dmesg | grep ath
[ 12.523148] ath5k_pci 0000:03:00.0: enabling device (0004 -> 0006)
[ 12.523170] ath5k_pci 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 12.523193] ath5k_pci 0000:03:00.0: setting latency timer to 64
[ 12.523443] ath5k_pci 0000:03:00.0: registered as 'phy0'
[ 12.664031] ath5k phy0: Atheros AR2425 chip found (MAC: 0xe2, PHY: 0x70)

Shahar Or (mightyiam) wrote :

It seems like in upstream they are opening one bug report per each subsystem of this device. See:
http://bugzilla.kernel.org/show_bug.cgi?id=12903
http://bugzilla.kernel.org/show_bug.cgi?id=13455
http://bugzilla.kernel.org/show_bug.cgi?id=12841

And I've just opened a new one:
http://bugzilla.kernel.org/show_bug.cgi?id=14607

Changed in linux (Ubuntu):
status: Fix Released → Confirmed
Shahar Or (mightyiam) wrote :

There's a bounty on this bug:
http://www.fossfactory.org/project/p187

tags: added: bounty
Shahar Or (mightyiam) on 2009-11-29
description: updated
Download full text (7.0 KiB)

מה זה בכלל אומר?

2009/11/29 Shahar Or <email address hidden>

> ** Description changed:
>
> For the first time ever my Atheros AR242x WLAN (in an Acer Aspire One)
> does indeed work with ath5k.
>
> Hooray!
>
> The card is shown as:
>
> 03:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg
> Wireless PCI Express Adapter (rev 01)
> - Subsystem: Foxconn International, Inc. Device e008
> - Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
> Stepping- SERR- FastB2B- DisINTx-
> - Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort-
> <TAbort- <MAbort- >SERR- <PERR- INTx-
> - Latency: 0, Cache Line Size: 128 bytes
> - Interrupt: pin A routed to IRQ 18
> - Region 0: Memory at 55200000 (64-bit, non-prefetchable) [size=64K]
> - Capabilities: [40] Power Management version 2
> - Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA
> PME(D0-,D1-,D2-,D3hot-,D3cold-)
> - Status: D0 PME-Enable- DSel=0 DScale=0 PME-
> - Capabilities: [50] Message Signalled Interrupts: Mask- 64bit-
> Queue=0/0 Enable-
> - Address: 00000000 Data: 0000
> - Capabilities: [60] Express (v1) Legacy Endpoint, MSI 00
> - DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s
> <512ns, L1 <64us
> - ExtTag- AttnBtn- AttnInd- PwrInd- RBE- FLReset-
> - DevCtl: Report errors: Correctable- Non-Fatal- Fatal-
> Unsupported-
> - RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop-
> - MaxPayload 128 bytes, MaxReadReq 512 bytes
> - DevSta: CorrErr+ UncorrErr+ FatalErr- UnsuppReq+ AuxPwr-
> TransPend-
> - LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1,
> Latency L0 <512ns, L1 <64us
> - ClockPM- Suprise- LLActRep- BwNot-
> - LnkCtl: ASPM L0s L1 Enabled; RCB 128 bytes Disabled-
> Retrain- CommClk+
> - ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
> - LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+
> DLActive- BWMgmt- ABWMgmt-
> - Capabilities: [90] MSI-X: Enable- Mask- TabSize=1
> - Vector table: BAR=0 offset=00000000
> - PBA: BAR=0 offset=00000000
> - Capabilities: [100] Advanced Error Reporting <?>
> - Capabilities: [140] Virtual Channel <?>
> - Kernel driver in use: ath5k_pci
> - Kernel modules: ath_pci, ath5k
> + Subsystem: Foxconn International, Inc. Device e008
> + Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
> Stepping- SERR- FastB2B- DisINTx-
> + Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort-
> <MAbort- >SERR- <PERR- INTx-
> + Latency: 0, Cache Line Size: 128 bytes
> + Interrupt: pin A routed to IRQ 18
> + Region 0: Memory at 55200000 (64-bit, non-prefetchable) [size=64K]
> + Capabilities: [40] Power Management version 2
> + Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA
> PME(D0-,D1-,D2-,D3hot-,D3cold-)
> + Status: D0 PME-Enable- DSel=0 DScale=0 PME-
> + Capabilities: [50] Message Signalled Interrupts: Mask- 64bit- Queue=0/0
> Enable...

Read more...

Shahar Or (mightyiam) wrote :

Please ignore Keren's message.

Bill Blesbok (bblesbok) wrote :

LEDs didn't work on Linux Mint Helena for me using D-Link PCI card. They now work (both flash green simultaneously) on both 10.04 LTS and 10.04 LTS Trisquel.

Shahar Or (mightyiam) on 2010-11-30
Changed in linux (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.