USB device 1a86:7523 (serial-to-USB cable) not recognised by CH341 driver

Bug #272485 reported by alanmilne on 2008-09-20
12
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Tim Gardner
Hardy
Undecided
Unassigned

Bug Description

There are cheap clones of the Winchiphead USB/Serial cable that use the VID 0x1a86 and PID 0X7523. The current
driver (Hardy Heron 2.6.24-19-386) does not include these codes for device recognition. For further details please see:-

http://ubuntuforums.org/showthread.php?p=5824157#post5824157

If the patch suggested is incorporated, then these devices will be recognised when plugged in.

alanmilne (alanandlinda) wrote :

Sorry, the link to the complete thread is:-

http://ubuntuforums.org/showthread.php?t=921409

TJ (tj) wrote :

This is a simple cherry-pick from Intrepid:

commit 82078234d4023c61b9d88e8be5e795423d17538e
Author: Michael F. Robbins <email address hidden>
Date: Fri May 16 23:48:42 2008 -0400

    USB: serial: ch341: New VID/PID for CH341 USB-serial

    Recent USB-serial devices using the WinChipHead CH340/CH341 chipset are
    being shipped with a new vendor/product ID code pair, but an otherwise
    identical device. (This is confirmed by looking at INF for the included
    Windows driver.)

    Patch is tested and working, both with new and old devices.

    Signed-off-by: Michael F. Robbins <email address hidden>
    Signed-off-by: Greg Kroah-Hartman <email address hidden>

diff --git a/drivers/usb/serial/ch341.c b/drivers/usb/serial/ch341.c
index ba28fdc..1f7c86b 100644
--- a/drivers/usb/serial/ch341.c
+++ b/drivers/usb/serial/ch341.c
@@ -28,6 +28,7 @@ static int debug;

 static struct usb_device_id id_table [] = {
        { USB_DEVICE(0x4348, 0x5523) },
+ { USB_DEVICE(0x1a86, 0x7523) },
        { },
 };
 MODULE_DEVICE_TABLE(usb, id_table);

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Low
milestone: none → ubuntu-8.04.2
status: New → Triaged
Tim Gardner (timg-tpi) wrote :

SRU Justification

Impact: This USB serial device is not detected.

Patch Description: Add USB device identifiers to the USB device ID table.

Patch: http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-hardy.git;a=commit;h=97e9ddb22ac4680937d60f7ad2a4f41e9a2b1abf

Test Case: See bug description

Tim Gardner (timg-tpi) wrote :
Changed in linux:
assignee: ubuntu-kernel-team → timg-tpi
status: Triaged → Fix Committed

Tim Gardner wrote:
> SRU Justification
>
> Impact: This USB serial device is not detected.
>
> Patch Description: Add USB device identifiers to the USB device ID
> table.
>
> Patch: http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-
> hardy.git;a=commit;h=97e9ddb22ac4680937d60f7ad2a4f41e9a2b1abf
>
> Test Case: See bug description
>
ACK

--

When all other means of communication fail, try words!

This is apparently fixed in intrepid already.

Changed in linux:
milestone: none → ubuntu-8.04.2
milestone: ubuntu-8.04.2 → none
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Accepted into intrepid-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Martin Pitt (pitti) wrote :

Accepted into hardy-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in linux:
milestone: ubuntu-8.04.2 → none
status: New → Fix Committed
Steve Langasek (vorlon) on 2008-11-14
Changed in linux:
milestone: none → ubuntu-8.04.2
psypher (psypher246) wrote :

Hi,

Could someone please tell me which package is the one I need to upgrade on Intrepid to test? Is it the kernel? If so is this safe to test on a production system?

Thanks

Martin Pitt (pitti) wrote :

psypher,

this update is for hardy, this bug is allegedly already fixed in intrepid. I just used the wrong incantation of my SRU processing script which is why comment 7 erroneously speaks about intrepid.

psypher (psypher246) wrote :

Sorry martin, my mistake. I saw that the device was still not associating to a device name in the lsusb output and thought the bug was not fixed yet.

hooked the cable up to router today and worked perfectly, yay!

Martin Pitt (pitti) wrote :

psypher, did you test the hardy-proposed update or intrepid?

psypher (psypher246) wrote :

Running stock install of Intrepid, worked perfectly, Another neeh neeeh neeeh at my windows friends who struggled getting it working with the windows driver on the CD that came with the cable ;)

Martin Pitt (pitti) wrote :

Accepted linux into hardy-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Launchpad Janitor (janitor) wrote :
Download full text (12.0 KiB)

This bug was fixed in the package linux - 2.6.24-23.46

---------------
linux (2.6.24-23.46) hardy-proposed; urgency=low

  [Alessio Igor Bogani]

  * rt: Updated PREEMPT_RT support to rt21
    - LP: #302138

  [Amit Kucheria]

  * SAUCE: Update lpia patches from moblin tree
    - LP: #291457

  [Andy Whitcroft]

  * SAUCE: replace gfs2_bitfit with upstream version to prevent oops
    - LP: #276641

  [Colin Ian King]

  * isdn: Do not validate ISDN net device address prior to interface-up
    - LP: #237306
  * hwmon: (coretemp) Add Penryn CPU to coretemp
    - LP: #235119
  * USB: add support for Motorola ROKR Z6 cellphone in mass storage mode
    - LP: #263217
  * md: fix an occasional deadlock in raid5
    - LP: #208551

  [Stefan Bader]

  * SAUCE: buildenv: Show CVE entries in printchanges
  * SAUCE: buildenv: Send git-ubuntu-log informational message to stderr
  * Xen: dma: avoid unnecessarily SWIOTLB bounce buffering
    - LP: #247148
  * Update openvz patchset to apply to latest stable tree.
    - LP: #301634
  * XEN: Fix FTBS with stable updates
    - LP: #301634

  [Steve Conklin]

  * Add HID quirk for dual USB gamepad
    - LP: #140608

  [Tim Gardner]

  * Enable CONFIG_AX25_DAMA_SLAVE=y
    - LP: #257684
  * SAUCE: Correctly blacklist Thinkpad r40e in ACPI
    - LP: #278794
  * SAUCE: ALPS touchpad for Dell Latitude E6500/E6400
    - LP: #270643

  [Upstream Kernel Changes]

  * Revert "[Bluetooth] Eliminate checks for impossible conditions in IRQ
    handler"
    - LP: #217659
  * KVM: VMX: Clear CR4.VMXE in hardware_disable
    - LP: #268981
  * iov_iter_advance() fix
    - LP: #231746
  * Fix off-by-one error in iov_iter_advance()
    - LP: #231746
  * USB: serial: ch341: New VID/PID for CH341 USB-serial
    - LP: #272485
  * x86: Fix 32-bit x86 MSI-X allocation leakage
    - LP: #273103
  * b43legacy: Fix failure in rate-adjustment mechanism
    - LP: #273143
  * x86: Reserve FIRST_DEVICE_VECTOR in used_vectors bitmap.
    - LP: #276334
  * openvz: merge missed fixes from vanilla 2.6.24 openvz branch
    - LP: #298059
  * openvz: some autofs related fixes
    - LP: #298059
  * openvz: fix ve stop deadlock after nfs connect
    - LP: #298059
  * openvz: fix netlink and rtnl inside container
    - LP: #298059
  * openvz: fix wrong size of ub0_percpu
    - LP: #298059
  * openvz: fix OOPS while stopping VE started before binfmt_misc.ko loaded
    - LP: #298059
  * x86-64: Fix "bytes left to copy" return value for copy_from_user()
  * NET: Fix race in dev_close(). (Bug 9750)
    - LP: #301608
  * IPV6: Fix IPsec datagram fragmentation
    - LP: #301608
  * IPV6: dst_entry leak in ip4ip6_err.
    - LP: #301608
  * IPV4: Remove IP_TOS setting privilege checks.
    - LP: #301608
  * IPCONFIG: The kernel gets no IP from some DHCP servers
    - LP: #301608
  * IPCOMP: Disable BH on output when using shared tfm
    - LP: #301608
  * IRQ_NOPROBE helper functions
    - LP: #301608
  * MIPS: Mark all but i8259 interrupts as no-probe.
    - LP: #301608
  * ub: fix up the conversion to sg_init_table()
    - LP: #301608
  * x86: adjust enable_NMI_through_LVT0()
    - LP: #301608
  * SCSI ips: handle scsi_add_host() failure, and other err cl...

Changed in linux:
status: Fix Committed → Fix Released

Hi psypher,

I don't suppose you'd also be able to test the kernel in hardy-proposed? I unfortunately do not have the hardware to test. We'd definitely appreciate any feedback before blindly pushing out a fix to Hardy without any verification. Thanks.

Changed in linux:
status: Fix Released → Fix Committed
Steve Langasek (vorlon) wrote :

marking again as fix released, since this kernel package has been copied to hardy-updates already on the basis of the number of other bugfixes that have been confirmed and the absence of reported regressions. If this bug turns out to not be fixed, please reopen the hardy task.

Changed in linux:
status: Fix Committed → Fix Released
botp (botpena) wrote :

Hi,

i just updated to hardy-proposed, but the device still is not recognized, eg

botp@jedi-hopeful:~$ lsusb
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 004: ID 1a86:7523 <--blank here-->
Bus 002 Device 003: ID 04f9:01a8 Brother Industries, Ltd
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 003: ID 1241:1603 Belkin
Bus 001 Device 001: ID 0000:0000

kind regards -botp

TJ (tj) wrote :

botp

lsub output does not represent what the kernel drivers handle. The names of devices reported are taken from the file /var/lib/misc/usb.ids in the usbutils package which might not have that information (see man lsusb).

When the device is connected look in /var/log/kern.log and you'll see something similar to this:

[13642.447989] usb 2-2: new full speed USB device using uhci_hcd and address 3
[13642.685296] usb 2-2: ch341-uart converter now attached to ttyUSB0

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers