GSPCA driver no longer works

Bug #270618 reported by mewithafez on 2008-09-15
10
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Declined for Intrepid by Brian Murray

Bug Description

I am running Intrepid 32 bit on a gateway CX210X and my Logitech Quickcam Communicate STX which had worked previously using the gspca driver now does not.

LSUSB returns Bus 002 Device 002: ID 046d:08d7 Logitech, Inc. QuickCam Communicate STX, so it recognizes it, but when I start cheese I get the tv-style bars and static, and when I test it on Skype the whole program crashes.

Thanks for any help and I'll try to be available but its a bit of a hectic time which is why this webcam working is so critical.

I can confirme this issue. I have a Logitech Quickcam Communicate STX and with Intrepid fully updated doesn't work, I have same issue with cheese
lsusb: Bus 003 Device 003: ID 046d:08d7 Logitech, Inc. QuickCam Communicate STX
uname -r: 2.6.27-3-generic

mewithafez (firefish17) wrote :

Just updated to 2.6.27-4 which had a lot of gspca fixes but it still does not work.

Florian Zeitz (florian-zeitz) wrote :

FWIW I have the same issue with cheese, but ekiga can use the camera just fine, so this might not be a kernel issue.

Can one of you attach you dmesg output after attempting to use the camera. Just curious if any errors get logged. As Florian mentioned, this might not be a bug with the kernel.

Changed in linux:
status: Confirmed → Incomplete
mewithafez (firefish17) wrote :

I believe this is the relevant dmesg output from mine using kernel 2.6.27-3, my networking just randomly stopped in 2.6.27-4 so I have to use it.

[ 477.208233] usb 1-2: new full speed USB device using uhci_hcd and address 2
[ 477.401329] usb 1-2: configuration #1 chosen from 1 choice
[ 477.587989] Linux video capture interface: v2.00
[ 477.605968] gspca: main v2.2.0 registered
[ 477.623234] gspca: probing 046d:08d7
[ 479.251362] zc3xx: probe 2wr ov vga 0x0000
[ 479.295363] zc3xx: probe sensor -> 11
[ 479.295378] zc3xx: Find Sensor HV7131R(c)
[ 479.301597] gspca: probe ok
[ 479.302583] gspca: probing 046d:08d7
[ 479.303668] gspca: probing 046d:08d7
[ 479.304825] usbcore: registered new interface driver zc3xx
[ 479.306543] zc3xx: registered
[ 479.421485] usbcore: registered new interface driver snd-usb-audio
[ 553.839728] zc3xx: probe 2wr ov vga 0x0000

this is after plugging in the camera and turning on cheese, which fails to use the camera

I have the same problem on kernel 2.6.27-4. My logitech STX cam (ID: 046d:08d7) no longer works.
I'll dmesg tonight when I'm home.

So far, all I can say is it worked on intrepid with kernel 2.6.26-*, any of you tried to reinstall gspca manually ?

Visko (visko) wrote :

I can confirm this, too:
root@Jupiter:~/download# lsusb
Bus 003 Device 006: ID 046d:08d7 Logitech, Inc. QuickCam Communicate STX
Bus 003 Device 003: ID 1058:1100 Western Digital Technologies, Inc.
Bus 003 Device 002: ID 05e3:0606 Genesys Logic, Inc. USB 2.0 Hub / D-Link DUB-H4 USB 2.0 Hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
root@Jupiter:~/download# lsmod | grep spc
gspca_zc3xx 55936 0
gspca_main 29312 1 gspca_zc3xx
videodev 41344 3 tuner,bttv,gspca_main
usbcore 148848 10 gspca_zc3xx,usbserial,snd_usb_audio,snd_usb_lib,gspca_main,usb_storage,libusual,ohci_hcd,ehci_hcd
root@Jupiter:~/download# dmesg | tail
[ 2344.069992] EXT3-fs: mounted filesystem with ordered data mode.
[ 2502.752318] usb 3-2.1: USB disconnect, address 6
[ 2502.755171] gspca: disconnect complete
[ 2504.360260] usb 3-2.1: new full speed USB device using ehci_hcd and address 7
[ 2504.469245] usb 3-2.1: configuration #1 chosen from 1 choice
[ 2504.471424] gspca: probing 046d:08d7
[ 2506.076423] zc3xx: probe 2wr ov vga 0x0000
[ 2506.108424] zc3xx: probe sensor -> 11
[ 2506.108432] zc3xx: Find Sensor HV7131R(c)
[ 2506.112366] gspca: probe ok

Indeed, the webcam still doesn't work. As far as I can remember, it used to work with spca5xx module, this zc3xx is unfamiliar. Anyway /dev/video1 exists (/dev/video0 is my tv-tuner card).

Visko (visko) wrote :

I forgot to say, that this is an ubuntu 8.10 beta (upgraded from alpha5).
root@Jupiter:~/download# uname -r
2.6.27-4-generic

Ron B. (flybye882001) wrote :

Here with same cam and 2.6.27-4-generic largely confirm above with remark that the built-in microphone seems to work fine - just the cam/video is the problem.

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, this bug is a duplicate of bug 267522 (and kind of bug 260918) and is being marked as such. Feel free to submit any future bugs you may find.

Changed in linux:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers