Synaptics Touchpad not recognized on Gigabyte M912 netbook

Bug #270611 reported by Bernhard Gehl on 2008-09-15
8
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xserver-xorg-input-synaptics

On a fresh install of Hardy 8.04.1 on a Gigabyte M912 ( the "X" version for that irrelevant matter) the touchpad doesn't work as it is not recognized by Xorg. Testing the same hardware on windows XP, the touchpad is doing its job just fine and is recognized as a Synaptics PS/2 touchpad.

Attached you'll find the debugging information for touchpads. If necessary I'll gladly do further testing so I can finally run Ubuntu as my main system on the netbook.

description: updated
William Grant (wgrant) wrote :

Can you please try this with the Intrepid alpha 6 desktop CD?

Changed in xserver-xorg-input-synaptics:
status: New → Incomplete

Ok, I did two things since my last report:
1) Gigabyte came out with a new BIOS version (F05) for "Linux compatibility". I flashed it, but nothing obvious happened - besides that my touchpad now sometimes hangs in Windows Vista. Since I do not know if any ACPI tables or bits changed, I 'll attach the touchpad debugging info for the F05 BIOS again.

2) Since I don't use Ubuntu as a productive system on the M912 (yet), I simply installed the current Intrepid (alpha 6) at the expense of touchscreen functionality but so what. Anyways, the touchpad doesn't work with Intrepid alpha 6.

William Grant (wgrant) wrote :

We also need the output of lshal these days.

Oh yeah, these modern times ... :-)

Attached is the lshal-output. I've also applied another BIOS update (F06) which didn't really change anything so I don't really think, all those output-files are required - or are they?

William Grant (wgrant) wrote :

There's nothing about it in lshal, so it's very probably a kernel bug.

Changed in xserver-xorg-input-synaptics:
importance: Undecided → Medium
status: Incomplete → New
JasonFarquhar (jdrf) wrote :

I've got this machine and a fix for this problem (for me) is to pass "i8042.noloop" as a boot option. Apparently its some problem with the kbd/mouse driver chip on this motherboard.

Charles Edward Pax (pax) wrote :

Jason, I tried your fix on my Gigabyte M912M, but it didn't work for me. I tried it on 8.10. Any suggestions?

Changed in linux:
status: New → Confirmed
ferryb (fer-chinaski) wrote :

The 'i8042.noloop=1' fix suggested by Jason worked for me (Intrepid)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers