Ubuntu

Dell Inspiron 2600 locks completely with Hardy and Ibex kernels

Reported by Ryan Novosielski on 2008-09-12
4
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Nominated for Hardy by Ryan Novosielski
Nominated for Intrepid by Ryan Novosielski

Bug Description

I am reporting a bug on my girlfriend's laptop that I'm currently borrowing to try to squash this bug. The problem is that on Gutsy, the machine worked great. After upgrading to Hardy, the machine started locking up at random. After a period of use, the machine will freeze. Reverting to the Gutsy kernel (2.6.22), the lockups are avoided completely. This problem has existed in every kernel I have tested since the Hardy release version of 2.6.24.

Recently, I had her try 2.6.27 from Ibex. The problem still exists, with a freeze at random. Now that I have this machine, I'd like to know what information to post or what types of things to try. This is a very serious bug, and the fact that a release is planned in a month that appears to still have this problem is pretty grave to me.

The only items of particular interest I think is a LinkSys wireless card that is using the TNET1130 driver via ndiswrapper. I haven't tried the machine without the wireless card in, but I believe that she has in the past.

Let me know what information I might want to provide. It appears as if nothing is written to any of the logfiles I've looked at after a crash, so I don't know how we're going to get to the bottom of this. I'm also not really convinced this is a bug with the Ubuntu kernel, and suspect it might be upstream. I don't know the best way to test that.

Ryan Novosielski (novosirj) wrote :
Ryan Novosielski (novosirj) wrote :
Ryan Novosielski (novosirj) wrote :

Hi Ryan,

Thanks for the bug report, lets see if we can try to get this resolved. You mention testing the latest kernel available for Intrepid. I suspect as you do that this might be a bug in the upstream kernel as well since we just rebased the Ubuntu kernel with upstream. If you would be intersted in testing the upstream kernel just to verify, try taking a look at the following:

https://wiki.ubuntu.com/KernelTeam/GitKernelBuild

Building the upstream kernel is obviously not something we expect you to know how to do so proceeding with doing this is completely voluntary and at your own comfort level. We appreciate all the help you can give. If you do happen to test the upstream kernel and can verify this is an issue upstream, it's likely we'll want to escalate this in an upstream bug report at bugzilla.kernel.org. The next step after that would likely be to perform a git bisect to try and narrow down the patch which is causing the regression. Again, this is competely at your own comfort level if you want to do this but will be extremely helpful to both us and upstream to narrow down this bug. Information regarding performing a git bisect can be found at:

http://www.kernel.org/doc/local/git-quick.html#bisect

You can perform the git bisect using the upstream kernel git tree or the Ubuntu kernel git tree. If you want to use the Ubuntu kernel git tree I'd suggest looking at the following:

https://help.ubuntu.com/community/Kernel/Compile => discussing building the Ubuntu kernel
https://wiki.ubuntu.com/KernelGitGuide => information regarding where to get the Ubuntu kernel git tree - You'll likely want to grab the Hardy git tree to reduce the number of bisections you'd need to perform.

Definitely let us know if you have any questions. I realize this might be a bit overwhelming with all this information I just gave you. But again, we really appreciate all the help you can provide. Thanks.

Ryan Novosielski (novosirj) wrote :

Leann,

I am a Linux sysadmin so I'm at the least well acquainted with actually compiling a kernel, it is Git that I'm completely unfamiliar with. I've always used source packages. I don't suspect it will be a problem, just will take a little time to get my feet wet. I'd also like to see the machine freeze while I'm using it. My girlfriend reported it having frozen with 2.6.27, but I haven't seen it myself to see the specifics (for example, I don't think the keyboard lights flash from this crash, but I'm not 100% sure). I have seen the repeated freezes with 2.6.24, though, and I feel like that one was much worse. Seemed you couldn't get more than a few minutes in with that one.

I'll let you know if I get stuck and where. Thanks for the quick response!

Ryan Novosielski (novosirj) wrote :

OK, I got what became 2.6.27-rc6-custom running (I didn't know I was going to end up with a linux-2.6 directory that was more than 3.5GB though -- actually just about ran out of disk space). I've already gotten it to lock up, so it looks like this is an upstream issue. Also, the NDISwrapper/TNET1130 combination was not working with this custom built kernel, so it definitely can't be blamed.

Let me know what I might need to do next.

Ryan Novosielski (novosirj) wrote :

I tried to start the git bisect process. This did not go so well though. What I did so far:

# git bisect start
# git bisect good v2.6.22
# git bisect bad v2.6.24

...and then attempted to build. This version that is created this way, however, does not compile. So, I tried:

# git bisect skip

...and then tried to build that one (this version appears to be 2.6.23, according to output). That one ALSO won't build. I'm guessing that the kernel has a lot of possibly interdependent patches that when not applied in groups yield an unbuildable kernel.

Any suggestions?

Ryan Novosielski (novosirj) wrote :

2.6.23 does not appear to have this problem. 2.6.24-rc1 did not want to build on my system. I'm in the process of building down 2.6.24-rc2. I figure that will at least narrow it down to reasonably small area.

I've found a bug or two reported on the BugZilla that somewhat mirror my circumstances, but I'm not sure whether to bother opening a new one. I figure when I have a little more information, I'll move forward.

I am still concerned for this release though -- I don't suppose you want to ship a broken kernel. :-\

I finally had my own machine lockup too, a Dell Latitude D620. Seems to me it has happened a couple of times in the past too, but I must have always attributed it to something else I was doing. With this 2600 though, the lockup would be evident in less than 12 hours in most cases.

2.6.23 is currently up for 26:41. I imagine it will make it until I install 2.6.24-rc2 without a crash.

ABe_CZ (bezrouk) wrote :

Hi,

I hope that it will be solved, because I observed the same problem on my Inspiron 2600!

THX

Hi Ryan,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 269248

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Incomplete and has not had any updated comments for quite some time. As a result this bug is being closed. Please reopen if this is still an issue in the current Ubuntu release http://www.ubuntu.com/getubuntu/download . Also, please be sure to provide any requested information that may have been missing. To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-expired
Changed in linux (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers