stkwebcam kernel-module doesn't support all the webcams supported previously with stk11

Bug #269123 reported by Rafi on 2008-09-11
98
This bug affects 16 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Stefan Bader
Nominated for Jaunty by Andres Mujica
Intrepid
Medium
Stefan Bader

Bug Description

Binary package hint: linux-source-2.6.27

The latest release of stk11 1.4.0 compiles under 2.6.27 giving support for a series of webcams that worked in hardy but because of this regression do not work in Intrepid.

hello

im using ubuntu intrepid alpha5 with the original-ubuntu-kernel 2.6.27-rc6 on a asus a6t.

root@PrinzIP:/home/rafael/treiber_N_progs/stk11xx-1.3.1# lsusb |grep Syntek
Bus 002 Device 003: ID 174f:a311 Syntek 1.3MPixel Web Cam - Asus A3A, A6J, A6K, A6M, A6R, A6T, A6V, A7T, A7sv, A7U

standartly the stkwebcam is loaded, but dont work

dmesg during booting:

[ 28.856942] stkwebcam: Syntek USB2.0 Camera is now controlling video device /dev/video0
[ 28.857103] usbcore: registered new interface driver stkwebcam
[ 837.751199] stkwebcam: error suspending the sensor
[ 837.756286] stkwebcam: stk_sensor_outb failed, status=0x02
[ 837.756298] stkwebcam: Sensor resetting failed

later in X:

root@PrinzIP:/home/rafael/treiber_N_progs/stk11xx-1.3.1# rmmod stkwebcam && modprobe stkwebcam && dmesg |grep stkwebcam

...

[ 1472.315645] usbcore: deregistering interface driver stkwebcam
[ 1472.315726] stkwebcam: Syntek USB2.0 Camera release resources video device /dev/video0
[ 1472.364186] stkwebcam: Syntek USB2.0 Camera is now controlling video device /dev/video0
[ 1472.367123] usbcore: registered new interface driver stkwebcam

but dont work with camorama ekiga cheese and so on...

even i cannot build the project stk11xx driver with the open used http://bookeldor-net.info/merdier/Makefile-syntekdriver , compare my german howto http://forum.ubuntuusers.de/topic/howto-z.b.-fuer-notebook-webcam-asus-a6t-id-1/?highlight=egika#post-915551 which worked fine before 2.6.27

root@PrinzIP:/home/rafael/treiber_N_progs/stk11xx-1.3.1# make -f Makefile-syntekdriver clean
rm -f *.o *.ko .*.o.d *~ .stk11xx*.cmd *.mod.c
rm -rf stk11xx-0.42 .tmp_versions
rm -f stk11xx-0.42.tar.bz2
root@PrinzIP:/home/rafael/treiber_N_progs/stk11xx-1.3.1# make -f Makefile-syntekdriver
make -C /lib/modules/2.6.27-rc6/build SUBDIRS=/home/rafael/treiber_N_progs/stk11xx-1.3.1 modules
make[1]: Betrete Verzeichnis '/usr/src/linux-source-2.6.27'
  CC [M] /home/rafael/treiber_N_progs/stk11xx-1.3.1/stk11xx-usb.o
/home/rafael/treiber_N_progs/stk11xx-1.3.1/stk11xx-usb.c: In function ‘usb_stk11xx_probe’:
/home/rafael/treiber_N_progs/stk11xx-1.3.1/stk11xx-usb.c:807: error: implicit declaration of function ‘PAGE_ALIGN’
make[2]: *** [/home/rafael/treiber_N_progs/stk11xx-1.3.1/stk11xx-usb.o] Fehler 1
make[1]: *** [_module_/home/rafael/treiber_N_progs/stk11xx-1.3.1] Fehler 2
make[1]: Verlasse Verzeichnis '/usr/src/linux-source-2.6.27'
make: *** [all] Fehler 2

maybe s.o. know how to fix...

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged
Jason Allen (jallen) wrote :

Confirming this is still an issue with Intrepid beta.

Refer Bug #278899 for module 'stk11xx'.

Tried using module 'stkwebcam', and the webcam still doesn't work for apps like aMSN, ekiga, cheese, etc.

Jos (namjos) wrote :

The last released version of stk11xx module driver do not compile on kernel 2.6.27
The last svn version do compile, maybe it should be included

Working version:
svn co https://syntekdriver.svn.sourceforge.net/svnroot/syntekdriver/trunk/driver

Lex Ross (lross) wrote :

I think it should, as with Intrepid release candidate the net result is no video device being detected. Those cameras are often being built into laptops which makes it essential to suppport them out of the box.

Jason Allen (jallen) wrote :

Agreed with Lex, especially as in most cases it worked out of the box in Hardy. It looks bad to have worked 100% in hardy and then 0% in Intrepid, and makes Itrepid seem a backward step, not a forward one.

Tom (beardtm) wrote :

Just writing to confirm that this is still an issue in the final release of Intrepid.

Andres Mujica (andres.mujica) wrote :

Hi i've marked some dupes from this bug,

would it be possible for the reporters to attach this info:

Output as separate attachments for:

      uname -a > uname-a.log
      cat /proc/version_signature > proc_version_signature.log
      sudo lspci -vvnn > lspci-vvnn.log (those are 2 v's not a w)
      dmesg > dmesg.log
      lsusb > lsusb.log
      lshal > lshal.log

thanks a lot

Logs attached as requested (with no webcam module loaded).

Then with:

$ sudo modprobe stkwebcam

tail of dmesg:

[ 539.088995] Linux video capture interface: v2.00
[ 539.109178] usbcore: registered new interface driver stkwebcam

$ lsmod | grep stk
stkwebcam 33668 0
compat_ioctl32 18176 1 stkwebcam
videodev 46720 2 stkwebcam,compat_ioctl32
usbcore 175376 5 stkwebcam,usbhid,ehci_hcd,uhci_hcd

Now if I try to start camorama:

$ camorama -D
VIDIOCGCAP -- could not get camera capabilities, exiting.....

Cheese doesn't get any video (No camera found). Ekiga also desn't get
any video (no device found with plugin V4L). Skype also can't use the
camera.

If I then unload the stkwebcam and load ver. 1.4 of the stk11xx, that
I have compiled from the sources at
http://syntekdriver.sourceforge.net :

$ sudo rmmod stkwebcam
$ sudo insmod ./stk11xx.ko

dmesg output:

[ 1591.307058] usbcore: deregistering interface driver stkwebcam
[ 1826.083489] stk11xx: Syntek USB2.0 webcam driver startup
[ 1826.083549] stk11xx: Syntek USB2.0 - STK-1135 based webcam found.
[ 1826.083554] stk11xx: Syntek AVStream USB2.0 1.3M WebCam - Product ID 0x6A31.
[ 1826.083560] stk11xx: Release: 0005
[ 1826.083564] stk11xx: Number of interfaces : 1
[ 1826.089065] stk11xx: Initialize USB2.0 Syntek Camera
[ 1826.206362] stk11xx: Check device return error (0x0201 = 0C) !
[ 1826.273228] stk11xx: Syntek USB2.0 Camera is ready
[ 1826.273436] stk11xx: Syntek USB2.0 Camera is now controlling video
device /dev/video0
[ 1826.273515] usbcore: registered new interface driver usb_stk11xx_driver
[ 1826.273522] stk11xx: v1.3.1 : Syntek USB Video Camera

With this module, camorama has video from the webcam. Ekiga also works
with the stk11xx module. So this is an improvement over the stkwebcam
module :)

But not all is good :( Cheece is not working again (No camera found)
and Skype detects the webcam, but when testing the webcam
functionality from the app settings, I only get a black screen.

I would be very interested if anyone else had better luck..

Here the files you want
NB: The manually compiled driver is running at this time, so the logs may contains info about it

Jos (namjos) wrote :

Sorry, I didn't find how to add several files, so I send an archive:

Jos (namjos) wrote :

BTW Athanasios Lefteris
For me, with the driver from sourceforge, Skype webcam works with no problem (on preview or on call)
Ekiga and cheese is also not working for me, cheese was working on ubuntu 8.04, but I don't know for Ekiga, I didn't test it on hardy

Sorry for the multiple posts

Andres Mujica (andres.mujica) wrote :

The problem here, as stated in the dupes from this bug report is the missing st11k module into the Intrepid kernel and as the stkwebcam module doesn't support all the modules we've got a regression.

stkwebcam supported webcams:

http://cateee.net/lkddb/web-lkddb/USB_STKWEBCAM.html

stk11 supported webcams:
http://syntekdriver.svn.sourceforge.net/viewvc/syntekdriver/tags/1.4.0/README?revision=82&view=markup

The latest release compiles in 2.6.27 kernel

https://sourceforge.net/forum/forum.php?forum_id=890411

description: updated

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Jim Lieb (lieb) on 2009-01-08
Changed in linux:
assignee: nobody → lieb
status: Triaged → In Progress
Jim Lieb (lieb) wrote :

I have built i386 and amd64 kernels with the lastest 1.4.0 stk11xx driver. Please test this and report back your results. Include the architecture/package you used. You can find the linux image packages at:

http://people.ubuntu.com/~lieb

with the packages under amd64|i386

The sooner this can be confirmed, the sooner it can be proposed for the next update.

Jim

Jason Allen (jallen) wrote :

Thanks Jim, much appreciated.

I can confirm the amd64 kernel worked fine for me, with camorama working instantly. All other things/hardware worked as per 2.6.27-9-generic.

I use/run nvidia (177.82) restricted/proprietary hardware drivers and these failed on the dkms when installing the kernel deb package, and thus the nvidia drivers did not load when I booted with your 2.6.27-11-generic. I expect this is more a problem with nvidia drivers than the kernel and something outside your control?

Jos (namjos) wrote :

Hi Jim and thanks for your work

I confirm that the i386 version is working for me, tested with skype.
There's only a regression from hardy with cheese, that is no more working with this webcam, but it is as in the sourceforge repository.

I attach an lsmod output from this kernel

Jos

Jim, It sounds like we have a confirm in both 64bit and i386. I'm very eager to see this comming in proposed. Thank you so much for your work. When can we expect it?

Nikola

mikele (michael-arnold) wrote :

Hi Jim,

my Webcam

$ lsusb | grep Syntek
Bus 003 Device 003: ID 174f:6a31 Syntek Web Cam - Asus A8J, F3S, F5R, VX2S, V1S

does still not work with your kernel. Shouldn't it also be supported by the driver you included?

Michael

Lex Ross (lross) wrote :

Hi Jim,

Same here.

$ lsusb | grep -i syntek
Bus 001 Device 003: ID 174f:6a31 Syntek Web Cam - Asus A8J, F3S, F5R, VX2S, V1S

Webcam is not detected and loading stk11 driver manually does not help. On a side note, I am resticted to low resolution graphics with my nVidia graphics card when using your kernel. Please make sure that proprietary nvidia driver is included with the kernel you propose before it gets to intrepid-proposed.

Lex

sojyujai (sojyujai) wrote :

Hi Jim,
I just tried your i386 kernel and it seems to be working, at least with Cheese and Skype.

$ lsusb | grep -i syntek
Bus 005 Device 003: ID 05e1:0501 Syntek Semiconductor Co., Ltd WebCam, Chipset DC-1125 similar to 174f:a311 - Asus F2F, F2J, F3J, F3T, G1, Z53JA

Jason Allen (jallen) wrote :

Any chance of a kernel for 2.6.28-7 (x64) that I can use for testing with Jaunty (9.04)?

Andres Mujica (andres.mujica) wrote :

so the driver/jim's kernel is not working for lsusb id 174f:6a31, according to the links above this id is supported by stk11 only in video stream mode.

the reporters with this id are using which module??

I think we all use the same driver. Here is a web site in French that has some details.

http://doc.ubuntu-fr.org/syntek

Nikola

mikele (michael-arnold) wrote :

I am also running my webcam (174f:6a31) by using the driver of Nikola's post.

Michael

Andy Whitcroft (apw) on 2009-02-24
Changed in linux:
assignee: nobody → lieb
importance: Undecided → Medium
status: New → In Progress
Jim Lieb (lieb) wrote :

We have built mainline kernels directly from kernel.org as Ubuntu
packages at the following location:

  http://kernel.ubuntu.com/~kernel-ppa/mainline

If you could install and test the stkwebcam driver one of the later kernels and report back.
There have been a number of patches including new device support in the 2.6.28
and later kernels for webcams. If a newer version of this driver solves your problem
it would be better than introducing a competing non-mainline driver as a backport package.
Your feedback will help us decide which backporting option is better.

Note: these kernels are for testing and experimentation only. They are not
supported in the Ubuntu distribution in any way nor do they contain any
Ubuntu bug fixes.

Andy Whitcroft (apw) on 2009-02-25
Changed in linux:
status: In Progress → Incomplete
Jim Lieb (lieb) on 2009-02-27
Changed in linux:
assignee: lieb → stefan-bader-canonical
Jim Lieb (lieb) on 2009-02-27
Changed in linux:
assignee: lieb → stefan-bader-canonical
status: In Progress → Incomplete
burnai (ian3008) wrote :

Does anyone know if this error is going to be fixed in the next Ubuntu release (Jaunty)?

I tried the current state of Jaunty and this issue is still there. The webcam doesn't work out of the box. However using the latest driver 1.4 stk11xx driver I managed to get it working. However Skype didn't quite worked with it... but this is different issue.

So Jim I think the answer is that the new 1.4 driver seems to work with 2.6.28 (the one in Jaunty).

Nikola

Lex Ross (lross) wrote :

I would like to see stkwebcam driver to support this webcam.

$ lsusb | grep -i syntek
Bus 001 Device 003: ID 174f:6a31 Syntek Web Cam - Asus A8J, F3S, F5R, VX2S, V1S

stkwebcam does not work on 2.6.8-11 kernel and is not being autoloaded making it possible to include skt11xx driver as temporary fix. Version 2.0.0 of stk11xx driver failed to compile on 64-bit Jaunty beta for some reason, complaining about stk11xx-v4l.c code. Same thing with svn. See http://syntekdriver.sourceforge.net/index.php?mode=download

Does anyone communicate with Linux kernel upstream about stkwebcam driver not supporting syntek cameras? What is the plan for 9.10 final release?

Thanks,
Lex

KaiserSoze (rodolfog) wrote :

This Driver is an authentic nighmare! Worked perfectly with Ubuntu 8.04 and with Opensuse 11.1. The rest is to forget. Can´t get it workign on Ubuntu 8.10 nor newer kernel versions.

Does someone knows if issue is going to be solved on the 9.04 release? Would be perfect! :-)

:( So I was fighting with the 1.4 version of the driver on the 2.6.28 kernel that is 9.04, but it is a NIGHTMARE. I haven't seen the linux kernel dies and burn so often ever. ;( Any attempt to start any program connected somehow with this device causes deep kernel crash and my scroll and caps lock lights start blinking. The only ways out of those crashesh was hard restart. I just looked on the web site of the driver

http://sourceforge.net/projects/syntekdriver/

And there is version 2.0 of the driver but is only for the 2.6.29 kernel or later ;(
Can someone smarter help us. It looks to me like there is no good version of the driver for the 2.6.28 kernel ;(

Very sad.

Can I help in any way.

Jos (namjos) wrote :

I confirm that my webcam is no more working on ubuntu 9.04
Driver version 1.4.0 compilation is OK, loading module is OK, green led is ligthing 1 second on load like before, but the webcam is unusable on any program.

Skype, cheese, ekiga do not detect it.

So:
Ubuntu 8.04: Work out of the box
Ubuntu 8.10: Need to compile and install manually a driver
Ubuntu 9.04: Compilation and load work but webcam is unusable

Can it be a regression of the stkwebcam module on ubuntu 9.04?

My webcam: ID 174f:6a51 Syntek 2.0MPixel Web Cam - Asus Z96J, Z96S, S96S

Lex Ross (lross) wrote :

Hi Joe,

I think your webcam is only supported by stk11xx driver. Mine is ID 174f:6a31 Syntek Web Cam - Asus A8J, F3S, F5R, VX2S, V1S and it used to work with stk11xx until Ubuntu 8.10 came out. The best thing would be to implement this webcam support into stkwebcam kernel module. I wrote to Jaime about this, and he is willing to co-operate. Jaime is sktwebcam maintainer. Here is what he says.

---------------------------
Both the camera controller (the chip made by Syntek) and the image sensor are different than the one supported
by stkwebcam.

But, as now most applications use libv4l, it _could_ be done if it works now with stk11xx. After reading the bug report, I see several unrelated problems, so I'm confused . The original report seems to be a problem with stkwebcam, as that camera should work out of the box (it's the same as mine). The cameras unsupported by stkwebcam (as yours) should keep working the same as before, with stk11xx.

If somebody is interested in adding support to stkwebcam, I'd help, but it could become very frustrating, so be warned!

The proccess would be:
1. test stk11xx and confirm that it works
2. try to remove cruft from stk11xx until it stops working. I could send patches
3. port the code to stkwebcam and test again. I'd send patches as well
4. if all works, it'll get into Linus' kernel eventually (after 2.6.30 for sure)

And the driver will only support RAW colorspace unless somebody figures out how to program the image sensor, so the application you want to use probably needs to use libv4l (if you're interested in skype, I don't know if it would work, maybe).

That's all, if you're still interested start with step 1 and tell me how it goes.

Regards,
Jaime
--------------------------------------

So it's not all that easy but if we could have someone from Ubuntu kernel team on our side to facilitate the process, then support for Syntek webcams in question can be built into stkwebcam module. Otherwise I would kindly ask Ubuntu kernel team to include stk11xx driver with 9.04 final release. I am willing to help as much as I can but unfortunately do not know much about kernel development. Time to call for collective wisdom, what do you think?

Jos (namjos) wrote :

Hi Lex

The problem for my webcam is that stk11xx driver works with ubuntu 8.10 (2.6.27 kernel) but not with ubuntu 9.04 (2.6.28 kernel)

As I said, on ubuntu 9.04, stk11xx driver module compilation is OK (version 1.4.0), loads OK after loading stkwebcam, but is not usable on any program.

stk11xx needs stkwebcam module, as he need some functions of it, so we can't test stk11xx without stkwebcam. I've not currently the needed exports from stkwebcam that stk11xx needs, but I can retrieve it if you want (just load stk11xx without loading stkwebcam, and copy /var/log/message stuff)

So include stk11xx on ubuntu 9.04 will not help me to have a succesfull webcam working.

A good test, if it is possible to do, would be to compile 2.6.27 stkwebcam module source on a 2.6.28 kernel, and try to see if my webcam is working with stk11xx on top of this stkwebcam module. It may be a regression on stkwebcam module, I don't actually now.

So for your step 1, it was what i've already tested, and stk11xx not currently working with ubuntu 9.04. I was maybe not enough clear in my previous message.

Regards,
Jos

I can confirm Jos story. I just want to add that I can actually get some picture using v4l2 but all the other applications that use v4l1 crash when they try to touch the webcam (My webcam: ID 174f:6a51 Syntek 2.0MPixel Web Cam - Asus Z96J, Z96S, S96S)

It is actually very scary because the kernel itself crashes very often when this program attempt to use the webcam. I'm very interested to see if the 2.0 driver works with 2.6.29 (it is supposed to). Unfortunately I don't know how to tell 9.04 to use 2.6.29 (if it is even in some repository...? is there a package somewhere?) Can someone guide me how to do this or someone can just test the webcam with 2.6.29 and 2.0 of stk11xx.

Thanks

Nikola

Jos (namjos) wrote :

Hi there,

I've made some tests with ubuntu 9.04, and the results are really stranges.
I've build some custom kernels to try to isolate the problem.

Ubuntu 9.04, kernel 2.6.28 with stk-webcam.c from 2.6.27 kernel: Not OK
Ubuntu 9.04, kernel 2.6.28 with all driver/media and include/media directory from 2.6.27: Not OK
Ubuntu 9.04, kernel 2.6.27: Not OK
Ubuntu 9.04, kernel 2.6.27-11-generic from ubuntu 8.10: Not OK

I really don't understand what is going on now, it seems that this is not the 2.6.28 kernel that is in fault, so I don't know where it could be other than kernel.

Any ideas to test something?

Ok i've finally found what's going on :)
It's a permission issue, users on ubuntu 9.04 was not added to video
group at creation, so they do not have right to use it.

To solve it:
[code]
sudo addgroup $USER video
[/code]

Then disconnect / reconnect your session, it will then work on ubuntu 9.04.

Is a bug already opened for this stuff of video group missing? Maybe we
should open one otherwise

Jos (namjos) wrote :

Ok i've finally found what's going on :)
It's a permission issue, users on ubuntu 9.04 was not added to video group at creation, so they do not have right to use it.

To solve it:
[code]
sudo addgroup $USER video
[/code]

Then disconnect / reconnect your session, it will then work on ubuntu 9.04.

Is a bug already opened for this stuff of video group missing? Maybe we should open one otherwise

Hi,
I added the user to the group video. Still no luck with with web cam. Is there any real solution for this problem coming up?

Thanks for all your efforts!

KaiserSoze (rodolfog) wrote :

Seems no update is to be made on this Kernel version?

I use Linux 99% of the time.. and it is just a shame I have to maintain a partition with Vista just for a Skype Video call :-(

Thank you all!

Stefan Bader (smb) wrote :

Thanks all for the comments and sorry for for being so unresponsive. There seems to be always another thing taking precedence over this. Essentially the better way to go forward would be to get the in-kernel driver working. I saw comments about the driver in 2.6.29 being better in that. If that is the case it probably is worth looking at whether this can be backported to Jaunty (for Intrepid there is no chance for that kind of change). We not got mainline kernels at https://wiki.ubuntu.com/KernelMainlineBuilds, which can be installed in parallel to the current kernel. If a recent kernel can be verified to be working, then it would be simpler to find the necessary changes.

Stefan Bader (smb) wrote :

Intrepid does not qualify for that type of SRU anymore.

Changed in linux (Ubuntu Intrepid):
status: Incomplete → Won't Fix
KaiserSoze (rodolfog) wrote :

Hi all,

I found a post wich actually worked! :-)

http://ubuntuforums.org/showthread.php?t=1182093

Kudos to noobi_agocs for making this work for me!
copy/
I had also problems whit my webcam. I googled around the web every evening after work to solve the problem. FINALLY it works for me...

I have an ASUS F5VL series laptop, and i'm using Ubuntu 9.04

1.
So, maybe the most important thing is, that you need to download the stk11xx Syntek driver, BUT the 1.4.0 release! This is very important! I had no chance to install the 2.0.0 release...

Here you can download it: http://sourceforge.net/projects/syntekdriver/

2.
Then, I followed this HOWTO: http://doc.ubuntu-fr.org/syntek

This is a french HOWTO (i dont speak french), but it's excellent. I followed it step by step, EXCEPT that I didn't donwloaded the latest syntek driver using the svn command.

Later I found an english HOWTO: http://www.zer0.net/2007/12/asus-syn...lation-on.html

3.
After this i installed video4linux using the command:
$ sudo apt-get install v4l-conf

4.
The last step was to add my user nick to a group that is allowed to use the webcam. The command is:
$ sudo adduser USERNICK video

Then RESTART...

After this i've tried the webcam whit: Camorama, aMSN and Skype. All of them recognized whitout any problem the webcam.

I hope this helps you a little...
Have a nice day! Cheers!

noobi
/copy

After this, as usual, my cam was upside down. Just type this on console:

$ echo 1 >/sys/class/video4linux/video0/vflip

to make it permanent after reboot paste the above line on /etc/rc.local

Cheers

The above did not work fully for me. Skype does recognize the webcam now. But the image is just black. ;( Will this maybe work out of the box on 9.10?

Amol (amolmodi) wrote :

I had this problem with the webcam in my Thinkpad, and managed to find the solution here: http://kylewilliams.co.za/2009/03/05/getting-the-lenovo-sl300-camera-to-work-on-linux

Basically, you just have to add the line "options uvcvideo quirks=16" to the uvcvideo.conf file in /etc/modprobe.d

Hi Amol,

Thanks for the help but this did not work for me. In skype when i start my video to someone else it is just a black picture. There are no errors or anything. The green light on the webcam lights up, but the picture is just black :(.

So sad. I have to keep two versions of Ubuntu 9.04 that I use mainly and if someone wants to talk in Skype with me I reboot into 8.04. I've been using Ubuntu since 5.04, I got this machine around 6.10. Up to 7.10 the webcam wasn't working by default I had to install drivers to make it work... In 7.10 and 8.04 the camera works out of the box I was so so happy and you actually see improvement. Than regression 8.10, 9.04... ;(( and no fix on the horizon. Can't even make it work compiling drivers and stuff.

Anyway thanks for the help Amol.

Nikola

Judderman (pmjudkins) wrote :

Nikola,
I had problems with the webcam as well for ages with no solution. However, I did manage to compile today using the latest driver from the http://sourceforge.net/projects/syntekdriver/. The problem seems to lie with the stk11xx-v4lc.c file, which was issuing an ERROR 2 on compiling. I just copied the file packaged with the 1.4 source files to the new directory I had created with the svn command, and it compiled without any problems. It works on preview in Skype, but not yet tried calling.
Hope this helps.
It seems that there is a syntax problem with the stk11xx-v4lc.c file that is shipped with the source files, but I can't work out what it is as I am rubbish at that sort of thing.

Thanks Judderman.

I actually grabbed revision 99 from the svn. This is the future version 2.2 of the driver and I had no problems compiling it. It now works. I will try to soon test if maybe the webcam works out of the box on 9.10. But I think that now that the driver compiles and looks better it should come with the kernel by default ...

There still work for this bug, but it looks closer.

Nikola

Lex Ross (lross) wrote :

Nikola,

Thank you so much for your post. Webcam is not recognized in 9.10 out of the box and does not work. Any chance that future version 2.2 of the driver is going into karmic-proposed?

tags: added: intrepid
Lex Ross (lross) wrote :

I have compiled and installed the driver from SVN (revision 99) on my 64-bit Ubuntu 9.10 with 2.6.31-19 kernel and it's all good. Kinda confused as to why it is same revision 3 months later as it sounds like it is time for the version 2.2 to be released. Hope it will be there by the time Ubuntu 10.04 comes out. So may I propose to include svn version of the driver with 10.04 alpha2 or beta release.

Lex

Nur (nur-ismail) wrote :

I have an acer laptop. I installed Ubuntu 9.10. The webcam was working fine at the begining without installing any additional driver.. after a few months it stopped working probably after I updated the kernel.. but I don't know exactly the moment in which it stopped working!

hadzhimurad (ustarkhanov) wrote :

Can anybody there tell me which sensor (model) use stk-1135 webcam?

gnimsh (loochyj) wrote :

I have an stk webcam in my ASUS F3Se laptop, and it used to work fine in hardy but has not worked in any prior releases. Now in lucid it is finally detected under lsusb, but not seen by skype or cheese. This means I still have to use windows for times when I need the webcam (which are very seldom these days, thankfully).

Filippo Bannò (oppilif86) wrote :

The same for me (Asus F3Sa, ID 174f:6a33 Syntek Web Cam - Asus F3SA, F9J, F9S, Ubuntu Lucid). The camera is not detected by Skype/Ekiga, while working perfectly with Hardy.

dpanario (danielpanario) wrote :

hi, try this, i will post my script to install ID 174f:a821 Syntek Web Cam - Packard Bell BU45, PB Easynote MX66-208W.
just save it and execute, it will install stk 2.1.0 driver

--------------------------------------------------------------- damn syntek ------------------------------------------------------------------------------
#!/bin/sh

# Dependencias
sudo apt-get install build-essential

# Controlador
wget http://downloads.sourceforge.net/project/syntekdriver/syntekdriver/Release%202.1.0/stk11xx-2.1.0.tar.gz?use_mirror=freefr
tar xvzf stk11xx-2.1.0.tar.gz && cd stk11xx-2.1.0 && wget http://bookeldor-net.info/merdier/Makefile-syntekdriver && make -f Makefile-syntekdriver && sudo make -f Makefile-syntekdriver install
sudo modprobe stk11xx && sudo lsusb -v | grep -A 8 Syntek && sudo addgroup $USER video && cat /sys/class/video4linux/video0/vflip && echo 1 >/sys/class/video4linux/video0/vflip

# Camorama
sudo apt-get install camorama

# Mensaje
zenity --info --title="Proceso finalizado" --text="Ya está, prueba abriendo Camorama a ver si funciona." \

-----------------------------------------------------------------------------------------------------------------------------------------

Hope it helps
regards

Hi dpanario,

I execute your script and successfully install the driver, I can find stk11xx.ko in /lib/modules/2.6.32-24-generic/kernel/drivers/usb/media, but I got error message (screenshot attached) when I open Camorama, any comment about this? thanks.

Lex Ross (lross) wrote :

The driver does not compile on x64 Ubuntu 10.10 release with 2.6.35-22 kernel. See error log below.

make -C /lib/modules/2.6.35-22-generic/build SUBDIRS=/home/lexross/stk11xx-2.1.0 modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.35-22-generic'
  CC [M] /home/lexross/stk11xx-2.1.0/stk11xx-v4l.o
/home/lexross/stk11xx-2.1.0/stk11xx-v4l.c:1737: error: unknown field 'compat_ioctl' specified in initializer
/home/lexross/stk11xx-2.1.0/stk11xx-v4l.c:1737: error: 'v4l_compat_ioctl32' undeclared here (not in a function)
make[2]: *** [/home/lexross/stk11xx-2.1.0/stk11xx-v4l.o] Error 1
make[1]: *** [_module_/home/lexross/stk11xx-2.1.0] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.35-22-generic'
make: *** [all] Error 2

Two years with this bug and more to come. With regressions like this one I wonder how anything can be possibly certicied to work with Ubuntu. Well, until next release.

apetrelli (antonio-petrelli) wrote :

In relation to comment #56, I had the same problem under Kubuntu 10.05. To make it work I removed that offending. "compat_ioctl" field (it's just at the end of the file).
It seems that the problem is that CONFIG_COMPAT is (incorrectly?) defined.

apetrelli (antonio-petrelli) wrote :

Obviously I meant Kubuntu 10.04, sorry for the typo.

Brad Figg (brad-figg) wrote :

Neither Intrepid nor Jaunty are supported any longer. If this issue still exists in a supported series, please file a new bug.

Changed in linux (Ubuntu):
status: Incomplete → Won't Fix
Lex Ross (lross) wrote :

Very nice indeed. The problem still exists in 10.10 (Maverick) with kernel versions up to 2.6.35-28
More than two years with no video calls! Is there a problem to include stk11 driver with the new kernel release?
I was able to compile and install the driver at some point but then having to recompile it after each kernel update is a royal pain in the arse. Is there a chance that upstream developers aren't even aware of this bug report?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers