hang after modifying cpufreq/* after suspend/resume on amd x2/690g

Bug #267958 reported by nqzero on 2008-09-09
2
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

machine:
amd x2 b3-2350 (low power, 45w), ati x1250, asus m2a-vm hdmi, 4g

i can suspend and resume, with two problems:
1. the virtual terminals are garbled after a resume
2. writing to any of the files in /sys/devices/system/cpu/cpu*/cpufreq results in an immediate crash / hang

i've tested this two ways. normally i use fglrx (restricted module) and X. in this case, the vt's are garbled but X works fine. to verify that fglrx wasn't part of the problem i booted with init=/bin/bash and set up the network (leaving fglrx unloaded, ie no X). in this case the vt's weren't garbled, but the monitor complained about "bad frequency" so i turned it off and ssh'd in.

in both methods, the suspend/resume succeeded (other than the vt issue) but as soon as the cpufreq files are changed, the machine crashes - can't ping, no ctrl-alt-delete, no sysrq, keyboard led's don't change, ...

nqzero (nqzero) wrote :
nqzero (nqzero) wrote :
nqzero (nqzero) wrote :
nqzero (nqzero) wrote :

i'd like to try manually rmmodding powernow_k8 before the sleep/resume cycle (i've tried setting it in acpi-support) but as soon as i load the k8 module, i'm unable to unload it - anyone know how to tell what is using it, or what device it creates (so i can find it in lsof) ?

[This is an automated message. Apologies if it has reached you inappropriately.]

This bug was reported against the linux-meta package when it likely should have been reported against the linux package instead. We are automatically transitioning this to the linux kernel package so that the appropriate teams are notified and made aware of this issue. Thanks.

affects: linux-meta (Ubuntu) → linux (Ubuntu)
kernel-janitor (kernel-janitor) wrote :

Hi lytles,

Please be sure to confirm this issue exists with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/releases/ . However, note you can only test Suspend, not Hibernate, when using a LiveCD. If you could run the following command from a Terminal (Applications->Accessories->Terminal) it will automatically gather and attach updated debug information to this report.

apport-collect -p linux 267958

Also, please be sure to take a look at https://wiki.ubuntu.com/DebuggingKernelSuspendHibernateResume . If you can provide any additional information outlined there it would be much appreciated.

Additionally, if you could try to reproduce this with the upstream mainline kernel that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Thanks in advance.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kernel-suspend
tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
nqzero (nqzero) wrote :

i am no longer seeing the hangs that i report above. i've been suspending and resuming on a regular basis for the last few months. i've changed 2 things - i upgraded the firmware and ubuntu. i believe that the firmware upgrade was what made the difference

i have seen potential filesystem corruption on 2 occasions - a git repo became unusable, and after resume i got a blank screen and a weird error: "end_request: I/O error, dev sda, sector ########"

no idea if this is related to the resume issues, or a failing hard drive

Linux version 2.6.28-14-generic
i'll try to remember to lookup the firmware version next time i reboot, but i think it's 1803 (i used whatever was the latest at the time i tried upgrading)

I'm going to mark this bug as fixed for now based on the previous comment. Thanks.

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers