Ubuntu

hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj

Reported by Jonh Wendell on 2008-09-08
338
This bug affects 59 people
Affects Status Importance Assigned to Milestone
Linux
Won't Fix
Medium
fglrx
Invalid
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I got this message in my dmesg:

 hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.

I don't know if it is a bug, but I haven't seen this message in 2.6.26.

I'm using 2.6.27-2-generic

Hi John,

Are you experiencing any sound issues? Looking at the kernel code it seems to just be a warning. Just so we can see which sound card you have, could you attach the output of:

sudo lspci -vvnn > lspci-vvnn.log

Thanks.

Changed in linux:
status: New → Incomplete
Jonh Wendell (wendell) wrote :

Hi.

No, I'm not experiencing any sound issue, except some little stops, but I guess it's pulseaudio's fault...

Changed in linux:
status: Incomplete → New

Hi,
i have the same message,
here is my lspci, my kernel is 2.6.27-3-generic .
Thanks

Changed in linux:
status: Unknown → Invalid
DSHR (s-heuer) wrote :

I observed this too with 2.6.27-3-generic on resuming from standby.

covox (covox) wrote :

I have that line in my dmesg, and as of 2.6.27-4 I no longer have sound; when music plays all I can hear is a series of pops from my speaker. This is a pretty serious regression as sound works perfectly (with model=3stack) in 2.6.27-3, with no such error message. This is on a Toshiba Satellite A100 with a Realtek ALC861.

Not sure if this is related, but roughly 2 times out of 3, on the 2.6.27 series of kernels my computer will lock up just before printing the "loading kernel modules" step.

covox (covox) wrote :

Sorry my bad, the crackly sound appears to be a pulseaudio thing. In other news I'm an idiot.

Dave Gilbert (ubuntu-treblig) wrote :

I also see this warning; audio seems to be OK.

Linux davros 2.6.27-4-generic #1 SMP Wed Sep 24 01:29:06 UTC 2008 x86_64 GNU/Linux

this is the first boot after an update to Intrepid.

00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
05:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
07:06.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller
07:06.1 FireWire (IEEE 1394): Texas Instruments PCIxx12 OHCI Compliant IEEE 1394 Host Controller
07:06.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD)
07:06.3 SD Host controller: Texas Instruments PCIxx12 SDA Standard Compliant SD Host Controller
07:08.0 Ethernet controller: Intel Corporation PRO/100 VE Network Connection (rev 02)

Evan Carroll (evancarroll) wrote :

I'm also receiving this message in dmesg, and my sound (ignoring pulse audio straight to the device with alsa) is **no longer working.**

cat /dev/urandom |aplay -f dat -D hw:0,3
Playing raw data 'stdin' : Signed 16 bit Little Endian, Rate 48000 Hz, Stereo

**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

I know my settings haven't changed insomuch as S16_LE 48000 Hz or two channel working on the *only* device that the kernel picks up. I also wrote the wikibooks on alsa on pulseaudio so I would elevate this bug to confirmed and assume a large percentage of people on ATI mobos with build in HDMI will fail on intrepid release.

http://en.wikibooks.org/wiki/Configuring_Sound_on_Linux
(for the wikibook, where I will put the solution if i find one)

Changed in linux:
status: New → Confirmed
Evan Carroll (evancarroll) wrote :

I actually think the problem might be removing my fglrx graphics driver and replacing it with open source ati, because fglrx wasn't working as of the time of upgrade to intrepid I will get back to you on this. I found more info at:
https://bugs.launchpad.net/ubuntu/+source/linux-ubuntu-modules-2.6.24/+bug/196026

Adam Porter (alphapapa) wrote :

I have a Dell M1330, and am running Hardy with the 2.6.27-5 kernel from Intrepid. I just noticed this error in my ring buffer after hitting the eject CD button a couple times; it seemed to show up immediately after trying to eject the CD, but not the first time, and not every time. I've been playing sound through Amarok (with ALSA, no PulseAudio) and have had no sound problems.

(The CD still hasn't ejected, by the way...but that's a separate problem.)

[ 2325.259251] hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.

Dr. Tyrell (dr.tyrell) wrote :

I don't run pulse, and it's not fglrx (I have nvidia)
This timing workaround has also cropped up for me.
Don't know for how long, but i'm on 2.6.27-5-generic 64-bit, with a Core Duo p8400 (ich9)
Could this be related to the "CE: hpet increasing min_delta_ns to 15000 nsec" (and on and on) issue?

The Doctor

Daniel Holm (danielholm) wrote :

I run 2.6.27-7-generic and also got this problem. And also CE: hpet increasing min_delta_ns to 75936 nsec
My computer also hangs completely from time to time. Freezes and all my diods starts to blink.

Nothin new regarding this bug?

Hi

I am using Fujitsu Siemens Amilo Li1705 laptop with VT8237A based chipset. I cannot get from external speakers when i plug them in to the laptop. Alsamixer controls are NOT muted.

I am currently using 2.6.24-21-generic and have Ubuntu 8.06 LTS installed on my laptop. By default i donot see the "Headphone" control in alsa-mixer and only the laptop's internal speakers work. I followed the procedure listed in
(http://ubuntuforums.org/archive/index.php/t-556217.html).
and managed to get the "headphones" control in alsamixer. and could get the sound by plugging in external speakers. But after reboot I can no longer get the sound from external speakers, but the internal speakers work as usual.

Output of aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: VT82xx [HDA VIA VT82xx], device 0: VT1708 Analog [VT1708 Analog]
  Subdevices: 2/2
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1

** The subdevices section is funny since there should be just one subdevice and not 2

Output of dmesg | grep hda

[ 86.304650] hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.

I can confirm that the same problem occurs for 2.6.24-16-generic also. I was using Edgy before and had to use the same trick as in the above link to get the sound to work on it but never got this problem.

Ian Corne (icorne) wrote :

Got the same [ 140.432774] hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.

$ uname -a
Linux quadian 2.6.27-10-generic #1 SMP Fri Nov 21 12:00:22 UTC 2008 i686 GNU/Linux

Ubuntu 8.10

Ian Corne (icorne) wrote :

Why isn't there an edit button?

Just to add: i'm having no sound porblems what-so-ever

mc.god (mc-god) wrote :

Hi, I'm having the same message:
hda_codec: Unknown model for ALC268, trying auto-probe from BIOS...
hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.

running Intrepid on an Acer Extensa 5620 notebook, with kernel:
2.6.27-9-generic #1 SMP Thu Nov 20 22:15:32 UTC 2008 x86_64 GNU/Linux

audio chip is:
Audio device [0403]: Intel Corporation 82801H (ICH8 Family) HD Audio Controller [8086:284b] (rev 03)

I notice that running Rythmbox and playng an audio file, when I try to open de volume control for the fist time, it doesn't respond and every window opened remain henged for some time, then the volume control open and the system returns responsive.

Never had this problem on Hardy with 2.6.26

Christoph Korn (c-korn) wrote :

I have just experienced this bug on my DELL Latitude D830 notebook.

The system has completely frozen and I could not do more than pull the plug.

Michael Marley (mamarley) wrote :

The exact same message also appears on my Vostro 1500, at about the time when KDE starts. Audio quality (directly through ALSA, no Pulseaudio) is good. Also, I do not get any lockups.

Nil (nicolas-limare) wrote :

Same here on a Panasonic Y5. I got this message when removing a SDcard, and immediatly my sound (from a VLC stream) freezed, and crashed. I could restart the audio stream, but It seems I can't mount a SDcard anymore. rebooting...

Michael Marley (mamarley) wrote :

You (Nil) might try doing a "cat /proc/interrupts" at the console and see if snd-hda-intel is using the same interrupt as your SD card reader. If it is, you may be able to work around the SD card problem by adding the line "options snd-hda-intel enable_msi=1" to the bottom of your /etc/modprobe.d/alsa-base file.

Nil (nicolas-limare) wrote :

@Mickael : You were right, `yenta` and `hda` were sharing the same
IRQ. Now with `options snd-hda-intel enable_msi=1` I have

  20: 216 0 IO-APIC-fasteoi mmc0
  22: 0 0 IO-APIC-fasteoi yenta
  23: 2 0 IO-APIC-fasteoi uhci_hcd:usb1, ehci_hcd:usb5
 221: 1544 0 PCI-MSI-edge HDA Intel

and alsa doesn't die anymore when I remove my SD card. Thanks a lot,
great!

Note: I still get the `IRQ timing workaround...` line in
/var/log/messages, but it doesn't hurt now.

Ariel Faigon (ariel.faigon) wrote :

I would like to add information that may shed light on this.
I too started getting this warning in the log after the upgrade from hardy to intrepid

could it have something to do with changing the time on the system?

For example, if I run hwclock --systohc + adjtimexconfig, I see the warning after a few seconds in the log. Here's the sequence:

Feb 22 01:07:45 myhost sudo: username : TTY=pts/9 ; PWD=/home/username ; USER=root
; COMMAND=/sbin/hwclock --systohc
Feb 22 01:07:47 myhost sudo: username : TTY=pts/9 ; PWD=/home/username ; USER=root
; COMMAND=/usr/sbin/adjtimexconfig
Feb 22 01:07:58 myhost kernel: [439231.900129] hda-intel: IRQ timing workaround is
activated for card #0. Suggest a bigger bdl_pos_adj.

This makes me suspect that changing the hardware clock, causes the hda-intel driver to wrongly conclude that something might be wrong and activate the presumably inferior "IRQ timing workaround". A pity.

Mike Mol (mikemol) wrote :

I just noticed this in my dmesg as well:

[ 38.792010] ath0: no IPv6 routers present
[ 3001.069882] CE: hpet increasing min_delta_ns to 15000 nsec
[66541.465330] hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.

(Those three lines follow each other in the output of dmesg; Included for timing context.)

Current kernel is 2.6.27-11-generic, using linux-restricted-modules, as well as a build of madwifi (Since Ubuntu's build doesn't support my model of Atheros card.).

I've attached the output of lspci -vvnn and lsmod. I'm not experiencing any sound issues outside of Flash hitting a massive stutter problem after it's allowed to run long enough, but I don't think that's related, as it happens on another computer with completely different hardware.

arky (arky) wrote :

Same issue, audio is scratchy.

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: Conexant Digital [Conexant Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

$ uname -a
Linux dell-desktop 2.6.28-11-generic #39-Ubuntu SMP Thu Apr 2 03:00:35 UTC 2009 i686 GNU/Linux

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu jaunty (development branch)
Release: 9.04
Codename: jaunty

RJ Ryan (rryan) wrote :

I'd like to add some more information.

I sometimes get this message close to login on 8.10:

[ 1815.360302] canberra-gtk-pl[28014]: segfault at ae64790 ip b718884d sp b6725190 error 6 in libpulse.so.0.4.1[b7149000+4e000]
[ 1885.644970] hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.

This message does /not/ result in the impaired audio functionality I describe below. In other circumstances, the below occurs:

My hda-intel driver sometimes shares an interrupt with sata_nv, and when it does (after some time, maybe 4-5 hours of using the computer) I end up with one of my internal hard drives reporting many SATA error codes and bus read errors, and eventually the kernel unmounts the partition to save it from data loss. Any use of audio is severely impaired -- any app that plays audio hangs while looping the first bit of the audio. For example, `aplay /usr/share/sounds/question.wav' will result in aplay hanging, and the first half second of question.wav being played repeatedly.

Shutting down pulseaudio (pulseaudio --kill), and then removing/reloading the hda-intel driver (rmmod snd_hda_intel / modprobe snd_hda_intel) does not fix the problem.

Hope this helps -- feel free to ask for any more info.

Thanks,
RJ Ryan

Michael Marley (mamarley) wrote :

In order to fix/workaround your nv_sata problem, you might try enabling MSI like a recommended and demonstrated to nil a few posts up. This should fix the IRQ conflict.

Dave Gilbert (ubuntu-treblig) wrote :

Still seeing the IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.
in Karmic alpha 2.6.30-5 #6

Sean Seago (speedkreature) wrote :

Got this message on Jaunty Jackalope x86-64 on an AMD+ATI chipset workstation (Giga-byte board). Sound card reports as "Azalia" though which uses the snd_hda_intel module.

Error occurs very rarely; usually occurs after being up for about a day or two. Has not occurred when the system is idle, only while I'm using it, but it doesn't necessarily need any sound (whether music or sounds associated with events) to trigger it. I have disabled system sounds and not played any music and I still get it on occasion.

I've attached output from dmesg, lshw, and lspci so that perhaps someone can isolate a pattern. System up time is about 23 hours at this point.

Sean Seago (speedkreature) wrote :

Oops...didn't "sudo lspci -vvnn". New lspci -vvnn is attached.

I see a SATA interface on IRQ 16 with my sound card, but it doesn't seem to know what pin the sound card is on.

Jonathan Davies (jpds) wrote :

http://lkml.org/lkml/2008/9/13/112 has some information on what's happening:

"Basically it's a warning message that CPU usage got higher due to
somehow wrongly behaving hardware. The driver behavior itself didn't
do anything wrong. That is, if the driver didn't show it, you
wouldn't have noticed any change (or noticed improvements in some apps
:)"

Michalxo (michalxo) wrote :

Toshiba Satellite A200
Bug occurred too, seems like cure for
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
is adding these 2 lines
options snd-hda-intel model=toshiba
options snd-hda-intel enable_msi=1

I was using model=lenovo so far, from gutsy --> jaunty, today I had this bug and sound no longer worked.
Ubuntu 9.04

Dave Gilbert (ubuntu-treblig) wrote :

the enable_msi doesn't seem to make any odds for me.
The source has a note that the model=toshiba hack autodetect is disabled for my hardware (A100-306) since it breaks soemthing else.

I also tried with a customer 2.4.31-rc4 kernel with CONFIG_PREEMPT and that doesn't seem to be helping.

Dave

tdn (spam-thomasdamgaard) wrote :

I experience this problem in Kubuntu 9.04.

Vector (alexander-grim) wrote :

Lenovo Thinkpad - Fedora 10 - x86 - same problem.
System freezes when playing bzFlag, and that dmesg output was the only clue that i can find so far.

Vector (alexander-grim) wrote :

 2.6.27.29-170.2.78.fc10.x86 - sorry, forgot that; no edit option.

Vector (alexander-grim) wrote :

[^v^]# dmesg
...
CE: hpet increasing min_delta_ns to 15000 nsec
CE: hpet increasing min_delta_ns to 22500 nsec
CE: hpet increasing min_delta_ns to 33750 nsec
hda-intel: IRQ timing workaround is activated for card #1. Suggest a bigger bdl_pos_adj.
...

[^v^]# cat /proc/interrupts
           CPU0 CPU1
  0: 2993437 0 IO-APIC-edge timer
  1: 405 0 IO-APIC-edge i8042
  8: 25 0 IO-APIC-edge rtc0
  9: 624 4323 IO-APIC-fasteoi acpi
 12: 2419 324821 IO-APIC-edge i8042
 14: 21824 0 IO-APIC-edge ata_piix
 15: 41413 0 IO-APIC-edge ata_piix
 16: 164 3803239 IO-APIC-fasteoi uhci_hcd:usb2, radeon, yenta
 17: 608852 0 IO-APIC-fasteoi uhci_hcd:usb3, HDA Intel, iwl3945
 18: 0 0 IO-APIC-fasteoi uhci_hcd:usb4
 19: 4 0 IO-APIC-fasteoi ehci_hcd:usb1, uhci_hcd:usb5
NMI: 0 0 Non-maskable interrupts
LOC: 1670141 3165382 Local timer interrupts
RES: 346783 168802 Rescheduling interrupts
CAL: 7539 5713 function call interrupts
TLB: 150 218 TLB shootdowns
TRM: 0 0 Thermal event interrupts
SPU: 0 0 Spurious interrupts
ERR: 0
MIS: 0

Jasper Frumau (jfrumau) wrote :

I have the same issue on Jaunty Jackalop using the latest kernel:

hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.

uname -a
Linux me-laptop 2.6.28-15-generic #48-Ubuntu SMP Wed Jul 29 08:54:56 UTC 2009 i686 GNU/Linux

dmesg | grep hda
[ 17.865023] hda_codec: Unknown model for ALC268, trying auto-probe from BIOS...
[ 4705.999220] hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.

Jasper Frumau (jfrumau) wrote :

Oh and the sound issues I experience are Pidgin not making any sounds anymore. Rhytmhbox and Skype still function with sound. I have added my lspci using sudo.

Same problem in Kubuntu Karmic Beta - kernel 2.6.31-14-generic x86_64 GNU/Linux . No sounds in Pidgin. System Load Viewer shows CPU at 100% RAM at 38%. Karmic worked quite well using kernel 2.6.31-13-generic x86_64.

adding "enable_msi=1" to "options snd-hda-intel ..." in "/etc/modprobe.d/alsa-base.conf" fixed this for me

initial symptoms beyond the kernel messages were some failing audio applications (notably "jackd" reporting "ALSA: poll time out" and crashing with a flood of "broken pipe" messages in "qjackctl"), also noticed there were no "HDA Intel" interrupts (0 counts on both cpus) in "/proc/interrupts", with the fix applied there are lots of interrupts and sound works great (even "jackd").

$ uname -a
Linux zebimus 2.6.31-14-generic-pae #48-Ubuntu SMP Fri Oct 16 15:22:42 UTC 2009 i686 GNU/Linux

$ lspci -vvv | grep Audio -A 10
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
        Subsystem: Hewlett-Packard Company Device 306d
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin B routed to IRQ 32
        Region 0: Memory at db000000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel

$ tail -n 1 /etc/modprobe.d/alsa-base.conf # also featuring options to avoid probe weirdness on this hardware
options snd-hda-intel power_save=10 power_save_controller=N probe_mask=1 model=hp-dv5 enable_msi=1

mrtwister (mrtwister) wrote :

I am also affected by this bug. I'm afraid but Claude's solution didn't work for me.

David Robert Lewis (afrodeity) wrote :

afrodeity@afrodeity-desktop:~$ dmesg | grep -i hda
[ 28.004034] HDA Intel 0000:80:01.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 28.004087] HDA Intel 0000:80:01.0: setting latency timer to 64
[ 28.004091] HDA Intel 0000:80:01.0: PCI: Disallowing DAC for device
[ 28.116404] input: HDA Digital PCBeep as /devices/pci0000:80/0000:80:01.0/input/input6
[ 36.449268] hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.

afrodeity@afrodeity-desktop:~$ lspci -vvv | grep Audio -A 10
80:01.0 Audio device: VIA Technologies, Inc. VT1708/A [Azalia HDAC] (VIA High Definition Audio Controller) (rev 10)
 Subsystem: Biostar Microtech Int'l Corp Device 820f
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 64 bytes
 Interrupt: pin A routed to IRQ 17
 Region 0: Memory at bfffc000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: <access denied>
 Kernel driver in use: HDA Intel
 Kernel modules: snd-hda-intel

Balazs Oveges (ovegesb) wrote :

I get the same error in messages. My system is unstable, but I don't know if this bug is the reason. I attached the lspci-vvnn.log

Balazs Oveges (ovegesb) wrote :

I get the same error in messages under Karmic Koala. My system is unstable, but I don't know if this bug is the reason. I attached the lspci-vvnn.log

Locque (locque69) wrote :

I too am having the same issue. It was working fine for a while. Got home from work today and no sound... I've attached lspci.out with `cat /proc/interrupts` appended at the bottom...

Locque (locque69) wrote :

Update...

Went to System -> Preferences -> Sound -> Output Tab

Selected 'Internal Audio Analog Stereo' and got my sound back!

Don't know why it mysteriously stopped working the first time with 'RS780 Azalia' selected, but this has worked for me. I wouldn't consider this a 'fix' but perhaps a workaround....

Ubuntu 9.10 2.6.31-17-generic
0:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
01:05.1 Audio device: ATI Technologies Inc RS780 Azalia controller

valus (blaedhorn) wrote :

Exact same error as OP here. I'm using Ubuntu 10 (alpha 2).

valus (blaedhorn) wrote :

Forgot to attach the lspci output...

Same Problem. My sound doesn't work good, too. I get often the syslog entry:

pulseaudio[2295]: ratelimit.c: XXXX events suppressed

Comment #46 worked for me too. Thanks Locque.

This problem appeared out of nowhere on my laptop. I recently installed Webcamstudio and xawtv. I also recently plugged in a couple of different USB webcams: Logitech and Kensinton.

Perhaps the USB webcams triggered a problem, because I was using my third USB jack and "usb3" shares an IRQ with HDA Intel, my sound chip:

dereks@dereks-laptop:~$ cat /proc/interrupts | grep Intel
 21: 72781 0 IO-APIC-fasteoi uhci_hcd:usb3, HDA Intel

Maybe one of the udev scripts triggered a change for the default sound?

Andrew Hamblin (lextori) wrote :

I am experiencing similar problems with this error. My sound will work for a while and then begin to pop.

WillyWongi (pongi) wrote :

After last Kernel upgrade, sound plays for a while then turns into some click and pops and finally stops. My uname is "Linux 2.6.32-23-generic #37-Ubuntu SMP x86_64 GNU/Linux".

WillyWongi (pongi) wrote :

After last Kernel upgrade, sound plays for a while then turns into some click and pops and finally stops. My uname is "Linux 2.6.32-23-generic #37-Ubuntu SMP x86_64 GNU/Linux". Everything used to work flawlessly on a plain Ubuntu install.

Mark (m-breman) wrote :

I also encounter these messages in the log, just before my system hangs:

...
Oct 19 18:53:22 mcenter kernel: [23935.138879] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Oct 19 18:54:00 mcenter pulseaudio[1300]: ratelimit.c: 512 events suppressed
Oct 19 19:34:31 mcenter kernel: [26404.224972] hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.
Oct 19 19:35:08 mcenter pulseaudio[1300]: ratelimit.c: 14977 events suppressed
Oct 19 19:37:19 mcenter kernel: imklog 4.2.0, log source = /proc/kmsg started.
...

It looks like the problem started after I changed the snd-hda-intel model from auto to 6stack-dlg in /etc/modprobe.d/alsa-base.conf: #options snd-hda-intel model=auto
options snd-hda-intel model=6stack-dig

(The model = auto didn't work after a resume from sleep)

I'm not sure if it's also related to the recent kernel upgrade to 2.6.32-25-generic...

I have attached my lspci output.
I have

Mark (m-breman) wrote :

Follow-up to #54:
Well, it turned out that my system freeze was caused by a defective VIDEO card! Can you believe that?! I also don't have the "hda-intel: IRQ timing ..." message any more.

Jan Kaláb (pitel) wrote :

My girlfriend's desktop is affected by this bug too. She can't make Skype call probably because of this, since sound get completeley silent, and only rmmod and modropbe of hda-intel makes it work again.

This is back in the 2.6.37-rc series kernels ( tried natty 2.6.37-5-generic ) and vanila-git pull of 2.6.37-rc2.

Issue starts causing degredation of entire system once it occurs, certainly on my machine appears to be related to the nvidia graphics card HDMI output.

Will post to nvidia bugs.

natty kernel with 2.60.21 nvidia drivers during issue

whoops version typo; 260.19.21

KruyKaze (kruykaze) wrote :

My system crashes after this. it only happens on my laptop not the desktop.
Ubuntu 10.10 64bit
2.6.35-23-generic
ATI Technologies Inc M880G [Mobility Radeon HD 4200]
This setup works fine under 10.04 but crashes more than once daily with 10.10

totof1169 (bourgeotc) wrote :

same message on maverick 64bits
kernel 2.6.36 (to solve another bug with intermal mic)

graphic is intel

Changed in linux:
status: Invalid → Won't Fix
Changed in linux:
importance: Unknown → Medium
Nicolas Diogo (nicolasdiogo) wrote :

hi,

getting same message

hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.

using lenovo T410
- nvidia graphics NVS 3100N
- i5

ubuntu 10.10 x64

any suggestions

mlodya (mlodya) wrote :

same mesage in maverick 32 bits ; 2.6.35-28-generic
using Asus k50ie nvidia 310m cerelon dualcore t3300

DaneM (dmutters) wrote :

I'm getting this same message on 11.04 64-bit Desktop. My SATA hard drives are performing slowly and making the whole system slow down much more than they should when I do any hard-drive-intensive task, like copying large files. Could this be related to the error message? RJ Ryan mentioned that hda-intel can share an interrupt with sata_nv. I'm not using Nvidia SATA on this PC, but could hda-intel be having a conflict with my Intel SATA? lspci output is attached, and the error text below.

[ 16.483944] hda-intel: IRQ timing workaround is activated for card #1. Suggest a bigger bdl_pos_adj.
[ 16.613488] hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.

DaneM (dmutters) wrote :

Here is a more verbose lspci output (using lspci -vvv).

Simon Déziel (sdeziel) wrote :

I am also affected by this using Natty 64bit on a Lenovo laptop T410. My graphic card is an Intel one builtin the CPU (core i7).

drey (inhuman-irk) wrote :

I'm too experiencing problems with sound. It has terrific lags from time to time.
I've removed pulseaudio few days ago, but lags on sound are still here.
uname -r = 2.6.31-23-generic
Also have these rows @messages:
"CE: hpet increasing min_delta_ns to 15000 nsec"
I have an acer 7920G with radeon HD2400 videocard and fglrx drivers

This bug started @2008, today is 2011. Is there any fix?

Simon Déziel (sdeziel) wrote :

@drey

According to the your kernel version you are running Ubuntu Karmic. Could you try a more recent version and see if the problem still affects you ? FYI, Karmic is now out of support.

I've this bug on my lenovo x201i. After that message in dmesg, sound does not work. Natty x86
hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.

Bernie Innocenti (codewiz) wrote :

I've just seen this message on a Lenovo x201 running Natty with kernel 2.6.39-3-generic.

It appeared in my dmesg while I was writing a raw image to an SD card. Not sure if the two things are related, but there sure was a lot of I/O on a slow device.

DaneM (dmutters) wrote :

I've just determined that my Windows 7 hard drive (750GB, NTFS, /dev/sdb) was faulty. It had around 100 bad sectors reported in the SMART logs, according to the Disk Utility (System > Administration > Disk Utility [in Natty]), and I discovered that the huge amount of I/O wait occurred only when I was accessing this drive, especially for a long data transfer (copy/move, etc.). Notably, after the first few hundred MB at around 45MB/s, it slowed abruptly to a crawl of about 5MB/s via 3GB/s SATA. It seemed to make little difference whether I had it mounted read-only (which is faster for NTFS on Linux), or r/w, and was equally slow in Windows 7 and in Linux (Ubuntu Natty).

I've since replaced the drive with a new 1TB SATA HD after testing it for bad sectors (using 'sudo badblocks -svb 4096 /dev/sdx'), and have noticed a dramatic speed increase. I've not yet checked whether the dmesg logs report this same error message as before, but I'll check when I get around to it.

So, here's my request for information from those experiencing this bug:

-Please ensure that SMART monitoring is enabled for all your drives, in BIOS.

-Open System > Administration > Disk Utility. Click on each of your drives, in turn, and click on the button for its SMART status. Please copy and paste any error entries you see, as well as anything that stands out to you.

-Please run the following command on each of your hard drives. You can do this on multiple drives at once, although I recommend not running many more instances than you have CPU cores. It's OK (and safe) to run this on mounted drives, even while data is being written to them. 'sudo badblocks -svb 4096 /dev/sdx' (Replace "sdx" with the device name for the hard drive you intend to test. Use only one drive per command, and DO NOT include the partition number--i.e. type "/dev/sda", and NOT "/dev/sda1".) Post all output from these commands to this thread. If any bad sectors at all are found--which will be noted by their block number--then your drive is bad, and should be replaced. This can usually be done under warranty, via the manufacturer's (Seagate, Western Digital, etc.--not Best Buy or similar). Badblocks will take a VERY long time to run, especially on a broken drive, so please be patient and continue until the end, or until you find a bad sector.

-Finally, run this command to get some verification and more information from SMART: 'sudo smartctl --log error /dev/sdx'. Replace sdx with your drive's /dev/ entry.

Please post all output from the above. I'm not a developer, but I have a whole lot of experience in dealing with the practical application of hardware testing and business-level computer repair. If my hunch is correct, this will allow you do solve your problems related to this bug once and for all! I'm honestly not sure how the sound driver relates to the performance problems or the hard drive failure I had, but given the excessive I/O wait that slowed down all 4 of my 2.66GHz CPU cores, it wouldn't surprise me if it's causing timeouts or other problems that the sound driver is sensitive to.

Good luck, and I look forward to reading your responses!

--Dane

DaneM (dmutters) wrote :

Notable correction: I should have written 3Gbit/s SATA, not 3GB/s. This amounts to a maximum transfer rate of around 45MB/s.

Correction to the information request above: please run badblocks BEFORE any of the other steps, including looking in Disk Utility or running smarctl. (You may have to install smartmontools [spelling?] to have that command available when the time comes.) If you run badblocks first, it will ensure that all sector replacements made from reserved blocks to compensate for read errors during the badblocks test (which reads every block on the drive) will get logged, and thereby provide a more accurate picture of whether bad sectors exist, but have been replaced and hidden/disabled by SMART. This is especially relevant if SMART wasn't already enabled in BIOS, as it will need an opportunity to start gathering data for the log that you will be checking later via Disk Utility and smartctl.

Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Confirmed
DaneM (dmutters) wrote :

(Sorry for the wait...)

I can now confirm that the error message:

[ 31.958964] hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.

is still appearing in my 'dmesg | grep hda-intel' output, as of this moment. I'm not experiencing any further problems with massive IO wait, regarding my hard drives, but the system is still a bit sluggish, compared to my Windows 7 installation on the same PC (but on a different drive). I intend to run another badblocks test on my Linux system drive (500GB SATA) to make sure that it's not having problems, but last I checked, it was fine.

DaneM (dmutters) wrote :

I should also note that I'm using Nvidia drivers 180.13 with a GeForce 9800 GTX, or GTX 560 Ti (when the latter is working--in process of RMA). Some previous posters have mentioned a possible link to the video card and its drivers.

I'm currently doing a badblocks on my Linux drive, but in Disk Utility, there's something I thought I should mention, which I don't entirely understand:

5. Reallocation Sector Count: Good - Normalized: 200; Worst: 200; Threshold: 140; Value: 0 sectors.

Does this mean that no sectors currently in use are bad, but 200 have been reallocated; or that the 200 number is some kind of setting for when to worry, and there have been no such incidents? I don't know whether this could relate to this bug, but if it does, it would be good to know what I'm looking at.

Thanks, all, for your interest in this bug.

DaneM (dmutters) wrote :

0 bad blocks found on my Linux drive.

John Wendell, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command in the development release from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please do not test the kernel in the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. As well, please comment on which kernel version specifically you tested.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream', and comment as to why specifically you were unable to test it.

Please let us know your results. Thanks in advance.

no longer affects: nvidia-graphics-drivers (Ubuntu)
Changed in fglrx:
status: New → Invalid
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-upstream-testing
Douglas (douglas-pearless) wrote :
Download full text (16.9 KiB)

I am also having this issue running linux-image-3.0.0-21-generic.

I note that I am using a SSD not a hard disk, dmesg gives me (Note: the CIFS errors are because I try to mount a NAS box before the network is fully up but mount points are just fine a few moments later):

[ 0.957613] registered taskstats version 1
[ 0.976891] Magic number: 4:638:75
[ 0.976997] rtc_cmos 00:03: setting system clock to 2012-07-26 11:05:02 UTC (1343300702)
[ 0.977838] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[ 0.977840] EDD information not available.
[ 0.988176] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input2
[ 1.242567] ata3: SATA link down (SStatus 0 SControl 300)
[ 1.253118] ata4: SATA link down (SStatus 0 SControl 300)
[ 1.416056] Refined TSC clocksource calibration: 2925.999 MHz.
[ 1.416063] Switching to clocksource tsc
[ 1.570663] ata2.00: SATA link down (SStatus 0 SControl 300)
[ 1.570674] ata2.01: SATA link down (SStatus 0 SControl 300)
[ 1.632019] usb 7-2: new full speed USB device number 2 using uhci_hcd
[ 1.716069] ata1.00: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[ 1.716081] ata1.01: SATA link down (SStatus 0 SControl 300)
[ 1.740534] ata1.00: ATA-8: OCZ-AGILITY3, 2.15, max UDMA/133
[ 1.740538] ata1.00: 175836528 sectors, multi 16: LBA48 NCQ (depth 0/32)
[ 1.772496] ata1.00: configured for UDMA/133
[ 1.772671] scsi 0:0:0:0: Direct-Access ATA OCZ-AGILITY3 2.15 PQ: 0 ANSI: 5
[ 1.772792] sd 0:0:0:0: [sda] 175836528 512-byte logical blocks: (90.0 GB/83.8 GiB)
[ 1.772837] sd 0:0:0:0: Attached scsi generic sg0 type 0
[ 1.772846] sd 0:0:0:0: [sda] Write Protect is off
[ 1.772848] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
[ 1.772866] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[ 1.773542] sda: sda1 sda2 < sda5 >
[ 1.773799] sd 0:0:0:0: [sda] Attached SCSI disk
[ 1.773882] Freeing unused kernel memory: 724k freed
[ 1.774100] Write protecting the kernel text: 5536k
[ 1.774174] Write protecting the kernel read-only data: 2244k
[ 1.774180] NX-protecting the kernel data: 4704k
[ 1.789468] udevd[98]: starting version 173
[ 1.810310] ATL1E 0000:02:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 1.810325] ATL1E 0000:02:00.0: setting latency timer to 64
[ 1.813748] pata_marvell 0000:03:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 1.813783] pata_marvell 0000:03:00.0: setting latency timer to 64
[ 1.816376] scsi4 : pata_marvell
[ 1.817511] scsi5 : pata_marvell
[ 1.817573] ata5: PATA max UDMA/100 cmd 0xec00 ctl 0xe880 bmdma 0xe400 irq 16
[ 1.817575] ata6: DUMMY
[ 1.980383] ata5.00: ATAPI: HL-DT-ST DVDRAM GSA-H12N, UL01, max UDMA/66
[ 1.996366] ata5.00: configured for UDMA/66
[ 2.005158] scsi 4:0:0:0: CD-ROM HL-DT-ST DVDRAM GSA-H12N UL01 PQ: 0 ANSI: 5
[ 2.011204] sr0: scsi3-mmc drive: 48x/48x writer dvd-ram cd/rw xa/form2 cdda tray
[ 2.011208] cdrom: Uniform CD-ROM driver Revision: 3.20
[ 2.011398] sr 4:0:0:0: Attached scsi CD-ROM sr0
[ 2.011459] sr 4:0:0:0: Attached scsi generic sg1 type 5
[ 3.21408...

msth67 (msth67) wrote :

I'm using the kernel 3.0.0-20-generic #34 on LUCID and I 've found this bug after searching for the following message :

 ubuntu-desktop kernel: [ 22.983587] hda-intel: IRQ timing workaround is activated for card #1. Suggest a bigger bdl_pos_adj.

that I've noticed after being forced to shut down the system as the display wasn't coming up again after being switched off according to my power management preferences,all this after the system had already been successfully resumed once from sleep state S3 according to the log.

I had "hda-intel: IRQ timing workaround is activated for card #1. Suggest a bigger bdl_pos_adj." in my dmesg.

So I knew had to increase "bdl_pos_adj" for my second sound card (Nvidia HDMI).

Added:

options snd-hda-intel enable_msi=1 bdl_pos_adj=1,48

to my /etc/modprobe.d/alsa-base.conf

After this tweak, both the warning message and the terrible crackling sound are gone.

Douglas / msth67 / Cleber Casali, if you have a bug in Ubuntu, the Ubuntu Audio Developer team, Ubuntu Kernel team, Ubuntu Bug Control team, and Ubuntu Bug Squad all would like you to please file a new report by executing the following in a terminal:
ubuntu-bug sound

For more on this, please see the Ubuntu Audio Developer team article:
https://wiki.ubuntu.com/DebuggingSoundProblems

the Ubuntu Kernel team article:
https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports

the Ubuntu Bug Control team and Ubuntu Bug Squad team article:
https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue

and Ubuntu Community article:
https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report would delay your problem being addressed as quickly as possible.

Thank you for your understanding.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.