webcams stop working with 2.6.27

Bug #267522 reported by Alexander Butenko on 2008-09-07
58
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Unknown
Release Notes for Ubuntu
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned
Intrepid
Undecided
Unassigned

Bug Description

camera #1

$ lsusb
Bus 004 Device 004: ID 093a:2468 Pixart Imaging, Inc. Cammaestro 2.5DU/X-EYE/Orite SC-120/ICGear TravelCam/Easy Snap Snake Eye WebCam

camera #2
$ lsusb
Bus 004 Device 005: ID 046d:092e Logitech, Inc. QuickCam Chat

cut from dmesg:
[ 4109.657126] gspca: disconnect complete
[ 5484.312502] usb 4-2: new full speed USB device using uhci_hcd and address 4
[ 5484.546381] usb 4-2: configuration #1 chosen from 1 choice
[ 5484.550435] gspca: probing 093a:2468
[ 5484.553159] pac207: Pixart Sensor ID 0x27 Chips ID 0x00
[ 5484.576212] pac207: Pixart PAC207BCA Image Processor and Control Chip detected (vid/pid 0x093A:0x2468)
[ 5484.578368] gspca: probe ok
[ 5608.072095] usb 4-2: USB disconnect, address 4
[ 5608.074346] gspca: disconnect complete
[ 5637.684098] usb 4-2: new full speed USB device using uhci_hcd and address 5
[ 5637.883346] usb 4-2: configuration #1 chosen from 1 choice
[ 5638.031172] gspca: probing 046d:092e
[ 5638.037229] gspca: probe ok
[ 5638.037948] usbcore: registered new interface driver spca561
[ 5638.039163] spca561: registered
[ 5748.193070] usb 4-2: USB disconnect, address 5
[ 5748.194535] gspca: disconnect complete

avb@ds:~$ ls -l /dev/video0
crw-rw----+ 1 root video 81, 0 2008-09-07 14:29 /dev/video0
avb@ds:~$ id
uid=1000(avb) gid=1000(avb) groups=4(adm),20(dialout),24(cdrom),25(floppy),29(audio),30(dip),44(video),46(plugdev),102(netdev),105(scanner),107(fuse),109(lpadmin),116(powerdev),118(admin),1000(avb)

Im using Ubuntu Intrepid Ibex with all latest updates up to today.

both cameras was working perfect with 2.6.26-5-generic kernel. After the upgrade to 2.6.27-2-generic both are not working now. Cameras was testing in cheese, skype and ekiga applications.

Alexander Butenko (avb) wrote :

sorry, seems i found a bug upstream http://bugzilla.kernel.org/show_bug.cgi?id=11400

Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report. Confirmed

Changed in linux:
assignee: nobody → ubuntu-kernel-team
status: New → Confirmed
Changed in linux:
status: Unknown → Confirmed
Stéphane Marguet (stemp) wrote :

My bug seems to be related to the lack of libv4l package in Ubuntu/Debian.

From gspcav2 creator homepage (http://moinejf.free.fr/gspca_README.txt)

V4L library

 Most applications don't know how to decode the raw frames generated
 by the driver, and also, many of them do not speak the V4L2
 interface. To make them work, you need the V4L application
 library found at:

  http://linuxtv.org/hg/~hgoede/v4l-dvb

 To generate:
  cd v4l2-apps/lib/libv4l/
  make
  make install
  (the installation is done under /usr/local)

 To use it:
  export LD_LIBRARY=/usr/local/lib/
  LD_PRELOAD=/usr/local/lib/libv4l/v4l1compat.so <application>

camorama still doesn't work, but cheese, ekiga and aMsn are working.

Stéphane Marguet (stemp) wrote :

Just uploaded, for testing, Gregor Jasny Package libv4l from Debian (He need a sponsor) into my PPA for Intrepid.

https://edge.launchpad.net/~stemp/+archive

Then you need to call camorama and cheese using :

LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so <application>

Alexander Butenko (avb) wrote :

cheese is working but skype dont see camera with both cameras. Also quallity of the image is horrible like it was with 2.6.24. With 2.6.26 driver pictures was way better on both of the cameras. I feel that will be fixed.

Stéphane Marguet (stemp) wrote :

There is more than one issue in this bug.
As far as I know, the new gspca drivers are v4l2 drivers.
We need libv4l package for compatibility with v4l (eg to use camorama).
For avb there is a quality problem (probably related to the driver).
And there is some v4l2 incompatibilites.
I can use v4l2 with mplayer :
mplayer -fps 15 tv:// -tv driver=v4l2:device=/dev/video1

But gstreamer-properties don't want to use Video for Linux 2 as Video Default Input :
Video for Linux 2 (v4l2): Could not negotiate format
(gstreamer-properties:29563): GStreamer-WARNING **: pad v4l2src3:src returned caps which are not a real subset of its template caps
gstreamer-properties-Message: Error running pipeline 'Video for Linux 2 (v4l2)': Could not negotiate format [gstbasesrc.c(2436): gst_base_src_start (): /pipeline0/v4l2src3:
Check your filtered caps, if any]

Stéphane Marguet (stemp) wrote :

Fedora have a very good page about gspcav2 and libv4l :
http://fedoraproject.org/wiki/Features/BetterWebcamSupport

Richard Rickwood (rickwookie) wrote :

I can't get camorama to work with this method:
   LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so camorama

but cheese seems to work with:
   LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so cheese

I agree, the picture quality is very bad.

Alexander Butenko (avb) wrote :

with 2.6.27-4-generic picture quallity is back in both mine cams. Now feel, that its time to place a bug for each software in order to use libv4l library for opening cameras or out-of-the-box v4l support

Changed in linux:
status: Confirmed → In Progress
Changed in linux:
status: In Progress → Fix Released
lupux (lupux-lupux) wrote :

my webcam's "Logitec 046d:08da" and "Labtec 046d:08a2" also do not work with 2.6.27-4 too, but very well in Hardy!

FYI: My webcam (ID 046d:08ce Logitech, Inc. QuickCam Pro 5000) works. It's even more stable compared to hardy when using Skype (less crashes).

Dee Bulante (dbulante) wrote :

I have the same problem. After the upgrade, I couldn't get my Logitech Quickcam to work on skype, cheese, and camorama.

lupux (lupux-lupux) wrote :

With the hotfix https://edge.launchpad.net/~stemp/+archive my cam Logitec(046d:08da) works well, the other cam Labtec(046d:08a2) too, but there is a permanent report in terminal: "libv4lconvert: Error decompressing JPEG: unknown huffman code: 0000ffff"

Riccardo 'c10ud' (c10ud) wrote :

$ lsusb
Bus 002 Device 004: ID 093a:2468 Pixart Imaging, Inc. Cammaestro 2.5DU/X-EYE/Orite SC-120/ICGear TravelCam/Easy Snap Snake Eye WebCam

this webcam worked out of the box in hardy in every application, now since i upgraded to intrepid (and even with latest updates) it's not working anymore - i didn't try the proposed fixes anyway.

Riccardo 'c10ud' (c10ud) wrote :

with latest kernel upgrade and preload "hack" webcam works (with some occasional framedrops gspca: frame overflow 102830 > 102400 ), without the preload hack i get a green..nothing (and errors in dmesg gspca: usb_submit_urb [0] err -28) :)

Brian Murray (brian-murray) wrote :

With regards to the packaging of lib4l for Ubuntu, you might be interested in following bug 260918 which is a packaging request for it.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Graham (ubuntu-grahams) wrote :

Broken link

https://wiki.ubuntu.com/KernelTeamBugPolicies:

" * KernelTeamBugPolicies

This page does not exist yet. You can create a new empty page, or use one of the page templates."

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.