wireless (atheros) doesn't work after suspend

Bug #267339 reported by Kieran Fleming on 2008-09-07
This bug report is a duplicate of:  Bug #275692: ath_pci must be reloaded after resume. Edit Remove
58
This bug affects 7 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

I am using a Fujitsu U1010 laptop. When using the 2.6.25-5 kernel, suspend and hibernate work fine, but in 2.6.27-1 and 2.6.27-2, after the system is resumed the wireless stops working and can't connect to anything until the system is restarted.
Curiously, running 'sudo s2both' works fine, it's just suspending through the GUI that's the problem. Please tell me if there's anything more I can add.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.10
NonfreeKernelModules: ath_hal
Package: linux-image-2.6.27-2-generic 2.6.27-2.3 [modified: lib/modules/2.6.27-2-generic/modules.pcimap lib/modules/2.6.27-2-generic/modules.dep lib/modules/2.6.27-2-generic/modules.ieee1394map lib/modules/2.6.27-2-generic/modules.usbmap lib/modules/2.6.27-2-generic/modules.isapnpmap lib/modules/2.6.27-2-generic/modules.seriomap lib/modules/2.6.27-2-generic/modules.alias lib/modules/2.6.27-2-generic/modules.symbols]
ProcCmdLine: root=UUID=98a08632-4c28-4141-a919-3e6c7009feff ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_AU.UTF-8
ProcVersionSignature: Ubuntu 2.6.27-2.3-generic
SourcePackage: linux

Kieran Fleming (kieran-fleming) wrote :

Hi Kieran,

Can you attach your dmesg output after a suspend/resume cycle? Thanks.

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged
Kieran Fleming (kieran-fleming) wrote :

dmesg attached.

Kieran Fleming (kieran-fleming) wrote :

This dmesg is after using 's2both' to hibernate. As you can see, I don't get the 'link is not ready' error.

plomlund (jonas-iki) wrote :

The atheros wireless does not come back to life after a suspend on my ThinkPad T42 running 2.6.27-7-generic on the latest (as of today) Intrepid beta. However, running "modprobe -r ath_pci; modprobe ath_pci" brings it back to life. Irritating, but not critical.

vwr0527 (vwr0527) wrote :

Same problem on my Thinkpad T61, running Intrepid Ibex
Linux ignignokt 2.6.27-7-generic #1 SMP Thu Oct 30 04:18:38 UTC 2008 i686 GNU/Linux
dmesg was produced while I was hooked up to my router via ethernet cable after a suspend/resume

vwr0527 (vwr0527) wrote :

Strangely, I can see all the wireless networks around me, I just can't connect to any of them.
It will ask for the password, try to connect, then ask for it again. Networks without passwords will not connect.
Of course all this works perfectly after rebooting. And breaks after suspend/resuming

Ken Phillis Jr (kphillisjr) wrote :

I also confirm this bug, however i do have a quick notes about this on reproduction...

1) start computer and connect to wireless network.
2) place computer in suspend.
3) resume computer about a minute later.
4) wait about 5 minutes ( depends on how long it takes for you system to wake up from suspend. )
5) check wireless... it won't work properly, and will cache the last seen access points, but not
let one connect to them.
6) run the command...
sudo rmmod ath_pci && sudo modprobe ath_pci
7) enjoy working wifi again.

also note that i am attaching my dmesg log which shows that i repeated this step multiple times, and
confirmed that it works.

Trampas (trampas) wrote :

I can confirm this bug on T61p x64 8.10

Trampas (trampas) wrote :

I added the following to /usr/lib/pm-utils/sleep.d/10NetworkManager which seems to have fixed the issue

case "$1" in
 hibernate|suspend)
  suspend_nm
  ;;
 thaw|resume)
  rmmod ath_pci
  modprobe ath_pci
  resume_nm
  ;;
 *) exit $NA
  ;;
esac

It is a complete hack but at least it fixes the issue.

Trampas

Trampas (trampas) wrote :

I still have a problem with networkmanager and 8.10. That is for the wireless when I resume or even reboot it asks for the WEP password several times. Does anyone know a method to fix this? But at least now I can connect to the wireless after sleeping...

Thanks
Trampas

Gergo Lippai (lipilee) wrote :

I'm having this problem too, with an Acer laptop (irrelevant) and this Atheros chip:

  06:05.0 Ethernet controller: Atheros Communications Inc. AR2413 802.11bg NIC (rev 01)

rmmodding and modprobing helps though, so all I'm waiting for is to have Trampas' solution in an official update :)

Dan McGuirk (incandenza) wrote :

An alternative to Trampas's fix is to create a file called /etc/pm/config.d/madwifi-fix (exact filename doesn't matter), with the following contents:

SUSPEND_MODULES="$SUSPEND_MODULES ath_pci"

pm-utils already provides you with this SUSPEND_MODULES variable, to deal with exactly this kind of thing, I suppose.

Brian Harkness (maestro-bwh) wrote :

Re: atheros 5001x+ card (ar5211/5112)

This worked for me for a while as resume from suspend/hibernate was my only issue and I fixed that a while ago... but I am embarrassed to say I finally put the original Broadcom card back in, I finally got tired of all the Atheros tweaking with Intrepid. The last upgrade or two rendered my Atheros card "useless."

Knowing that since Hardy, Ubuntu has had issues ndiswrapper I used the Hardware Manager with the Broadcom (Jockey-kde installing firmware with fw-cutter): It just works. Curious.

After 2 years of enjoying out of the box Atheros performance in which any update/upgrade would leave it working this is my solution.

I have used Ubuntu since Dapper, so I know most of the tricks mere mortals (blacklisting ath5k, hand compiling madwifi and installing it again) would use and none of them worked to get the Atheros card working. It works with a live CD of Intrepid Beta...

Martin Backhaus (salemaleikum) wrote :

I have the same problem:
After a suspend of my Laptop I am not able to find any Wireless Lan Hotspots. The hotspot-list of the network manager is empty. Deactivating an activating the boxes "Enable Wireless" and "Enable Networking" is useless.

sudo /etc/init.d/networking restart
or
sudo /etc/init.d/NetworkManager restart
do not work, too.

Laptop:
https://wiki.ubuntu.com/LaptopTestingTeam/FujitsuAmiloPA1510

Ubuntu 8.10 Intrepid Ibex
Kernel: 2.6.27-7-generic
NetworkManager Applet 0.7.0

Wireless Lan Ethernet controller:
05:03.0 Ethernet controller: Atheros Communications Inc. AR2413 802.11bg NIC (rev 01)
The proprietary driver is used.

I will post DMESG output soon.

Martin Backhaus (salemaleikum) wrote :

Here is the DMESG output after a suspend.

After a while I typed in:
sudo rmmod ath_pci && sudo modprobe ath_pci

and the connection was established.

Thomas Schewe (thosch66) wrote :

@Martin

You are doing manually what Dan McGuirk is doing automatically via his /etc/pm/config.d/madwifi-fix.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

ptn (tn-pablo) wrote :

I can confirm that Dan McGuirk's solution works, but for me it was:

SUSPEND_MODULES="$SUSPEND_MODULES ath9k"

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers