Buffer I/O error on device sr0 Logical Block XXXXXX in Intrepid Ibex Alpha 5

Bug #266951 reported by Marlon Cisternas Milla on 2008-09-05
120
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Fedora
Invalid
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned
Nominated for Intrepid by yossarian_uk
Nominated for Jaunty by yossarian_uk

Bug Description

Hello everyone.

When I run Intrepid Ibex Alpha 5 in my Compaq Presario C708LA the system operative not start. I don't have logs because the system repeat the same mistake.

I attached photos of the error and I don't know with precision the affected package. If we need more information about my system, please don't forget notifying me.

Thanks in advance.
--

This also affects the 8.10 release.

Hi Marlon,

Just curios if you know if this issue existed with previous Alpha releases? The reason I ask is that Alpha4 contained a 2.6.26 based kernel and Alpha5 contains a 2.6.27 based kernel. I'd be interested in knowing if this is a specific regression from 2.6.26 or not.

Hi Leann

Thank you for your interest for this bug. I can confirm that this bug does not happen at alpha 4 with the kernel 2.6.26. I used smooth alpha 4 a month ago and I had no problems.

Thanks again!.

Chris Coulson (chrisccoulson) wrote :

Marlon,

This could very well be a problem with the CD that you have burnt. Could you please try to reburn the ISO on a new disc at a slower speed.

Thanks

Changed in linux:
status: New → Incomplete
Roman Semenov (rsemenov) wrote :

Hi,

I am experiencing the same issue, tried with Ubuntu 8.10 Alpha 5 (md5s are ok) and daily image from 12 September.
Getting the same error on IBM T60, old whitebox P3 and IBM ThinkCenter. However runs fine on VmWare.
tried "all_generic_ide, noapic, nolapic, irqpoll" kernel parameters - wont help.

Thanks

I see the same bug during clean install not only of Intrepid Ibex Alpha 5 on my T40, but also with the latest Hardy Heron 8.04.1 ISO-image !

Stefan

Ok let's see... Yesterday I used alpha 6 of Intrepid Ibex and the problem does not exist. The system was started perfectly and I don't have problem with nothing.

Thanks in advance.

Leszek Lesner (leszek-lesner) wrote :

I am experiencing the same problem with alpha 6 of Intrepid Ibex.
I didn't experience this problems with alpha 4.I reburned the ISO several time with several speeds (even 1x).
Finally I checked the md5sum and everything seems to be ok.
Vmware works also.

reh4c (gene-hoffler) wrote :

I have received the below error message during boot up for all Intrepid alpha releases thus far (1-6):
"Buffer I/O error on device sr0, logical block 178568
 end_request: I/O error on device sr0, sector 1428544"
System just hangs at this point. I've switched hard drives (SATA) and burned the install image several times on both Linux and Windows. Also, alternate CD installation fails also at "Select and Install Software" modules. I'm stuck!

Hardy 8.04.1 won't boot past the language/splash screen either...I get kicked out into a busybox prompt.

I built this computer one month ago to make the switch from Windows to Ubuntu, but no luck so far.

reh4c (gene-hoffler) wrote :

Intrepid x86_64 beta boots up without getting the previous identified error. Finally, I can get into the live desktop with getting kicked out into a busybox prompt. I'll continue to monitor and check the RC when it arrives.

Chris Coulson (chrisccoulson) wrote :

As two people (including the original reporter) have stated that this bug appears to be resolved for them, I'm going to mark this as fixed.

Thanks

Changed in linux:
status: Incomplete → Fix Released
tej (bewith-tej) wrote :

Hi Cris

I have upgraded 8.10 beta from 8.04
http://www.ubuntu.com/testing/intrepid/beta

i am still getting these errors, but my machine boots fine.. but these errors are really ugly. i didn't experience any problem yet although. dmesg attached

thanks
-tej

I just started getting this message in Intrepid after updates today. I attached my dmesg output.

I am also getting this on 8.10 Live CD (release version). I have used 2 separate drives (an old 6x Sony CD drive, and a Samsung DVD/CD-RW). I have attempted to burn the live CD using various speeds (using a debian box to burn) but nothing has changed. Also fiddling with the PIO and DMA settings in the BIOS as failed to solve the problem.

An interesting thing I noticed however is I get the same errors just inserting a the ubuntu CD while my system is running Ubuntu off the harddrive (this was a 8.04 install that was upgraded to 8.10 sometime in the alpha period). I also get a DBUS error too (see attachment). The CD does eventually get mounted, but it takes a while.

From dmesg after insertion:
[ 334.700552] sr 3:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
[ 334.700564] sr 3:0:0:0: [sr0] Sense Key : Medium Error [current]
[ 334.700570] Info fld=0x0
[ 334.700572] sr 3:0:0:0: [sr0] Add. Sense: L-EC uncorrectable error
[ 334.700577] end_request: I/O error, dev sr0, sector 1431184
[ 334.700585] Buffer I/O error on device sr0, logical block 178898
<repeated 9 times, then...>
[ 384.326780] UDF-fs: No VRS found
[ 384.373349] ISO 9660 Extensions: Microsoft Joliet Level 3
[ 384.429337] ISO 9660 Extensions: RRIP_1991A

also I'm running the i386 version (I have a pre-64-bit pentium 4).

Rob Hubble (rob-hubble) wrote :
Download full text (3.8 KiB)

I'm having the same issue with trying to play DVDs. The drive worked perfectly about a week or two ago. (I don't use my DVD drive very often, so I am uncertain whether this problem occurred before or after updating to 8.10 RC.)

Relevant dmesg:

[38779.018260] end_request: I/O error, dev sr0, sector 15525888
[38779.018267] Buffer I/O error on device sr0, logical block 3881472
[38779.019766] end_request: I/O error, dev sr0, sector 15525892
[38779.019771] Buffer I/O error on device sr0, logical block 3881473
[38779.021129] end_request: I/O error, dev sr0, sector 15525888
[38779.021132] Buffer I/O error on device sr0, logical block 3881472
[38779.022523] end_request: I/O error, dev sr0, sector 15525892
[38779.022528] Buffer I/O error on device sr0, logical block 3881473
[38779.024093] end_request: I/O error, dev sr0, sector 15526096
[38779.024098] Buffer I/O error on device sr0, logical block 3881524
[38779.025495] end_request: I/O error, dev sr0, sector 15526100
[38779.025501] Buffer I/O error on device sr0, logical block 3881525
[38779.026971] end_request: I/O error, dev sr0, sector 15526096
[38779.026975] Buffer I/O error on device sr0, logical block 3881524
[38779.028535] end_request: I/O error, dev sr0, sector 15526100
[38779.028540] Buffer I/O error on device sr0, logical block 3881525
[38779.029939] end_request: I/O error, dev sr0, sector 15526112
[38779.029943] Buffer I/O error on device sr0, logical block 3881528
[38779.031341] end_request: I/O error, dev sr0, sector 15526112
[38779.031347] Buffer I/O error on device sr0, logical block 3881528
[38779.033018] end_request: I/O error, dev sr0, sector 15526112
[38779.034738] end_request: I/O error, dev sr0, sector 15526112
[38779.036216] end_request: I/O error, dev sr0, sector 15526112
[38779.037612] end_request: I/O error, dev sr0, sector 15526112
[38779.039017] end_request: I/O error, dev sr0, sector 15526112
[38779.040996] end_request: I/O error, dev sr0, sector 15526048
[38779.043579] end_request: I/O error, dev sr0, sector 15526052
[38779.045640] end_request: I/O error, dev sr0, sector 15526104
[38779.047043] end_request: I/O error, dev sr0, sector 15526108
[38779.048436] end_request: I/O error, dev sr0, sector 15526112
[38779.049822] end_request: I/O error, dev sr0, sector 15526112
[38779.409048] UDF-fs: Partition marked readonly; forcing readonly mount
[38779.498585] UDF-fs INFO UDF: Mounting volume 'KILLBILL_VOL1', timestamp 2004/03/01 20:51 (1ed4)
[38803.019171] end_request: I/O error, dev sr0, sector 522556
[38803.019179] __ratelimit: 11 callbacks suppressed
[38803.019182] Buffer I/O error on device sr0, logical block 130639
[38803.019188] Buffer I/O error on device sr0, logical block 130640
[38803.019191] Buffer I/O error on device sr0, logical block 130641
[38803.019193] Buffer I/O error on device sr0, logical block 130642
[38803.019195] Buffer I/O error on device sr0, logical block 130643
[38803.019198] Buffer I/O error on device sr0, logical block 130644
[38803.019202] Buffer I/O error on device sr0, logical block 130645
[38803.019205] Buffer I/O error on device sr0, logical block 130646
[38803.019208] Buffer I/O error on device sr0, logical block 130647
[38803.019211] Buffer ...

Read more...

Peter (darkcentrino) wrote :

Hi,
i have this error, too.
I used Ubuntu 8.10 and tryed it on 32bit, 64bit, 32bit alternative, 64bit alternative.
I have a SATA Samsung DVD Drive.
thanks
peter

linuxduke (cspechetty) wrote :

Hi,
I am also getting the same errors. I just purchased a dell inspirion 1525 and trying to install Ubuntu 8.10.
Please provide a workaround.

Thanks
Chander

linuxduke (cspechetty) wrote :

Problem solved using SonicRecordNow Software for writing CD(probably uses a slower speed to copy the image). Ubuntu rocks !!!!
I used the ISORecorder by downloading it from the links on ubuntu site and used the default speed settings (48 somthing).
Since there was a problem with slower speed on ISO, i just used my already available SonicRecordNow on my XP to do the job.

Peter (darkcentrino) wrote :

Hi,
i using nero 7 on Windows und i burned the iso not on a CD, but on a DVD.
Now the problem didn't come again!
Thanks

whocarez (whocarez1) wrote :

I'm experiencing the same kind of errors while trying to install Ubuntu 8.10 release. I have tried both i386 and amd64. The issue occurs during boot from the cd, and no matter what I do I get a medium error with error messages exactly as those draimus listed. I have tried differend media, different burning speed, it doesn't help. Media always burns fine, and I have no problems mounting the burnt cd-media in 8.04 and copying all the content. It's during boot that the problem arises, and it's always the same sector that's listed.

I have two different Samsung drives, the one that gives med the error is SH-S203P. Tried burning a cdr i the SH-S183A, and then booting in the second one, same error same sector. I'm probably going to try a dvd-r this time, and check what happens. I find it very strange. My motherboard is Asus Formula Rampage with the X48 chipset, if it matters. Both DVD burners are SATA.

TSSTcorp' 'CD/DVDW SH-S183A' 'SB02' Removable CD-ROM
TSSTcorp' 'CDDVDW SH-S203P ' 'SB01' Removable CD-ROM

whocarez (whocarez1) on 2008-11-10
Changed in linux:
status: Fix Released → New
whocarez (whocarez1) wrote :

I just rebooted the computer with the Samsung SH-S183A drive, and it gives me the same medium error with the same sectors. This computer has another Asus motherboard, althoug it's Asus M2N-SLI Deluxe, so it's entirely different. Yes, this happens on different cdr-media. I find it higly unlikely that both drives are defective and that 8 cd's fail.

The error is more or less like this:
sr 4:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
sr 4:0:0:0: [sr0] Sense Key : Medium Error [current]
 Info fld=0x0
sr 4:0:0:0: [sr0] Add. Sense: L-EC uncorrectable error
end_request: I/O error, dev sr0, sector 1336808
Buffer I/O error on device sr0, logical block 167101

I noticed that this bug is marked for Alpha 5 of Intrepid, but the errors occur in the release. Should it be tagged differently?

whocarez (whocarez1) wrote :

I did some more testing today on the SH-S203P drive. I did both a BIOS upgrade, tried to to experiment with setting SATA to compatible mode in BIOS and disabling memory remapping. Also tried to boot with acpi=off noapic nolapic nohz=off pci=nomsi settings (and a combination of those), but it didn't help. If a cd is in the drive during boot, this error occurs once the "Uniform cd-rom driver Revision: 3.20" is loaded and then it has to timeout to go further.

If I try to mount a cd-rom, the error occurs at once:
Nov 10 17:53:14 pluto kernel: [ 909.054544] sr 4:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
Nov 10 17:53:14 pluto kernel: [ 909.054550] sr 4:0:0:0: [sr0] Sense Key : Medium Error [current]
Nov 10 17:53:14 pluto kernel: [ 909.054553] sr 4:0:0:0: [sr0] Add. Sense: L-EC uncorrectable error
Nov 10 17:53:14 pluto kernel: [ 909.054556] end_request: I/O error, dev sr0, sector 1336808
Nov 10 17:53:14 pluto kernel: [ 909.054560] Buffer I/O error on device sr0, logical block 167101

Then it goes on for about a minute or so:
Nov 10 17:54:32 pluto kernel: [ 986.849538] Buffer I/O error on device sr0, logical block 167101
Nov 10 17:54:33 pluto kernel: [ 987.829874] ISO 9660 Extensions: Microsoft Joliet Level 3
Nov 10 17:54:33 pluto kernel: [ 987.915463] ISO 9660 Extensions: RRIP_1991A

But after that the drive settles, it's mounted and all the contents can be copied over at full speed with no problems at all. I have noticed that the errors also occur with factory printed cds, but also here the contents can be copied over at full speed once the drive settles:

Nov 10 18:07:39 pluto kernel: [ 1774.095301] end_request: I/O error, dev sr0, sector 1111296
Nov 10 18:07:39 pluto kernel: [ 1774.095308] Buffer I/O error on device sr0, logical block 138912
Nov 10 18:07:39 pluto kernel: [ 1774.097340] end_request: I/O error, dev sr0, sector 1111296
Nov 10 18:07:39 pluto kernel: [ 1774.097343] Buffer I/O error on device sr0, logical block 138912
Nov 10 18:07:39 pluto kernel: [ 1774.099899] end_request: I/O error, dev sr0, sector 1111528
Nov 10 18:07:39 pluto kernel: [ 1774.099902] Buffer I/O error on device sr0, logical block 138941
Nov 10 18:07:39 pluto kernel: [ 1774.101600] end_request: I/O error, dev sr0, sector 1111528
Nov 10 18:07:39 pluto kernel: [ 1774.101603] Buffer I/O error on device sr0, logical block 138941
Nov 10 18:07:39 pluto kernel: [ 1774.103282] end_request: I/O error, dev sr0, sector 1111536
Nov 10 18:07:39 pluto kernel: [ 1774.103285] Buffer I/O error on device sr0, logical block 138942
Nov 10 18:07:39 pluto kernel: [ 1774.104962] end_request: I/O error, dev sr0, sector 1111536

But if I insert a factory printed DVD, everything works with no errors at all! Tried with different DVDs. Yesterday I installed 8.10 server from a burnt mini iso, and although I had to wait with patience to wait for a timeout everytime the drive was accessed, the install completed.

If you want me to perform any more testing, just tell me. It would be nice to get this resolved.

description: updated
Peter (darkcentrino) wrote :

The Problem is the CD, when you burn the iso to a DVD, everything is fine!
I have found this links:
http://<email address hidden>/msg04512.html
http://www.troubleshooters.com/linux/coasterless.htm

whocarez (whocarez1) wrote :

I have done some more testing, and as you say DVD-s work fine. My previous cdr-s were burnt with wodim 1.1.2 (debian etch) and wodim 1.1.8. This time I tried adding -dao option to wodim, and guess what, now the cds boot fine and give me no errors during mount. However, since I also experienced error with some factory made cds (not all) and also with a cd burnt with ISO recorder Powertoy in windows, then I still suspect that the cd-rom driver being the culprit. I'm not sure though, but I'm happy with the workaround for the time being.

Many thanks to Zenit.

Same problem as you : on the same CDRW no problem to burn and to install Ubuntu 8.04 but "... Error on device sr0 ..." with ubuntu 8.10 iso (i386 or AMD64).
So I tried to burn ubuntu 8.10 iso on this same CDRW with the wodim -dao option and .... it works.
-> no more error when installing.

Burning the LiveCD as DAO allowed me to boot off it just fine.

If you are still experiencing issues, please open a new report as you are likely experiencing a slightly different bug than the original reporter as Marlon has commented this is no longer an issue. Thanks.

Changed in linux:
status: New → Fix Released
Olivier Prieur (mumbly) wrote :

[SOLVED]
At the boot prompt, just after the language choice, press F6 and simply add this parameter : all_generic_ide
It solved everything for me ! No more error messages !

Brian Parma (bj0) wrote :

I'm trying to boot the release version of 8.10 on an Asus s5n, adding all_generic_ide does not solve the problem. It drops me to BusyBox prompt and spits out:

end_request: I/O error, dev sr0, sector 1431184
Buffer I/O error on device sr0, logic block 178898

AL-X (danel) wrote :

I suspect this is problem occurs only for WRITE capable devices. I have a store-bought CD with Ubuntu install. In one DVD drive it had the "error . . . sr0" problem, but in the other DVD drive it did not. The difference is that it failed on the burner, but succeeded on the ROM. (I.e., failed on write capable DVD drive, succeeded on read-only DVD drive.)

My theory is this: For certain (but not all) write capable (burner) DVD devices, the OS might be misinformed that it can write to the device. Upon believing that it has the ability to write, the OS might try to write. But of course the **device** capabilities don't matter when the CD **media** is not in fact write-able; therefore, the attempt to write fails and an error is reported.

Use a read only device, or try the "all_generic_ide" command line option, mentioned in Olivier Prieur post of 2009-01-04, above.

schorem (schorem) wrote :

I used the Alternate Install CD and did have the same problem. If you wait it out and use the "all_generic_ide" command line option, it will install properly. But is this going to be corrected? New PC's do not have read only devices and this also rules out USB Flash drives.

hmbemis (ethanms) wrote :

I'm getting similar errors to above using ubuntu-8.10-desktop-amd64.iso

"
Buffer I/O error on device sr0, logical block 357906
end_request: I/O error, dev sr0, sector 143161
"

The numbers at the end of the line change slightly, it repeats roughly 10-12 times before stopping and then just doing nothing.

- I do have a write-able optical drive, but the media is write-once

+ I have tried re-burning the CD at a slower speed (my laptop's max is 24X, tried re-burning at 12X)
- I used ISO Record v2 to make my CDs

+ I have tried adding all_generic_ide to the boot option, no difference in behavior

* I plan to try re-try burning using a different machine and burning SW
* I will also burn to a DVD (target machine's optical drive is dvd-rom)

thx

AL-X (danel) wrote :

I eventually replaced the DVD device being used for the installation. I took the DVD device back to the store, got a store credit, and bought the most expensive one I could find as a replacement.

T. Middleton (timtoo) wrote :

I was having this problem with kubuntu-9.04-beta-alternate-amd64.iso

Reading the comments here I noted the person who said they burned using DAO and it worked. Strange, but I decided to give it a shot. It worked for me also.

Details. I burned the ISO originally with K3B 1.0.5 (the version currently part of Jaunty's beta) using (i think) all default settings. It was burned to a Maxell CD-RW disk.

The second time time I reburned the exact same ISO image to the exact same CD-RW disk, again using K3B. The only difference was that I changed the "Write method" dropdown from "Auto" to "DAO", and I changed the write speed from "Auto" to "4x".

This seems strange to me. I suppose it could be a coincidence, and the first time there was a bad burn for some reason. But this is my experience nevertheless.

Philipp Kern (pkern) wrote :

Also got hit by this problem with a Intrepid i386 CD image burned on a DVD with growisofs and then brasero. Failure encountered with both. Drive in question is read-only. all_generic_ide did not help me.

yossarian_uk (morgancoxuk) wrote :
Download full text (4.5 KiB)

Hi.

Am getting similar errors:

In intrepid and Jaunty(beta)

dvd burning is completely fine in Opensuse 11.1 - Debian Lenny and Arch Linux .

It is just Ubuntu that it fails (100% of the time) it is always at the end - during the cache

When I put the blank dvd in I get

---------------------------------
[ 234.402408] cdrom: This disc doesn't have any tracks I recognize!
[ 234.942996] sr 2:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
[ 234.943005] sr 2:0:0:0: [sr0] Sense Key : Blank Check [current]
[ 234.943013] sr 2:0:0:0: [sr0] Add. Sense: No additional sense information
[ 234.943021] end_request: I/O error, dev sr0, sector 0
[ 234.943029] Buffer I/O error on device sr0, logical block 0
[ 234.943039] Buffer I/O error on device sr0, logical block 1
[ 234.943044] Buffer I/O error on device sr0, logical block 2
[ 234.943050] Buffer I/O error on device sr0, logical block 3
[ 235.005872] sr 2:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
[ 235.005879] sr 2:0:0:0: [sr0] Sense Key : Blank Check [current]
[ 235.005885] sr 2:0:0:0: [sr0] Add. Sense: No additional sense information
[ 235.005892] end_request: I/O error, dev sr0, sector 0
[ 235.005897] Buffer I/O error on device sr0, logical block 0
--------------------------------------------------------

Brasero - errors with

--------------------------------------------------------
BraseroGrowisofs stdout: 714637312/729899008 (97.9%) @4.0x, remaining 0:03 RBU 45.5% UBU 100.0%
BraseroGrowisofs called brasero_job_get_action
BraseroGrowisofs called brasero_job_set_current_action
BraseroGrowisofs stderr: /dev/sr0: flushing cache
BraseroGrowisofs called brasero_job_set_current_action
BraseroGrowisofs stderr: HUP
BraseroGrowisofs stdout: HUP
BraseroGrowisofs process finished with status 0
BraseroGrowisofs called brasero_job_get_fd_out
BraseroGrowisofs called brasero_job_get_action
BraseroGrowisofs Finished successfully session
BraseroGrowisofs stopping
BraseroGrowisofs got killed
Dummy session successfully finished (brasero_burn_record_session burn.c:2090)
Checking session consistency (brasero_burn_check_session_consistency burn.c:1905)
Session error : An internal error occurred (brasero_burn_record burn.c:2599)
--------------------------------------------------------

Also noticing this in 9.04 beta (amd64)
----------------------------------------------------------
[ 9.023878] ck804xrom ck804xrom_init_one(): Unable to register resource 0x00000000ff000000-0x00000000ffffffff - kernel bug?
[ 9.023887] resource map sanity check conflict: 0xff000000 0xffffffff 0xffff0000 0xffffffff pnp 00:0c
[ 9.023893] ------------[ cut here ]------------
[ 9.023896] WARNING: at /build/buildd/linux-2.6.28/arch/x86/mm/ioremap.c:226 __ioremap_caller+0x349/0x390()
[ 9.023897] Modules linked in: ck804xrom(+) mtd chipreg parport_pc(+) hid_logitech(+) i2c_nforce2 map_funcs parport ff_memless usbhid ohci1394 forcedeth ieee1394 fbcon tileblit font bitblit softcursor
[ 9.023908] Pid: 837, comm: modprobe Not tainted 2.6.28-11-generic #37-Ubuntu
[ 9.023910] Call Trace:
[ 9.023915] [<ffffffff802509bf>] warn_on_slowpath+0x5f/0x90
[ 9.02...

Read more...

Changed in linux (Ubuntu):
status: Fix Released → Incomplete
n00d (noodles-km) wrote :

same error with a HP 550 and ubuntu 8.10

the laptop works perfectly with ubuntu 8.04

I do confirm the same problem on my HP laptop (6530b). The ubuntu 8.10 installation from a CD wen well but I cannot read any video DVD. The DVDs are fine (I checked them on a DVD reader) and the laptop is fine as well (I can read the DVD OK when booting on Windows)

lshw output attached

[83329.794378] end_request: I/O error, dev sr0, sector 14857064
[83329.794398] Buffer I/O error on device sr0, logical block 3714266
[83330.280309] end_request: I/O error, dev sr0, sector 14857064
[83330.280319] Buffer I/O error on device sr0, logical block 3714266
[83331.338708] UDF-fs: Partition marked readonly; forcing readonly mount
[83331.412612] UDF-fs INFO UDF: Mounting volume 'JE_VAIS_BIEN ', timestamp 2007/01/08 18:15 (1078)
[83338.744999] end_request: I/O error, dev sr0, sector 654884
[83338.745016] Buffer I/O error on device sr0, logical block 163721
[83338.745030] Buffer I/O error on device sr0, logical block 163722
[83338.745038] Buffer I/O error on device sr0, logical block 163723
[83338.745045] Buffer I/O error on device sr0, logical block 163724
[83338.745052] Buffer I/O error on device sr0, logical block 163725
[83338.745060] Buffer I/O error on device sr0, logical block 163726
[83338.745067] Buffer I/O error on device sr0, logical block 163727
[83338.745074] Buffer I/O error on device sr0, logical block 163728
[83338.745081] Buffer I/O error on device sr0, logical block 163729
[83338.745088] Buffer I/O error on device sr0, logical block 163730

n00d (noodles-km) wrote :

no problem with ubuntu 9.04!

whoop (tiredandnumb) wrote :

As for ubuntu 9.04: This issue is still being reported (even with official cd's from Canonical).
Check this thread: http://ubuntuforums.org/showthread.php?t=1157450

i'm getting this to in 9.04. i've tried four discs so far, an official Ubuntu 8.04 cd that i ordered from shipit, my burned 9.04 that i installed from, Transformers Pal2, and my StarCraft cd. none of them work anymore.

This happened just recently, i first installed libdvdcss-dev and then i started watching a movie. i paused this movie for a short break, then afterwards when i started it again smplayer crashed and no cd/dvd's would read.

I rebooted to see if that would fix it but now i don't even get the I/O errors in the log and it doesn't mount which i find odd, however it mounts my empy discs.

Ubuntu finds my drive just fine and its a: TSSTcorp CDDVDW SH-S223F.

It was all working fine earlier today...

Mei (ddouthitt) wrote :

I'm getting this error now with Xubuntu 9.04 Desktop. Kubuntu has been installed to this machine just fine, as has Linux Mint 7. Machine is a Toshiba Portege M100 with 512M RAM. The Xubuntu CDROM was burnt with DeepBurner 1.9.0.228 on Windows XP with a write speed of 16x (the burner seems to be capable of 24x or faster, but I always slow it down for read reliability).

The write device is listed as a TEAC CDRWDVD DV224EV D.CF and there is no DAO option that I can find (the interface is designed to be simple).

Sometimes I use InfraRecorder Portable (on same env) v0.45.0.0 to do burns: choice is a matter of wimsey (yes, it is!). I use defaults, except again I slow the burning process down (usually to 16x or 12x). Again, there's no DAO: on SAO (Session-at-Once, the default) and TAO (Track-at-Once) - I use the default.

The reader in the laptop is a TEAC DW-224E-A35 (Drive rev. A01) - logos state "Compact Disk ReWritable Utra Speed" and "DVD ROM".

Will see if I can't get success on another drive - but this does seem unusual.

T-Bone (varenet) wrote :

I have the same problem with 9.04. Tried 3 drives on a HP dx6050 and a HP xw3100 (Pioneer DVR-111L, Samsung SM352, HL DT ST GWA 4164b), none of them can properly read any DVD I throw at them.

Fun fact: booting debian Lenny with the exact same hardware setup, everything works fine. Lenny's kernel doesn't seem to use libata for optical drives (devices show as /dev/hd*). Seems to point at a kernel bug.

HTH

T-Bone (varenet) wrote :

Just tried linux-image-2.6.26-2-686 2.6.26-15 (from Debian Squeeze) on my 9.04 setup. All the I/O errors are gone, drives are working flawlessly (afaict). The machine has ICH5 chipset.

Snahrck (hansenclever) wrote :

I'm having, the same issue using a USB flash drive. Detail: this USB flash drive boots fine in another computer. So, I don't thing this is media or drive related.

It seems like I have the problem, too.

It took me ages and a stack of DVD and CD coasters to install Ubuntu in the first place, because my system didn't finish the install process regardless of the medium used (because of read errors). All DVDs and CDs turned out okay in a different machine, though. The only way that worked for me for installing Ubuntu was a USB stick configured using unetbootin.

The Ubuntu version installed is 9.04, the kernel being Linux version 2.6.28-14-generic (buildd@yellow) (gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #47-Ubuntu SMP Sat Jul 25 01:19:55 UTC 2009
The system is a Dell Inspiron 531, AMD Athlon(tm) 64 X2 Dual Core Processor 5600+, the DVD drive is an Optiarc DVD+-RW AD-5170S 101B:

*-cdrom
             description: DVD writer
             product: DVD+-RW AD-5170S
             vendor: Optiarc
             physical id: 1
             bus info: scsi@1:0.0.0
             logical name: /dev/cdrom
             logical name: /dev/cdrw
             logical name: /dev/dvd
             logical name: /dev/dvdrw
             logical name: /dev/scd0
             logical name: /dev/sr0
             logical name: /media/cdrom0
             version: 101B
             serial: [Optiarc DVD+-RW AD-5170S101B Jan29,2007
             capabilities: removable audio cd-r cd-rw dvd dvd-r
             configuration: ansiversion=5 mount.fstype=udf mount.options=ro,nosuid,nodev,utf8 state=mounted status=ready
           *-medium
                physical id: 0
                logical name: /dev/cdrom
                logical name: /media/cdrom0
                configuration: mount.fstype=udf mount.options=ro,nosuid,nodev,utf8 state=mounted

The dmesg output during the (failing) attempt at reading a DVD is:

[ 107.291994] end_request: I/O error, dev sr0, sector 302112
[ 107.291998] Buffer I/O error on device sr0, logical block 75528
[ 107.292001] Buffer I/O error on device sr0, logical block 75529
[ 107.292004] Buffer I/O error on device sr0, logical block 75530
[ 107.292006] Buffer I/O error on device sr0, logical block 75531

Funnily, audio CDs work just great. What amazes me slightly is that VLC actually managed to get some video off the DVD but no audio. Totem failed completely.

I already installed the most recent BIOS version 1.0.13. The kernel is 32bit, the system 64bit but other than the DVD drive everything else is working perfectly.

Just for the record: this bug isn't solved in Linux version 2.6.28-15-generic (buildd@yellow) (gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #49-Ubuntu SMP Tue Aug 18 19:25:34 UTC 2009.

T-Bone (varenet) wrote :

Does anyone actually care about this almost year-old bug? Ever considered doing the same thing as Debian does (i.e. disabling CONFIG_PATA_*), which yields perfectly working CD/DVD drives? A workaround is not a fix, but working hardware is still better than non-working one...

my 2c.

@T-Bone: Yes. I do. I really don't want to run a kernel/distro mix.

T-Bone (varenet) on 2009-09-29
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
assignee: nobody → Ubuntu Kernel Storage Team (ubuntu-kernel-storage)
akirasan (akirasan21h) wrote :

Hi, I have upgraded to Ubuntu 9.10 and this issue is solved for me. Finally!!!

P4man (duvel123) wrote :

I never had this problem from ubuntu 7.04 to 9.10. I still didnt have it this morning, but then I burnt a window 7 dvd and installed W7 on another drive and now im getting this Buffer I/O error on device sr0, logical block xxx on botting . I have this dvd writer: TSSTcorp CD/DVDW SH-S183A. No cd or dvd was inserted.

Oddly, going into the bios and disabling my dvd drive as boot device (not disabling it all together, just not having it in the list of boot order) solves this problem. Weird. Before making that change my dvd was listed as 3rd boot device after hdd and usb, so this doesnt make any sense whatsoever, but since it solved it for me, I thought Id mention it here.

Okay, here's the kicker: I upgraded to 9.10 and tried playing DVDs again. No dice. The only difference this time was this:

[ 1406.593479] sr 1:0:0:0: [sr0] Add. Sense: Read of scrambled sector without authentication

Then I thought - just out of despair - maybe it's the DVD and tried my whole collection (11 DVDs - I know). The result: 5 don't play, 6 do. Some of the 5 that don't play are marked "copy protected", some aren't. This sounds like kind of a success but given that I could play any of these a few Ubuntu releases ago still leaves a taste. Especially since I now own store bought copies of "Serenity" and "Matrix" that I can't watch anymore. (BTW: so sad they never made a sequel to Matrix.)

What I don't get is that even though libdvdread is installed I can't read these DVDs.

Here's the next kicker. Somehow my libdvdcss got deleted - probably during an upgrade, but I can only guess. I started VLC with -vv to find a cute README at the top that said that there is no decss library installed. With a little help from the wiki I actually installed that thing again and now DVDs play. Still I wonder why the only error message that appeared anywhere was in dmesg and only in 9.10 began to contain some useful information. To me, this particular bug is fixed, but the usability bug is still open. I cannot imagine how my mom would have dealt with that.

studentz (studenz) wrote :

It happened with me too. First: I got the same error in the tittle of this tread but in Karmic K. Second: I read all the thread. Third: I made a new CD but I burned it at 4X. Fourth: I use my old DVD player wich is DMA instead of my new brand ultrafast UDMA. I hope this problem can be solved in Lucid Linx. Take me 2 hours to figured out the solution.
UBUNTU rocks even though this small tiny problems ;)

Gerard (gerard78) wrote :

Hi

I burned several ISOs from last year when I started U/Kubuntu 8.04, 8.10 and 9.04 and I never get this I/O error.
But when I burned Ubuntu 9.10 ISO using an old 2003 LG CD-RW drive GCE-8520B at 24X (maximium speed) with a CD-RW Verbatim that had Ubuntu 8.10 and I get that error. In 1st burning appeared that error: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/468956. I thought that was for the CD was a bit scratched but that wasn't the reason (excuse my english)

As I say at the end of my post (nobody answered ! O() I emailed Nero and LG to discard that soft/hardware would be the reason of the problem. As they took their time to answer me I did waht I say in the last post: use the DVD drive instead of CD drive and repeat the burning with the same CD-RW and a new one and:

1st
The burning process was faster

2nd
The access of data from LG-DVD RAM too so integrity check of data and loading the CD Live to test too.

3rd (+important!)
The error/bug dissapeared ! ;)

I look at my CD and DVD specs and appear that have the same buffer (as this is a buffer error) so unless LG and NEro techs say the opposite I think that my CD drive is starting to fail and the DVD drive is newer so perhaps did better the burning so:

What type of drive are u using? CD/DVD or Blueray?

Gerard (gerard78) wrote :

I forget:

CD-RW drive with brasero didn't allow me to reduce speed from 24 to 16x and when I used DVD drive allowed me in Brasero and Nero 7. In brasero didn't appear the method of burning so waht type uses to burn a ISO or any type of file? I say that for I used Nero 7 in TAO mode to burn cause that was predefined when I clicked on my ISO Ubuntu 9.10 and I/o errors didnt appeared but after when testing Live CD a console screen saying that 2 missing files appeared. Thats what I say in my post: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/468956 and I dont know if is safe to install Ubuntu 9.10 over my present 9.04 that works fine (if I test live CD too).

I repeat the burning in DAO mode using Nero (as Brasero don't allow me to change it) and after, when loading It happened the same like the CD-RW burned in TAO mode. In fact if u pay attention when Brasero burns the ISO in the window appear "burning track 1" so it only burns 1 track so the problem of TAO I think that is only for music, in which songs are tracks as the link of other user above says.

Help? Suggestions? Corrections?

sanemanmad (sanemanmad) wrote :

Hi All,

sanemanmad (sanemanmad) wrote :

I am having this same issue. As you can see in the error log.

root@alice:~# dmesg | grep sr | less
[ 9.370675] sda:<4>Driver 'sr' needs updating - please use bus_type methods
[ 9.453367] sr0: scsi3-mmc drive: 48x/12x writer dvd-ram cd/rw xa/form2 cdda tray
[ 9.453595] sr 3:0:0:0: Attached scsi CD-ROM sr0
[ 9.457227] sr1: scsi3-mmc drive: 48x/48x writer dvd-ram cd/rw xa/form2 cdda tray
[ 9.457374] sr 5:0:0:0: Attached scsi CD-ROM sr1
[216763.733968] sr 3:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
[216763.733974] sr 3:0:0:0: [sr0] Sense Key : Medium Error [current]
[216763.733978] sr 3:0:0:0: [sr0] Add. Sense: No seek complete
[216763.733982] end_request: I/O error, dev sr0, sector 1024
[216763.734012] Buffer I/O error on device sr0, logical block 128
[216774.442340] sr 3:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
[216774.442345] sr 3:0:0:0: [sr0] Sense Key : Medium Error [current]
[216774.442349] sr 3:0:0:0: [sr0] Add. Sense: No seek complete
[216774.442352] end_request: I/O error, dev sr0, sector 1024
[216774.442380] Buffer I/O error on device sr0, logical block 128
[216786.250567] sr 3:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
[216786.250574] sr 3:0:0:0: [sr0] Sense Key : Medium Error [current]
[216786.250578] sr 3:0:0:0: [sr0] Add. Sense: No seek complete
[216786.250582] end_request: I/O error, dev sr0, sector 0
[216786.250611] Buffer I/O error on device sr0, logical block 0
[216786.250642] Buffer I/O error on device sr0, logical block 1
[216786.250667] Buffer I/O error on device sr0, logical block 2
[216786.250694] Buffer I/O error on device sr0, logical block 3
[216798.653131] sr 3:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
[216798.653137] sr 3:0:0:0: [sr0] Sense Key : Medium Error [current]
[216798.653140] sr 3:0:0:0: [sr0] Add. Sense: No seek complete
[216798.653144] end_request: I/O error, dev sr0, sector 0
[216798.653172] Buffer I/O error on device sr0, logical block 0
[260106.014496] sr 3:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
[260106.014503] sr 3:0:0:0: [sr0] Sense Key : Medium Error [current]
[260106.014507] sr 3:0:0:0: [sr0] Add. Sense: No seek complete
[260106.014510] end_request: I/O error, dev sr0, sector 1024
[260106.014541] Buffer I/O error on device sr0, logical block 128
[260115.418308] sr 3:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
[260115.418315] sr 3:0:0:0: [sr0] Sense Key : Medium Error [current]
[260115.418319] sr 3:0:0:0: [sr0] Add. Sense: No seek complete

Odin Hørthe Omdal (velmont) wrote :

I have such a DVD from *long* ago. I need to get the information out. Actually, that's not a big problem, because my computer can easily read it (karmic). My computer at work (also karmic koala) can not read it and gets those messages.

[ 4287.768724] Buffer I/O error on device sr0, logical block 0
[ 4287.775575] sr 4:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[ 4287.775580] sr 4:0:0:0: [sr0] Sense Key : Illegal Request [current]
[ 4287.775584] sr 4:0:0:0: [sr0] Add. Sense: Logical block address out of range
[ 4287.775589] end_request: I/O error, dev sr0, sector 0
[ 4287.775592] Buffer I/O error on device sr0, logical block 0
[ 4287.776799] sr 4:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[ 4287.776803] sr 4:0:0:0: [sr0] Sense Key : Illegal Request [current]
[ 4287.776806] sr 4:0:0:0: [sr0] Add. Sense: Logical block address out of range
[ 4287.776811] end_request: I/O error, dev sr0, sector 0
[ 4287.776814] Buffer I/O error on device sr0, logical block 0

Thousands of these.

Odin Hørthe Omdal (velmont) wrote :

[ 4149.754266] UDF-fs: No anchor found
[ 4149.754268] UDF-fs: No partition found (1)
[ 4149.759132] sr 4:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[ 4149.759136] sr 4:0:0:0: [sr0] Sense Key : Illegal Request [current]
[ 4149.759140] sr 4:0:0:0: [sr0] Add. Sense: Logical block address out of range
[ 4149.759145] end_request: I/O error, dev sr0, sector 64
[ 4149.759151] isofs_fill_super: bread failed, dev=sr0, iso_blknum=16, block=16

This also, actually. I noticed there was some extra info there.

Ron Wills (ron-rwsoft) wrote :

I have seem to have stumbled on to this bug and now my cd/dvd, on a Toshiba laptop, is now completely unusable. I tested the the cd/dvd with Windows Vista and works without a problem to eliminate problems with the hardware.

This seems to have started with an upgrade, but I can't say which one. I mostly use the cd/dvd for ripping my CDs for my blackberry and just today this started happening (it's been a at least 3-4 weeks since I last ripped a new CD).

On Ubuntu 9.04:
uname -a
Linux ron-laptop 2.6.28-16-generic #57-Ubuntu SMP Wed Nov 11 09:47:24 UTC 2009 i686 GNU/Linux

dmesg
[ 839.000533] ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
[ 839.000556] ata2.00: cmd a0/01:00:00:00:08/00:00:00:00:00/a0 tag 0 dma 2048 in
[ 839.000559] cdb be 00 00 04 da 2e 00 00 01 10 00 00 00 00 00 00
[ 839.000562] res 40/00:02:00:0c:00/00:00:00:00:00/a0 Emask 0x4 (timeout)
[ 839.000571] ata2.00: status: { DRDY }
[ 839.000620] ata2: soft resetting link
[ 839.180538] ata2.00: configured for UDMA/25
[ 839.181002] ata2: EH complete
[ 842.357902] end_request: I/O error, dev sr0, sector 0
[ 842.357914] __ratelimit: 24 callbacks suppressed
[ 842.357921] Buffer I/O error on device sr0, logical block 0
[ 842.357929] Buffer I/O error on device sr0, logical block 1
[ 842.357941] Buffer I/O error on device sr0, logical block 2
[ 842.357948] Buffer I/O error on device sr0, logical block 3
[ 842.357955] Buffer I/O error on device sr0, logical block 4
[ 842.357962] Buffer I/O error on device sr0, logical block 5
[ 842.357969] Buffer I/O error on device sr0, logical block 6
[ 842.357975] Buffer I/O error on device sr0, logical block 7
[ 842.375251] end_request: I/O error, dev sr0, sector 0
[ 842.375264] Buffer I/O error on device sr0, logical block 0
[ 842.375273] Buffer I/O error on device sr0, logical block 1

I'm also getting dbus timeout errors when eject the a cd/dvd...

ginalfa (ginalfa) wrote :

I'm experiencing the same problem in karmic

uname 2.6.31-15-generic

If I burn an iso image burnig looks OK but when I insert the burned CD dmesg shows these errors:
[ 1070.463949] sr 5:0:0:0: [sr0] Unhandled sense code
[ 1070.463955] sr 5:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[ 1070.463960] sr 5:0:0:0: [sr0] Sense Key : Medium Error [current]
[ 1070.463967] Info fld=0x5604c
[ 1070.463969] sr 5:0:0:0: [sr0] Add. Sense: L-EC uncorrectable error
[ 1070.463977] end_request: I/O error, dev sr0, sector 1409328
[ 1070.463984] Buffer I/O error on device sr0, logical block 352332
[ 1075.533057] sr 5:0:0:0: [sr0] Unhandled sense code
[ 1075.533063] sr 5:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[ 1075.533068] sr 5:0:0:0: [sr0] Sense Key : Medium Error [current]
[ 1075.533075] Info fld=0x5604c
[ 1075.533078] sr 5:0:0:0: [sr0] Add. Sense: L-EC uncorrectable error
[ 1075.533086] end_request: I/O error, dev sr0, sector 1409328
[ 1075.533094] Buffer I/O error on device sr0, logical block 352332
[ 1080.678989] sr 5:0:0:0: [sr0] Unhandled sense code
[ 1080.678994] sr 5:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[ 1080.678999] sr 5:0:0:0: [sr0] Sense Key : Medium Error [current]
[ 1080.679007] Info fld=0x5604c
[ 1080.679009] sr 5:0:0:0: [sr0] Add. Sense: L-EC uncorrectable error
[ 1080.679017] end_request: I/O error, dev sr0, sector 1409328
[ 1080.679024] Buffer I/O error on device sr0, logical block 352332
[ 1085.747930] sr 5:0:0:0: [sr0] Unhandled sense code
[ 1085.747936] sr 5:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[ 1085.747941] sr 5:0:0:0: [sr0] Sense Key : Medium Error [current]
[ 1085.747948] Info fld=0x5604c
[ 1085.747951] sr 5:0:0:0: [sr0] Add. Sense: L-EC uncorrectable error
[ 1085.747958] end_request: I/O error, dev sr0, sector 1409328
[ 1085.747964] Buffer I/O error on device sr0, logical block 352332
[ 1088.084023] UDF-fs: No VRS found
[ 1088.084028] UDF-fs: No partition found (1)
[ 1088.171269] ISO 9660 Extensions: Microsoft Joliet Level 3
[ 1088.217187] ISO 9660 Extensions: RRIP_1991A

If i burn the same image on the same medium (cd-RW) in windows no errors occours.
This issue didn't occours in 8.04, 8.10 and 9.04.

Adrian Nicoara (noshelter) wrote :

+1 for version 9.10, I didn't see this on 9.04. Description is identical to ginalfa's - I had a CD which was mounting correctly (it had the 9.10 image on it :D ), then I overwritten it using Brasero (which is what I guess nautilus uses by default when you tell it to write to disc by default), and now when I insert the disc into the dvd drive, i get the following in dmesg:

Dec 14 18:48:22 oz kernel: [ 689.200059] sr 4:0:0:0: [sr0] Unhandled sense code
Dec 14 18:48:22 oz kernel: [ 689.200063] sr 4:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Dec 14 18:48:22 oz kernel: [ 689.200066] sr 4:0:0:0: [sr0] Sense Key : Medium Error [current]
Dec 14 18:48:22 oz kernel: [ 689.200070] sr 4:0:0:0: [sr0] ASC=0x10 <<vendor>> ASCQ=0x90
Dec 14 18:48:22 oz kernel: [ 689.200075] end_request: I/O error, dev sr0, sector 1433792
Dec 14 18:48:22 oz kernel: [ 689.200080] Buffer I/O error on device sr0, logical block 358448
Dec 14 18:48:28 oz kernel: [ 695.192679] sr 4:0:0:0: [sr0] Unhandled sense code
Dec 14 18:48:28 oz kernel: [ 695.192688] sr 4:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Dec 14 18:48:28 oz kernel: [ 695.192698] sr 4:0:0:0: [sr0] Sense Key : Medium Error [current]
Dec 14 18:48:28 oz kernel: [ 695.192708] sr 4:0:0:0: [sr0] ASC=0x10 <<vendor>> ASCQ=0x90
Dec 14 18:48:28 oz kernel: [ 695.192721] end_request: I/O error, dev sr0, sector 1433792
Dec 14 18:48:28 oz kernel: [ 695.192733] Buffer I/O error on device sr0, logical block 358448
Dec 14 18:48:34 oz kernel: [ 701.182495] sr 4:0:0:0: [sr0] Unhandled sense code
Dec 14 18:48:34 oz kernel: [ 701.182504] sr 4:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Dec 14 18:48:34 oz kernel: [ 701.182513] sr 4:0:0:0: [sr0] Sense Key : Medium Error [current]
Dec 14 18:48:34 oz kernel: [ 701.182524] sr 4:0:0:0: [sr0] ASC=0x10 <<vendor>> ASCQ=0x90
Dec 14 18:48:34 oz kernel: [ 701.182537] end_request: I/O error, dev sr0, sector 1433792
Dec 14 18:48:34 oz kernel: [ 701.182548] Buffer I/O error on device sr0, logical block 358448

uname -a
Linux oz 2.6.31-16-generic #53-Ubuntu SMP Tue Dec 8 04:02:15 UTC 2009 x86_64 GNU/Linux

David Tombs (dgtombs) wrote :

Original reporter has confirmed that the fix is released. If you're still experiencing this issue, please open a new report.

Changed in fedora:
status: New → Invalid
Changed in linux (Ubuntu):
assignee: Ubuntu Kernel Storage Team (ubuntu-kernel-storage) → nobody
status: Confirmed → Fix Released
bobbycarr (bc6255) wrote :
Download full text (33.7 KiB)

Since I upgraded from version 9.04 to 9.10 I cannot mount usb cd drive. Here is a copy of the log file:
[ 0.167311] pci 0000:02:03.0: IO window: 0x003400-0x0034ff
[ 0.167319] pci 0000:02:03.0: PREFETCH window: 0xe8000000-0xebffffff
[ 0.167326] pci 0000:02:03.0: MEM window: 0xc4000000-0xc7ffffff
[ 0.167333] pci 0000:02:03.1: CardBus bridge, secondary bus 0000:07
[ 0.167339] pci 0000:02:03.1: IO window: 0x003800-0x0038ff
[ 0.167346] pci 0000:02:03.1: IO window: 0x003c00-0x003cff
[ 0.167353] pci 0000:02:03.1: PREFETCH window: 0xec000000-0xefffffff
[ 0.167361] pci 0000:02:03.1: MEM window: 0xc8000000-0xcbffffff
[ 0.167368] pci 0000:00:1e.0: PCI bridge, secondary bus 0000:02
[ 0.167374] pci 0000:00:1e.0: IO window: 0x3000-0x7fff
[ 0.167382] pci 0000:00:1e.0: MEM window: 0xc0200000-0xcfffffff
[ 0.167390] pci 0000:00:1e.0: PREFETCH window: 0xe8000000-0xefffffff
[ 0.167409] pci 0000:00:1e.0: setting latency timer to 64
[ 0.167963] ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 11
[ 0.167969] PCI: setting IRQ 11 as level-triggered
[ 0.167978] pci 0000:02:03.0: PCI INT A -> Link[LNKA] -> GSI 11 (level, low) -> IRQ 11
[ 0.168506] ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 11
[ 0.168514] pci 0000:02:03.1: PCI INT B -> Link[LNKB] -> GSI 11 (level, low) -> IRQ 11
[ 0.168526] pci_bus 0000:00: resource 0 io: [0x00-0xffff]
[ 0.168533] pci_bus 0000:00: resource 1 mem: [0x000000-0xffffffff]
[ 0.168539] pci_bus 0000:01: resource 0 io: [0x2000-0x2fff]
[ 0.168546] pci_bus 0000:01: resource 1 mem: [0xc0100000-0xc01fffff]
[ 0.168552] pci_bus 0000:01: resource 2 pref mem [0xe0000000-0xe7ffffff]
[ 0.168559] pci_bus 0000:02: resource 0 io: [0x3000-0x7fff]
[ 0.168565] pci_bus 0000:02: resource 1 mem: [0xc0200000-0xcfffffff]
[ 0.168571] pci_bus 0000:02: resource 2 pref mem [0xe8000000-0xefffffff]
[ 0.168578] pci_bus 0000:02: resource 3 io: [0x00-0xffff]
[ 0.168584] pci_bus 0000:02: resource 4 mem: [0x000000-0xffffffff]
[ 0.168590] pci_bus 0000:03: resource 0 io: [0x3000-0x30ff]
[ 0.168596] pci_bus 0000:03: resource 1 io: [0x3400-0x34ff]
[ 0.168602] pci_bus 0000:03: resource 2 pref mem [0xe8000000-0xebffffff]
[ 0.168609] pci_bus 0000:03: resource 3 mem: [0xc4000000-0xc7ffffff]
[ 0.168615] pci_bus 0000:07: resource 0 io: [0x3800-0x38ff]
[ 0.168621] pci_bus 0000:07: resource 1 io: [0x3c00-0x3cff]
[ 0.168627] pci_bus 0000:07: resource 2 pref mem [0xec000000-0xefffffff]
[ 0.168634] pci_bus 0000:07: resource 3 mem: [0xc8000000-0xcbffffff]
[ 0.168713] NET: Registered protocol family 2
[ 0.168929] IP route cache hash table entries: 2048 (order: 1, 8192 bytes)
[ 0.169565] TCP established hash table entries: 8192 (order: 4, 65536 bytes)
[ 0.169689] TCP bind hash table entries: 8192 (order: 4, 65536 bytes)
[ 0.169789] TCP: Hash tables configured (established 8192 bind 8192)
[ 0.169794] TCP reno registered
[ 0.169954] NET: Registered protocol family 1
[ 0.170067] Trying to unpack rootfs image as initramfs...
[ 0.493227] Switched to high resolution mode on CPU 0
[ 0.49719...

bobbycarr (bc6255) on 2010-03-02
Changed in linux (Ubuntu):
status: Fix Released → In Progress
status: In Progress → Fix Released
David Tombs (dgtombs) wrote :

@bobbycarr, please file a new bug report by running "ubuntu-bug storage" from Alt+F2.

ceg (ceg) wrote :
Rotilio Salvatore (salvy) wrote :

i'm use Ubuntu Lynx beta1

my error buffer is:
[ 2495.411263] end_request: I/O error, dev sr0, sector 457260

Chris Olin (chris.olin) wrote :

Using fresh Lucid 10.04 and I'm experiencing this error. I didn't upgrade from a previous install.

 sr0] Add. Sense: Logical block address out of range
 sr 4:0:0:0: [sr0] CDB: Read(10): 28 00 00 00 00 00 00 00 01 00
 end_request: I/O error, dev sr0, sector 0
 sr 4:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
 sr 4:0:0:0: [sr0] Sense Key : Illegal Request [current]
 Info fld=0x0
 sr 4:0:0:0: [sr0] Add. Sense: Logical block address out of range
 sr 4:0:0:0: [sr0] CDB: Read(10): 28 00 00 00 00 00 00 00 01 00
 end_request: I/O error, dev sr0, sector 0

When trying to burn a DVD ISO image with Brasero.

David Tombs (dgtombs) wrote :

Chris: please file a new report with "ubuntu-bug linux". Thanks.

This happened to me and the problem was the CD/DVD reader.

Husni (husnihassan1) wrote :

Hello,

I am new in this page, I receive the same error using any type of linux flavor except, a flavor that is used in public schools in spain, I have a feeling that the OS that is being used in Spain for schools has been developed nationally. anyways back on track.

Computer:
ASUS EEE PC 1001PX
1GB RAM
Samsung HM321HI (320GB)
Win XP pro (SP3)

FAILED:
Linuxmint 11 (Linux Live USB Creator) (Universal USB Installer) (YUMI Installer)
Ubuntu 11 (Linux Live USB Creator) (Universal USB Installer) (YUMI Installer)
PinguyOS - LATEST (Linux Live USB Creator) (Universal USB Installer) (YUMI Installer)
Backtrack 5 (Linux Live USB Creator) (Universal USB Installer) (YUMI Installer)

Succeeded:
Guadalinex (made in Spain?) (Linux Live USB Creator) (any, even the latest, works flawlessly in my PC)
DL LINK FOR GUADALINEX:
http://www.guadalinex.org/mas-programas/descargas/cds-de-instalacion/

I think, but iam not sure, but i think to solve this problem is to go back in the flavor's version you want, install (if you ever reach there) and upgrade through prompt. I have used these installers (Linux Live USB Creator, Universal USB Installer, YUMI Installer) because the laptop that i use is a netbook (provided from school) and i don't have a external disk drive neither i can't access to one, the laptop doesn't have a integrated disk drive.

Thanks.

martin suc (martin-suc) wrote :

unfortunately this problem still exist in 12.10 Ubuntu Quantal. workarround is still the same - remove CD/DVD/BD disk from "CD/DVD/BD burner".

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.