Ubuntu

minivox ( mvox100) usb speakerphone doesn't work.

Reported by Sam Kaplan on 2005-12-07
12
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

The minivox (mvox100) usb speakerphone (http://www.mvox.com/mv100.html) isn't
properly recognised. When the device is plugged in, dmesg reports:

[4296407.944000] usb 5-4.3: new full speed USB device using ehci_hcd and address 6
[4296407.996000] invalid SELECTOR UNIT descriptor 7
[4296407.996000] snd-usb-audio: probe of 5-4.3:1.0 failed with error -5

Sam Kaplan (stkaplan) wrote :

(In reply to comment #0)

More info: the output of 'cat /proc/bus/usb/devices' is,

---snip---
T: Bus=05 Lev=02 Prnt=03 Port=02 Cnt=02 Dev#= 8 Spd=12 MxCh= 0
D: Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
P: Vendor=138c ProdID=0001 Rev= 0.01
S: Manufacturer=FORTEMEDIA
S: Product=FM1083
C:* #Ifs= 3 Cfg#= 1 Atr=80 MxPwr=500mA
I: If#= 0 Alt= 0 #EPs= 0 Cls=01(audio) Sub=01 Prot=00 Driver=(none)
I: If#= 1 Alt= 0 #EPs= 0 Cls=01(audio) Sub=02 Prot=00 Driver=snd-usb-audio
I: If#= 1 Alt= 1 #EPs= 1 Cls=01(audio) Sub=02 Prot=00 Driver=snd-usb-audio
E: Ad=81(I) Atr=05(Isoc) MxPS= 16 Ivl=1ms
I: If#= 2 Alt= 0 #EPs= 0 Cls=01(audio) Sub=02 Prot=00 Driver=snd-usb-audio
I: If#= 2 Alt= 1 #EPs= 2 Cls=01(audio) Sub=02 Prot=00 Driver=snd-usb-audio
E: Ad=02(O) Atr=05(Isoc) MxPS= 16 Ivl=1ms
E: Ad=83(I) Atr=0d(Isoc) MxPS= 8 Ivl=1ms
---snip---

Carthik Sharma (carthik) wrote :

Does this still occur on the latest Dapper?

Thank you for reporting this bug.

Yes, the problem remains in Dapper, and the error message remains the
same too.

Thank-you very much for your response.

Best,

Sam

On Sat, 2006-27-05 at 16:00 +0000, Carthik Sharma wrote:
> Does this still occur on the latest Dapper?
>
> Thank you for reporting this bug.
>
> ** Changed in: Ubuntu
> Status: Unconfirmed => Needs Info
>

tyson (tyson-tucker) wrote :

Not sure if anyone cares about this anymore but its a really simple fix. Heres a patch for sound/usb/usbmixer.c in 2.6.19.1. You may need to use OSS emulation for some applications to avoid sound distortion.

1486c1486,1487
< if (! num_ins || desc[0] < 6 + num_ins) {
---
> /* the magic number is '5'. */
> if (! num_ins || desc[0] < 5 + num_ins) {

Andrew Ash (ash211) wrote :

Thanks for that patch, Tyson.

Is this bug still a problem in Edgy, Sam?

HillClimber (launchpad-pub) wrote :

I can confirm this bug on Feisty with an IOGear "usb speakerphone".

# uname -a
Linux inspiron.box 2.6.20-16-generic #2 SMP Fri Aug 31 00:55:27 UTC 2007 i686 GNU/Linux

dmesg:
[92598.208000] usb 3-1: new full speed USB device using uhci_hcd and address 3
[92598.408000] usb 3-1: configuration #1 chosen from 1 choice
[92598.420000] invalid SELECTOR UNIT descriptor 7
[92598.420000] snd-usb-audio: probe of 3-1:1.0 failed with error -5
[92598.420000] usb 3-1: device_add(3-1:1.0) --> -5

lsusb:
Bus 003 Device 003: ID 138c:0001

Chuck Short (zulcss) wrote :

Added to my git tree.

Luke Yelavich (themuso) wrote :

I am wondering whether those of you who have this device are using gutsy. If not, could you try gutsy and reply to let us know whether the device works properly?

Thanks.

Greg Smart (gsmart-gmail) wrote :

I have attempted to use it in 7.10 and it doesn't work on a standard install on an intel machine. Would be great if it did work... it is a great little speakerphone.

Sam Kaplan (stkaplan) wrote :

Hello,

I can confirm that it still does not work in 8.04.

Sam

Daniel T Chen (crimsun) wrote :

Not a regression - unsetting importance.

Changed in alsa-lib:
importance: Medium → Undecided
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
assignee: Ubuntu Audio Team (ubuntu-audio) → nobody
Sam Kaplan (stkaplan) wrote :

The hardware works in Ubuntu 9.10

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.