Hardy/Intrepid/Jaunty boot hangs with the message: "ACPI: EC: non-query interrupt received, switching to interrupt mode"

Bug #263140 reported by sheps999 on 2008-08-30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Fedora)
linux (Ubuntu)
Nominated for Jaunty by Krastanov
Nominated for Karmic by Krastanov
linux (openSUSE)

Bug Description

Installed Hardy 8.04, but laptop hangs for about 15-30 seconds with the message:

"ACPI: EC: non-query interrupt received, switching to interrupt mode".

After the hang, the boot proceeds as normal.

Tried updating to the latest kernel (2.6.24-21-generic), but to no avail.

Tried giving the switch "acpi=off" at bootup, laptop doesn't hang, but all ACPI related functions (standby, CPU throttling, etc) are removed.

Tried updating BIOS, but it is already the latest version.

sheps999 (sheps999) wrote :

Forgot to mention, hang also occurs in recovery mode, whether or not "quiet" mode is on, and whether or not AC power is plugged in.

And here's the result of dmesg.

Hi sheps999,

Would you be willing to confirm if this will still be an issue with the upcoming Intrepid Ibex 8.10 release? The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test using the Intrepid repository.


2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Thanks again, we really appreciate your help and feedback.

sheps999 (sheps999) wrote :

>Would you be willing to confirm if this will still be an issue with the upcoming Intrepid Ibex 8.10 release?

Absolutely :)

I'll download the ALpha 5 LiveCD when it is released, and have a play about with it.

sheps999 (sheps999) wrote :

H'okay, downloaded and installed Intrepid, and it still hangs at "ACPI: EC: non-query interrupt received, switching to interrupt mode". However, boot-time doesn't seem to take as long as before.

zorpox (nononinono) wrote :

I'm getting the same error message, but my laptop locks up completely at this point (hard reboot needed). I read somewhere, that the same issue affected Sony Vaio notebooks, so I guess that this might be connected.

Three oddities though:

Opening the cd-rom drive (only thing that works) will resume the boot process.
Disabling dma-mode seems to circumvent this issue.
The boot process of Damn Small Linux (currenct version) also generates this issue.

sheps999 (sheps999) wrote :


Have you tried booting up on the battery? I've read that removing the power cable can prevent these lock-ups.

Sasquatch (sasquatch) wrote :

I'm having the same issue on my laptop too (Fujitsu-Siemens Amilo Pi 1536). It started with Hardy, but Intrepid has it too. Even the kernel from Jaunty, 2.6.28-4, does the same thing. I tried Fedora 9 with a LiveCD, does the same thing, but SuSE Enterprise 10 SP2 didn't. I forgot what kernel it had, and what options. This bug is really annoying, it stalls my boot for 18 seconds.

haldyr (haldyr-gmail) wrote :

I am having the same issue too (FS Amilo Pi1536, Kubuntu 8.10, kernel 2.6.27-12-generic).
I have exactly the same experience as Sasquatch.

sheps999 (sheps999) wrote :

I think this ACPI issue might be a bug in the actual Linux kernel, as I've tried several other distros (Fedora, Debian, Mandriva, etc), and they all hang at exactly the same point.

Sasquatch (sasquatch) wrote :

Perhaps, but why did SuSE Enterprise not hang during boot like I mentioned? Taking a look at the website from Novell (owner of SLED), it seems that they are using 2.6.16. So only the more recent kernels have this issue.

gipsey (gipsey1954) wrote :

I got the same problem on the exactly the same system. I asked myself about the following:

BIOS bug: multiple APIC/MADT found, using 0
ACPI: If "acpi_apic_instance=2" works better, notify <email address hidden>

Maybe it really works better with "2" but I don't know how to change it.

gipsey (gipsey1954) wrote :

I change setting but boot is as slow as before.

Krastanov (krastanov-stefan) wrote :

On Intrepid AMD64 2.26.7-13 the bug is present. It was present in all older kernel versions for intrepid. I am ready to run test if some of the kernel-team is interested. Should I try also the 9.04 live cd.

Sasquatch (sasquatch) wrote :

Krastanov, don't bother with Jaunty. I run the Jaunty kernel, same issue. 32 bit though, but that doesn't really matter.

Krastanov (krastanov-stefan) wrote :

Still, if there is any use here is my report:

on battery - no change
acpi=no - 15 seconds faster boot
acpi_apic_instance=2 - no change

Attached are dmesg logs and bootchart.

Is there ongoing work on the bug in ubuntu's kernel team or in the vanilla kernel team?

Krastanov (krastanov-stefan) wrote :

Hi again,
I don't want to sound ungrateful for the work done by the developers and ubuntu kernel team but, as the last comment by someone from the devs is seven months old and the bug is also in 9.04, will someone care to tell when we can expect the bug to be investigated.
I can understand that the bug is not a priority, but in my case for a year now I must wait minutes until the computer boots.

summary: - Hardy boot hangs with the message: "ACPI: EC: non-query interrupt
- received, switching to interrupt mode"
+ Hardy/Intrepid/Jaunty boot hangs with the message: "ACPI: EC: non-query
+ interrupt received, switching to interrupt mode"
tags: added: acpi boot linux
Dave W (weezerdave) wrote :

Same problem here on the release version of jaunty 64bit, was also present in 8.04 and 8.10. ~20s pause in booting.

Sasquatch (sasquatch) wrote :

I tried the and 2.6.30-rc3 kernels from http://kernel.ubuntu.com/~kernel-ppa/mainline/ and they too give this wait.

Dave W (weezerdave) wrote :

I'm not entirely sure this is an acpi problem. There is still an 8s wait with acpi disabled (I used acpi=off noacpi).

Apr 25 12:45:27 rock-laptop kernel: [ 1.006726] io scheduler cfq registered (default)
Apr 25 12:45:27 rock-laptop kernel: [ 9.004007] pci 0000:00:1d.7: EHCI: BIOS handoff failed (BIOS bug?) 01010001

Jarko P. (jarko) wrote :

I can confirm this on my laptop, Amilo Pi 1556 with Jaunty 32 bit. It hangs to this stage for about 20 secs. Rest of the boot proccess goes normally.

papukaija (papukaija) on 2009-06-02
Changed in linux (Ubuntu):
status: New → Confirmed
jfrantzius (jfrantzius) wrote :

On openSUSE, the problem seems to be solved with a recent kernel update to

sheps999 (sheps999) wrote :

Recent kernel update to Fedora ( doesn't fix this.

sheps999 (sheps999) wrote :

I found a fix here: https://bugs.launchpad.net/suse/+source/acpi/+bug/100110/comments/10 for OpenSUSE. Could this somehow be edited for Ubuntu/Fedora?

Krastanov (krastanov-stefan) wrote :

The fix found by sheps999 works for me. I'm marking this bug as a duplicate and subscribing the ACPI team to it.

sheps999, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command in the development release from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please do not test the kernel in the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. As well, please comment on which kernel version specifically you tested.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream', and comment as to why specifically you were unable to test it.

Please let us know your results. Thanks in advance.

tags: added: hardy needs-upstream-testing
removed: acpi boot linux
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Sid Lori (16siddy) wrote :
Download full text (8.5 KiB)

Bug still present on Ubuntu 16.04 LTS, running on an HP Elitebook 850 G2. Ubuntu is installed on an SSD, and I noticed that there were long delays that the hard drive light wasn't active. A check of dmesg showed two ~6 second delays in the boot process, both on the same problem:

[ 0.141122] ACPI: bus type PCI registered
[ 0.141123] acpiphp: ACPI Hot Plug PCI Controller Driver version: 0.5
[ 0.141183] PCI: MMCONFIG for domain 0000 [bus 00-ff] at [mem 0xe0000000-0xefffffff] (base 0xe0000000)
[ 0.141184] PCI: not using MMCONFIG
[ 0.141185] PCI: Using configuration type 1 for base access
[ 0.157183] HugeTLB registered 1 GB page size, pre-allocated 0 pages
[ 0.157184] HugeTLB registered 2 MB page size, pre-allocated 0 pages
[ 0.157406] ACPI: Added _OSI(Module Device)
[ 0.157406] ACPI: Added _OSI(Processor Device)
[ 0.157407] ACPI: Added _OSI(3.0 _SCP Extensions)
[ 0.157408] ACPI: Added _OSI(Processor Aggregator Device)
[ 0.164672] ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
[ 0.169886] ACPI: Dynamic OEM Table Load:
[ 0.169894] ACPI: SSDT 0xFFFFA08A05621000 0003F3 (v02 PmRef Cpu0Cst 00003001 INTL 20130927)
[ 0.170667] ACPI: Dynamic OEM Table Load:
[ 0.170674] ACPI: SSDT 0xFFFFA08A055F8800 0005DB (v02 PmRef ApIst 00003000 INTL 20130927)
[ 0.171490] ACPI: Dynamic OEM Table Load:
[ 0.171495] ACPI: SSDT 0xFFFFA08A0568AA00 000119 (v02 PmRef ApCst 00003000 INTL 20130927)
[ 0.172854] ACPI : EC: EC started
[ 6.094429] ACPI: Interpreter enabled
[ 6.094459] ACPI: (supports S0 S3 S4 S5)
[ 6.094460] ACPI: Using IOAPIC for interrupt routing
[ 6.094480] PCI: MMCONFIG for domain 0000 [bus 00-ff] at [mem 0xe0000000-0xefffffff] (base 0xe0000000)
[ 6.094904] PCI: MMCONFIG at [mem 0xe0000000-0xefffffff] reserved in ACPI motherboard resources
[ 6.094917] PCI: Using host bridge windows from ACPI; if necessary, use "pci=nocrs" and report a bug
[ 6.096366] ACPI: Power Resource [APPR] (off)
[ 6.098669] ACPI: Power Resource [COMP] (on)
[ 6.098863] ACPI: Power Resource [LPP] (on)
[ 6.099525] ACPI: Power Resource [PXP2] (on)
[ 6.218841] ACPI: Power Resource [WRST] (on)
[ 6.221957] ACPI: PCI Root Bridge [PCI0] (domain 0000 [bus 00-fe])
[ 6.221962] acpi PNP0A08:00: _OSC: OS supports [ExtendedConfig ASPM ClockPM Segments MSI]
[ 6.223644] acpi PNP0A08:00: _OSC: OS now controls [PCIeHotplug PME AER PCIeCapability]
[ 6.223645] acpi PNP0A08:00: FADT indicates ASPM is unsupported, using BIOS configuration
[ 6.224136] PCI host bridge to bus 0000:00
[ 6.224138] pci_bus 0000:00: root bus resource [io 0x0000-0x0cf7 window]
[ 6.224139] pci_bus 0000:00: root bus resource [io 0x0d00-0xffff window]
[ 6.224140] pci_bus 0000:00: root bus resource [mem 0x000a0000-0x000bffff window]
[ 6.224141] pci_bus 0000:00: root bus resource [mem 0xae800000-0xdfffffff window]
[ 6.224144] pci_bus 0000:00: root bus resource [mem 0xf0000000-0xfed3ffff window]
[ 6.224145] pci_bus 0000:00: root bus resource [mem 0xfed45000-0xfedfffff window]
[ 6.224146] pci_bus 0000:00: root bus resource [mem 0xfee01000-0xffffffff window]
[ 6.224148] pci_bus 0000:00: ...


To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers