Ubuntu

cannot install linux-image-2.6.27-1-server and linux-image-2.6.27-1-generic together

Reported by wateenellende on 2008-08-29
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: linux-image

In the process of bug 256316 I stumbled on the following:

$ sudo dpkg -i linux-image-2.6.27-1-server_2.6.27-1.2_amd64.deb
Selecting previously deselected package linux-image-2.6.27-1-server.
(Reading database ... 203428 files and directories currently installed.)
Unpacking linux-image-2.6.27-1-server (from
linux-image-2.6.27-1-server_2.6.27-1.2_amd64.deb) ...
Done.
dpkg: error processing
linux-image-2.6.27-1-server_2.6.27-1.2_amd64.deb (--install):
 trying to overwrite `/lib/firmware/atmsar11.fw', which is also in
package linux-image-2.6.27-1-generic
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Running postrm hook script /usr/sbin/update-grub.
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /boot/vmlinuz
Found kernel: /boot/vmlinuz.old
Found kernel: /boot/vmlinuz-2.6.27-1-generic
Found kernel: /boot/vmlinuz-2.6.26-5-generic
Found kernel: /boot/vmlinuz-2.6.24-19-generic
Found kernel: /boot/memtest86+.bin
Updating /boot/grub/menu.lst ... done

Errors were encountered while processing:
 linux-image-2.6.27-1-server_2.6.27-1.2_amd64.deb

Now, if I'm not mistaken, the linux-image-2.6.27-1-server and linux-image-2.6.27-1-generic packages should either be installable together, or should be made aware that they conflict.

graysky (da-audiophile) wrote :

I have experience this as well when attempting to install my custom compiled 2.6.28.x series kernel.

dpkg: error processing linux-image-2.6.28.7-em64t_1_amd64.deb (--install):
trying to overwrite `/lib/firmware/atmsar11.fw', which is also in package linux-image-2.6.27.10-em64t
dpkg-deb: subprocess paste killed by signal (Broken pipe)

Here is the complete log:

$ sudo dpkg -i linux-image-2.6.28.7-em64t_1_amd64.deb
[sudo] password for squishy:
(Reading database ... 144190 files and directories currently installed.)
Unpacking linux-image-2.6.28.7-em64t (from linux-image-2.6.28.7-em64t_1_amd64.deb) ...
Done.
dpkg: error processing linux-image-2.6.28.7-em64t_1_amd64.deb (--install):
 trying to overwrite `/lib/firmware/atmsar11.fw', which is also in package linux-image-2.6.27.10-em64t
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Running postrm hook script /sbin/update-grub.
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /boot/vmlinuz-2.6.27.10-em64t
Found kernel: /boot/vmlinuz-2.6.27-11-generic
Found kernel: /boot/memtest86+.bin
Updating /boot/grub/menu.lst ... done

Errors were encountered while processing:
 linux-image-2.6.28.7-em64t_1_amd64.deb

[This is an automated message. Apologies if it has reached you inappropriately.]

This bug was reported against the linux-meta package when it likely should have been reported against the linux package instead. We are automatically transitioning this to the linux kernel package so that the appropriate teams are notified and made aware of this issue. Thanks.

affects: linux-meta (Ubuntu) → linux (Ubuntu)
kernel-janitor (kernel-janitor) wrote :

Hi wateenellende,

Please be sure to confirm this issue exists with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/releases/ . Please then run following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 262783

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Incomplete and has not had any updated comments for quite some time. As a result this bug is being closed. Please reopen if this is still an issue in the current Ubuntu release http://www.ubuntu.com/getubuntu/download . Also, please be sure to provide any requested information that may have been missing. To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-expired
Changed in linux (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers