Regression: new Toshiba Laptop Support (tlsup) driver breaks Toshiba hotkeys; input device does not support 'kbd' input handler

Bug #261318 reported by Dana Goyette on 2008-08-26
126
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
hal (Ubuntu)
Undecided
Unassigned
Intrepid
Undecided
Unassigned
Jaunty
Undecided
Unassigned
linux (Ubuntu)
High
Tim Gardner
Intrepid
High
Andy Whitcroft
Jaunty
High
Tim Gardner
toshset (Ubuntu)
Undecided
Unassigned
Intrepid
Undecided
Unassigned
Jaunty
Undecided
Unassigned
xorg (Ubuntu)
Undecided
Unassigned
Intrepid
Undecided
Unassigned
Jaunty
Undecided
Unassigned

Bug Description

In the latest Intrepid kernel, the toshiba_acpi module has been removed, in favor of the new 'tlsup' driver. However, this breaks all the hotkeys on an old Toshiba laptop I'm testing Intrepid on; system is a Satellite 1415-S105, with an aftermarket ipw2200 card.

HAL has no fdi file matching the device, but even when I add one to make the lshal output for that device match the lshal output for the 'Video Bus' device, it doesn't fix the problem.

Here's what Xorg.0.log reports upon loading the 'tlsup' driver:
(II) config/hal: Adding input device tlsup: Toshiba Fn Hotkeys
(**) tlsup: Toshiba Fn Hotkeys: always reports core events
(**) tlsup: Toshiba Fn Hotkeys: Device: "/dev/input/event7"
(WW) tlsup: Toshiba Fn Hotkeys: Don't know how to use device
(II) UnloadModule: "evdev"
(EE) PreInit returned NULL for "tlsup: Toshiba Fn Hotkeys"
(EE) config/hal: NewInputDeviceRequest failed

I shall attach some relevant info in additional posts, rather than embedding it all in the report.

Dana Goyette (danagoyette) wrote :
Dana Goyette (danagoyette) wrote :

One factor: the HANDLER line for the tlsup device in 'cat /proc/bus/input/devices' shows only 'event7' -- no 'mouse' or 'kbd' at all!

Marking as affecting HAL, Linux, and Xorg, since I'm not sure where the bug exactly lies, and the behavior involves all three.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Dana Goyette (danagoyette) wrote :

I've upgraded that Toshiba laptop to the 2.6.27-1-generic kernel; previously it was using 2.6.26-5-generic. Upgrading to the newer kernel has not produced any change in behavior. This makes sense, since the version of the tlsup module itself has not changed. It's likely that this driver simply does not properly identifty itself as a 'keyboard' device.

The 'tlsup' module currently DOES produce a regression compared to previous kernels with the toshiba_acpi support, though that module only worked once you fixed (worked around) the separate issue of acpi_fakekey brokenness -- https://bugs.launchpad.net/ubuntu/+source/linux/+bug/217504 . If tlsup cannot be fixed in time, it would be a good idea to revert to using toshiba_acpi.

I shall also attach an FDI file I tested, in an attempt to get Xorg to use the device; however, this did not work -- apparently the "/proc/bus/input/devices" output trumps the hal information.

Dave (dme26-lp) wrote :

Update to Intrepid has essentially turned my Toshiba Portege R100 into a (1.1kg) desktop machine: I've lost fn keys, suspend to RAM, toshset controls, trackpad scrolling, and hibernate decided to break also. At least the first couple relate to this kernel change I suspect... Everything's currently still broken using kernel 2.6.27-5.

If there's anything systematic here (and it looks like there might be), non-technical users of (affected) Toshiba laptops should be warned not to upgrade to Intrepid.

Ante Karamatić (ivoks) wrote :

I can report that software suspend to ram (System -> Turn off -> Suspend) works, but function keys don't. There's also problem with all other toshiba hotkeys - no way to turn on bluetooth, redirect video output, lock the screen... IMHO, this is only a hal bug. This should get higher priority, since it represents major regression from Hardy :(

Hello Ante. Yes - I can run hibernate-ram successfully from a shell, but
for me suspend no longer appears in the logout options in the user
switcher panel in the manner I'd expect. I agree completely that the
Toshiba fn keys issue is a major regression from Hardy.

Murali (mshanker) wrote :

I have the same problem as above, in that I don't see the Suspend option. Running it from a shell blanks the screen, and immediately I then get a prompt for my password as if it is waking up. I cannot suspend or hibernate as long as I am logged in to my account. Running Hibernate from the main username/password prompt does work though.

tog

As far as I can see in my /usr/src/linux-headers-2.6.27-6-generic/.config CONFIG_ACPI_TOSHIBA is not set.
Now, I don't know if this is required for the new kernel/drivers, but I've seen that it was necessary to make fnfx work. And it sounds like something that you wouldn't want to do in a Toshiba laptop. (?)

BTW, I have a Tecra M2 and none of my Fn keys work. This is an upgrade from Hardy - where all my Fn keys used to work just fine.

Regards,
Alfonso

John Cooper (choffee) wrote :

I I think this may be related to #269831

I don't understand why we have switched from the previously working toshiba_acpi support to this module which does not do half the stuff the last one did. Can we just switch back.

Where do we go to help develop this module as there is no mention of it on acpi-devel mailing list and google only returns bugs in Ubuntu?

I have a Toshiba Portage R500 which still hibernates and suspends but none of the Fn buttons work.

Bryce Harrington (bryce) wrote :

Not sure why this got filed against xorg, since xorg isn't involved in hotkey stuff, and from the description it seems to be due to the change in kernel modules.

Changed in xorg:
status: New → Invalid

On Sat, 18 Oct 2008 17:42:20 -0000
Bryce Harrington <email address hidden> wrote:

> Not sure why this got filed against xorg, since xorg isn't involved in
> hotkey stuff, and from the description it seems to be due to the
> change in kernel modules.

I wouldn't exclude xorg yet. It might be related to evdev. Eh...

Dana Goyette (danagoyette) wrote :

I would agree with the 'invalid' evaluation on the Xorg task, since evdev refusing to handle the device is merely because the device does not present itself as a valid keyboard (as shown in /proc/bus/input/devices). I had marked Xorg as affected due to its interaction with the bug. I would like to see this marked 'confirmed', but I am not sure which tasks should be marked as such. In addition, this seems very important to fix before release... and needs merely a kernel configuration change to bring back the old toshiba_acpi and 'toshiba' modules.

Dave (dme26-lp) wrote :

Dana: Agreed RE the kernel config. I'm happy to have to cause the old
Toshiba ACPI modules to be loaded myself, but would definitely prefer not
to lose the convenience of using the generic Ubuntu kernel modules.

[Compared to my previous post, I'm pleased to note that all power
management regressions have since been fixed :-) ]

Ben Collins (ben-collins) wrote :

This will get fixed post release in an SRU by reverting back to toshiba-acpi

Changed in hal:
status: New → Invalid
Changed in toshset:
status: New → Invalid
Changed in linux:
assignee: nobody → ben-collins
importance: Undecided → High
status: New → In Progress
Pete Graner (pgraner) wrote :

This bug will not be fixed in time for 8.10 GA. It will be address in an update in the 8.10 maint. cycle. Adjusting milestone per process.

Changed in linux:
milestone: none → intrepid-updates
Dana Goyette (danagoyette) wrote :

Is there any way to build the module out-of-tree? It'd be a great help if somebody could build either a full kernel image, or just the .ko file, and attach it to this bug page. I'd do it myself, but the linux-source package doesn't have the Ubuntu patches installed, so it can't use hotkeys_over_acpi.

Dana Goyette (danagoyette) wrote :

After a lot of searching, I managed to find the Ubuntu-patched toshiba_acpi source; for some reason, neither the linux-source package, nor the source (apt-get source) for linux-image-2.6.27-7-generic contained the current 0.19a-dev version of the toshiba_acpi module. In fact, the Ubuntu patches also haven't reached upstream, either.

In order to get toshiba_acpi to compile on the 2.6.27-7-generic kernel, I had to comment out the following line (somewhere around 697), and thus disable the compatibility layer that utilities such as toshset use. This function call (to a function that no longer exists) will need to be converted into some current equivalent. Building the module out-of-tree also requires a bit of hacking at the .config file, and at parameters passed to the kbuild system.

static int __init
old_driver_emulation_init(void)
{
        int status;
        void __iomem *bios = ioremap(0xf0000, 0x10000);
        if (!bios)
                return -ENOMEM;

        if ((status = misc_register(&tosh_device))) {
                printk(MY_ERR "failed to register misc device %d (\"%s\")\n",
                        tosh_device.minor, tosh_device.name);
                return status;
        }

        setup_tosh_info(bios);
/* had to comment this out: create_proc_info_entry(OLD_PROC_TOSHIBA, 0, NULL, tosh_get_info); */

        iounmap(bios);

        return 0;
}

Steve Langasek (vorlon) wrote :
Changed in ubuntu-release-notes:
status: New → Fix Released
Alvarodt (bloodymind) wrote :

Hello! I'm not too much related with english language but I've reached this thread following a solution for my lapton, a toshiba tecra A9 (8 or 9 I think), because my bluetooth doesn't work and I think I need toshiba acpi to make ir works, because in kubuntu 8.04 it worked perfectly but now I have the message:

"alvarodt@alvarodt-laptop:~/Escritorio$ sudo toshset -bluetooth on
required kernel toshiba support not enabled."

Could anybody tell me if we are waiting to have acpi module in ubuntu or we already have a solution? Thank you!

Ken Phillis Jr (kphillisjr) wrote :

for some reason i found a quick fix on this, it was to do some quick changes to the boot params... the hotkeys worked after i added the following kernel parameters.

acpi=noirq apic=debug irqpoll

Thanks for posting, Ken. The given boot parameters do not work around the
problems on my Toshiba Portege R100, but never mind - I have alternative
means to achieve most of the functions not currently available to me.

Alan Ghafour (algha4) wrote :

This also does not work on Tecra M384.

Ken Phillis Jr (kphillisjr) wrote :

I did some checking, my bios is pheonix based, but displays as a toshiba... it might prove useful to compare mine to this other one. ( my functionality is repaired by the flags i mentioned. )

sudo dmidecode -t 0
# dmidecode 2.9
SMBIOS 2.4 present.

Handle 0x0000, DMI type 0, 24 bytes
BIOS Information
 Vendor: TOSHIBA
 Version: V2.20
 Release Date: 08/11/2008
 Address: 0xE4750
 Runtime Size: 112816 bytes
 ROM Size: 1024 kB
 Characteristics:
  PCI is supported
  PNP is supported
  BIOS is upgradeable
  BIOS shadowing is allowed
  ESCD support is available
  Boot from CD is supported
  Selectable boot is supported
  BIOS ROM is socketed
  EDD is supported
  Print screen service is supported (int 5h)
  8042 keyboard services are supported (int 9h)
  Serial services are supported (int 14h)
  Printer services are supported (int 17h)
  CGA/mono video services are supported (int 10h)
  ACPI is supported
  USB legacy is supported
  IEEE 1394 boot is supported
  BIOS boot specification is supported
  Targeted content distribution is supported

This does not work for me either in a Toshiba Tecra M9.

Before switching to intrepid I always had bluetooth disabled by default and now I'm not able to turn it on since toshset also does not work.

mamue (mathe-mueller) wrote :

The boot parameters didn't work for the toshiba satellite m30. I guess it does have a phoenix bios, too.
Still no fn-keys in intrepid. There were no problems with hardy.

Andy Whitcroft (apw) wrote :

I have some test kernels for Intrepid posted up which have the original toshiba_acpi module enabled. It would be helpful if anyone who with this hardware could test that version and report back:

    http://people.ubuntu.com/~apw/lp269831/

Andy Whitcroft (apw) on 2008-11-19
Changed in linux:
assignee: ben-collins → apw
assignee: ben-collins → apw
mamue (mathe-mueller) wrote :

Hi Andy!

I just tested the kernel you posted!
The fn-keys work fine, but the nvidia driver couldn't be installed anymore.
The generic driver does not use the right colors in for example in totem.

Sameer Morar (smorar) wrote :

Enabling bluetooth using toshset with the test kernel works for me. I have a Toshiba Tecra M4.

DKMS however did fail on installation of the nvidia driver.

I aint got the laptot here now to try again, but for me the nvidia driver also failed to install.

I'm not sure if that's the problem, but I think it was looking for the linux-2.6.27-9 source and I got linux-2.6.27-7

Andre Schild (andre-schild) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Ambrosio Sanchez schrieb:
> I aint got the laptot here now to try again, but for me the nvidia
> driver also failed to install.
>
> I'm not sure if that's the problem, but I think it was looking for the
> linux-2.6.27-9 source and I got linux-2.6.27-7
>
Yes,

that is the problem. I noticed the same problem with the virtualbox
drivers, they also could not rebuild with DKMS because the sources for
that kernel are not installed/available.

André
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.10-svn4864 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkkkOdwACgkQQmPjtp6C4TGV2QCePf+nE9AbPeMBZ8unFVcyX9uu
Yc4An1jOLKabRqLkyK2S52QJPPrwJYEE
=Kr3s
-----END PGP SIGNATURE-----

Thanks Andy. Reporting back on a Toshiba Portege R100:

* toshset now works for what I use it for: switching the external VGA on
and off, and changing the LCD backlight brightness. Very good. Definitely
more fun than having to edit xorg.conf and restart X for such changes.

* A number of fn keys work: sound mute/unmute, display brightness up and
down. The volume up and down fn keys don't work, but I suspect that will
just require some local tinkering... or possibly undoing local tinkering
that I've already done incorrectly!

* I didn't notice any regressions, e.g. suspend to RAM still works (I'm
guessing there's some ACPI help for it).

Let me know if you'd like me to prod anything else.

As an aside I note that if I change the LCD backlight brightness with the
fn keys, my display zooms into the top-left 640x480 (?) of the screen (as
it would when pressing fn-spacebar under Windows). Doing a VT shuffle in
and out of X fixes the issue. Using toshset to change the LCD backlight
brightness does not cause the zooming effect, however. After suspend to
RAM, though, the fn-key LCD backlight change is not causing zooming,
although I note that video reverted to the LCD only (but toshset -video
both brought back the CRT output successfully). FWIW I think I fixed this
problem under Debian by changing the boot-time kernel video parameter...
(but of course I can't remember exactly what I did previously)

Andy Whitcroft (apw) on 2008-11-20
Changed in linux:
status: In Progress → Fix Committed
milestone: intrepid-updates → none

In my case, Toshiba Tecra M9

- toshset works well to switch bluetooth on and off (haven't tested anything else)
- Fn keys alow me to enable bluetooth and asjust brightness, but no suspend to ram.
- As expected, nvidia module does not work

Btw, I'm not sure the thing is related, but I can't use my audio headset with bluetooth (btsco) as I did before.

Thanks again for the work,

Andy Whitcroft (apw) wrote :

The kernel containing this fix has now been accepted into intrepid-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in linux:
status: Fix Committed → Fix Released

Andy,

Which specific package in proposed should I be installing for the fixed kernel? And is the fix that the original toshiba_acpi driver is enabled in it?

Sameer Morar (smorar) wrote :

@Andy Whitcroft

Thanks for pushing the fix into proposed. As far as I can tell, the fix should be in kernel version 2.6.27-10.20, but the latest kernel version that I can see in proposed is 2.6.27-8.17.

Did the build fail?

On Mon, Nov 24, 2008 at 04:43:54PM -0000, Sameer Morar wrote:
> @Andy Whitcroft
>
> Thanks for pushing the fix into proposed. As far as I can tell, the fix
> should be in kernel version 2.6.27-10.20, but the latest kernel version
> that I can see in proposed is 2.6.27-8.17.
>
> Did the build fail?

I believe that the kernel build succeeded but was waiting on the
linux-meta update to make the new kernel applicable. I would hope that
that has been done by the end of today, if it is not already.

-apw

Sameer Morar (smorar) wrote :

Thanks Andy.

The -proposed kernel works for me. Thank you.

Ken Phillis Jr (kphillisjr) wrote :

The problem with my machine was not fixed in the proposed package at all.

Linux Kernel 2.6.24-21 - my hotkeys work flawlessly ( at least the brightness controls and the updating of battery status )
Linux Kernel 2.6.27-* - not working so far, it's linked to the acpi module because irq9 gets released, and irqpoll causes some issues with suspend. ( last tested 2.6.27-10.20)

Andy Whitcroft (apw) wrote :

@Chris -- just the kernel update should be sufficient.

@Ken -- are there any messages from the driver in dmesg as it loads? If so could you add them to this bug. Also which laptop model is yours, as your symptoms seem different to the other reporters.

Ken Phillis Jr (kphillisjr) wrote :

andy, I have a Toshiba Satellite P305D-S8828... it's some issue where irq #9 is being used by both keyboard services and acpi... for more details, look at bug #294323 ( it's marked as duplicate, although clearly is not )

betzi (s-betzinger) wrote :

I installed kernel 2.6.27-10 to get acpi support on my Toshiba Portege R100 but in fact it doesn't work completely...
i only can use the brightness keys and the mute key, volume up/down and all other keys don't work at all.
i get an acpi event on all my fn keys. will there be an update to fix this?

I'm running the 2.6.27-10 intrepid-proposed image on my Toshiba Portege M200, and it works perfectly. :)
The brightness keys are fixed entirely.
Thank you so much!

Ken Phillis Jr (kphillisjr) wrote :

I got the keys working well enough, but it doesn't always respond once i put the screen to sleep... and as for args at boot, i added these 4...

acpi=noirq apic=debug irqpoll disable_8254_timer

so far i know it's a regression between the 2.6.24 and the 2.6.27 series of kernel.

Ken Phillis Jr (kphillisjr) wrote :

I did a quick reboot, because keyboard does not always work when i close the lid and have the acpi brightness working on 2.6.27.

this time the log is with the following parameters defined by me.
irqpoll disable_8254_timer

Dana Goyette (danagoyette) wrote :

Any chance of "forward-porting" this to the Jaunty 2.6.28 kernels?

Andy Whitcroft (apw) wrote :

On Sat, Jan 03, 2009 at 04:13:39AM -0000, Dana Goyette wrote:
> Any chance of "forward-porting" this to the Jaunty 2.6.28 kernels?

Figuring out how difficult this will be is on my todo list.

Andy Whitcroft (apw) wrote :

I have put together a forward port of this for the Jaunty kernel, could those of you who are able test the kernels at the url below:

    http://people.ubuntu.com/~apw/lp269831-jaunty/

Ken Phillis Jr (kphillisjr) wrote :

I gave the 2.6.28 kernel a try, and it still didn't work... of particular interest, look at line line 426, because here is where a trace happens, and irq9 gets disabled.

Dana Goyette (danagoyette) wrote :

The 2.6.28 kernel works for me -- the hotkeys give ACPI events again. However, I run into two other issues: some hotkeys are incorrectly defined for the laptop's keyboard, and acpi_fakekey doesn't work ( https://bugs.launchpad.net/ubuntu/+source/linux/+bug/217504 ).
Interestingly enough, it seems like any combination of fn+letter gives an ACPI event; too bad there's no easy way to expose that to userspace.

Ken Phillis Jr (kphillisjr) wrote :

I did a few more tests, it seems that my acpi is still somewhat debugged, even with the test i posted about, however i did notice that Brightness Function Keys now work, however the Wireless and trackpad toggle keys still do not work. However the latter was true even on the Ubuntu 8.04 kernel.

Tim Gardner (timg-tpi) wrote :

Uploaded linux_2.6.28-7.18, though the bug reference is LP 269831. See 'move toshiba laptops back from tlsup to toshiba_acpi' in the changelog.

Changed in linux:
assignee: apw → timg-tpi
status: In Progress → Fix Released
Anfanglir (anfanglir) wrote :

Sorry for a newbie question, but what is one supposed to do with the patches Andy Whitcroft linked to:
http://people.ubuntu.com/~apw/lp269831-jaunty/

?

Would appreciate some advice how to proceed. / Anfanglir

(running Ubuntu Jaunty on a Toshiba Libretto U100)

Andy Whitcroft (apw) wrote :

On Sun, Apr 26, 2009 at 03:39:10PM -0000, Anfanglir wrote:
> Sorry for a newbie question, but what is one supposed to do with the patches Andy Whitcroft linked to:
> http://people.ubuntu.com/~apw/lp269831-jaunty/

Those patches are the patches I used to build the kernels which used to
be in the same directory. They have now expired. According to the bug
the fixes that they contained are already released in both Intrepid and
Jaunty kernels. If you are running those releases and are up to date
your should already have the fixes and those kernels would be of no use
to you. If you are seeing an issue it is likely a new one and needing a
new bug filed.

Toshiba A300

Started with Hardy....upgraded to Intrepid....upgraded to Jaunty

Hardy:
brightness hotkeys worked...nothing else

Intrepid:
same as Hardy

Jaunty:
No hotkeys work...WTF!!!!

I'm stunned that this hotkey issue still exists....it is and should be made a huge priority as it causes basic laptop functionality to be crippled...not good for Linux and certainly makes Ubuntu look the way the Windows folks love to say....fulll of silly bugs.

OK...rant over....just frustrated beyond belief!

I tried to load toshiba-acpi (no such module)

I tried to load tlsup (no such module)

How is that possible??

Any advice greatly appreciated....and I'll test and provide whatever feedback you want...as long as it helps this sucker get resolved.

Thanks for reading

Cheers

Toshiba Portege R100: I have all hotkeys I'd want working under Jaunty. I
think that the kernel modules involved, and tool support for those modules
have had a rocky ride. I've had to futz in different ways in the different
Ubuntu releases to get things working.

However this (Jaunty) time around I just needed to: aptitude install fnfxd
and LCD backlight brightness, volume etc keys worked straight away.

I subsequently installed fnfx-client so that I could bind my own actions
to fn keys (indeed on the R100 most keys can be detected in an fn+key
combination, which is rather nice), such as poking DBUS to do actions such
as suspend or hibernate.

Steve Langasek (vorlon) wrote :

ColdFusion,

The toshiba-acpi module is part of the jaunty kernel. If you're getting a 'no such module' error, then something appears to be wrong with your Ubuntu install.

Martin Olsson (mnemo) wrote :

@Dave, hmm, if you hotkeys doesn't work until after you manually install the fnfxd package then I suggest you open a bug about this. Some people might not even know about this package, ideally it should really just work "out of the box".

Dave (dme26-lp) wrote :

@Martin, it could well be that fresh installations of Ubuntu work out of
the box. I've upgraded through the last three releases including some time
in proposed kernels, etc. I'll definitely report back if I have to
reinstall my machine from scratch in the next little while.

First off....I reverted my xorg.conf file back to the defaults after posting yesterday. That caused an inability to boot....not recoverable in safe mode (repairing X). So I booted with the live CD and replaced my xorg.conf file with the backup that was made when I replaced it....solved the problem. While in the live session, my brightness hotkeys were working as they had under Hardy/Intrepid. After the live session I booted as normal and my brightness hotkeys are working again under Jaunty.

So at least I'm back to normal....but still not happy ;-)

I suppose I should run another live session and see if the seemingly missing modules are there.

STEVE:
Thanks for the info on the possibility of my install being messed up. I have no idea how to go about proving it one way or the other. Any ideas?

I can say that all signs point to the upgrade having been successful...correctly reports as 9.04....notification area changes are seen...perhaps anecdotal tidbits...but there ya go.

DAVE:
Thanks for the fnxfd info...I'll give that a whirl....much appreciated. I still wish this kind of messing around to get basic things working was not necessary.....hopefully it gets there soon ;-)

I saw your comment on fresh vs upgrade installs. I sure hope that's not the case for me....but I fully understand that customizations can cause problems for upgrades over time ;-)

Thanks All

Just tried loading the modules again...here's the output so I'm as clear as possible ;-)

sudo modprobe toshiba-acpi
FATAL: Error inserting toshiba_acpi (/lib/modules/2.6.28-11-generic/kernel/drivers/acpi/toshiba_acpi.ko): No such device

sudo modprobe tlsup
FATAL: Module tlsup not found.

So it looks like I was bit off....looks like toshiba-acpi may exist....but something is not right....this is where my Linux knowledge strts getting fuzzy (damn those many years in the Windows world) ;-)

FYI...I am a programmer (of many years)...so not shy around the technical details.

Cheers

I tried out fnfxd and it complained:

fatal error: Could open /proc/acpi/toshiba/keys.

Please make sure that your kernel has enabled the Toshiba option in the ACPI section.

So I'm guessing ACPI is turned off?? How would I turn it on? Am I looking at compiling my own kernel to get what I need?

TIA

Cheers

OK....some dmesg output of interest...and I'll shut up for now ;-)

[ 1.912902] ACPI Warning (nseval-0168): Insufficient arguments - method [_OSC] needs 5, found 4 [20080926]
[ 1.913017] ACPI Warning (nspredef-0252): \_SB_.PCI0._OSC: Parameter count mismatch - ASL declared 5, expected 4 [20080926]
[ 1.914485] ACPI Warning (nseval-0168): Insufficient arguments - method [_OSC] needs 5, found 4 [20080926]

I saw the first and third lines MANY times
FYI I don't have the dreaded Phoenix bios AFAIK....I have InsydeH20 rev 3.0

Cheers

Steve Langasek (vorlon) wrote :

ColdFusion, since the problem you're encountering appears to be specific to your model of laptop, I would advise you to open a separate bug report (using 'ubuntu-bug linux') so that the kernel developers can diagnose why the module load is failing on your hardware.

Thanks Steve....but it is definitely NOT specific to my laptop model.

I've now found other recent threads noting various Toshiba laptop models and the SAME toshiba-acpi loading issues.

My fear is the developers would spend valuable time trying to figure out if it's related to the large number of Toshiba hotkey issues currently in the wild and not get the thing sorted.

Anyways....I'll keep digging for now.

Cheers

fig_wright (fig-wright) wrote :

I also have this problem from a new jaunty install. New kernel evidently not fixed for this.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers