Comment 64 for bug 259157

Victor Mataré (matare) wrote :

Atheros Communications Inc. AR5212 802.11abg NIC [168c:1014] (rev 01)

does NOT work with ath_pci.ko from /lib/modules/2.6.27-11-generic/volatile.

works perfectly with /lib/modules/2.6.27-11-generic/ath5k.ko from linux-backports-modules-2.6.27-11-generic

# dpkg-query -S /lib/modules/2.6.27-11-generic/volatile/ath_pci.ko
dpkg: *root@wiese:/lib/modules/2.6.27-11-generic/volatile/ath_pci.ko* not found.

Dunno where the driver comes from, but it's used for this adapter per default in a fresh install. Maybe this should become a quirk.