Comment 51 for bug 259157

Patrick Wagstrom (pridkett) wrote :

Just to add some more noise to the discussion. I have a Thinkpad t43p, which contains an Atheros card. According to dmesg here's the info:

[ 150.839980] wifi0: Atheros 5212: mem=0xa8400000, irq=21

This machine is utilized in several locations, some that require WPA and others that have no encryption. The machine has been running Ubuntu since betas of Dapper. In the Dapper days, Wifi was a pain -- reception was very poor and would frequently go in and out. But NM still worked to manage the interface. As long as I was really close to the access point, I could use Wifi. Sometime around Edgy or Feisty this got fixed so it worked completely, and everything was good.

Then, I upgraded to Intrepid -- and now I'm back in the Dapper days again. After resuming from sleep the machine does not properly activate Wifi0 again, although I see that ath0 is brought up again. Using a terminal and running "ifconfig wlan0 up" seems to fix this problem.

Once the network is up, I get one of two different problems:

1) if I'm on the unencrypted network, reception will be very poor and drop out the first time I connect. I then go and tell NM to disable then re-enable networking and it works fine again (or good enough, I haven't done anything scientific with this).

2) if I'm on the encrypted (WPA2-PSK) network, the machine will fail to connect to the network. A dialog comes up asking me for my WPA password (wha? didn't I tell NM to save this for a reason?). I click OK and then the machine is able to reconnect to the WPA network fine.

With whatever changes happened in NM or the Ahteros driver in Intrepid, this has gone from being a 3 second process that is automatic after waking up my laptop to a 1 minute+ action that requires my attention.

Furthermore, there's a serious usability issue in the fact that it prompts me for my network password again, I click "show password" to have it show the network password and it shows my the hexadecimal password. I use an ascii passphrase, so showing hexadecimal doesn't mean a lot to me here.

So, is there any workaround? I can't just setup static interfaces because I travel a lot and it would result in me taking even more time every time I unsleep my laptop.