Ralink rt73 hangs and requires reboot

Bug #258985 reported by Stuart Bishop on 2008-08-18
68
This bug affects 7 people
Affects Status Importance Assigned to Milestone
linux (Mandriva)
Unknown
High
linux (Ubuntu)
Medium
Andy Whitcroft
Hardy
Undecided
Tim Gardner
Intrepid
Medium
Andy Whitcroft
linux-backports-modules-2.6.24 (Ubuntu)
Medium
Andy Whitcroft
Hardy
Medium
Andy Whitcroft
Intrepid
Undecided
Unassigned

Bug Description

My rt73 based DLink DWA-110 USB stick had no problem under Hardy 2.6.24-19, so this seems to be a regression.

The connection initially works fine. However, under load the connection locks up - the system tray icon shows signal but there is no network traffic going in or out. Running sudo /etc/dbus-1/event.d/25NetworkManager restart restarts network manager but the connection will no longer connect to the network. Rebooting the machine gets me connected again.

This is easily reproducible - I just need to fire up a Bittorrent client for a few minutes.

===

SRU Justification

Impact: high network load leads to loss of connectivity, a reboot is required to recover

Fix Description: switches to former atomic operations

Patch: http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-intrepid.git;a=commit;h=a52e017788f9ab062372bf1a27107101ad46e733

Risks: this is a driver specific change

TEST CASE: see bug report

Stuart Bishop (stub) wrote :
Stuart Bishop (stub) wrote :
Stuart Bishop (stub) wrote :
Stuart Bishop (stub) wrote :

I can no longer reproduce this with 2.6.24-21.40

Changed in linux:
status: New → Fix Released
Stuart Bishop (stub) wrote :

Spoke too soon - it is still happening. Just took longer to trigger.

I noticed that if I restart network manager after the hang (/etc/dbus-1/event.d/25NetworkManager restart), the wireless networks will still be seen but cannot be connected too (in the panel icon both circles stay blue while the swirly thing swirls for a bit, where as the bottom circle is normally green).

Changed in linux:
status: Fix Released → New

The same problem occurs with me! :(

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Changed in linux:
status: New → Incomplete
Stuart Bishop (stub) wrote :

Why was this flagged incomplete? The issue for Hardy is still there, and all information asked for Hardy has been provided. If it works under 2.6.27 is irrelevant unless Hardy is switching from 2.6.26.

Changed in linux:
status: Incomplete → New

Hi Stuart,

We really appreciate all the information and testing you've provided already. However, according to SRU Policy we need to verify this issue is first resolved in the current development release before a backport for Hardy can be considered - https://wiki.ubuntu.com/StableReleaseUpdates . If this is not resolved for Intrepid a fix will need to be applied to Intrepid first and then backported to Hardy. Or, it could be that this is already resolved for Intrepid which can then help narrow down the possible patch to backport for Hardy.

There has also been some discussion of providing a newer kernel for Hardy so any feedback you can give us will help with making that assessment.

Also I'm curious if rather than rebooting in order to reconnect, what if you just unload and reload the module? Thanks.

Changed in linux:
status: New → Incomplete
Steve Beattie (sbeattie) wrote :

Subscribing the SRU team, as this looks to be a regression in the proposed 2.6.24-21 update.

Changed in linux:
status: New → Confirmed
Martin Pitt (pitti) wrote :

Tim, this is a regression in the current hardy-proposed SRU. Can you please take a look at this? Thanks!

Changed in linux:
assignee: nobody → timg-tpi
Tim Gardner (timg-tpi) wrote :

@Stuart - The rt73 USB driver has not changed since November 2007 in the main kernel sources. Do you have linux-backports-modules installed? There is an updated driver in that package that may work better.

@Martin - I do not think this is a regression. The rt73 driver was barely functional from the very beginning.

Stuart Bishop (stub) wrote :

@Tim - Yes, I have linux-backports-modules installed, as does everyone else using Ralink cards in Hardy (?) because Bug 134660 did not get resolved in time for Hardy release. Should this be targetted at linux-backports-modules instead?

I have the same problem using Ubuntu 8.10 beta 1, with a Ralink PCI card and a RT73USB driver.

The connection breaks after some times of internet uses. It depends of the quantity of data you exchange : if you do a ftp with a 1.3 Mo/s rate it will break sooner.

I'm a using a 2.6.27-4-generic kernel.

I have tried with other linux distributions, and I had the same problem.

With a Mandriva I have dumped those lines in messages log :

*Sep 20 20:10:04 localhost kernel: phy0 -> rt2x00queue_write_tx_frame: Error -
Arrived at non-free entry in the non-full queue 2.
Sep 20 20:10:04 localhost kernel: Please file bug report to
http://rt2x00.serialmonkey.com.*

It seems to be a regression in the kernel :

http://groups.google.com/group/linux.kernel/browse_thread/thread/189864466d6ed5f4/5189422969b027b8?lnk=raot

Download full text (3.6 KiB)

I have some more traces with this newer 2.6.27 kernel in the messages log. When RT73 hangs everything seems to work but the connection (network manager indicates an alive connection) is broken. I have to desactivate it and to connect again.

Oct 16 07:08:15 Ubuntu-Nicolas kernel: [ 28.720753] firmware: requesting rt73.bin
Oct 16 07:08:15 Ubuntu-Nicolas kernel: [ 29.006232] NET: Registered protocol family 17
Oct 16 07:08:20 Ubuntu-Nicolas kernel: [ 33.809669] NET: Registered protocol family 10
Oct 16 07:08:20 Ubuntu-Nicolas kernel: [ 33.810424] lo: Disabled Privacy Extensions
Oct 16 07:08:20 Ubuntu-Nicolas kernel: [ 33.811509] ADDRCONF(NETDEV_UP): wlan0: link is not ready
Oct 16 07:08:20 Ubuntu-Nicolas pulseaudio[7108]: ltdl-bind-now.c: Failed to find original dlopen loader.
Oct 16 07:08:20 Ubuntu-Nicolas pulseaudio[7108]: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Opération non permise
Oct 16 07:08:20 Ubuntu-Nicolas pulseaudio[7108]: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Opération non permise
Oct 16 07:08:21 Ubuntu-Nicolas pulseaudio[7108]: alsa-util.c: Device hw:1 doesn't support 44100 Hz, changed to 16000 Hz.
Oct 16 07:08:21 Ubuntu-Nicolas pulseaudio[7108]: alsa-util.c: Device hw:1 doesn't support 2 channels, changed to 1.
Oct 16 07:09:28 Ubuntu-Nicolas kernel: [ 101.547335] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Oct 16 07:15:34 Ubuntu-Nicolas syslogd 1.5.0#2ubuntu6: restart.
Oct 16 07:28:05 Ubuntu-Nicolas -- MARK --
Oct 16 07:48:05 Ubuntu-Nicolas -- MARK --
Oct 16 08:08:05 Ubuntu-Nicolas -- MARK --
Oct 16 08:28:05 Ubuntu-Nicolas -- MARK --
Oct 16 08:31:50 Ubuntu-Nicolas kernel: [ 5043.256845] usb 4-5.2: reset high speed USB device using ehci_hcd and address 6
Oct 16 08:48:05 Ubuntu-Nicolas -- MARK --
Oct 16 09:08:05 Ubuntu-Nicolas -- MARK --
Oct 16 09:12:32 Ubuntu-Nicolas kernel: [ 7485.257260] usb 4-5.2: reset high speed USB device using ehci_hcd and address 6
Oct 16 09:28:05 Ubuntu-Nicolas -- MARK --
Oct 16 09:48:05 Ubuntu-Nicolas -- MARK --
Oct 16 10:08:05 Ubuntu-Nicolas -- MARK --
Oct 16 10:28:05 Ubuntu-Nicolas -- MARK --
Oct 16 10:48:05 Ubuntu-Nicolas -- MARK --
Oct 16 11:08:05 Ubuntu-Nicolas -- MARK --
Oct 16 11:28:05 Ubuntu-Nicolas -- MARK --
Oct 16 11:48:05 Ubuntu-Nicolas -- MARK --
Oct 16 12:08:05 Ubuntu-Nicolas -- MARK --
Oct 16 12:28:05 Ubuntu-Nicolas -- MARK --
Oct 16 12:33:44 Ubuntu-Nicolas kernel: [19557.259031] usb 4-5.2: reset high speed USB device using ehci_hcd and address 6
Oct 16 12:48:05 Ubuntu-Nicolas -- MARK --
Oct 16 13:08:05 Ubuntu-Nicolas -- MARK --
Oct 16 13:28:05 Ubuntu-Nicolas -- MARK --
Oct 16 13:48:05 Ubuntu-Nicolas -- MARK --
Oct 16 14:08:05 Ubuntu-Nicolas -- MARK --
Oct 16 14:28:05 Ubuntu-Nicolas -- MARK --
Oct 16 14:48:05 Ubuntu-Nicolas -- MARK --
Oct 16 15:08:05 Ubuntu-Nicolas -- MARK --
Oct 16 15:28:05 Ubuntu-Nicolas -- MARK --
Oct 16 15:48:05 Ubuntu-Nicolas -- MARK --
Oct 16 16:08:05 Ubuntu-Nicolas -- MARK --
Oct 16 16:28:05 Ubuntu-Nicolas -- MARK --
Oct 16 16:48:05 Ubuntu-Nicolas -- MARK --
Oct 16 17:08:05 Ubuntu-Nicolas -- MARK --
Oct 16 17:28:05 Ubuntu-Nicolas -- MARK --
Oct 16 17:42:40 Ubuntu-Nicolas kernel: [38093.253747] usb 4-5.2: reset high speed USB devi...

Read more...

Steve Beattie (sbeattie) on 2008-10-17
Changed in linux-backports-modules-2.6.24:
status: New → Invalid
Changed in linux:
status: Confirmed → Invalid
Steve Beattie (sbeattie) wrote :

Marking the Hardy task for the linux package as invalid and adding the linux-backports-modules-2.6.24 package to the bug, based on Stuart Bishop's comment.

Stuart, Rodrigo:can you confirm that you are seeing this problem with linux-backports-modules 2.6.24-21.27 installed, as released in hardy updates?

Nicolas: are you still seeing this in the latest Intrepid kernels?

Leann: do you think it would be best if Nicolas reported his problem with 2.6.27 in a separate bug?

Thankyou all for your patience in tracking down this bug.

Changed in linux-backports-modules-2.6.24:
status: New → Confirmed

I have the some problem after the kernel upgrade to 2.6.24.21 :-(

My rt73 based DLink DWA-110 USB stick had no problem under 2.6.24-19.

I hope in some solution, plese.

Hi Steve,
With an upgrade from today and the last kernel I still see this behaviour
with the RT73usb module.

I have seen in the Ubuntu bug list today a new opened bug about this same
problem on Intrepid.

This new bug description is showing interesting messages log (that I could
see while I was using Mandriva 2009 but that I could not find in Ubuntu).

You have asked Leann if I should separate my problem from the existing one
but someone else has already done that !

This new bug is there :
https://bugs.launchpad.net/ubuntu/+bug/283759
rt73usb intrepid 8.10 beta -- wireless connection periodically lost; must
restart driveI am at disposition for further help or test or question.
Nicolas

2008/10/17 Steve Beattie <email address hidden>

> Marking the Hardy task for the linux package as invalid and adding the
> linux-backports-modules-2.6.24 package to the bug, based on Stuart
> Bishop's comment.
>
> Stuart, Rodrigo:can you confirm that you are seeing this problem with
> linux-backports-modules 2.6.24-21.27 installed, as released in hardy
> updates?
>
> Nicolas: are you still seeing this in the latest Intrepid kernels?
>
> Leann: do you think it would be best if Nicolas reported his problem
> with 2.6.27 in a separate bug?
>
> Thankyou all for your patience in tracking down this bug.
>
> ** Changed in: linux-backports-modules-2.6.24 (Ubuntu)
> Status: New => Invalid
>
> ** Changed in: linux (Ubuntu Hardy)
> Status: Confirmed => Invalid
>
> ** Changed in: linux-backports-modules-2.6.24 (Ubuntu Hardy)
> Status: New => Confirmed
>
> --
> Ralink rt73 hangs with 2.6.24-21 and requires reboot
> https://bugs.launchpad.net/bugs/258985
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "linux" source package in Ubuntu: Incomplete
> Status in "linux-backports-modules-2.6.24" source package in Ubuntu:
> Invalid
> Status in linux in Ubuntu Hardy: Invalid
> Status in linux-backports-modules-2.6.24 in Ubuntu Hardy: Confirmed
>
> Bug description:
> My rt73 based DLink DWA-110 USB stick had no problem under 2.6.24-19, so
> this seems to be a regression.
>
> The connection initially works fine. However, under load the connection
> locks up - the system tray icon shows signal but there is no network traffic
> going in or out. Running sudo /etc/dbus-1/event.d/25NetworkManager restart
> restarts network manager but the connection will no longer connect to the
> network. Rebooting the machine gets me connected again.
>
> This is easily reproducible - I just need to fire up a Bittorrent client
> for a few minutes.
>

--
http://www.linuxbidouille.com

Nicolas, thanks for your comment and the pointer to bug 283759; people who are having trouble this hardware under Intrepid should follow that bug. Closing out that portion of this bug.

Changed in linux:
status: Incomplete → Invalid

Ok but it seems to be very related. Could you tell me if this new bug will
be taken in charge by the Ubuntu team ?
https://bugs.launchpad.net/ubuntu/+bug/283759
Thanks,
Nicolas

2008/10/17 Steve Beattie <email address hidden>

> Nicolas, thanks for your comment and the pointer to bug 283759; people
> who are having trouble this hardware under Intrepid should follow that
> bug. Closing out that portion of this bug.
>
> ** Changed in: linux (Ubuntu)
> Status: Incomplete => Invalid
>
> --
> Ralink rt73 hangs with 2.6.24-21 and requires reboot
> https://bugs.launchpad.net/bugs/258985
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "linux" source package in Ubuntu: Invalid
> Status in "linux-backports-modules-2.6.24" source package in Ubuntu:
> Invalid
> Status in linux in Ubuntu Hardy: Invalid
> Status in linux-backports-modules-2.6.24 in Ubuntu Hardy: Confirmed
>
> Bug description:
> My rt73 based DLink DWA-110 USB stick had no problem under 2.6.24-19, so
> this seems to be a regression.
>
> The connection initially works fine. However, under load the connection
> locks up - the system tray icon shows signal but there is no network traffic
> going in or out. Running sudo /etc/dbus-1/event.d/25NetworkManager restart
> restarts network manager but the connection will no longer connect to the
> network. Rebooting the machine gets me connected again.
>
> This is easily reproducible - I just need to fire up a Bittorrent client
> for a few minutes.
>

--
http://www.linuxbidouille.com

I'm reconfirming this. This is still a regression bug in Hardy, and Hardy is still supported. The last known good release is the 2.6.19 package which we can thankfully still boot too.

Changed in linux-backports-modules-2.6.24:
status: Invalid → Confirmed
Stuart Bishop (stub) wrote :

I'm seeing identical behavior after upgrading to Intrepid with the linux-backports-modules removed (the device is not detected at all with linux-backports-modules installed).

Changed in linux:
status: Invalid → New
Changed in linux-backports-modules-2.6.24:
status: New → Invalid
Stuart Bishop (stub) wrote :

Some possibly relevant messages:

Dec 7 13:50:10 aargh kernel: [14538.952593] phy0 -> rt2x00queue_write_tx_frame: Error - Arrived at non-free entry in the non-full queue 2.
Dec 7 13:50:10 aargh kernel: [14538.952595] Please file bug report to http://rt2x00.serialmonkey.com.

Stuart Bishop (stub) wrote :

The Mandriva bug lists the same error message and same behavior.

description: updated
Stuart Bishop (stub) wrote :
Stuart Bishop (stub) wrote :
Stuart Bishop (stub) wrote :
Stuart Bishop (stub) wrote :
Stuart Bishop (stub) wrote :

http://rt2x00.serialmonkey.com/phpBB/viewtopic.php?f=5&t=5006&start=0&st=0&sk=t&sd=a constains the upstream bug report from two months ago but it hasn't been gardened into their bug tracker yet.

Changed in linux:
status: Unknown → In Progress
Andy Whitcroft (apw) wrote :

@Stuart Bishop -- it is quite possible your bug is related to the bug fixed in the commit below, in the upstream wireless tree. It does not yet appear to be merged into mainline, not sure when that will occur as yet.

http://git.kernel.org/?p=linux/kernel/git/linville/wireless-testing.git;a=commit;h=9fe32736d2cf27dfbf25cb7536c4358cd0dab6de

The patch which Andy referenced is available in the kernel for the latest pre-release of Jaunty 9.04 (currently Alpha 5) - http://cdimage.ubuntu.com/releases/jaunty/ . It contains a 2.6.28 based kernel. It would be great if someone could test with the latest Jaunty Alpha 5 LiveCD and confirm if this issue remains. Below is the jaunty git commit for this patch. Please let us know your results.

ogasawara@yoji:~/ubuntu-jaunty$ git log -p 0262ab0df64a67d4c0ed7577a29b7d866819cc68
commit 0262ab0df64a67d4c0ed7577a29b7d866819cc68
Author: Ivo van Doorn <email address hidden>
Date: Fri Aug 29 21:04:26 2008 +0200

    rt2x00: Fix race conditions in flag handling

Changed in linux:
importance: Undecided → Medium
status: New → Incomplete
Andy Whitcroft (apw) on 2009-03-04
Changed in linux:
importance: Undecided → Medium
Changed in linux-backports-modules-2.6.24:
importance: Undecided → Medium
importance: Undecided → Medium
Changed in linux:
assignee: nobody → apw
assignee: nobody → apw
Changed in linux-backports-modules-2.6.24:
assignee: nobody → apw
assignee: nobody → apw
Andy Whitcroft (apw) on 2009-03-10
Changed in linux:
status: New → In Progress
Andy Whitcroft (apw) wrote :

@Stuart Bishop -- I have pulled this patch back to Intrepid and built some test kernels. If you could test those kernels and report back here that would help us justify an SRU for Intrepid. The kernels are at the URL below:

    http://people.ubuntu.com/~apw/lp258985-intrepid/

Changed in linux:
status: In Progress → Incomplete
Aspora.Isernia (asporaa) wrote :

@Andy -- Would it be possible to have a patched kernel for the hardy heron also? I would be pleased to test it.

Stefan Bader (smb) wrote :

@Aspora, for Hardy there is little chance to get this into the driver (the code base is just too different). There is a chance that linux-backports-modules works (though the driver there is not at the same stage as in intrepid). I prepared LBM packages for the latest proposed version of the Hardy kernel. Should you need them for the updates version, please let me know. The packages can be found at http://people.ubuntu.com/~smb/bug258985/

Stuart Bishop (stub) wrote :

@Andy - No dropouts, decent signal and decent speeds for about 8 hours so far. Looks good from this end.

Stuart Bishop (stub) wrote :

Still no dropouts or other problems. Please consider this for SRU.

Andy Whitcroft (apw) on 2009-03-16
Changed in linux:
status: Incomplete → In Progress
Steve Beattie (sbeattie) wrote :

Closing the development task for l-b-m-2.6.24.

Changed in linux-backports-modules-2.6.24:
status: Confirmed → Invalid
Andy Whitcroft (apw) on 2009-03-17
Changed in linux-backports-modules-2.6.24:
status: Confirmed → Incomplete
Andy Whitcroft (apw) on 2009-03-17
Changed in linux:
status: In Progress → Fix Committed
description: updated
Andy Whitcroft (apw) wrote :

The fix for this issue is already fixed in Jaunty kernels.

Changed in linux:
status: Incomplete → Fix Released
Changed in linux (Mandriva):
status: In Progress → Invalid
Stefan Bader (smb) on 2009-04-23
Changed in linux-backports-modules-2.6.24 (Ubuntu Hardy):
status: Incomplete → Fix Committed
Martin Pitt (pitti) wrote :

Accepted linux-backports-modules-2.6.24 into hardy-proposed; please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Steve Beattie (sbeattie) on 2009-05-01
tags: added: hw-specific
Aspora.Isernia (asporaa) wrote :

I installed the proposed module and after 10 days the bug seems to be fixed: until now no more reboots were needed... Thanks!!

Martin Pitt (pitti) on 2009-05-04
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-backports-modules-2.6.24 - 2.6.24-24.32

---------------
linux-backports-modules-2.6.24 (2.6.24-24.32) hardy-proposed; urgency=low

  [Stefan Bader]

  * SAUCE: compat-wireless: Fix module load for crypto modules
    - LP: #322434

  [Upstream Kernel Changes]

  * rt2x00: Fix race conditions in flag handling
    - LP: #258985
  * iwlwifi: scan correct setting of valid rx_chains
    - LP: #330902

linux-backports-modules-2.6.24 (2.6.24-24.31) hardy-proposed; urgency=low

  [Stefan Bader]

  * Update to match bumped kernel ABI

 -- Stefan Bader <email address hidden> Wed, 25 Feb 2009 17:46:49 +0100

Changed in linux-backports-modules-2.6.24 (Ubuntu Hardy):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Accepted linux into intrepid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Ivo Jimenez (ivotron) wrote :
Download full text (3.1 KiB)

Hi,

For the last couple of months I've been plugged to the cable because I haven't had the chance to continue to test the fixes proposed for this bug. Finally I was able to make some time and I've tested it, unfortunately my desktop-PC still hangs as soon as the module is loaded. I'm using Jaunty so the only thing I had to do is to remove the module from the blacklist.conf file.

I tried it with and without using NetworkManager

Messages from dmesg are:

Jul 7 15:52:34 ivotron-desktop kernel: [ 32.010698] rt73usb 1-10:1.0: firmware: requesting rt73.bin
Jul 7 15:52:34 ivotron-desktop kernel: [ 32.237253] ADDRCONF(NETDEV_UP): wlan0: link is not ready
Jul 7 15:52:36 ivotron-desktop kernel: [ 33.723865] eth0: no link during initialization.
Jul 7 15:52:36 ivotron-desktop kernel: [ 33.724777] ADDRCONF(NETDEV_UP): eth0: link is not ready
Jul 7 15:52:37 ivotron-desktop kernel: [ 34.528764] usb 1-10: USB disconnect, address 5
Jul 7 15:52:37 ivotron-desktop kernel: [ 34.908522] usb 1-10: new high speed USB device using ehci_hcd and address 8
Jul 7 15:52:37 ivotron-desktop kernel: [ 35.202254] usb 1-10: configuration #1 chosen from 1 choice
Jul 7 15:52:39 ivotron-desktop kernel: [ 35.467353] Registered led device: rt73usb-phy1::radio
Jul 7 15:52:39 ivotron-desktop kernel: [ 35.467363] Registered led device: rt73usb-phy1::assoc
Jul 7 15:52:39 ivotron-desktop kernel: [ 35.467374] Registered led device: rt73usb-phy1::quality
Jul 7 15:52:44 ivotron-desktop kernel: [ 39.729068] rt73usb 1-10:1.0: firmware: requesting rt73.bin
Jul 7 15:52:44 ivotron-desktop kernel: [ 39.821820] ADDRCONF(NETDEV_UP): wlan0: link is not ready
Jul 7 15:52:44 ivotron-desktop kernel: [ 41.170804] usb 1-10: USB disconnect, address 8
Jul 7 15:52:44 ivotron-desktop kernel: [ 41.552518] usb 1-10: new high speed USB device using ehci_hcd and address 9
Jul 7 15:52:44 ivotron-desktop kernel: [ 41.846090] usb 1-10: configuration #1 chosen from 1 choice
Jul 7 15:52:44 ivotron-desktop kernel: [ 42.110201] Registered led device: rt73usb-phy2::radio
Jul 7 15:52:44 ivotron-desktop kernel: [ 42.110212] Registered led device: rt73usb-phy2::assoc
Jul 7 15:52:44 ivotron-desktop kernel: [ 42.110222] Registered led device: rt73usb-phy2::quality
Jul 7 15:52:51 ivotron-desktop kernel: [ 46.989645] rt73usb 1-10:1.0: firmware: requesting rt73.bin
Jul 7 15:52:52 ivotron-desktop kernel: [ 47.097229] ADDRCONF(NETDEV_UP): wlan0: link is not ready
Jul 7 15:52:52 ivotron-desktop kernel: [ 49.663087] usb 1-10: USB disconnect, address 9
Jul 7 15:52:54 ivotron-desktop kernel: [ 50.032521] usb 1-10: new high speed USB device using ehci_hcd and address 10
Jul 7 15:52:54 ivotron-desktop kernel: [ 50.327878] usb 1-10: configuration #1 chosen from 1 choice
Jul 7 15:52:54 ivotron-desktop kernel: [ 50.599700] Registered led device: rt73usb-phy3::radio
Jul 7 15:52:54 ivotron-desktop kernel: [ 50.599712] Registered led device: rt73usb-phy3::assoc
Jul 7 15:52:54 ivotron-desktop kernel: [ 50.599723] Registered led device: rt73usb-phy3::quality

Messages repeat until this gets to "USB disconnect, address 18" or the system freezes, whatever happen...

Read more...

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.27-14.41

---------------
linux (2.6.27-14.41) intrepid-proposed; urgency=low

  [ Stefan Bader ]

  * Revert "SAUCE: input: Blacklist digitizers from joydev.c"
    - LP: #300143

linux (2.6.27-14.40) intrepid-proposed; urgency=low

  [ Amit Kucheria ]

  * Disable DEVKMEM for all archs on Intrepid
    - LP: #354221
  * SAUCE: Quirk for BT USB device on MacbookPro to be reset before use
    - LP: #332443

  [ Andy Isaacson ]

  * LIRC_PVR150: depends on VIDEO_IVTV
    - LP: #341477
  * SAUCE: FSAM7400: select CHECK_SIGNATURE
    - LP: #341712

  [ Andy Whitcroft ]

  * SAUCE: hotkey quirks for various Zepto Znote and Fujitsu Amilo laptops
    - LP: #330259
  * SAUCE: unusual devs: add an entry for the ScanLogic SL11R-IDE 0.78
    - LP: #336189

  [ Anton Veretenenko ]

  * SAUCE: sony-laptop: add support for Sony Vaio FW series function/media
    keys
    - LP: #307592

  [ Ayaz Abdulla ]

  * SAUCE: forcedeth: msi interrupt fix
    - LP: #288281

  [ Chuck Short ]

  * SAUCE: [USB] Unusual Device support for Gold MP3 Player Energy
    - LP: #125250

  [ Ike Panhc ]

  * squashfs: correct misspelling
    - LP: #322306
  * SAUCE: Fixing symbol name in HECI module
    - LP: #336549
  * Copy header files for various kernel media driver
    - LP: #322732

  [ Stefan Bader ]

  * SAUCE: vgacon: Return the upper half of 512 character fonts
    - LP: #355057
  * SAUCE: input: Blacklist digitizers from joydev.c
    - LP: #300143

  [ Upstream Kernel Changes ]

  * libata: make sure port is thawed when skipping resets
    - LP: #269652
  * x86-64: fix int $0x80 -ENOSYS return
    - LP: #339743
  * rt2x00: Fix race conditions in flag handling
    - LP: #258985
  * USB: cdc-acm: Add another conexant modem to the quirks
    - LP: #323829
  * Bluetooth: Add fine grained mem_flags usage to btusb driver
    - LP: #268502
  * Bluetooth: Handle bulk URBs in btusb driver from notify callback
    - LP: #268502
  * Bluetooth: Submit bulk URBs along with interrupt URBs
    - LP: #268502
  * hwmon: (abituguru3) Match partial DMI board name strings
    - LP: #298798
  * x86: mtrr: don't modify RdDram/WrDram bits of fixed MTRRs
    - LP: #292619
  * sis190: add identifier for Atheros AR8021 PHY
    - LP: #247889
  * ath9k: implement IO serialization
    - LP: #373034
  * ath9k: AR9280 PCI devices must serialize IO as well
    - LP: #373034
  * acer-wmi: fix regression in backlight detection
    - LP: #333386

 -- Stefan Bader <email address hidden> Wed, 26 Aug 2009 11:48:11 +0200

Changed in linux (Ubuntu Intrepid):
status: Fix Committed → Fix Released

Is there a regression??? I got this, too. Kernel 2.6.31-19-generic and Networkmanager as frontend

Oh, I forgot it.. I'm using Karmic 9.10

Changed in linux (Mandriva):
status: Invalid → Unknown
Changed in linux (Mandriva):
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.